1.htm

Учебник по Corel Painter 8.0

Содержание

  • Введение
  • Основные сведения
  • Первое знакомство
  • Создание, открытие и сохранение документа
  • Цвет и разрешение
  • Печать
  • Первые действия
  • Средства автоматизации
  • Настройки инструментов рисования
  • Клонирование
  • Палитра Art Materials
  • Настройка цвета
  • Использование градаций
  • Шаблоны и плетения
  • Текстура и бумага
  • Инструмент Image Hose
  • Три основы
  • Выделения и маски
  • Слои
  • Формы
  • Специальные эффекты
  • Динамичные слои Burn, Tear, Bevel World, Liquid Metal
  • Динамичные слои над всем холстом
  • Инструменты Impasto и Мозаика
  • Работа с текстом


Первое знакомство

  • Требование к системным ресурсам
  • Установка программы Painter 8
  • Интерфейс Painter
    • Окно документа
  • Палитры
  • Палитра управления Controls
  • Палитра инструментов
    • Инструменты общего назначения
    • Инструменты, предназначенные для работы с цветом
    • Инструменты выделения
    • Регулирующие инструменты
    • Инструменты для работы с векторными объектами
  • Другие палитры
  • Простейшие действия
    • Режим отмены
    • Удаление
  • Работа с линейкой, сеткой и ориентиром

Painter является признанным лидером среди программ для профессиональных художников, занимающихся компьютерным искусством

Это необычный графический редактор. Он уникален, как может быть уникальным произведение искусства или научное открытие. Создание этого программного продукта — само по себе явление.

Дело в том, что в основе его лежит новый раздел математики, появившийся в 80-х годах благодаря бурному развитию компьютерной техники. Это так называемая фрактальная математика. Она возникла из необходимости постичь и описать динамические процессы, в том числе и возникновение хаоса. И это понятно, ведь трудно себе представить что-либо в природе, что представляло бы собой правильный процесс или естественную форму, соответствующую геометрическим формам.

В основе представлений этого раздела математики лежит понятие фракталов как множеств дробной размерности. Эти объекты обладают структурами различных масштабов, отражающих иерархический принцип организации, то есть фрактальные объекты самоподобны, и их вид не претерпевает существенных изменений при значительном увеличении. Безусловно, это идеализация и значительное упрощение действительных процессов. Но это условие позволило иначе взглянуть на привычное мировоззрение. К понятию фрактала мы еще вернемся в главе Цвет и разрешение.

Так или иначе, искусство ближе к сложному хаотическому динамическому процессу. Именно Painter предоставляет вам возможность творить с помощью всех существующих средств и инструментов. К сожалению, этот продукт не относится к интуитивно доступным. И при освоении его вы, возможно, столкнетесь с рядом сложностей. Но программа превзойдет все ваши ожидания.

Кроме того, по отзывам известных художников, применение Painter значительно сокращает время и средства, необходимые для большого проекта.

Многие художники, работающие в традиционной технике, делают всю подготовительную работу в Painter и, только получив удовлетворяющий их или заказчика результат, переносят изображение на полотно.

Один известный художник-монументалист рассказывает, что в Painter он за несколько месяцев сделал проект, который затем был распечатан на широкоформатном принтере на современном полимерном материале, подобном высокопрочной клейкой ленте. Эта современная «фреска» украсила зал дорогого отеля. Обычно на выполнение такого проекта уходят годы.

Итак, Painter позволяет вам:

  • создавать изображения подобно инструментальным средствам, таким как перо, фломастеры, уголь, пастель, цветные карандаши, аэрограф, акварель или масляные краски и др.;
  • моделировать изображения с помощью коллекции заливок: текстур, градаций, шаблонов;
  • работать с плавающими объектами, благодаря чему можно перемешать, отражать, изменять пропорции, размеры, угол наклона для любого растрового или векторного изображения;
  • восстанавливать с минимальными потерями наиболее удачный вариант изображения, используя возможность отмены;
  • применять невероятные эффекты, порой непредсказуемые и не имеющие аналогов среди традиционных художественных средств;
  • расширить возможности изобразительных средств Painter, пользуясь встроенными модулями Dynamic Layers и наконечниками кистей Image Hose;
  • преобразовать фотографии в графические или живописные изображения;
  • попробовать себя в качестве начинающего аниматора;
  • создать собственную страницу в Интернете средствами Painter;
  • автоматизировать часто повторяемые процедуры, что существенно экономит время.

Требование к системным ресурсам

Программа может быть установлена в нескольких конфигурациях. Минимальные требования для Windows:

  1. Windows 95, 98, Me, NT или Windows 2000.
  2. Pentium 233 или более быстрый процессор.
  3. Память 48 Мбайт (64 Мбайт, для Windows NT).
  4. Видеоадаптер SVGA.
  5. Привод CD-ROM.

Установка программы Painter 8

  1. Вставьте компакт-диск Painter 8 в ваш компьютер.
  2. Запустите Windows, нажмите кнопку Пуск, выберите команду Настройка > Панель управления. На панели управления дважды щелкните на значке Установка\удаление программ. Откроется диалоговое окно Свойство: Установка\удаление программ. Нажмите кнопку Установить. Следуйте инструкциям в диалоговом окне.
  3. В процессе установки раскроется диалоговое окно, в котором можно выбрать параметры установки.
  4. При выборе параметра Typical будет установлен полный пакет программы. Если возможности вашего компьютера соответствуют минимальным требованиям к системным ресурсам, имеет смысл воспользоваться вариантом Compact. При желании установить конфигурацию программы из необходимых вам компонентов выберите Custom.

Для завершения процедуры установки выполняйте дальнейшие команды.

Интерфейс Painter

При открытии Painter 8 на экране появится основное окно, приведенное на рис. 1.1. В нем можно выделить следующие элементы:

  • строка заголовка;
  • главное меню;
  • палитры инструментов.

Рис. 1.1. Основное окно Painter 8

Строка заголовка документа содержит значок [image], открывающий системное меню документа, и стандартные кнопки управления документом [image]:

  • свернуть документ;
  • увеличить или уменьшить размер окна;
  • закрыть документ.

Строка главного меню состоит из стандартных команд, обычно используемых при работе с графическими редакторами:

Каждая из команд открывает собственное меню, с командами которого вы постепенно познакомитесь в процессе освоения Painter.

При открытии Painter на экране нет документа. Его вы должны открыть с помощью команды File > Open (Файл > Открыть) или создать, выбрав File > New (Файл > Новый). Команда File > Open выбирается для уже созданного документа Painter или конвертированного из других программ.

Если вы хотите сразу начать рисовать в новом документе, создайте его, выбрав команду File > New. При этом откроется окно New Picture, представленное на рис. 1.2.

Рис. 1.2. Диалоговое окно New Picture

Вы можете выбрать размеры холста, указав их в соответствующих полях Width и Height (Ширина и Высота) в удобной размерности. Кроме того, вы можете установить требуемое разрешение в поле Resolution (Разрешение) в пикселах на дюйм или на сантиметр. В этом же окне можно выбрать желаемый цвет бумаги для работы. Для этого щелкните в белой области в поле Paper Color (Цвет бумаги), откроется диалоговое окно Цвет, в котором устанавливается нужный цвет. В итоге вы получите лист для работы, с установленными вами параметрами (рис. 1.3).

Рис. 1.3. Рабочая область — окно документа

Окно документа

Итак, у вас открыт документ. Его окно имеет обычные полосы прокрутки, позволяющие перемещать изображение в окне документа в горизонтальном и вертикальном направлениях. Кроме того, на концах полос прокрутки содержатся дополнительные кнопки, с помощью которых можно выполнять некоторые действия, не прибегая к командам меню (табл. 1.1).

Таблица 1.1. Дополнительные кнопки полос прокрутки

Кнопка | Название | Назначение
 | Tracing Paper (Калька) | Делает клонированное изображение прозрачным, подобно кальке, аналогично команде Canvas > Tracing Paper (Холст > Калька)
 | View Grid (Видимая сетка) | Делает видимой сетку для точного расположения композиции
 | Output Preview (Режим промотра) | Открывает режим просмотра документа
 | Enable Impasto (Включить Impasto) | Включает Impasto — эффект «выдавленности»
 | Disable Impasto (Отключить Impasto) | Отключает эффект Impasto
 | Image Information (Параметры изображения) | Выводит параметры графического изображения
 | Draw Anywhere (Рисовать везде) | Позволяет рисовать в любом месте холста
 | Draw Inside (Рисовать внутри) | Позволяет рисовать внутри выделенной области
 | Draw Outside (Рисовать снаружи) | Позволяет рисовать снаружи выделенной области

При нажатии кнопки Image Information поверх открытого документа появляется окно, отражающее параметры документа: ширину, высоту и разрешение (Width, Height, Resolution), расположение его на странице (в виде прямоугольника с диагоналями). Кроме того, серым цветом выделены непечатаемые поля.

Кнопки Draw Inside и Draw Outside появляются при нажатии кнопки Draw Anywhere. Тогда можно выбрать любую из них в зависимости от ваших намерений.

Строка меню содержит команды главного меню, с которыми вы постепенно познакомитесь в процессе работы с Painter.

Палитры

Painter 8 содержит семь основных палитр, открыть которые можно в меню Window (Окно) или комбинацией клавиш. Они представлены на экране при открытии Painter по умолчанию.

Каждая из основных палитр содержит много вложенных палитр. В процессе работы с этой книгой вы постепенно познакомитесь со всеми палитрами. Палитры легко перемещаются по экрану, накладываются одна на другую, убираются за ненадобностью или в целях экономии места для работы с изображением и так же легко открываются. Чтобы убрать палитру, достаточно нажать кнопку [image], комбинацию клавиш, установленную для палитры, или соответствующую команду меню Window (Show — показать или Hide — спрятать).

В Painter имеется несколько типов палитр. Наиболее привычна для пользователей палитра Tools (Инструменты). Она состоит из привычных кнопок с символами инструментов. Ее мы подробно рассмотрим позже. Среди палитр в Painter можно условно выделить простые, состоящие из одной секции, и сложные — из нескольких секций.

Среди простых палитр есть складывающиеся палитры. К ним относится палитра Brushes (Кисти) (рис. 1.4). В ней имеются:

  • главное меню палитры;
  • строка значков;
  • дополнительные меню.

Рис. 1.4. Палитра Brushes

Главное меню палитры содержит обычные ниспадающие меню команд. Строка значков представлена образцами загруженной коллекции.

Собственно коллекцию можно открыть, нажав кнопку со стрелкой, расположенную в центре полосы под строкой значков. Этот способ открытия коллекции образцов будет встречаться часто. Он напоминает открытие ящика письменного стола (см. рис. 1.4). Складываются палитры так же, как и открываются, — с помощью кнопки со стрелкой.

Есть и другой тип простых палитр — они не складываются и устроены подобно обычным диалоговым окнам. Пример такой палитры — Controls (Управление). Обычно простые палитры вложены в сложную.

Сложные палитры устроены однотипно. Такие палитры состоят из секций, содержащих кнопки в виде стрелки слева [image] — для открытия секции, справа [image] — для открытия меню секции. При желании можно открыть все вложенные палитры-секции, правда, при этом раскрытые палитры не помещаются на экране. Чтобы открыть несколько палитр, их нужно выбирать при нажатой клавише Shift. Полоса прокрутки, расположенная справа, предназначена для перемещения по открытым палитрам (рис. 1.5a и 1.5b).

Рис. 1.5a. Сложная палитра Brush Controls в свернутом состоянии

Рис. 1.5b. Сложная палитра Brush Controls в развернутом состоянии; открыты одновременно три секции: General (Главная), Size (Размер), Spacing (Интервал)

Вложенные палитры могут быть складывающимися, как палитра Brushes. Например, палитра Art Materials (Художественные средства) состоит из подобных вложенных палитр-секций (рис. 1.6a, 1.6b и 1.6c).

Рис. 1.6a. Палитра Art Materials в свернутом виде

Рис. 1.6b. Палитра Art Materials в открытом виде

Рис. 1.6c. Палитра Art Materials в открытом виде

Приведенная на рис. 1.6c палитра Art Materials не раскрыта полностью. Не поместившуюся на экране часть можно просмотреть с помощью полосы прокрутки. Если раскрытая палитра не помещается на экране, передвиньте ее немного вверх, ненужные в данный момент закрытые палитры, расположенные выше нее, переместятся вниз.

Наличие кнопки в правой части секции [image] позволяет раскрыть меню секции. Такие кнопки есть в палитрах Art Materials и Object (Объекты).

Палитра управления Controls

Палитра управления Controls — универсальна. Ее вид и функции меняются в зависимости от выбранного средства для работы с графикой. С помощью этой палитры устанавливают дополнительные параметры для выбранного средства. Ее присутствие на экране почти всегда обоснованно. Функции этой палитры невозможно рассматривать в отрыве от графического средства, поэтому мы изучим ее подробно применительно к каждому из средств.

Палитра инструментов

Палитра инструментов (рис. 1.7) содержит средства, обычные для графических программ ( [image] ). Назначение и способы использования их стандартны. Кнопки шести инструментов имеют дополнительные раскрывающиеся панели, о чем свидетельствует маленький треугольник в правом нижнем углу. Чтобы открыть такую дополнительную панель, следует несколько задержать нажатие подобной кнопки (если нажать быстро, как обычную кнопку, то панель не откроется, а просто будет выбран данный инструмент).

Для выбора инструмента в дополнительной панели откройте ее и, удерживая нажатой кнопку мыши, переместите указатель на нужный инструмент. Отпустите кнопку мыши — дополнительная панель закроется, а выбранный инструмент станет текущим в основной панели.

Условно инструменты палитры можно разделить на несколько групп:

  • Инструменты общего назначения.
  • Инструменты, предназначенные для работы с цветом.
  • Инструменты выделения.
  • Регулирующие инструменты.
  • Инструменты создания и редактирования форм.
  • Инструменты для создания объектов.

Рис. 1.7. Палитра инструментов

Инструменты общего назначения

К инструментам общего назначения относятся:

  • Magnifier (Лупа);
  • Grabber (Захватчик);
  • Rotate Page (Поворот страницы);
  • Crop (Обрезка).

Соответствующие им кнопки и их назначение приведены в табл. 1.2.

Таблица 1.2. Инструменты общего назначения

Кнопка | Название | Назначение
 | Magnifier (Лупа) | Изменение масштаба изображения
 | Grabber (Захватчик) | Просмотр фрагментов изображения; дополняет функции полос прокрутки
 | Rotate Page (Поворот страницы) | Поворот изображения под любым произвольным углом
 | Crop (Обрезка) | Вырезание фрагмента изображения прямоугольной формы

С помощью инструмента Magnifier вы можете на время работы над изображением изменить его размеры, однако это никак не отразится на истинном размере изображения. Для возвращения размеров изображения к исходным достаточно двойного щелчка на кнопке этого инструмента.

При выборе инструмента Magnifier палитра управления имеет вид, приведенный на рис. 1.8. В поле Zoom Level (Масштаб) указан текущий масштаб изображения. При щелчке на этом поле открывается список масштабов.

Рис. 1.8. Палитра управления инструмента Magnifier

Два прямоугольника в левой части палитры управления показывают текущий цвет объекта (передний прямоуголышк) и цвет фона (задний прямоугольник). Чтобы поменять цвет фона на цвет объекта и наоборот, нужно нажать маленькую угловую стрелку слева под вторым прямоугольником.

Grabber (Захватчик). С помощью этого инструмента удается гораздо быстрее перемещаться по изображению, чем с помощью полос прокрутки. Для возвращения к исходному положению достаточно щелкнуть на инструменте. Палитра управления при выборе инструмента просмотра Grabber имеет вид, представленный на рис. 1.9. Поле Zoom Level предоставляет возможность просмотреть желаемое изображение в любом масштабе. X и Y соответствуют координатам указателя мыши, который при выборе этого инструмента принимает вид ладони, соответствуя рисунку на кнопке панели.

Рис. 1.9. Палитра управления инструмента Grabber

Rotate Page (Поворот страницы). Этот инструмент расположен на дополнительной панели, открывающейся при задержке нажатия на соответствующей кнопке.

Патитра управления при выборе инструмента Rotate Page представлена на рис. 1.10.

Рис. 1.10. Палитра управления инструмента Rotate Page

Благодаря Rotate Page вы можете установить любой угол поворота с помощью прямоугольника со стрелкой, перемещая его в выбранном направлении (рис. 1.11a). Именно этот угол поворота будет установлен для вашего рисунка (рис. 1.11b). Указатель мыши при этом будет иметь вид указующей руки.

Рис. 1.11a.Установка угла поворота

Рис. 1.11b. Поворот рисунка

Для возвращения рисунка к исходному положению щелкните на нем кнопкой мыши.

Crop (Обрезка). Позволяет вырезать прямоугольный фрагмент рисунка. При выборе этого инструмента указатель мыши принимает крестообразную форму. Перемещая указатель мыши, выделите желаемый фрагмент прямоугольной рамкой (рис. 1.12a). Внутри фрагмента указатель мыши приобретает вид раскрывающихся и закрывающихся ножниц (если ножницы раскрыты, фрагмент вырезан не будет). В результате обрезки в рабочей области остается только вырезанный фрагмент (см. рис. 1.12b).

Рис. 1.12a. Выделение фрагмента с помощью инструмента Crop

Рис. 1.12b. Результат обрезки (справа)

На палитре управления (рис. 1.13) в полях области Ratio (Пропорция) установлено соотношение сторон рисунка, их размеры и положение вырезаемого фрагмента.

Рис. 1.13. Палитра управления инструмента Crop

Инструменты, предназначенные для работы с цветом

Для работы с цветом предназначены инструменты, представленные в табл. 1.3. В дальнейшем мы вернемся к ним и рассмотрим их работу более подробно.

Таблица 1.3. Инструменты для работы с цветом

Кнопка | Название | Назначение
 | Brash (Кисть) | Позволяет рисовать, устанавливает тип рисования: свободное рисование (Freehand strokes) или построение рисунка (Straight line strokes)
 | Dropper (Пипетка) | Позволяет задать цвет объекта путем взятия пробы с желаемого фрагмента
 | Paint Bucket (Заливка) | Позволяет закрашивать выделенные фрагменты как с помощью цвета, так и различными фактурами и заранее созданными рисунками-заполнителями

Brush (Кисть) — один из основных инструментов в Painter. С ним связано несколько панелей и коллекции кистей (подробно об этом инструменте см. главу Настройки инструментов рисования). Обращаем ваше внимание на то, что Brush (Кисть) — это основной рисовальный инструмент. На панели управления можно установить следующие параметры рисования:

  • Draw Style (Стиль);
  • Size (Размер кисти);
  • Opacity (Непрозрачность);
  • Grain (Зерно) — фактура бумаги.

Палитра управления инструмента Brush представлена на рис. 1.14.

Рис. 1.14. Палитра управления инструмента Brush

Стиль рисования устанавливается с помощью переключателей Freehand (Свободное рисование) или Straight Line (Прямолинейный штрих). Установка переключателя Straight line strokes позволяет строить рисунок с помощью прямых линий от точки к точке.

Размер, непрозрачность, зерно изображения устанавливаются перемещением соответствующих ползунков. При этом в полях, расположенных рядом, отражаются числовые значения изменяемых параметров.

Dropper (Пипетка) — инструмент, позволяющий точно установить нужный цвет. Цвет, на который, помещена пипетка, отображается в левой части панели управления (рис. 1.15) на переднем прямоугольнике. Под полем Zoom Level — координаты точки, в которой определяется цвет. В правой части палитры расположены характеристики цвета, влиять на которые с палитры управления нельзя, они задаются с помощью палитры Color (Цвет).

Рис. 1.15. Палитра управления инструмента Dropper

Paint Bucket (Заливка) — инструмент для закрашивания выделенного фрагмента. На палитре управления отображается образец заливки, будь то выбранный цвет, орнамент или текстура (рис, 1.16).

Рис. 1.16. Палитра управления инструмента Paint Bucket

Регулятор Tolerance (Допустимое отклонение) задает допустимое отклонение от выбранного цвета.

Регулятор Feather (Размытость) определяет размеры области плавного перехода. В крайнем левом положении ползунка область плавного перехода отсутствует. По мере перемещения ползунка вправо область плавного перехода расширяется.

Параметр What to Fill (Что заполнять) определяет режим заливки: Image (Изображение) или Cartoon Cel (Окружающий фон).

Раскрывающееся меню Fill With (Чем заполнять) определяет заполнитель: выбранный цвет, градация, клонированное изображение, текстура (плетение).

Флажок Anti-Alias (Сглаживание границы) задает состояние границы между окрашиваемой областью и остальной частью изображения. По умолчанию флажок Anti-Alias установлен, то есть при заливке создается как можно более плавный цветовой переход к незакрашенной части изображения. Для создания контрастной границы снимите флажок Anti-Alias.

Инструменты выделения

Инструменты выделения (табл. 1.4) схожи между собой, поэтому углубляться в тонкости их работы мы не будем. Палитра управления отражает координаты выделяемого фрагмента, цвет фона и объекта, масштаб (рис. 1.17). Действие инструментов выделения очевидно: нажатием кнопки мыши на соответствующем значке инструмент активируется. Перемещением указателя мыши при нажатой клавише Shift по выделяемому объекту очерчивается зона выделения в виде прямоугольника или квадрата, овала или круга.

Таблица 1.4. Инструменты выделения

Кнопка | Название | Назначение
 | Rectangular Selection (Прямоугольное выделение) | Выделяет прямоугольную область
 | Oval Selection (Овальное выделение) | Выделяет овальную область
 | Lasso (Лассо) | Выделяет произвольно отмеченную область
 | Magic Wand (Волшебная палочка) | Выделяет области, близкие по цветовой гамме без предварительного очерчивания границ

При работе с инструментами Rectangular или Oval Selection на панели Controls: Selection фиксируются координаты левого верхнего и правого нижнего углов прямоугольника. Координаты левого верхнего угла обозначены: Т (верх) и L (слева). Координаты правого нижнего угла обозначены: D (низ) и R (справа). Начало координат— левый верхний угол. По разности координат определяются W (ширина) и Н (высота) прямоугольника. При активизации инструмента Oval Selection выделение производится с помощью овала, вписанного в тот же прямоугольник.

Рис. 1.17. Палитра управления инструмента выделения

Если границы области имеют сложную форму, воспользуйтесь инструментом Lasso и очертите границу выделяемой области при нажатой кнопке мыши.

Если вы не замкнули границу с помошью инструмента Lasso, она будет замкнута автоматически по прямой между началом и концом контура.

При работе с инструментом Lasso на панели управления Controls: Lasso в момент начала выделения фиксируются координаты начальной точки, а в момент окончания — координаты конечной точки. Координаты X (абсцисса) и Y (ордината), начало отсчета — левый верхний угол.

Необычно действие только инструмента Magic Wand (Волшебная палочка). Как правило, с помощью инструментов выделения можно выделить только одну область изображения. Исключение составляет инструмент Magic Wand, позволяющий одновременно выделить несколько областей одинакового цвета.

Для выделения фрагмента изображения с помощью инструмента Magic Wand достаточно активизировать его, переместить указатель мыши в нужное место, где он принимает вид волшебной палочки, и нажать кнопку мыши — все однотонные области будут выделены автоматически.

Для расширения выделения проведите по дополнительной области инструментом Magic Wand, удерживая нажатыми клавишу Shift и кнопку мыши.

Для уменьшения выделения проведите по лишней части выделенной области инструментом Magic Wand, удерживая нажатыми клавишу Ctrl и кнопку мыши.

Параметры выделения задаются в контрольной панели Controls: Magic Wand с помощью регуляторов Tolerance (Допустимое отклонение) и Feather (Размытость) и флажка Anti-Alias (Сглаживание границы) (рис. 1.18).

Рис. 1.18. Палитра управления инструмента Magic Wand

Регулятор Tolerance (Допустимое отклонение) задает допустимое отклонение от цвета в точке выделения. В крайнем левом положении регулятора, когда допустимое отклонение равно нулю, выделяется минимальная пиксельная группа, в пределах которой установлен указатель мыши. По мере перемещения бегунка вправо область выделения расширяется и может охватить все изображение.

Регулятор Feather (Размытость) определяет размеры области плавного перехода от выделяемой части к остальному изображению. В крайнем левом положении регулятора область плавного перехода отсутствует. По мере перемещения регулятора вправо область плавного перехода расширяется.

Флажок Anti-Alias (Сглаживание границы) задает состояние границы между выделяемой областью и остальной частью изображения.

В области Destination (Назначение) выбирается назначение инструмента, поскольку он может использоваться как для выделения (Selection), так и для создания маски (User Mask). При установке переключателя Selection (Выделение) очерчивается граница выделенной области. При установке переключателя User Mask (Использовать маску) выделенная область окрашивается в красный цвет. Действие параметра Anti-Alias лучше наблюдается при установленном переключателе User Mask.

С помощью инструмента Magic Wand можно выделять несколько пиксельных групп, состоящих из одинаково окрашенных соприкасающихся пикселов. Чтобы выделить несколько групп одинаково окрашенных пикселов для всего изображения, необходимо нажать и не отпускать в процессе выделения комбинацию клавиш Ctrl+Shift. Для возврата к одной выделенной пиксельной группе достаточно повторить выделение без участия клавиш Ctrl+Shift.

Регулирующие инструменты

Назначение и функции регулирующих инструментов, представленных в табл. 1.5, будут рассмотрены в процессе работы с объектами Painter. В Painter представлены два типа объектов: растровые (пиксельные) и векторные (контурные). К векторным относятся выделения и формы. К растровым — маски и слои (Layers). Различие этих объектов и их особенности мы рассмотрим в дальнейшем.

Таблица 1.5. Описание регулирующих инструментов

Кнопка | Название | Назначение
 | Layers Adjuster (Регулятор слоев) | Управление плавающими объектами и формами
 | Selection Adjuster (Регулятор выделения) | Выделение и управление выделением
 | Shape Selection (Управление формой) | Выделение и управление формами

Инструменты для работы с векторными объектами

Все нижеперечисленные инструменты предназначены для работы с векторными объектами. В табл. 1.6 представлены инструменты, с помощью которых векторные объекты создаются.

Таблица 1.6. Инструменты создания векторных объектов

Кнопка | Название | Назначение
 | Pen (Перо) | Рисование прямых линий и кривых Безье
 | Quick Curve (Быстрая кривая) | Свободное рисование формы
 | Rectangular Shape (Прямоугольная форма) | Создание объектов прямоугольной и квадратной формы
 | Oval Shape (Овальная форма) | Создание овальных и круглых форм
 | Text (Текст) | Создание текстовых форм

Действие практически всех инструментов очевидно. Остановимся лишь на работе с текстом. Как мы уже говорили, текст в Painter относится к векторным объектам, а именно является так называемой формой.

Все основные параметры шрифта выбираются в контрольной панели Controls: Text (рис. 1.19). Стиль шрифта устанавливается с помощью списка Font (Шрифт). Помимо шести гарнитур из этого списка можно воспользоваться множеством других, открыв список Choose fonts (Другие шрифты) (рис. 1.20). Кегль (размер шрифта) определяется параметром Point Size (Размер точки). Нужный размер шрифта устанавливается с помощью одноименного ползунка и отображается в поле, расположенном рядом. Параметр Tracking (Интервал) определяет межсимвольный интервал. Установив параметры шрифта, вводите текст с клавиатуры.

Рис. 1.19. Палитра Controls: Text

Рис. 1.20. Диалоговое окно Choose Font

Подробно функции инструментов создания и редактирования форм мы рассмотрим в главе 15.

В табл. 1.7 собраны инструменты для редактирования векторных объектов.

Таблица 1.7. Инструменты редактирования векторных объектов

Кнопка | Название | Назначение
 | Scissors (Ножницы) | Вырезание выделенного фрагмента
 | Add Point (Добавить точку) | Добавление контрольной точки
 | Delete Point (Удалить точку) | Удаление контрольной точки
 | Convert Point (Преобразовать точку) | Изменение формы объекта путем перемещения контрольной точки

Другие палитры

Как мы уже говорили, Painter содержит множество палитр-секций, открывающихся из основных палитр. Устройство палитр однотипно. Далее, в главе Настройки инструментов рисования, мы рассмотрим устройство таких палитр на примере палитры Brush Controls (Управление кистью). Разобравшись с одной палитрой, вы без труда сможете пользоваться остальными.

Простейшие действия

Во время рисования, впрочем, как и в процессе редактирования, неизбежны ошибки. Как и в любом другом программном продукте, в Painter предусмотрен режим отмены.

Режим отмены

Режим отмены предусматривает только пять отменяемых действий, выполненных до последнего сохранения. Он включается выбором команды Edit > Undo (Правка > Отмена) или комбинацией клавиш Ctrl+Z (что гораздо удобнее и быстрее).

Можно изменить установки и увеличить число возможных отмен до 32. Для этого выполните следующие действия:

  1. Выберите команду Edit > Preferences > Undo (Правка > Установки > Отмена). Откроется диалоговое окно Undo Preferences (Установки отмены) (рис. 1.21).
  2. Введите с клавиатуры требуемое количество отмен, нажмите кнопку ОК.

Рис. 1.21. Диалоговое окно Undo Preferences

При этом необходимо иметь в виду, что чем больше отмен вы устанавливаете, тем больше памяти идет на запоминание этих действий. К сожалению, сложная многоуровневая работа сама по себе занимает изрядное количество памяти, и вы, следовательно, проигрываете в быстродействии. Поэтому, единственное, что можно посоветовать: почаще сохраняйтесь. С помощью комбинации клавиш Ctrl+S это не так долго.

Удаление

Чаще всего приходится пользоваться ластиком — Eraser. Хотя это может показаться хлопотным, но не более хлопотно, чем пользоваться обычной резинкой. Для этого достаточно выбрать Eraser (Ластик) в списке палитры Brush. В соседнем списке будет предложено на выбор несколько различных резинок разного размера и качества.

Помимо стирания можно выделить фрагмент средствами выделения и удалить его. При желании можно удалить, предварительно выделив, всю работу, выбрав команду Select > All (Выделить все) или нажав комбинацию клавиш Ctrl+A, а затем выбрав Edit > Clear (Правка > Очистить).

Работа с линейкой, сеткой и ориентиром

Для точной кропотливой работы в Painter есть свои приспособления:

  • Rulers — линейки;
  • Grid — сетка;
  • Guides — ориентиры.

Назначение этих приспособлений очевидно — все они предназначены для точного расположения изображений на холсте. Каждое из них имеет одноименную команду в меню Canvas.

Чтобы установить или убрать линейки, выберите команду Canvas > Rulers > Show/Hide Rulers (Холст > Линейки > Показать/Спрятать линейки). Выбрав команду Ruler Options (Параметры линейки), установите удобную размерность (пикселы, дюймы, сантиметры, точки, пики) (рис. 1.22a).

Рис. 1.22a. Установлены линейки

Ориентиры — дополнительные прямые, параллельные краю страницы и взаимно перпендикулярные. Их можно установить сколько угодно в любом нужном месте.

Чтобы установить ориентиры, выберите команду Canvas > Guides > Show/Hide Guides (Холст > Ориентиры > Показать/Спрятать ориентиры). Теперь достаточно выбрать точку на линейке, и появится линия из выбранной точки до противоположного края страницы. Можно создать ряд параллельных ориентиров, можно добавить перпендикулярные к ним линии (см. рис. 1.22b).

Рис. 1.22b. Установлены ориентиры

Еще одним удобным средством является сетка. Она накрывает изображение как калька, слегка сглаживая его детали (рис. 1.23a и 1.23b). При этом становится удобнее обводить контур изображения, не отвлекаясь на детали. Сетку можно использовать и как ориентир. Чтобы установить сетку, выберите команду Canvas > Grid > Show/ Hide Grid (Холст > Сетка > Показать/Спрятать сетку).

Рис. 1.23a. Исходное изображение

Рис. 1.23b. Изображение с установленной сеткой

Вы можете выбрать шаг сетки, удобный для каждого отдельного случая. Для этого предназначено диалоговое окно Grid Options (Параметры сетки) (рис. 1.24), открываемое одноименной командой меню Canvas. С помощью этого окна можно установить только вертикальные или горизонтальные линии, их цвет и цвет фона, покрывающего изображение листа, толщину линий сетки и ее прозрачность.

Рис. 1.24. Диалоговое окно Grid Options


Создание, открытие и сохранение документа

  • Создание нового документа
  • Открытие документа
  • Изменение размеров рабочей области
  • Формат документа
  • Сохранение документа
  • Особенности графических форматов
    • Формат TIFF
    • Формат EPS
    • Формат TARGA
    • Формат PCD
    • Формат PC Paintbrush
    • Формат BMP
    • Формат PICT
    • Формат PDF
    • Формат Microsoft Video для Windows
    • Формат GIF
    • Формат JPEG
    • Формат PNG

Чтобы работать с изображением, необходимо сначала его создать. Создать изображение можно, что называется, «с нуля» или с чистого листа, то есть просто начать рисовать в пустом документе, предварительно создав его

Создание нового документа

Для создания нового документа в Painter выбирается команда File > New (Файл > Новый) или комбинация клавиш Ctrl+N. При этом открывается диалоговое окно New Picture (Новая картинка) (рис. 2.1). В нем вы можете установить размеры рабочей области для рисования — Canvas Size (Размер холста), которые определяются полями Width (Ширина) и Height (Высота). Величины вводятся в соответствующее поле с клавиатуры.

Рис. 2.1. Диалоговое окно диалога New Picture

Нажав кнопку рядом с полем, можно выбрать удобную размерность: пикселы, дюймы, сантиметры, точки, пики, строки.

В поле Resolution (Разрешение) устанавливается нужное разрешение в пикселах на дюйм или сантиметрах на дюйм.

Можно установить цвет бумаги, на которой вы собираетесь печатать создаваемое изображение, щелкнув на поле Paper Color (Цвет бумаги). Откроется диалоговое окно Цвет (рис. 2.2), содержащее палитру базовых и дополнительных цветов, окно подбора цвета. Цвет устанавливается перемещением значка в виде перекрестья [image].

Рис. 2.2. Диалоговое окно Цвет

Кроме того, в окне New Picture, вы можете установить точные характеристики визуально выбранного цвета в цветовой модели палитр RGB и HSL (оттенок, контраст, яркость).

В нижней части окна в разделе Picture type (Тип картинки) следует установить переключатель, определяющий тип изображения: Image (Изображение) или Movie with (В движении), то есть обычное изображение или предназначенное для анимации. По умолчанию установлен переключатель Image. Создавая изображение для анимации, необходимо указать номер кадра в поле Frames (Рамки). После установки всех параметров нажмите кнопку ОК. На экране будет открыт чистый холст установленных вами размеров.

Открытие документа

Для открытия документа в Painter, как и везде, выбирается команда File > Open (Файл > Открыть) или комбинация клавиш Ctrl+О. При этом открывается окно Select Image (Выбор изображения) (рис. 2.3), в котором представлен обычный каталог папок. В верхнем поле Папка представлены уровни вложенности папок.

Рис. 2.3. Диалоговое окно Select Image

С помощью кнопки На один уровень вверх вы можете изменять уровень каталога для поиска нужной папки.

В нижнем поле представлен один уровень каталога. Когда вы достигнете уровня файла и выделите нужный, его имя появится в поле Имя файла. Файл, сохраненный в формате RIF, виден в окне просмотра (см. рис. 2.3). Если он сохранен в другом формате, окно просмотра останется пустым. Если вы точно помните название искомого файла и его местоположение, можете сразу ввести его с клавиатуры в поле Имя файла и нажать кнопку Открыть. Тогда он будет найден автоматически.

Кнопка Создание новой папки позволяет организовать новую папку в каталоге для изображений.

Кнопка Browse (Просматривать) служит для просмотра имеющихся документов, сохраненных в формате RIF.

Две следующие кнопки Список и Таблица по-разному представляют каталог: одна в виде списка, что удобно для просмотра всего уровня каталога, другая — в виде таблицы с указанием размера файла и даты его создания, что может облегчить вам поиск.

Установленный флажок Open numbered Files (Открыть пронумерованные файлы) позволяет открывать пронумерованные файлы для редактирования анимации.

Изменение размеров рабочей области

Для изменения размеров имеющегося изображения выберите команду Canvas > Resize (Холст > Изменить размер). Откроется диалоговое окно Resize (Изменение размера) (рис. 2.4).

Рис. 2.4. Окно Resize

В области Current Size (Текущий размер) окна Resize отображаются исходные размеры холста, в области New Size (Новый размер) расположены поля, предназлаченные для изменения параметров. Причем при изменении одного из размеров другой автоматически устанавливается пропорционально.

На рис. 2.5 приведено исходное изображение, на рис. 2.6 его размер увеличен. При этом размер рабочей области не изменяется.

Рис. 2.5. Изображение в рабочей области исходного размера

Рис. 2.6. Размер изображения увеличен, рабочая область осталась прежней

Для увеличения размеров рабочей области достаточно нажать кнопку увеличения размера рабочей области [image].

Тогда рабочая область перемещается в середину экрана, и полосы прокрутки перемещаются в стандартное положение (рис. 2.7).

Рис. 2.7. Размер изображения увеличен, рабочая область раскрыта полностью

Размеры рабочей области можно увеличить, добавляя дополнительное пространство с любой стороны и даже со всех вместе. На рис. 2.8 приведено изображение, к которому добавлена рамка из незаполненного холста. Для этого выберите команду Canvas > Canvas Size (Холст > Размер холста).

Рис. 2.8. Добавление незаполненного пространства к изображению

Откроется диалоговое окно Canvas Size, в разделе Current Size которого приведены действующие размеры изображения (рис. 2.9).

Рис. 2.9. Окно Canvas Size

В разделе Adjust Size (Установка размера) предусмотрены четыре поля ввода Add (Добавить) для добавления дополнительного пространства по всем сторонам: сверху, снизу, справа и слева.

Формат документа

Работа с графическими файлами имеет свои особенности. Первая проблема, с которой вы столкнетесь, — необходимость переносить документ из одного графического приложения в другое.

Каждое из них имеет свой формат. Например, изображение отсканировано и получило определенный формат, далее требуется улучшить его четкость, яркость и другие характеристики. На следующем этапе вы решите перенести его в Painter для добавления различных эффектов. Возможно, вы захотите придать изображению 3-D эффект, для чего опять перенесете его в соответствующее графическое приложение. Затем вы решите его отправить в Web или подготовить для печати. Каждый из этих случаев требует своего формата.

Painter поддерживает форматы, представленные в приведенной ниже табл. 2.1.

Таблица 2.1. Форматы, поддерживаемые Painter

Формат | Расширение
RIFF — собственный формат Painter | RIF
Tagged Image File Format | TIFF
Encapsulated PostScript | EPS
TARGA | TGA
Kodak PhotoCD | PCD
PC Paintbrush | PCX
Windows Bitmap | BMP
Macintosh PICT Files | PCT
Frame Stacks — собственный анимационный формат Painter | FRM
Pyramid Images | PYR
Microsoft Video для Windows Audio Video Interleaved | AVI
Graphics Interchange Format | GIF
Joint Photographic Experts Group | JPG

Для открытия документов, созданных в Adobe Illustrator, предусмотрена специальная команда File > Acquire > Adobe Illustrator File (Файл > Приобрести > Adobe Illustrator файл), открывающая окно Adobe Illustrator File (рис. 2.10).

Рис. 2.10. Окно Adobe Illustrator File

Для получения файла со сканера или цифровой камеры выберите команду File > Export (Файл > Отправить).

Сохранение документа

Работая с графикой, важно помнить, что своевременное сохранение документа позволит вам избежать повторных действий и безрезультатных потерь времени. Однако учитывая, что графические документы занимают большой объем памяти, их следует записывать на дополнительных устройствах, таких как магнитооптические диски, компакт-диски, переносной жесткий диск и т. д.

Рекомендуется одновременно делать две копии: если по техническим причинам одну вы не сможете прочесть, у вас останется вторая.

СОВЕТ. На каждом значительном этапе работы над документом сохраняйте его под разными именами или с номерами копий, регистрируя в заметках к ним, какой этап работ был осуществлен в документе.

Для сохранения документа в Painter, как и в других программах, выберите команды File > Save (Файл > Сохранить) (или комбинацию клавиш Ctrl+S) или File > Save as (Файл > Сохранить как). В результате чего откроется стандартное окно сохранения документа Save Image As (Сохранить изображение как) (рис. 2.11), в котором вы должны определить место сохранения документа в дереве каталога и его имя.

Рис. 2.11. Диалоговое окно сохранения документа

Чтобы зафиксировать этап работы, выберите команду Get Info (Получить информацию) или комбинацию клавиш Ctrl+l. Откроется диалоговое окно File Information (Информация о документе), предназначенное для введения информации о данном документе (рис. 2.12).

Рис. 2.12. Окно File Information

Обычно, сохраняя документ с помощью команды File > Save или File > Save as, вы сохраняете его в формате, установленном по умолчанию, то есть в собственном формате Painter — RIF. Однако во многих ситуациях приходится использовать и другие графические форматы.

Особенности графических форматов

Работая в Painter, вы можете использовать файлы разных форматов (см. табл. 2.1). Однако это далеко не все существующие графические форматы.

ПРИМЕЧАНИЕ. Если документ не открывается в Painter, его можно открыть и сохранить в каком-либо универсальном формате, поддерживаемом почти всеми графическими приложениями. А затем уже сохраненное в универсальном формате изображение открыть в Painter.

При выборе промежуточного универсального формата следует руководствоваться прежде всего, соображением максимального сохранения качества изображения.

ВНИМАНИЕ. Один и тот же файл занимает разный объем памяти в разных программах. К сожалению, в разных программах один и тот же формат выглядит по-разному. Это связано с различными методами записи данных в этих программах. На этот факт вы повлиять не в силах, об этом просто нужно знать.

При сохранении изображения могут быть использованы различные форматы в зависимости от поставленных задач. Для печати в цвете используются одни, для передачи изображения по телевидению или в рекламе — другие, для представления в Web, видео — третьи. Ниже мы рассмотрим в общих чертах возможности наиболее распространенных форматов.

Формат TIFF

Формат TIFF (Tagged Image File Format) — один из самых распространенных и доступных графических форматов. Он задуман как универсальный и открытый, то есть постоянно обновляемый и развиваемый формат, кроме того, он может применяться для создания графических приложений. TIFF поддерживается операционными системами Macintosh и IBM PC, а также большинством UNIX-подобных платформ. Он имеет многоканальную организацию передачи цвета и сохраняет все параметры растрового изображения.

Формат TIFF позволяет сохранить изображение в одной из двух цветовых систем — RGB или CMYK (рис. 2.13). Особенностью этого формата является существенное уменьшение размера файла без потери качества.

Рис. 2.13. Окно определения цветового пространства при сохранении в формате TIFF

С помощью данного формата в Painter осуществляется цветоделение. При сохранении документа, предназначенного для печати, в формате CMYK TIFF Painter производит цветоделение в автоматическом режиме. Вы не можете вмешаться в этот процесс, а результат виден только при печати.

Кроме того, Painter не открывает документ, сохраненный в формате CMYK TIFF. Если вас не удовлетворил результат цветоделения, исправить его в Painter будет нельзя. Поэтому всегда сохраняйте копии документа в Painter. Проводимое автоматическое цветоделение можно отнести к разряду пробного. На самом деле, цветоделение — это своего рода искусство, поэтому лучше предоставить его специалистам. Только цветоделение, произведенное ручным способом в Adobe Photoshop, позволит сохранить качество работы при офсетной печати.

Формат EPS

EPS (Encapsulated PostScript) — один из наиболее распространенных графических форматов, используемых для печати. Он поддерживается большинством графических программ и почти всеми широко используемыми программами верстки, такими как Quark Xpress, Corel Ventura, Adobe PageMaker, FrameMaker. Формат EPS поддерживает цветовые модели RGB и CMYK.

Сохранение в формате EPS включает установку параметра DCS (document color separation — цветоделение документа), что позволяет экспортировать CMYK-изображение в программы, предназначенные для верстки (см. главу 4). Кроме того, при сохранении документа Painter в формате EPS DCS загружаются профили ICC для создания гексахромного цветоделения (рис. 2.14). При этом к цветам CMYK добавляются оранжевый и зеленый цвета.

Рис. 2.14. Диалоговое окно при сохранении в формате EPS

СОВЕТ. Документ, сохраненный в формате EPS и TIFF, открыть для редактирования нельзя. Если вы решили сохранить документ в этом формате для выведения на печать с цветоделением, обязательно сохраните его копию в исходном формате RIF. Для открытия такого документа следует выбрать универсальный формат, поддерживаемый Painter, например TARGA (TGA).

Формат TARGA

Формат TARGA (TGA) также поддерживается большинством графических программ и программ верстки. Как и TIFF, для передачи цветного изображения TARGA использует дополнительные альфа-каналы. Но в TGA в отличие от TIFF в дополнение к трем стандартным каналам имеется информационный альфа-канал. Поэтому качество цветопередачи в TGA безусловно выше. Благодаря этому свойству TGA широко используется для передачи телевизионного изображения.

Формат PCD

PCD — формат Photoshop. Он поддерживает все виды графики как цветной, так и монохромной, многоканальность цветопередачи, а также дополнительные пользовательские альфа-каналы. Он может содержать количество слоев, ограниченное только техническими параметрами вашего компьютера. К сожалению, формат PCD поддерживается пока небольшим числом графических программ.

При сохранении в нем изображения, созданного в Painter, векторная графика форм (Shapes) становится растровой, плавающие объекты (floaters) переносятся в слои, а маски организуются в каналы для оптимальной цветопередачи.

Итак, TIFF, EPS, TGA, PCD — наиболее распространенные общие графические форматы, используемые для печати изображения. В трех из них, кроме EPS, применяется многоканальная организация передачи цветного изображения.

Формат PC Paintbrush

Формат PCX (PC Paintbrush) был создан и применялся ранее для графического редактора PC Paintbrush. В дальнейшем он был использован для создания других графических приложений, и следовательно, стал открытым и непрерывно обновляется. Однако он имеет значительные ограничения в цветопередаче, не поддерживает многоканальной организации изображений. Поэтому применяется в основном для изображений в монохромной графике, градациях серого и индексированных цветах.

Формат BMP

BMP (Windows Bitmap) является графическим форматом Microsoft. Он широко используется независимо от среды, то есть является универсальным и постоянно обновляется, так как используется для создания других приложений. Но, так же как и PCX, BMP имеет ограничения в цветопередаче и не поддерживает многоканальной организации изображений. Спектр применения этого формата такой же, как и PCX, — монохромная графика, градации серого и индексированные цвета.

Формат PICT

Формат PICT (MacPict Files) — графический формат Macintosh. Он широко распространен, поддерживается большинством программ графики и верстки, является универсальным и открытым. Кроме того, часто размер файла, сохраненного в формате PICT, меньше, чем в других, так что он еще и экономичен. Многоканальность и цветовая модель CMYK не поддерживается.

Формат PDF

PDF (Portable Document Format) — переносимый формат документов, созданный фирмой Adobe System. Он создан для использования в качестве универсального формата, не зависящего от платформ и приложений. Изначально он задумывался как формат, в котором можно продемонстрировать любой документ, cозданный в каком-либо приложении, без установки самого приложения. Это большое удобство. Для работы с ним нужна лишь бесплатная программа Acrobat Reader.

Первоначально PDF создавался как электронный формат с удобной системой позиционирования и перемещения в документе. Кроме того, файлы, сохраненные в PDF, компактнее, то есть занимают меньший объем памяти, поэтому быстрее передаются по сети.

Многие издатели пытаются приспособить этот формат для использования в печатном процессе и небезуспешно. Для представления графических изображений PDF вполне подходит, однако он использует смешанные цвета, которые не разделены, как требуется в традиционных печатных процессах, что усложняет его внедрение. Но PDF — широко развиваемый и перспективный формат. Вероятно, очень скоро этот формат можно будет использовать не только для просмотра, но и для вывода на печать, электронные носители, для создания ссылок на страницах Интернета, для мультимедиа.

Формат Microsoft Video для Windows

Формат Microsoft Video для Windows, или AVI (Audio Video Interleaved), — мультимедийный файловый формат. Позволяет синхронизировать сохраняемый звук и изображение. Возможность формата AVI сжимать файлы позволяет значительно уменьшить их размер.

Формат GIF

Формат GIF (Graphics Interchange Format) был разработан в качестве простого графического формата для распространения информации в Интернете. Он является безубыточным форматом, то есть при сохранении в нем потери информации не происходит и качество изображения не страдает. При этом архивация и разархивация файла происходят автоматически. Однако этот формат поддерживает индексированные цвета, что обычно достаточно для передачи изображения в Web. Поэтому если сохраняемое вами изображение организовано более сложно или вы планируете напечатать изображения, полученные по Web, то вряд ли качество их будет удовлетворять вас.

Формат GIF поддерживает модели градации серого и битовую (Bitmap). Однако из-за ограниченности цветовой палитры этот формат не рекомендуют использовать для передачи фотографий и 24-битовых RGB цветных изображений.

Формат JPEG

JPEG (Joint Photographic Experts Group) — формат, предназначенный для сжатия файлов. Он широко используется для передачи сложной растровой графики и фотографий по Web. Сжатие файлов может происходить как с потерей данных, так и без нее. Однако эффективность сжатия зависит от характера изображения, а не от способа сжатия. Метод сжатия без потерь эффективен для растровой графики, содержащей большие области повторяющихся узоров или однотонной окраски. При этом может достигаться коэффициент сжатия 10 : 1. Для сложных фотографических изображений, не содержащих больших однотонных фрагментов или повторяющихся узоров, метод сжатия без потерь зачастую не дает ожидаемых результатов. Метод сжатия с потерями больше подходит для сохранения изображения, не содержащего однотонных или повторяющихся фрагментов.

В отличие от GIF, JPEG сохраняет сложно организованную цветовую информацию, за исключением многоканальности. Кроме того, он позволяет быстро и экономично передать цветную графику по Web с получением приемлемого результата. В настоящее время существует прогрессивная улучшенная модификация JPEG, значительно ускоряющая передачу изображения с возможно максимальным сохранением его качества.

Формат PNG

Формат PNG (Portable Network Graphics) становится преемником GIF. Он сжимает информацию на 25% сильнее. Сохраняет информацию о цвете объемом 48 бит. При этом три байта используются для хранения информации о цветах R, G, В, а четвертый байт — для хранения информации о самом изображении. Возможность лучшего сжатия информации при сохранении ее качества реализована с помощью системы многочисленных фильтров.


Цвет и разрешение

  • Цветовые модели
    • Цветовая модель RGB
    • Цветовые модели HSV, HSB, HSL
    • Цветовая модель CMYK
    • Модель Grayscale
    • Модель CIE Lab
    • KCMS
    • Системы сопоставления цветов
  • Немного о фракталах
  • Разрешение
    • Векторная графика
    • Растровая графика
  • Разрешающая способность изображения
  • Первичные элементы изображения и разрешающая способность технических устройств

Цветовая палитра Painter наиболее проста и интуитивна среди графических программ, использующих аналогичные модели

Приступая к работе с компьютерной графикой, пользователь неизбежно сталкивается с вопросом воспроизведения цвета. Эту проблему можно условно разделить на две части:

  • соответствие зрительного образа созданному на компьютере или введенному в него со сканера или цифрового фотоаппарата;
  • соответствие образа, созданного на экране компьютера, выводимому на печать.

Следует отдать должное разработчикам этой замечательной программы. Они учитывали, что Painter предназначен для профессиональных художников — творческих людей, которым вникать в техническую сущность вопроса цветопередачи проблематично. Поэтому создатели Painter постарались максимально облегчить работу с программой. Они включили в Painter самонастраивающиеся plug-in программы подбора цветов.

Для максимального расширения возможности цветопередачи естественных цветов на экране используется программа одной из лидирующих в вопросах подбора цветов фирм — Kodak. Эта программа осуществляет автоматический подбор цвета с помощью системы KCMS, о которой мы также расскажем в этой главе.

Программа PANTONE® HEXACHROME (TM) Colors используется для упрощения вывода сложного графического документа на печать и максимально близкого автоматического подбора соответствия цветов экрана и отпечатанного варианта документа. Однако следует иметь в виду, что перед выводом изображения на печать потребуется его дополнительная обработка в программе Photoshop. Об этом мы расскажем в следующей главе, посвященной вопросам печати (см. главу 4).

Если вы не новичок в работе с графическими программами или хорошо владеете программой Photoshop, то изложенная нами информация вряд ли будет вам полезна. Если же вы только вступили на тернистый путь создания компьютерной графики, сведения, приведенные в данной главе, вам наверняка пригодятся.

Вопросы, связанные с разрешением (Resolution) изображения и технических средств, будь то сканер, принтер или монитор, также вызывают некоторую путаницу. Поэтому они также будут рассмотрены нами. Информация, приведенная здесь, не претендует на исчерпывающее изложение. Передача и воспроизведение цвета может быть темой отдельной книги для специалистов соответствующего технического уровня, не говоря уже о проблемах разрешающей способности изображения и устройств ввода и вывода. Возможно, у вас останутся неясными некоторые вопросы, но обязательно разберитесь с этой проблемой с помощью любых доступных вам книг и пособий.

Цветовые модели

С детства мы знаем о том, что существуют три основных цвета — крон, кармин, кобальт, а попросту, желтый, красный, синий, с помощью которых можно получить все прочие цвета. Это и есть первая цветовая модель, с которой мы знакомимся сознательно.

Однако есть и другая цветовая модель, с которой мы знакомы с младенческого возраста, только не знаем об этом. Это модель, с помощью которой наши зрительные рецепторы сетчатки глаз и мозг воспринимают цвет. Как принято считать, это модель состоит из других цветов: красного, зеленого, синего, или Red, Green, Blue, по первым буквам которых — RGB — названа эта модель. Именно этой цветовой моделью воспользовались ученые, создавая экран компьютера, отображающего цвета, и с этой моделью вам придется иметь дело. Таким образом, с помощью трех основных, или базовых, цветов можно получить множество цветов. Эти цвета называют аддитивными, так как все прочие цвета получаются путем их сложения или комбинации.

Цветовая модель RGB

Итак, мы выяснили, что цветовая модель человеческого зрительного анализатора и экрана компьютера близки, тем не менее возможности их различны. Глаз может различать гораздо больше цветов, чем воспроизводит компьютер. Возможностей компьютера вполне достаточно для воспроизведения миллионов цветов и оттенков. Компьютер использует 8 бит памяти (28) для воспроизведения каждого из основных цветов. А совокупность трех базовых цветов обеспечивает 224 цветов, что составляет около 16,7 млн.

Проблема цветопередачи состоит в следующем. Цветоощущение человека основано на восприятии волн света различной длины, отражающихся или поглощающихся поверхностью различных объектов. А устройство экрана компьютера таково, что волны различной длины испускаются люминофорами — светящимися элементами экрана. В результате цвет предмета, на который мы смотрим, и его же цвет в рисунке на компьютере — не одно и то же, даже если длины волн в точности соответствуют друг другу.

Цветовые модели HSV, HSB, HSL

Естественным желанием разработчиков любого программного обеспечения является увеличение его интуитивности для облегчения освоения. С этой целью были созданы цветовые модели HSY, HSB, HSL. Они основаны на RGB и действительно упрощают подбор цвета. Эти модели почти идентичны, последняя буква в их названиях — практически один и тот же параметр — яркость или светлость.

Устройство нашего цветового анализатора таково, что он усредняет исходные длины волн и мы видим результат этого процесса. Эта характеристика цвета называется цветовой тон (Hue).

Даже при беглом взгляде на предмет любой человек со здоровым зрением может сказать, какого он цвета. Например, глядя на летний лес, можно сразу сказать, что преобладает зеленый цвет, но сколько оттенков этого цвета в нем! Притом что свет, отраженный или поглощенный поверхностью однотонного предмета, может иметь разную длину волн, большая часть поверхности отражает близкие длины волн.

Другой характеристикой цвета является насыщенность (Saturation). Она характеризует количество доминирующей длины волны (степень чистоты цвета) в тоне.

Высокая насыщенность цвета характеризуется преобладанием волн основного тона. Низкая насыщенность приближает тон к нейтральным цветам, таким как серый, белый, черный. Таким образом, насыщенность характеризует соотношение основного и нейтрального (серого) цветов в тоне. Она выражается в процентах: 0 % — серый цвет, 100 % — полностью насыщенный цвет.

При низкой насыщенности, то есть приближенной к серому, становится актуальной следующая характеристика цвета — яркость (Brightness).

Абсолютно ярким принято считать белый цвет — 100 %. Полное отсутствие яркости — 0 % — черный цвет, промежуточные значения яркости — серый цвет. Яркость является нелинейной величиной.

Цветность (Chromacity или Chroma) — комплексная характеристика цвета. Она представляет собой цветовой тон и его насыщенность одновременно. В некоторых цветовых моделях она используется в качестве аналога цветового тона.

Светлость (Lightness) — цветовая характеристика, близкая к яркости, отличающаяся от нее линейностью.

Иногда характеристики цветность и светлость используются совместно.

Цветовая палитра Painter, приведенная на рис. 3.1 и основанная на модели HSV, наиболее проста и интуитивна среди графических программ, применяющих аналогичные модели. Она использует все те же три характеристики: цветовой тон (Hue), насыщенность (Saturation) и величина (Value) — показатель, характеризующий яркость цвета.

Рис. 3.1. Цветовой сортировщик Painter

Цветовая модель CMYK

Но есть цветовые модели, в которых все прочие цвета могут быть получены путем вычитания одного цвета из другого. Такие цвета и модели называют субтрактивными.

Подобной цветовой моделью является CMYK. Она была создана для объектов, цвет которых обусловлен отраженными волнами, а именно для воспроизведения цвета при цветной печати. В основе этой модели лежит допущение, что белый лист бумаги полностью отражает цвет, а область, на которую нанесен краситель, частично поглощает цвет пропорционально количеству нанесенного красителя. При смешивании нескольких красителей отражающая способность листа снижается — это значит, что цвет как бы исключается из сочетания. В этой модели отсутствие цвета — белый цвет, а смешение трех основных цветов — черный.

Основными цветами в этой модели являются в отличие от RGB вторичные цвета, то есть полученные в результате смешивания: Cyan (голубой), Magenta (пурпурный), Yellow (желтый) и Black (черный). Однако чтобы избежать путаницы в обозначении последнего компонента, решено было заменить букву В буквой К. Необходимость использования дополнительного черного пигмента связана с тем, что смешение основных красителей в действительности не дает абсолютно черного цвета — он получается в разной степени коричневатым. Поэтому для улучшения цветового воспроизведения введен дополнительный черный цвет.

При печати краситель наносится на бумагу точками определенного размера. Смешанные цвета — это иллюзия, которую создают расположенные рядом точки разных цветов.

Диапазоны цветов, полученных с помощью палитры RGB и CMYK, различны. На рис. 3.2 приведена стандартная диаграмма цветности, взятая нами из фейнмановских лекций по физике. Она построена с помощью уравнения: Х=аА+ЬВ+сС, где А, В, С — основные цвета (красный, зеленый, синий); а, Ь, с — количества основных цветов. В тех же координатных осях построены диаграммы цветности для моделей RGB и CMYK.

Рис. 3.2. Сопоставление цветовых охватов RGB, CMYK, Lab

Как видите, зона цветов видимого спектра и зона цветов, создаваемых с помощью палитры RGB, не совпадают, а зона, создаваемая с помощью палитры CMYK, еще меньше.

Для выбора цветового соответствия при печати используются различные средства. Во многих графических программах при подборе цветов есть зоны, при выборе которых программа предупреждает о несоответствии цветов этих цветовых моделей. В этом случае вам следует выбрать наиболее близкий к первому, но разрешенный, совпадающий в обеих палитрах цвет. Однако даже совпадение цветов палитр не решает проблемы до конца, так как цвета CMYK на экране и на печати оказываются различными из-за люминофорного строения экрана.

Модель Grayscale

Эта цветовая модель используется для черно-белой печати и сканирования изображений на черно-белых или полутоновых сканерах. В модели Grayscale различные оттенки серого задаются с помощью разного процентного содержания двух цветов — черного и белого. Каждый пиксел полутонового черно-белого изображения характеризуется значением яркости, изменяющимся в диапазоне от 0 (черный) до 255 (белый). Яркость оттенка серого может быть интерпретирована как процентное содержание черной краски (0 % — белый и 100 % — черный).

Значение серого цвета может быть выражено также в терминах других цветовых моделей. В модели RGB оттенок серого цвета соответствует равному количеству всех трех основных компонентов, в CMYK — нулевым значениям компонентов С, М и Y и положительному значению компонента К, в HSB — нулевым значениям компонентов Н и S и положительному значению компонента В.

Модель CIE Lab

Именно проблема несоответствия цветов, связанная с аппаратными средствами, заставила искать новые возможности для ее преодоления. В итоге была выработана модель CIE Lab.

В ее основе лежит модель, созданная ранее в качестве международного стандарта измерения цветов для международной комиссии по освещению CIE (Commission International del Eclairage). В дальнейшем она была усовершенствована и получила название CIE Lab. Эта цветовая модель включает в себя как пространство RGB, так и CMYK. Она предложена как аппаратно-независимая модель (device independent). Это значит, что цветопередача, установленная с помощью этой модели, не подвержена искажениям, связанным с техническими средствами.

С помощью данной модели специалисты создают стандартные библиотеки цветов, используя которые вы можете сравнить диапазоны устройств ввода и вывода. Это нужно для обеспечения соответствия цветов, передаваемых сканером, компьютером и принтером. Также эта модель используется в цветоизмерительных приборах, таких как спектрофотометры и колориметры.

В некоторых графических программах, в том числе Adobe Photoshop, модель Lab используется для осуществления взаимного конвертирования между моделями RGB и CMYK.

Основные параметры модели Lab — L (lightness) (яркость и цветность), представленная двумя составляющими: а — от зеленого до красного и b — от синего до желтого.

Диаграмма цветности, построенная для модели Lab, практически полностью совпадает с зоной цветов видимого спектра. Все три модели — Lab, RGB и CMYK (см. рис. 3.2), имеют перекрывающиеся цветовые диапазоны (цветовой охват). Однако из-за различия исходных цветовых компонентов, используемых при описании этих моделей, а также различных физических принципов формирования цветовых оттенков диапазоны воспроизводимых этими моделями цветов будут отличаться.

Цветовой охват (Color Gamut) — это диапазон цветов, который может различать человек или воспроизводить устройство независимо от механизма получения цвета — излучения или отражения.

Среди цветовых моделей самым широким цветовым охватом обладает модель Lab (см. рис. 3.2). Она включает в себя цветовые диапазоны моделей HSB, RGB и CMYK, которые являются как бы подмножествами цветов модели Lab. Это самая перспективная модель, как считают эксперты, и за ней большое будущее.

Цветовой охват модели RGB составляет подмножество цветов, которые могут быть воспроизведены на экране телевизора или монитора (излучающего красный, зеленый и синий свет). Некоторые цвета, такие как чистый голубой или чистый желтый, не могут быть точно воссозданы на экране.

Самым узким цветовым охватом характеризуется модель CMYK — она воспроизводит только те цвета, которые могут быть напечатаны с помощью триадных красок. Об экранных цветах, не воссоздающихся при печати, говорят, что они лежат вне цветового охвата модели CMYK. Под цветами, лежащими вне цветового охвата триады CMYK, понимаются цвета, которые могут быть представлены в других цветовых моделях, но при этом не имеют печатных аналогов в цветовом пространстве CMYK.

При переходе к модели CMYK от любой другой цветовой модели программа автоматически настраивает цвета, лежащие «вне CMYK», в соответствии с возможностями триады CMYK. Это действующая реальная модель, позволяющая получать, при должной технической подготовке, оттиски приличного качества. И если Lab — дело будущего, то CMYK — реальность, с которой необходимо научиться работать.

KCMS

KCMS (Kodak Color Management System) — модель, использовавшаяся первоначально для работы с изображениями Photo CD. На основе модели Lab компанией Kodak было разработано цветовое пространство YCC, в котором составляющая Y управляет яркостью, а оси СС являются цветовыми составляющими. Поскольку модель Lab обладает самым большим цветовым охватом, то и ее производное — YCC также имеет наиболее полный диапазон цветов.

Фирмы Kodak и Digital Stock Corporation, компания-распространитель коллекций Photo CD, рекомендуют модель KCMS и программу, поддерживающую ее, как средство достижения наилучшего качества печати. Изображения, созданные с использованием KCMS, перед печатью автоматически преобразуются в цветные файлы CMYK.

KCMS интегрирована в программное обеспечение Painter. Это гарантирует адекватность воспроизведения отсканированного, экранного и выведенного на печать изображений. К вопросу настройки KCMS мы вернемся в главе 4.

Системы сопоставления цветов

Все вышеизложенные способы не смогли решить проблему точной передачи цвета полностью. И все же было найдено компромиссное решение, которое позволяет компьютерным художникам мирно сотрудничать с печатниками, воспроизводящими их работы. Это решение состоит в создании системы сопоставления цветов.

Каждая система сопоставления цветов включает в себя эталонную таблицу цветов, выполняющих функции палитры. Изготовление эталона требует тщательного контроля. Каждому цвету присваивается свое уникальное имя и указывается тип пигмента или состав смеси из различных пигментов, необходимых для его создания. Указывается также тип бумаги, соответствующий данному пигменту. В дополнение к этой таблице, используемой как справочник, пользователь получает образцы цветов, которые можно вырезать и прикрепить к изображению. Это позволяет точно указать печатнику и заказчику, какой цвет предполагается получить.

Система сопоставления цветов обеспечивает точный визуальный контроль. Вы можете выбрать цвет в изображении и сопоставить его с образцом, взятым из эталонной таблицы.

ВНИМАНИЕ. Существует система сопоставления цветов и система управления цветами, предназначенная для согласования данных, представленных в цветовой модели одного устройства, с данными для цветовой модели другого устройства. Это необходимо для адекватного преобразования цвета из одной модели в другую. Например, из RGB-модели для монитора в CMYK-модель для принтера.

Иногда в качестве синонима системы управления цветами используется также термин сопоставление диапазонов цветов.

Система управления цветами ориентирована на монитор. Учитывая ограничения, определяемые выходными характеристиками конкретного принтера, можно отрегулировать способ отображения изображения (например, с помощью приложения Color Managerment — Диспетчера цветов) таким образом, чтобы изображение на экране монитора близко соответствовало изображению, которое будет получено при печати (точное соответствие принципиально невозможно из-за различной физической природы синтеза цветовых оттенков на экране и на бумаге — аддитивной и субтрактивной). В связи с этим система управления цветами базируется на мониторе, демонстрирующем возможности принтера или фотонаборного устройства.

Для дизайнерских разработок обычно используется палитра, соответствующая системе сопоставления цветов, выбранной для конкретного проекта, и для которой имеется полная уверенность, что напечатанный цвет будет соответствовать цвету определенной ячейки палитры. Следует регулярно обновлять альбомы образцов цветов, поскольку выцветание ооразцов может повлиять на правильность выбора цвета.

Палитры PANTONE

Это одна из самых больших и полных систем сопоставления цветов. Она первой получила международный статус системы стандартизации цветов и пока остается доминирующей на рынке полиграфической продукции. Система сопоставления цветов PANTONE возникла задолго до того, как она стала использоваться в качестве цветной электронной палитры при создании компьютерных изображений. Во многих современных программах графики электронные палитры соответствующих систем сопоставления цветов поставляются вместе с высококачественными копиями цветовых каталогов:

  • PANTONE Process Colors (PANTONE триадные цвета);
  • PANTONE MATCHING SYSTEM Colors (PANTONE плашечные цвета);
  • PANTONE HEXACHROME Colors (PANTONE шестицветная система).

Компьютерный вариант палитры PANTONE Process Colors содержит более 3000 различных типов триадных цветов, каждый из которых попадает в области цветового охвата монитора и принтера. Все они созданы на основе модели CMYK.

Первые 2000 цветов представляют собой двухцветные комбинации, остальные — трех- и четырехцветные комбинации. Поскольку все цвета палитры основаны на модели CMYK, при печати изображений, созданных с помощью этой палитры, не требуется дополнительных слоев цветоделения.

Компьютерный вариант палитры PANTONE MATCHING SYSTEM Colors включает свыше 220 плашечных цветов.

Плашечные цвета воспроизводятся с помощью специальной технологии, базирующейся на использовании для каждого цвета соответствующего ему уникального красителя (чернил). Поскольку они не прозрачны, то отражают свет поверхностным слоем.

Это позволяет добиться воспроизведения очень ярких тонов и специальных эффектов типа металлизации и иризации (перелива оттенков при разных углах
зрения).

Компьютерный вариант палитры PANTONE HEXACHROME Colors введен в Painter. Эта палитра базируется на цветовой модели CMYK, но дополнительно к ее четырем цветам она использует два новых цвета; зеленый (G) и оранжевый (О). Это позволяет существенно расширить диапазон воспроизводимых цветов при офсетной печати и заметно поднять качество цветопередачи.

Полиграфисты, занимающиеся подготовкой и изданием красочных буклетов по живописи, и специалисты в области рекламы, чьи доходы напрямую связаны с воздействием цветных публикаций на покупателя, уже давно имеют претензии к стандартной модели CMYK из-за относительно узкого диапазона воспроизводимых цветов. При четырехцветной печати можно получить достаточно реалистичные красные цвета, но невозможно добиться ярких розовых, синих, фиолетовых и многих других цветов. Но даже те цвета, которые хорошо воспроизводятся с помощью этой модели, часто оказываются недостаточно насыщенными.

По этой причине была разработана новая технология воспроизведения цвета, получившая известность как HiFi Color. К настоящему времени создано несколько вариантов HiFi Color. Их обшей чертой является расширение используемой при цветовой печати гаммы цветов за счет добавления новых цветов к четырем цветам CMYK. Наряду с рассмотренной шестицветной системой PANTONE® HEXACHROME (TM) Colors, использующей два дополнительных цвета — зеленый и оранжевый, реализованы и другие системы. Так, в системе HiFi Color 3000 фирмы LinoTipe-Hell для получения ярких красных, зеленых и синих цветов используются семь цветов (три аддитивных цвета модели RGB и четыре субтрактивных — модели CMYK).

При выборе с помощью палитр PANTONE цветовой ячейки соответствующие ей значения компонентов цвета могут быть отображены одновременно с помощью двух цветовых моделей из приведенного списка: RGB, HSB, CMYK и Lab.

Немного о фракталах

Фракталы — это удивительные геометрические объекты, долгое время почему-то остававшиеся незамеченными. Даже в воображении математиков фракталы появились сравнительно недавно, около ста лет назад. В действительности фракталы буквально окружают нас. Фракталы — это то, что подобно самому себе. Их трудно точно измерить с помощью циркуля или линейки, клеток или кубиков. Примерами подобных объектов могут быть береговые линии, русла рек, облака, горы, овраги, ветви деревьев, наросты кристаллов, то есть все ветвящееся и самоподобное.

Определяющее свойство самоподобной геометрической фигуры состоит в том, что её можно разрезать на конечное число одинаковых фигур, подобных исходной. Разумеется, самоподобие в природе допускает случайные отклонения.

Самоподобие, то есть повторение объекта в бесконечной последовательности масштабов, приводит к тому, что фракталы обладают дробной размерностью. Что такое дробная размерность?

Известно, что самый простой способ измерить длину кривой — аппроксимировать ее прямолинейными отрезками. Чем короче отрезки, тем выше точность. Если попытаться измерить длину обыкновенной линии с помощью циркуля или линейки, то по мере уменьшения раствора циркуля или цены деления линейки в пределе получаем постоянную величину, которая принимается за длину линии.

С фрактальной кривой не так. По мере уменьшения масштаба измерений результат меняется, длина фрактальной кривой увеличивается до тех пор, пока цена деления не станет соизмеримой с толщиной линии. Получается, что длина фрактальной линии бесконечна, поскольку линия повторяет сама себя. Таким образом, фрактальная кривая — это уже не линия, но еще и не поверхность. Она обладает переходной, то есть дробной, размерностью. Такой же результат даст измерение площади фрактальной поверхности или объема трехмерного фрактального тела. В этих случаях получится также дробная размерность.

Этим занимается фрактальная геометрия. Сам термин фрактал был введен в 1975 голу родоначальником этого направления в математике Бенуа Б. Мандельбротом при описании множеств, тогда же и была применена дробная размерность.

Сначала построение фрактальных моделей производилось с учебной целью для наглядности описываемого процесса. Однако авторы, поразившись красоте получаемых компьютерных изображений, стали создавать модели для всех описываемых фрактальных процессов. В конце концов, устроили выставку изображений, которая неожиданно имела огромный успех у ненаучной публики, и даже несколько раз издали альбомы с изображениями моделей фрактальных процессов. Вот тогда-то и возникла идея создания графического продукта на основе моделей фрактальной геометрии.

Фракталы в изобразительном искусстве — это отдельная тема. Даже простые фрактальные рисунки всегда привлекают к себе внимание, не говоря об изображениях с более сложной фрактальной геометрией.

Использование фрактальной математики в графических редакторах открыло новую страницу в компьютерной графике. Удивительная способность фрактальных объектов очень естественно имитировать рельеф земной поверхности, скопление облаков или переплетение ветвей привела к созданию поразительных фрактальных пейзажей, изображающих фантастические фрактальные миры.

В притягательности фрактальной геометрии вы можете убедиться, работая с пакетом графических программ Meta Creation, где фрактальная геометрия присутствует как в текстуре бумаги, так и в рисунке, сделанном кистью, пастелью, карандашом или любым другим инструментом.

На рис. 3.3 приведена иллюстрация модели множества Мандельброта. Рисунок 3.4 демонстрирует эффект увеличения разрешающей способности (иллюстрации фрактальной геометрии заимствованы из книги «Красота фракталов» X. О. Пайтген, П. X. Рихтер).

Рис. 3.3. Иллюстрация множества Мандельброта

Рис. 3.4. Иллюстрация эффекта увеличения разрешающей способности

Ярким примером использования фрактальной геометрии являются фильтры KPT — Kais Power Tools, входящие в комплект поставки Painter 8.

Разрешение

Вопросы, связанные с таким понятием, как разрешение, как правило, вызывают путаницу.

Дело в том, что, работая с компьютерной графикой, мы сталкиваемся с несколькими вариантами разрешения:

  • разрешение сканера или цифрового фотоаппарата;
  • разрешение компьютера;
  • разрешение принтера.

Эти три типа разрешений порождают определенные проблемы, с которыми необходимо разобраться.

Как известно, изображение, воспроизводимое монитором компьютера, является цифровым. Цифровые изображения подразделяются на два типа — векторные и растровые.

Векторная графика

Векторные изображения создаются с помощью так называемых примитивов — прямых, кривых, прямоугольников, окружностей и других геометрических элементов, создаваемых с помощью векторов и описываемых соответствующим математическим аппаратом. Векторную графику называют также объектно-ориентированной, так как файл изображения формируется из дискретных, не связанных между собой элементов изображения.

Качество изображений, полученных с помощью векторной графики, не зависит от разрешающей способности аппаратного обеспечения, поэтому вы можете менять его размеры без потери общего количества элементов и четкости линий. Кроме того, изображения, созданные с помощью векторной графики, легко перемещаются. При их создании используются также цветовые заливки довольно сложных рисунков и цветовых сочетаний.

Поскольку векторные изображения очень четко передают линии и текст, они чаше применяются при использовании в изображениях множества символов разных размеров, необходимости четкости линий и т. д. Например, при создании логотипов и технических иллюстраций векторная графика практически незаменима. Векторная графика представлена в Painter формами Shapes. К ним же относится и текст. Однако, поскольку большая часть изображения в Painter создается растровыми средствами, векторные элементы при подготовке к печати должны быть превращены в растровые. Этот процесс называется растрированием.

Но в связи с ограничением параметров регулирования изображения, таких как освещенность и фокусировка, невозможно получить сложные фотореалистичные образы, используя только программы векторной графики.

Представителями векторных графических программ являются Corel Draw, Adobe
Illustrator и Macromedia Freehand.

Растровая графика

Растровая графика создается следующими способами:

  • сканирование изображения;
  • с дискет цифрового фотоаппарата;
  • с помощью растровых графических программ.

Растровое изображение состоит из маленьких цветных квадратных элементов, называемых пикселами. Размер их в растровом изображении на экране меньше 1/72 дюйма.

Конечно, пикселы можно различить при сильном увеличении изображения (рис. 3.5), однако в обычном состоянии они составляют равномерное фотореалистичное изображение.

Рис. 3.5. Фрагмент растрового изображения при значительном увеличении

Каждый такой элемент имеет свои координаты в сетке экрана: по горизонтали — ряд. по вертикали — колонка.

Растровая графика позволяет воспроизводить сложные графические эффекты, такие как освещенность, прозрачность, глубина резкости. Поскольку в растровой графике не используется математический аппарат, то при ее создании задаются размеры изображения и разрешение.

Особенно большую проблему в растровых программах представляет текст. Он не поддается обычному редактированию, так как с буквой связан и фон, поэтому нельзя просто вставить или удалить букву. Кроме того, буквы, состоящие из пикселов, получатся недостаточно качественными при печати. Для улучшения их необходимо высокое разрешение, что займет большой объем памяти.

Создавая изображение в любой графической программе, следует иметь в виду ее назначение и возможности. Дело в том, что Painter не предназначен для создания монументальных произведений, которые могли бы быть выведены на широкоформатных печатных устройствах. Это связано со свойством растровых изображений. Любой круглый предмет при сильном увеличении становится многоугольником. Поэтому такие изображения, очевидно, лучше доводить в векторной программе, так как векторные изображения масштабируются без проблем.

Разрешающая способность изображения

Разрешающей способностью изображения (resolution) принято считать количество пикселов изображения на линейный дюйм, например 72 пиксела на дюйм (pixel per inch — ppi), или размеры изображения, выраженные в пикселах, например, 640 х 480 пикселов.

Если установлено разрешение 72 ppi, это значит, что каждый квадратный дюйм изображения будет состоять из количества пикселов, равного 72 х 72 = 5184, а изображение с разрешением 300 х 300 = 90 000 пикселов.

ВНИМАНИЕ. Пиксел не имеет определенного размера, он является элементом памяти, содержащим сведения о цвете. Но при выводе изображения на каком-либо выводящем устройстве, например мониторе или принтере, он приобретает реальный размер, определяемый разрешающей способностью устройства вывода.

Когда изображение сканируется, его разрешение определяется разрешающей способностью сканера. Если это фотография, ее разрешение соответствует разрешающей способности цифрового фотоаппарата, с помощью которого получено изображение.

Разрешение изображения напрямую связано с размером файла, так как каждый пиксел занимает определенный объем памяти, например для черно-белого изображения — 1 бит, для режима градации серого — 8 бит, цветное изображение в RGB — 24 бита. Зная разрешение, можно подсчитать размер файла изображения. Для этого нужно: количество пикселов изображения умножить на объем памяти, занимаемый одним пикселом, и разделить все это на 8. Например: 300 х 300 х 24 : 8 = 270 000.

На каждом этапе обработки изображения важна разрешающая способность. Качество получаемого изображения находится в прямой зависимости от его разрешающей способности. Чем выше разрешение, тем выше качество изображения. Но, как мы уже выяснили, чем выше разрешение, тем больший объем памяти вовлекается в процесс обработки изображения и тем медленнее будет идти сам процесс работы над ним. Чаще всего компьютерным художникам приходится пользоваться следующей тактикой. Работа над проектом ведется в версии с низким разрешением, что получается значительно быстрее. Затем, когда получилось то, что вы хотели, создается версия с высоким разрешением (см. главу 5).

Painter позволяет записывать отдельные сеансы с низким разрешением, а затем вы можете автоматически изменить разрешение на высокое.

Первичные элементы изображения и разрешающая способность технических устройств

Как вы уже поняли, основным кирпичиком компьютерного графического изображения является пиксел. Он является единицей измерения, принятой в компьютерной графике. Однако встречаются и другие термины: точка, элемент. Подчас кажется, что это синонимы. Но это не совсем так. Эти термины используются на разных этапах получения изображения.

Так, при сканировании изображения устанавливается линейное разрешение, то есть задается количество цифровых элементов, создаваемое сканером на дюйме изображения.

Разрешающая способность сканера определяется в точках на дюйм (dots per inch — dpi). Сканер просматривает изображение, анализирует его и присваивает каждой точке определенное место в условной сеточной структуре.

Физическая разрешающая способность монитора определяется максимальным количеством отдельных точек в одной горизонтальной строке, которые он может генерировать. Она измеряется числом точек в одной горизонтальной строке и числом этих строк, и зависит от размеров и качества монитора.

Реализация этой разрешающей способности зависит от видеокарты, установленной на компьютере, и программного обеспечения, поддерживающего работу данного устройства.

Многие модели мониторов позволяют менять фиксированные значения разрешения: 640 х 480, 1024 х 768, 1280 х 1024, 1600 х 1200. Но разрешающая способность монитора — это возможность создать вам комфортные условия для лучшей работы и, к сожалению, она не влияет на результат, полученный при печати.

ВНИМАНИЕ. Разрешающая способность монитора никак не связана с разрешением самого изображения.

Разрешающая способность принтера определяется количеством точек, которые принтер может напечатать на одном дюйме, то есть также в точках на дюйм (dots per inch — dpi).

Для того чтобы избежать путаницы в терминологии, следует иметь в виду, что понятие точки зависит от типа устройства. Точки, определяющие разрешение принтера, совсем не те, что определяют разрешение сканера.

Изображение, создаваемое для печати в типографии, будут выводить на печатном станке. При этом изображение также создается из множества точек, которые складываются в полутона. В процессе печати полутона перекрываются, создавая нужное изображение. Точки, составляющие полутон, расположены не хаотично, а организованы в линии или строки.

Количество строк на дюйм в полутоне называется линейным растром (line screen) или экранной частотой и измеряется в линиях или штрихах на дюйм (line per inch — Ipi).

На практике линейный растр зависит от бумаги и типа печатной машины. Чем выше линейный растр, тем более качественным получится изображение.

ВНИМАНИЕ. Как правило, разрешение изображения, предназначенного для типографской печати, должно быть в 2 раза выше его экранной частоты.

Разрешающая способность неплохого настольного принтера 720, однако это не количество линий на дюйм. Такой принтер осуществляет печать с линеатурой около 100 Ipi. А слабый принтер с разрешающей способностью 300 при печати дает 60 Ipi. Таким образом, разрешение изображения устанавливается в каждом случае в зависимости от устройств вывода. Для предварительного просмотра в домашних условиях — 120 ppi или 200 ppi соответственно установленному принтеру. Если вы предполагаете печатать изображение типографским способом на печатной машине с линейным растром 150 Ipi, то его разрешающая способность должна быть вдвое выше, то есть, 300 ppi.

Однако не все так однозначно. При высоком разрешении возникают свои проблемы. При разрешении, не согласованном с экранным растром печатной машины, изображение может потерять глубину и стать плоским из-за чрезмерной «набитости», то есть слишком большого количества точек в линии изображения.

К проблемам связи разрешения монитора и принтера с печатным изображением мы вернемся в главе 4.


Печать

  • Полутона
  • Печать векторных и растровых объектов в Painter
  • Подготовка к печати
    • Последние настройки
  • KCMS
    • Настройка профилей устройств
  • Представление о цветоделении
  • Параметры печати

Процесс печати очень сложен и требует опыта и терпения. Он может свести к нулю всю проделанную вами работу

В процессе печати изображение формируется из мельчайших точек, называемых полутонами. Точки всех четырех цветов CMYK (голубой, пурпурный, желтый и черный), расположенные под определенным углом для каждого цвета, имеют различную величину и находятся очень близко друг к другу. Именно из них создается все богатство цветовой гаммы, которую мы видим на печати.

Определенный угол расположения цветов нужен в связи с тем, что для осуществления печатного процесса используются четыре печатные формы — по одной для каждого цвета CMYK. Нанесение цвета происходит по очереди, сначала один цвет, затем другой и т. д. Если точки полутонов будут располагаться одна под другой и на желтую точку будет нанесена пурпурная точка, а на нее голубая, то получится просто грязь. Установлено, что для получения качественного изображения эти точки должны быть расположены под определенным углом друг к другу.

Для создания печатной формы используется пленка для каждого из цветов. Причем изображение вначале разделяется на четыре цвета. Это называется цветоделением. Затем для каждого из цветов на фотонаборной машине создается пленка, выполненная в градации серого. В типографии по каждой из пленок создается печатная форма, соответствующая цвету. На каждую из печатных форм наносится нужный цвет. Когда все цвета нанесены под правильным углом друг к другу с правильным интервалом, мы видим непрерывный цвет с бесконечным числом оттенков.

Однако на качество полученного изображения влияет экранная частота, распространение краски на бумаге — так называемый шаг точки, и, безусловно, качество бумаги.

Полутона

Итак, создаваемое изображение состоит из мельчайших точек — пикселов, которые и формируют полутон. Число полутонов на дюйм изображения определяется частотой экрана: чем она выше, тем лучше изображение. Однако на печати это уже не совсем так. Имеет значение размер полутона. Оказывается, точки большего размера дают на печати больше градаций серого, чем полутона меньшего размера. А полутон тем меньше, чем больше экранная частота. Таким образом, увеличивая экранную частоту, мы тем самым уменьшаем количество градаций серого. Кроме того, количество градаций серого напрямую связано с разрешением принтера. Дла определения градаций серого в изображении используется формула:

(РП/ЭЧ) х 2 + 1,

где РП — разрешение принтера (в dpi), ЭЧ — экранная частота (в Ipi).

Так, поскольку разрешение принтера ограничено его параметрами, при увеличении экранной частоты изображение не станет лучше и количество градаций серого уменьшится.

Чтобы понять, как связано изображение с качеством бумаги, на которой оно печатается, рассмотрим простой пример. Всем знакома газетная бумага — она очень пористая. Если на ней печатать изображение с большой экранной частотой, оно получается мутным и размытым. Поэтому для газетной бумаги чаще используется экранная частота 80-90 Ipi, для печати книг — 100-133 Ipi, журналов - 133-150 Ipi.

Минимальное допустимое разрешение принтера при печати легко можно установить: РП = 2 х ЭЧ.

Таким образом, при экранной частоте 133-150 Ipi минимально допустимое разрешение принтера должно быть 300 ppi. Однако для окончательной установки экранной частоты рекомендуем посоветоваться со специалистами типографии, в которой будут печататься ваши изображения.

Печать векторных и растровых объектов в Painter

В отличие от многих других дизайнерских программ, таких как CorelDraw и Adobe Illustrator, имеющих дело с векторной графикой, в Painter представлена как векторная, так и растровая графика.

Векторная графика представлена в Painter в виде форм (Shape). Формы созданы на основе построения математических линий (кривых и прямых). Их контуры и размеры можно легко изменять. Формы могут быть залиты только сплошным цветом. При применении к ним действий, свойственных растровым объектам, они автоматически растрируются. На этапе подготовки к печати векторные объекты должны быть растрированы.

Растровая графика представлена в виде плавающих объектов (Layer), состоящих из пикселов. Плавающие объекты должны быть совмещены между собой с помощью транспарантного или композитного методов. Кроме того, на итоговой стадии подготовки изображения к печати плавающие объекты должны быть опущены на холст, что осуществляется выбором команды Layer > Drop (Слой > Опустить) в меню панели Objects (Объекты).

СОВЕТ. Помните, что всегда следует оставлять копию работы с не опущенными на холст объектами на случай, если к изображению придется вернуться.

Когда форма перекрывается плавающим объектом, она должна быть растрирована корректно и совмещена удобным для вас методом, но если вы не уверены в удачном выборе совмещения и хотели бы посмотреть, как ваше изображение будет выглядеть на печати, имеет смысл клонировать изображение и печатать клон, а не оригинал (см. главу 7).

Подготовка к печати

Соответствие качества изображения на экране выведенному на печать зависит от следующих причин:

  • цветовой настройки сканера;
  • цветовой настройки монитора;
  • цветовой настройки принтера.

Мы уже говорили о несоответствии цветовых моделей RGB и SMYK. Кроме этого, принтеры и мониторы имеют различные диапазоны цветов. Каждый монитор, сканер или принтер имеет собственный цветовой диапазон.

Безусловно, качество печати зависит от монитора и видеокарты компьютера, а также принтера. Но и это еще не все. Практически все современные устройства снабжены системами калибровки цвета, позволяющими улучшить качество цветопередачи с помощью настроек и свести проблему несоответствия цветов к минимуму.

В большинстве случаев калибровка монитора производится средствами программно-аппаратного обеспечения. К ним относятся: ColorSync компании Apple, обеспечивающий все компьютеры Macintosh, Colorific компании Kodak, устанавливаемый на мониторы Philips, и др.

Система калибровки, как правило, позволяет согласовать работу всех трех устройств — сканера, монитора и принтера. При этом ваша роль сводится к минимуму: вы устанавливаете параметры устройств в диалоговых окнах настройки, а компьютер сам производит калибровку экрана в соответствии с ними.

Такие программные продукты, как Painter и Adobe Photoshop, предусматривают в своем составе средства для согласованной работы монитора и принтера.

Одной из самых передовых и, несомненно, удачной системой настройки цветопередачи является KCMS. О ней мы расскажем ниже.

Последние настройки

Итак, ваша работа готова к печати. Необходимо внести последние настройки:

Выберите команду Effect > Tonal Control > Correct Colors (Эффект > Управление тоном > Корректировать цвет). Откроется диалоговое окно Color Correction (Цветовая коррекция) (рис. 4.1).

Рис. 4.1. Диалоговое окно Color Correction

Ползунки Brightness (Яркость) и Contrast (Контрастность) служат для настройки соответственно яркости и контрастности изображения. При этом можно изменять параметры каждого из трех цветов RGB. Переключая цвет с помощью соответствующих кнопок, настраивайте яркость и контрастность, ориентируясь на изменения в изображении. В заключение нажмите кнопку ОК. Если итог вас не удовлетворяет, отмените установки, нажав кнопку Reset (Сброс), и, не закрывая окна, попробуйте сделать их снова. Нажатие кнопки Cancel (Отменить) не только отменит установки, но и закроет окно.

В действительности настройка яркости и контрастности изображения производится с помощью Dynamic layers — динамических слоев, о которых мы будем говорить подробно в главе 16 и главе 17. Painter создает прозрачный слой поверх изображения; затемняя или осветляя его, мы изменяем яркость и контрастность.

Закончив с первой настройкой, выберите команду Effect > Tonal Control > Adjust Colors (Эффект > Управление тоном > Регулировка цвета). Откроется окно Adjust Color (Регулировка цвета) (рис. 4.2), в котором настройка цвета производится изменением параметров модели HSV с помощью перемещения соответствующих ползунков и использования просмотрового окна Preview (Просмотр).

Рис. 4.2. Окно Adjust Color

Если вы не удовлетворены предыдущей настройкой, выберите команду Effect > Tonal Control > Adjust Selected Colors (Эффект > Управление тоном > Регулировка выбранных цветов). Открывшееся окно Adjust Selected Colors (Регулировка выбранных цветов) (рис. 4.3) позволяет осуществить более сложную настройку. Однако все эти настройки сугубо субъективны и осуществляются визуально.

Рис. 4.3. Окно Adjust Selected Colors

Целесообразна дополнительная настройка яркости и контрастности для изображения в целом, потому что Painter, по свидетельству многих пользователей, в некоторых случаях затемняет печатаемое изображение. Конечно, вы освоите на практике все этапы настройки, и только тщательное наблюдение и опыт позволят вам добиться превосходных результатов.

Выберите команду Effect > Tonal Control > Brightness/Contrast (Эффект > Управление тоном > Яркость\Контрастность). Перемещением ползунков в раскрывшемся окне Brightness/Contrast (Яркость\Контрастность) (рис. 4.4) установите нужные параметры.

Рис. 4.4. Диалоговое окно Brightness/Contrast

Соотношение темных и светлых тонов можно изменять с помощью гистограммы диалогового окна Equalize (Выравнивание).

Для его раскрытия выберите команду Effect > Tonal Control > Equalize (Эффект > Управление тоном > Выравнивание).

Смещая к центру белый ползунок под гистограммой (рис. 4.5), вы добавляете в изображение светлые тона, черный ползунок — темные тона.

Рис. 4.5. Рабочая область Painter с окном Equalize

Изменение тонов происходит за счет перемещения предепьных точек черного и белого цветов и перераспределения яркости в соответствии с их новыми значениями. Также можно регулировать яркость с помощью расположенной ниже шкалы Brightness, перемещая ползунок в нужную сторону.

KCMS

Painter 8 поддерживает систему KCMS (Kodak Color Management System, см. главу 3), которая контролирует согласованность действий сканера, монитора и принтера на всех этапах обработки изображения. Это своего рода корректор калибровки. Дело в том, что KCMS использует ICCDSP — стандартные цветные профили устройств (сканера или фотокамеры, монитора и принтера). Цветные профили самых популярных моделей введены в систему, их около двадцати. Ваша задача сводится к тому, чтобы выбрать используемые устройства в списке. При отсутствии их в списке свяжитесь с техническими представителями фирм-изготовителей, с тем чтобы они снабдили вас нужной информацией. Если подобным образом вашу проблему решить не удалось, предлагается ввести усредненные параметры для ваших устройств.

Таким образом, KCMS позволяет выполнять аппаратно-зависимую коррекцию цветов изображения для печати. При этом вам удается повлиять на результат выполнения этой настройки. Кроме того, вы можете увидеть, как будет выглядеть ваша работа в напечатанном на конкретном принтере виде до осуществления самой печати.

Перед проведением настройки следует иметь в виду несколько правил:

  • Если в вашем распоряжении имеется несколько систем калибровки монитора, например, компьютер Мас с системой ColorSync, мониторы Philips с системой Colorific и Painter или Adobe Photoshop, допустимо использование только одной из них.
  • Протрите экран монитора. Он достаточно интенсивно притягивает пыль из воздуха и затемняет экран.
  • Отрегулируйте с помощью ручек яркость и контрастность экрана.

Сама по себе настройка незначительно влияет на цвета экрана монитора, но очень важна для изображений при выводе на печать в формате SMYK. Это особенно важно, если планируется цветоделение, даже если вы сами не собираетесь этим заниматься.

Настройка профилей устройств

KCMS интегрирован в Painter и загружается автоматически. Установка профилей рабочих устройств, которые вы используете, осуществляется следующим образом:

  1. Выберите команду Canvas > Output Preview > Kodak Color Correction (Холст > Режим просмотра > Kodak Color коррекция).
  2. Выберите команду Canvas > Color Management (Холст > Параметры просмотра). Откроется диалоговое окно Select Profiles (Выбрать профиль) (см. рис. 4.6).
  3. В раскрывающемся списке Input Profile (Вводящий профиль) выберите используемое вами устройство ввода изображения. Если изображение не вводилось, а создавалось, оставьте None (Нет).
  4. Таким же образом выберите в раскрывающемся списке устройств вывода Output Profile (Выводящий профиль) используемый вами принтер.
  5. Если в процессе работы вы изменили свои намерения и решили воспользоваться другим принтером, не забудьте изменить установку Output Profile.
  6. Выберите нужный монитор в списке Monitor Profile (Профиль монитора).
  7. Установите флажок Show Gamut Warning (Показывать опасный цветовой охват) для возможности предварительного просмотра. Это позволит увидеть, попадает ли все ваше изображение в гамму принтера, на котором вы собираетесь выводить его. Именно так, как отображается на экране, будет выглядеть в напечатанном виде ваша работа (рис. 4.7).

Рис. 4.6. Окно Color Management

Рис. 4.7. Изображение в режиме предварительного просмотра: проблемные области окрашены сплошным серым цветом

Чаще всего после настройки профилей изображение практически не меняется, может быть, становится более или менее ярким, темным или светлым в зависимости от установленных устройств. Но иногда часть изображения бывает окрашена нормально, а часть — в ярко-зеленый цвет. Нормально окрашенные зоны совпадают с цветовым профилем вашего принтера, но с зонами ярко-зеленого цвета возникнет проблема при выводе на печать. Рекомендуется подобрать более приемлемый вариант, перемещая ползунок по шкале Warning Opacity (Предупреждение непрозрачности).

На рис. 4.7 представлено изображение, только частично попадающее в гамму принтера. Иногда это может означать, что настройки сделаны дважды, то есть откалиброван экран монитора, а затем проведена установка параметров Output Profile.

После завершения установок Output Profile просмотреть работу можно, не открывая диалогового окна. Нажав кнопку, изображающую монитор [image], на полосе прокрутки рабочей области, вы увидите свою работу в том виде, в котором она будет выведена на печать, а вид самой кнопки, включающей режим предварительного просмотра (Output Preview), изменится — экран символического монитора станет радужным [image].

Представление о цветоделении

Как вы помните, процесс создания и редактирования изображения происходит в цветовой модели RGB. Но для печати необходимо преобразовать RGB-файлы в CMYK. При этом цвета CMYK не полностью соответствуют RGB. Обычно изображение создается целиком в RGB и только на последнем этапе преобразуется в CMYK.

Painter производит автоматическое цветоделение при сохранении в формате CMYK TIFF. Однако его результат не всегда оправдывает ваши ожидания.

Вручную цветоделение можно произвести в Adobe Photoshop. Цветоделение автоматическое и ручное осуществляется на одной и той же основе — таблицах Colorstudio. Photoshop может производить цветоделение, используя установленные в Painter ICC профили. Если вы произвели установки, используя режим Output Preview, то, возможно, результаты цветоделения в Painter и Photoshop будут совпадать.

Перед преобразованием обязательно сделайте копию файла, чтобы можно было вернуться к изображению в случае неудачи. В принципе, Adobe Photoshop позволяет редактировать CMYK-файлы, но они занимают больший объем памяти, чем RGB-файлы, примерно на 33%. Изображение сохраняют в формате EPS. Затем переходят в Adobe Photoshop.

Чтобы увидеть, как будет выглядеть изображение в Photoshop, также используется окно предварительного просмотра.

Итак, для подготовки к цветоделению в Adobe Photoshop:

  1. Выберите команду Canvas > Preview Options (Холст > Параметры просмотра). Откроется диалоговое окно Select Profiles (Выбор профиля) (см. рис. 4.6).
  2. Раскройте список Output Profile для выбора устройств, выводящих изображение на печать. Помимо наиболее распространенных моделей принтеров он содержит параметры, позволяющие произвести цветоделение.
    • Если вы собираетесь производить цветоделение в Adobe Photoshop, выберите параметр Photoshop RGB to CMYK (см. рис. 4.8).
    • Если вы собираетесь произвести цветоделение HiFi-6 color с использованием моделей Pantone Hexachrome, выберите Pantone Hexachrome High SID или Pantone Hexachrome Normal SID.
  3. Нажмите кнопку OK для закрытия окна Select Profiles.
  4. Выберите команду File > Save As (Файл > Сохранить как). В открывшемся окне Save Image As (Сохранить изображение как) выберите в списке Тип файла: Postscript *EPS. Нажмите кнопку Сохранить.
  5. Выберите команду File > Print (Файл > Печать), откроется диалоговое окно Print (Печать).
  6. В области Print Type (Тип печати) установите переключатель Separations (Цветоделение).

Рис. 4.8. Выбор параметра в списке Output Profile

Теперь при цветоделении изображения будут использованы установки Output Profile, что гарантирует адекватность цветопередачи.

Параметры печати

Далее необходимо настроить установки принтера для пробной печати.

  1. Выберите команду File > Page setup (Файл > Установка страницы). Откроется окно Настройка принтера (см. рис. 4.9).
  2. Выберите принтер в списке установленных принтеров.
  3. Установите ориентацию листа бумаги: альбомную или книжную. Нажмите кнопку Свойства, откроется диалоговое окно, соответствующее установленному принтеру.
    Диалоговые окна различны для каждого принтера, в частности окна, приведенные на рис. 4.9, рис. 4.10 и рис. 4.11, относятся к бытовому принтеру. Но основные параметры, требующиеся для печати, являются общими.
  4. На вкладке Main (Ручная установка) (см. рис. 4.10) установите переключатель варианта настройки печати:
    • Automatic — оптимальные установки подбираются автоматически;
    • Advanced — усложненные установки печати подбираются вручную.
  5. В раскрывающемся списке Media Type (Тип бумаги) выберите тип бумаги для печати.
  6. В области Ink (Чернила) установите переключатель Color (Цвет), если собираетесь печатать в цвете, или Black (Черный) для печати в градациях серого.
    Для более тонкой настройки печати используется окно дополнительных настроек More Settings (Другие установки) (см. рис. 4.11). Эти настройки подбираются экспериментальным путем в процессе использования данного принтера.
  7. Перейдите на вкладку Paper (Бумага) (см. рис. 4.12). Выберите нужный формат бумаги в раскрывающемся списке Paper Size (Размер бумаги). (Практически ни один из принтеров не заполняет полностью печатную страницу. Всегда есть поля. В данном случае выбор невелик.)
  8. Установите переключатель Maximum (Максимально) при желании установить максимальные размеры печатных полей. При этом свободные поля могут располагаться асимметрично. Если вы предпочитаете центральное расположение, установите переключатель Centered (Центрировано). В этом случае изображение симметрично окружено свободными полями.
  9. Для просмотра расположения изображения на странице нажмите кнопку [image] на горизонтальной полосе прокрутки рабочей области.
  10. Закройте последовательно все окна, нажимая кнопку ОК.

Рис. 4.9. Диалоговое окно Настройка принтера

Рис. 4.10. Вкладка Main диалогового окна установленного принтера

Рис. 4.11. Окно More Settings

Рис. 4.12. Вкладка Paper диалогового окна установленного принтера

Теперь все установки, связанные со свойствами самого принтера, сделаны. Вы можете печатать:

  1. Выберите команду File > Print (Файл > Печать), откроется диалоговое окно Print (см. рис. 4.13).
  2. В области Print Type (Тип печати) установите соответствующий вашему принтеру переключатель:
    • Color Postscript (Цветная постскриптовая) — для цветного принтера, поддерживающего PostScript;
    • B&W Postscript (Черно-белая постскриптовая) — для черно-белого PostScript-принтера;
    • GDI Printing — для принтера, не поддерживающего PostScript;
    • Separations (Цветоделение) — если предстоит цветоделение.
  3. Установите флажок Size to Fit Page (Размер изображения к основанию страницы). Если размер страницы меньше устанавливаемого изображения, вы получите предупреждение. В противном случае изображение будет напечатано на странице частично.
  4. Чтобы направить вывод в файл, установите флажок Print to file (Печать в файл).
  5. Если вы предполагаете печатать в градациях серого, установите флажок Print Grayscale (Градации серого).
  6. Установите число копий в области Copies (Копии).
  7. Установив флажок Collate (Сопоставить), вы получите копии серии изображений, идущих последовательно. Если флажок не установлен, копии каждого изображения будут напечатаны отдельно.
  8. Нажатием кнопки ОК запускается процесс печати.

Рис. 4.13. Диалоговое окно Print

Не огорчайтесь, если результат не оправдал ваших ожиданий. Лучшие специалисты по компьютерной графике тоже когда-то начинали. Опыт и терпение, безусловно, дадут свои плоды.


Средства автоматизации

  • Автоматизация штриха
  • Сценарии
    • Запись сценария
    • Воспроизведение сценария
    • Запись сценария с низким разрешением
    • Редактирование сценария
    • Создание нового сценария из фрагментов
  • Использование сценариев для создания клипов

Чаще всего автоматизация осуществляется путем записи определенной последовательности действий с целью многократного воспроизведения их в дальнейшем

Практически любой современный программный продукт предусматривает возможность средств автоматизации каких-либо действий. Чаще всего автоматизация осуществляется путем записи определенной последовательности действий с целью многократного воспроизведения их в дальнейшем. Как правило, имеются в виду действия, которыми вы пользуетесь довольно часто. Painter предоставляет возможность пользоваться двумя типами автоматизации:

  • автоматизация штриха;
  • сценарий.

В данной главе мы рассмотрим эти средства. Дело в том, что автоматизация штриха — это тот же сценарий. Просто такой сценарий позволяет записать только один штрих и ничего более. То есть автоматизация штриха является одношаговым сценарием. Однако записываются и воспроизводятся эти процедуры в Painter с помощью разных палитр: автоматизация штриха — с помощью палитры Brushes, сценарий — с помощью палитры Object.

Автоматизация штриха

Запись штриха актуальна в двух случаях:

  • для получения аккуратной штриховки;
  • для заполнения пространства однотипными элементами (чешуя, волосы, листва, ступени и т. д).

Кроме того, штрихи воспроизводятся различными инструментами в любом месте рабочей области.

Запись и воспроизведение штриха осуществляются с помощью команд меню Stroke (Штрих) — основного меню палитры Brushes: Record Stroke (Записывать штрих), Playback Stroke (Проигрывать штрих), Auto Playback (Автоматически проигрывать).

К тому же можно сохранить записанный штрих и использовать его в дальнейшем.

Команда Stroke > Stroke (Штрих > Штрих) открывает дополнительное меню, команды которого предназначены для получения различных вариантов изменений созданного штриха. Записав один штрих, вы можете воспроизвести целых семь его модификаций.

Команда Use Stroke Data (Использовать параметры штриха) используется, когда часть работы вы выполнили стилусом, записали штрих, а после перерыва работаете мышью. Выбрав команду Use Stroke Data, вы получите штрих, подобный записанному.

Чтобы записать штрих:

  1. Откройте палитру Brushes, выбрав команду Window > Brushes.
  2. Выберите тип кисти в меню Brush, категорию, метод и субкатегорию или воспользуйтесь предложенными по умолчанию (см. главу 6).
  3. Выберите команду Stroke > Record Stroke (Штрих > Записывать штрих).
  4. Для воспроизведения записанного штриха выберите команду Stroke > Playback Stroke (Штрих > Проигрывать штрих).

При желании можете сменить инструмент, изменить цвет. Вы можете повторять каждый новый штрих другим инструментом и цветом. Чтобы прекратить воспроизведение записанного штриха, достаточно снять флажок команды Playback Stroke в меню Stroke. Если вы установите флажок возле команды Auto Playback (Автоматически проигрывать). Painter будет воспроизводить записанный штрих в автоматическом режиме до тех пор, пока не закроет всю поверхность. Остановить процесс можно, выбрав команду Edit > Undo.

На рис. 5.1, выполненном в стиле японской акварели, записаны штрихи струи дождя и ветви ивы на переднем плане.

Рис. 5.1. Акварельный этюд в японском стиле выполнен с помощью автоматизации штриха

Сценарии

В большинстве программ записи действий называются Scripts. Иногда используются термины: оригиналы, скрипты, в продуктах Microsoft — макросы. Мы же в дальнейшем будем пользоваться термином сценарий. Смысл этой процедуры состоит в оптимизации ваших возможностей. Это дает вам некоторые преимущества:

  • экономия вашего времени: как бы ловко вы ни выполняли какую-либо процедуру, компьютер, зная поставленную задачу, самостоятельно выполнит это действие гораздо быстрее;
  • избавление от утомительной рутинной работы.

Кроме того, нельзя не учитывать использование сценариев с учебной целью. При воспроизведении сценария Painter демонстрирует весь процесс создания изображения, выбор средств, параметров и т. д. К тому же вы можете выполнять сценарии в пошаговом режиме, при котором открывается лист сценария с записями, поясняющими действия, происходящие в рабочей области.

Помимо обычных преимуществ сценарий в Painter предлагает вам следующие возможности:

  • Painter автоматически записывает в сценарий абсолютно все ваши действия и процедуры, что может оказаться весьма полезным, например, при ошибочном использовании команды Undo. В случае утраты текущей работы по какой-либо причине вы можете попытаться восстановить ее, скопировав, переименовав, а затем воспроизведя содержание установленного по умолчанию сценария.
  • Известно, что для работы с графикой при высоком разрешении требуется значительный ресурс памяти и времени на сохранение. Painter дает вам возможность создавать работу при низком разрешении, а по окончании переписать записанную в сценарий работу с высоким разрешением.
  • Можно записать выполнение рисунка в одной технике, например в карандаше, а воспроизвести, изменив установки, например, для пастели или фломастеров и т. д.
  • Особенно удобно использовать сценарий при создании анимации. Не нужно делать заново одну и ту же работу, вы просто добавляете новые кадры.
  • Сам по себе сценарий тоже может служить основой для создания специальных эффектов. Для этого его сохраняют в формате Quick Time или видео для Windows.

Кроме того, можно копировать фрагменты сценария, вставлять их в другие сценарии или создавать из них новые сценарии. Записывая сценарий, помните, что бессмысленно создавать длительную процедуру, даже если она будет происходить без вашего участия, и в это время вы свободно могли бы выпить кофе. Запись такой процедуры займет слишком много памяти, и вряд ли это будет полезно.

Практически, можно записать любое действие. Однако средства редактирования сценариев, предоставляемые Painter, очень ограничены. Поэтому, если вы намерены записать какую-то процедуру в сценарии, предварительно просмотрите последовательность команд и запишите план на бумаге, с тем чтобы не делать лишних движений и не выполнять ошибочных команд. Иначе придется удалять записанный сценарий и повторять все заново.

Помимо возможности записывать сценарии Painter предоставляет в ваше распоряжение библиотеку готовых сценариев и меню команд, позволяющих осуществлять запись, удаление, копирование и, в некоторой степени, редактирование сценария.

Все действия, связанные со сценариями, выполняются с помощью секции Scripts палитры Object, открываемой нажатием кнопки со стрелкой, расположенной в верхней части секции (рис. 5.2a и 5.2b).

Рис. 5.2a. Секция Scripts в закрытом виде

Рис. 5.2b. Секция Scripts в раскрытом виде

Палитра устроена аналогично другим сложным палитрам. Верхний ряд представлен значками сценариев. Загруженная библиотека сценариев открывается нажатием на длинную кнопку со стрелкой.

В табл. 5.1 приведен набор кнопок для удобства работы со сценариями.

Таблица 5.1. Кнопки для работы со сценариями

Кнопка | Название | Назначение
 | Stop (Остановка) | Выключает выполнение сценария
 | Play (Проигрывать) | Запускает выполнение сценария
 | Record (Запись) | Осуществляет запись
 | Pause (Пауза) | Останавливает запись и выполнение сценария, предусматривает продолжение после паузы
 | Single Step (Один шаг) | Пошаговое выполнение сценария

Кнопка Stop позволяет фиксировать отдельные фазы создания образа и вмешиваться в эту стадию работы.

Рядом с панелью кнопок расположено поле, указывающее имя выбранного сценария. При нажатии на него открывается список сценариев загруженной библиотеки.

Пока сценарий не загружен, окно, расположенное под панелью кнопок, остается пустым.

Запись сценария

Кнопки дублируют команды меню, открываемого нажатием кнопки со стрелкой, расположенной в правой части секции. Это меню команд предназначено для управления сценариями.

Работая со сценариями, важно иметь в виду следующие правила:

  • Не имеет смысла записывать в сценарий очень продолжительную процедуру.
  • Если вы все же хотите записать большой сценарий, лучше разбить его на части.
  • Перед записью обязательно составьте точный план действий.

В начале записи необходимо установить параметры записываемых в сценарий действий в диалоговом окне Script Options (Параметры сценария) (рис. 5.3).

Рис. 5.3. Диалоговое окно Script Options

При установленном флажке Record Initial State (Запись начального состояния) Painter фиксирует все материалы и средства, используемые вами в работе, например бумагу, кисти. Если флажок снят, то, создавая сценарий, Painter не фиксирует материалы, зато позволяет воспроизвести сценарий в другой технике. Например, вы можете экспериментировать с различными типами кистей или мелков и т. д.

Флажок Save Frames on Playback (Сохранять рамки при проигрывании) служит для сохранения рамок при воспроизведении. Его установка полезна при создании анимации или клипа.

Установив параметры, начинайте запись, нажав кнопку Record (Запись). Завершая действия, нажмите кнопку Stop. Откроется окно Name the Script (Название сценария) (рис. 5.4). В поле Save As (Сохранить как) введите название работы, нажмите кнопку ОК.

Рис. 5.4. Диалоговое окно Name the Script

Painter автоматически внесет записанный сценарий в библиотеку, установленную по умолчанию, и создаст для него значок. Вы можете перенести сценарий в другую библиотеку с помощью сортировщика Script Mover (Сортировщик сценариев), открываемого командой Script Mover.

Воспроизведение сценария

Чтобы воспроизвести нужный сценарий:

  1. Выберите его в списке сценариев, он появится среди пяти значков и будет выделен красной рамкой.
  2. Нажмите кнопку Play (она станет ярко-зеленой) или выберите команду Playback Script. Откроется окно Recorded Scripts (Записанные сценарии), приведенное на рис. 5.5.
  3. Выберите в списке необходимый сценарий и нажмите кнопку Done (Применить).

Рис. 5.5. Окно диалога Open Scripts

На рис. 5.5 первым в списке указан Current Script (Текущий сценарий) — тот самый сценарий, в который записываются все ваши действия и с помощью которого можно попытаться восстановить испорченную работу.

Кнопки окна Recorded Scripts приведены в табл. 5.2. Окно содержит список сценариев загруженной библиотеки. В нижней его части отображается объем памяти, занимаемой выбранным сценарием.

Таблица 5.2. Назначение кнопок окна Recorded scripts

Кнопка | Назначение
Import (Ввод) | Открывает диалоговое окно Input script file (Ввол сценарного файла), позволяющее выбирать сценарий из библиотек или совместимых приложений
Export (Отправка) | Открывает окно Enter script name (Ввести имя файла), позволяющее внедрить сценарий из Painter в другое совместимое приложение
Get Info (Получить информацию) | Предоставляет информацию об объеме памяти, занимаемом сценарием, и его авторе (см. рис. 5.6)
Playback (Проигрывать) | Применяет сценарий или воспроизводит его в исходном авторском варианте
Open (Открыть) | Открывает сценарий, выбранный в списке, для редактирования
Close (Закрыть) | Закрывает выбранный для редактирования сценарий
Delete (Удалить) | Удаляет ненужный сценарий
Done (Применить) | Применяет сценарий
Open library (Открыть библиотеку) | Раскрывает диалоговое окно Open script library file (Открыть библиотеку сценарных файлов), позволяющее открыть библиотеку сценариев

На рис. 5.6 показано диалоговое окно Script Information (Информация о сценарии), открываемое щелчком на кнопке Get Info. В нем представлена информация об объеме памяти, занимаемой сценарием, и его авторе.

Рис. 5.6. Диалоговое окно Script Information

Воспроизводить сценарий можно в пошаговом режиме, нажимая кнопку Single Step, можно делать паузы с помощью кнопки Pause.

Запись сценария с низким разрешением

Одно из преимуществ сценариев связано с резервами памяти вашего компьютера. Это преимущество не так очевидно, как предыдущие, и имеет ряд ограничений. Смысл его в том, чтобы записывать действие какого-либо инструмента с низким разрешением, а воспроизводить его с более высоким. Мы уже вскользь упомянули об этой возможности. Дело в том, что работа с графикой при высоком разрешении требует больших ресурсов памяти и соответственно - времени на обработку. Если вы работаете не на профессиональном студийном компьютере, а на домашнем, то наверняка уже это почувствовали. Иногда приходится долго ждать, пока выполняется то или иное действие. А результат может не оправдать ваших ожиданий.

В такой ситуации, когда применение какого-либо эффекта неочевидно, разумнее выполнить пробное действие с маленьким фрагментом изображения в низком разрешении, записывая последовательность действий в сценарий. Если эффект вас удовлетворит, вы сможете без труда воспроизвести автоматически действия с высоким разрешением для всей работы. Если нет, можно изменять эффекты, не меняя сценария, подбирая наиболее оптимальный вариант.

К сожалению, применение данного средства ограничено технической проблемой, связанной с предельной возможностью разрешения программы Painter. Например, предельная ширина штриха, которую можно установить с помощью ползунка Size на панели управления или в палитре Controls: Size — 1500 пикселов. И если вы записали сценарий с разрешением в 72 ppi и установленным размером кисти в 500 пикселов, то, увеличив разрешение в 4 раза, получите ширину штриха только предельно установленную — 1500, а не ожидаемую 2000 пикселов. Также ограничен масштаб бумаги — 400 %.

Кроме того, имеет значение ограничение размеров изображения, воспроизводимого с высоким разрешением. Если вы выполнили этюд в небольшом размере с низким разрешением, затем сильно увеличили изображение и разрешение, то можете получить размытость и нечеткость контуров.

В качестве простого примера запишем сценарий с низким разрешением, а воспроизведем его с высоким. Для этого:

  1. Создайте новый документ, выбрав команду File > New.
  2. В диалоговом окне New Picture установите ширину и высоту, вводя в поля Width и Height значения 200 и 200.
  3. Установите разрешение 72 в поле Resolution. Нажмите кнопку ОК. Появилось окно нового документа, в котором можно создавать изображение.
  4. Выберите в меню команду Select All.
  5. Выберите команду Script Options (Параметры сценария). В открывшемся окне Scripts Options (см. рис. 5.3) установите флажок Record Initial State (Запись начального состояния).
  6. Откройте секцию Script. Нажмите кнопку Record.
  7. Теперь рисуйте. Закончив, нажмите кнопку Stop, прекращающую запись сценария.
  8. Откроется окно Name the Script (см. рис. 5.4): в поле Save As введите название работы, нажмите кнопку ОК.
  9. Создайте новый документ. Установите разрешение 200. Нажмите кнопку ОК.
  10. Выберите команду Select All.
  11. Выберите команду Playback Script. В диалоговом окне Recorded Scripts (Записанные сценарии) или в раскрывающемся списке палитры Objects: Scripts выберите название только что записанного вами сценария. Нажмите кнопку Play или Playback. Ваша работа будет воспроизведена с более высоким разрешением.

Редактирование сценария

Средства редактирования сценария, предоставляемые Painter, очень ограничены. Это и понятно. Во-первых, эта программа предназначена для художников, а не программистов, поэтому средства редактирования должны быть простыми и доступными. Во-вторых, редактирование сценариев, записывающих графику, — это серьезная проблема, и средства, используемые для этого, отличаются от Visual Basic.

Поэтому все ваши действия при редактировании будут сводиться к копированию, вырезанию и вставке отдельных действий.

Чтобы отредактировать сценарий:

  1. Выберите команду Open Script, откроется диалоговое окно Recorded Script.
  2. Выделите нужный сценарий — кнопка Open станет доступной. Нажмите ее. Выбранный сценарий будет загружен в лист сценария, остававшийся до сих пор пустым (см. рис. 5.7).
  3. Просмотрите список действий. Нажмите кнопку со стрелкой выбранного действия. После некоторой паузы откроется более подробный список. При этом выделенная секция с действием окрашивается в сиреневый цвет, а кнопка меняет направление стрелки (см. рис. 5.8a и 5.8b). Нажав и удерживая клавишу Shift, вы можете выделить несколько действий одновременно. Выберите желаемые действия таким способом.
  4. Выберите команду Сору (Копировать). Затем выберите команду Close Script (Закрыть сценарий), чтобы перенести скопированные действия в другой сценарий. Команда Open (Открыть) снова станет доступной.
  5. Выполните шаги 1 и 2 для другого сценария. Вставьте в выбранное место скопированные фрагменты первого сценария, выбрав команду Paste (Вставить).

Рис. 5.7. Сценарий загружен в лист сценария

Рис. 5.8a. Загруженный лист сценария. Выделен выбор текстуры бумаги

Рис. 5.8b. Загруженный лист сценария. Открыта библиотека текстур и выбрана определенная текстура

ПРИМЕЧАНИЕ. К сожалению, нельзя открыть одновременно несколько сценариев и иметь на экране хотя бы два загруженных листа сценариев, поэтому вам придется открывать один сценарий, копировать из него действия, закрывать его, затем открывать другой и вставлять скопированные действия.

Чтобы не испортить сценарии, составляющие библиотеку, необходимо создать сценарий, в который вы будете копировать действия. Поэтому мы рассмотрим, как создать новый сценарий, в который можно вставлять скопированные фрагменты.

Создание нового сценария из фрагментов

Для создания нового сценария:

  1. Выберите команду New Script (Новый сценарий), откроется окно Name the Script (Название сценария). Введите имя для создаваемого сценария, нажмите кнопку ОК.
  2. Теперь у вас есть новый сценарий, в который вы можете копировать действия из других сценариев. Закройте только что созданный сценарий. Стала доступна команда Open Script.
  3. Выберите команду Open Script (Открыть сценарий), откроется диалоговое окно Recorded Script (Записанные сценарии).
  4. Выделите нужный сценарий. Кнопка Open стала доступной, нажмите ее.
  5. Нажмите клавишу Shift и, удерживая ее, выделите несколько действий одновременно. Выберите команду Сору (Копировать).
  6. Чтобы перенести скопированные действия в первый сценарий, выберите команду Close Script (Закрыть сценарий). Команда Open снова стала доступной.
  7. Выполните шаги 1 и 2 для другого сценария. Вставьте в выбранное место скопированные фрагменты первого сценария, выбрав команду Paste (Вставить).
  8. Повторяя действия по открытию других сценариев, выделению, копированию действий, закрытию, вставке в новый сценарий, вы можете получить любопытный результат.

Использование сценариев для создания клипов

Существует несколько вариантов использования сценариев для создания клипов. Вы можете:

  • Записать действия в сценарий, затем разбить его на кадры с установленной частотой и сохранить в видеоформате, например, Quick Time или AVI.
  • Записать сценарий с применением какого-либо эффекта, затем наложить его на любое изображение, разбить изображение на кадры с установленной частотой и сохранить в видеоформате, например, Quick Time или AVI.
  • Использовать сценарий для создания анимации.

В любом из этих случаев удобно воспользоваться рассмотренной ранее возможностью записи действий в сценарий при низком разрешении и воспроизведении при более высоком.

Перед записью сценария необходимо установить параметры в диалоговом окне Script Options (Параметры сценария):

  1. Выберите команду Script Options.
  2. В открывшемся окне Script Options (см. рис. 5.3) установите флажок Save Frames on Playback (Сохранить рамки при проигрывании).
  3. Введите в поле Every (Каждый) нужное значение частоты кадров. При этом имейте в виду, что высокая частота требует большого объема памяти, а низкая частота ведет к тому, что кадры не сливаются в плавное действие. Запишите сценарий.
  4. Нажмите кнопку Play, откроется диалоговое окно Enter Movie Name (Ввод названия клипа) (см. рис. 5.9), в котором введите имя и местоположение клипа. Нажмите кнопку ОК.
  5. Откроется окно New Frame Stack (Новая полоса кадров) (см. рис. 5.10). С помощью переключателей Layers of Onion Skin (Слои луковой кожуры) укажите число рабочих кадров, которые будут выводиться одновременно в следующем окне. С помощью переключателей Storage Type (Тип сохранения) укажите цветовой режим, в котором создается клип (8-bit в градациях серого, 8-bit, использующий цвета системной палитры, 15-bit цветной с 1-bit альфа-каналом, 24-bit цветной с 8-bit альфа каналом). Нажмите кнопку ОК.
  6. Откроется панель Frame Stack (Последовательная полоса кадров) для просмотра кадров полученного клипа (см. рис. 5.11). Эта панель позволяет переключать стрелками кадры в пошаговом режиме и редактировать их в рабочей области, затем переходить к следующему кадру.

Рис. 5.9. Окно Enter Movie Name

Рис. 5.10. Окно New Frame Stack

Рис. 5.11. Панель Frame Stack

Для применения какого-либо эффекга для анимации:

  1. Запишите сценарий с наложением какого-либо эффекта, например применение динамического слоя (Plug-in) Калейдоскоп для единичного изображения.
  2. Откройте анимационный клип, выберите команду Movie > Apply Script to Movie (Клип > Применить сценарии к клипу). Painter применит эффект, записанный в сценарии, к каждому кадру вашего клипа.


Настройки инструментов рисования

  • Стилус и планшет
    • Настройка стилуса
  • Настройка инструментов рисования
  • Инструменты палитры Brushes
  • Палитра Brush Controls
    • Секция General
    • Просмотр создания штриха
    • Параметр Dab Type
    • Секция Size меню Control
    • Секция Spacing
    • Секция Angle
    • Секция Random
    • Секция Bristle
    • Секция Rake
    • Секция Well
    • Секция Airbrush
    • Секция Expression
  • Упражнение. Двухцветная кисть
    • Секция Water
  • Работа с мышью

Painter дает вам в руки не просто имитацию всевозможных художественных инструментов, средств, приемов. Он может больше, чем традиционные средства

Painter — поистине уникальная программа для настоящего творчества. Причем приступить к рисованию вы можете немедленно. После приобретения некоторого опыта работы вы поймете, что целесообразнее изучить уже имеющиеся приемы, которые используют многие художники, чем до всего доходить самим. Тем более что по этим вопросам существует обширная литература.

Вспомните, ведь наверняка, когда вы начинали работать в традиционной технике, в вашей практике случались неприятности, теперь уже ставшие забавными эпизодами, связанные с элементарным незнанием особенностей техники. Тогда удачная работа была безвозвратно утрачена. Примером подобного казуса может служить разведение масляной краски льняным маслом, когда работа практически не высыхает.

В книге Адель ДробласТринберг и Сета Гринберг «Цифровые изображения: Практическое руководство» наше внимание привлек небольшой эпизод о том, как лаборатория программистов компании Fractal Design арендовала помещение настоящей художественной студии для наблюдения за работой художников традиционными средствами, с тем чтобы создавать компьютерные аналоги. И в результате труда таких, без сомнения, талантливых программистов вы получили наряду с имитацией существующих художественных инструментов, средств, приемов много новых возможностей по сравнению с традиционными.

Но как и обычные художественные средства, электронные инструменты имеют свои особенности и возможности настройки. Рассмотрению этих вопросов и посвящен данный урок.

Стилус и планшет

Многие графические программы дают возможность не только строить изображение из готовых элементов или создавать их с помощью кривых Безье, а просто рисовать. Долгое время эта возможность устраивала немногих. Дело в том, что работа с мышью и ее аналогами не позволяет рисовать так же легко, как карандашом или кистью. В развитии компьютерной графики большую роль сыграло создание электронного сенсорного пера (стилуса).

Одним из лидеров на рынке электронных перьев заслуженно является японская компания Wacom, производившая с 1983 года дигитайзеры — устройства, служившие для обводки контуров и чертежей в системах CAD. В дальнейшем эта идея получила свое развитие в связи с тем. что в Японии пользуется большой популярностью искусство каллиграфии, где нажим пера имеет значение для создания иероглифов. Современные перья беспроводные и не требуют батареек. Одно из последних достижений в этой области — стилус Intuos, имеющий специальное колесико, с помощью которого можно регулировать поток краски, как в настоящем аэрографе.

Рисование происходит на специальной чувствительной поверхности планшета. Этот процесс не требует привыкания. Вы просто рисуете привычным способом.

Но вначале необходимо настроить стилус. В Painter для этого предусмотрены специальные средства, которые мы и рассмотрим.

Настройка стилуса

При работе с обычным пером толщина и яркость линии зависят от степени нажима на него. Имеет значение также и скорость рисования отдельных линий.

Настройку стилуса необходимо выполнять каждый раз в начале сеанса работы, так как после выключения компьютера состояние кистей возвращается к исходному. При этом имеет смысл настраивать только те инструменты, которыми вы чаще всего пользуетесь.

  1. Выберите команду Edit > Preferences > Brush Tracking (Правка > Установки > Прослеживание кисти). Появится диалоговое окно Brush Tracking (Прослеживание кисти) (см. рис. 6.1).
  2. Выберите Pencil (Карандаш) в списке палитры Brush, а в расположенном рядом списке типов карандашей — 2В Pencil.
  3. Установите стилус в окне Scratch Pad (Гравировочная поверхность), проведите линию с нормальной скоростью, не особенно нажимая на перо. Нажмите кнопку ОК.
  4. Выберите Felt Pens (Чувствительные ручки-фломастеры) в списке Brush, а в соседнем списке типов фломастеров — Felt Marker (Чуствительный маркер).
  5. Снова откройте окно Brush Tracking и быстро проведите линию, нажимая совсем чуть-чуть. Нажмите кнопку ОК. Это сделает перо чувствительным к нажиму и скорости.

Рис. 6.1. Диалоговое окно Brush Tracking

Выполните несколько подобных настроек для разных инструментов, делая их привычными и удобными для себя. Например, проводите линии очень быстро, если вы привыкли рисовать быстрым движением, или с разной степенью давления. Каждый раз, нажимая кнопку ОК, проверяйте затем уровень чувствительности пера к вашим движениям в рабочей области.

Настройка инструментов рисования

Как уже говорилось, в Painter любое средство отражается в палитре управления Controls и именно с ее помощью можно настроить любой инструмент. С помощью этой палитры настраиваются следующие параметры инструментов рисования:

  • стиль рисования — Freehand (свободный) или Straight Lines (построить фигуру из прямых линий);
  • размер наконечника кисти — Size;
  • непрозрачность линии — Opacity;
  • зернистость бумаги, проступающей сквозь нанесенную краску, — Grain.

Однако Painter обладает таким богатством инструментов и их настроек, что формат данной книги позволит дать только представление о них. В этой части урока мы рассмотрим палитру кистей — Brushes.

Рис. 6.2. Палитра управления Controls Brush

Как и другие палитры, она открывается с помощью команды Window > Show Brushes (Окно > Показать кисти).

В верхней строке расположено основное меню палитры. Ниже расположены значки с изображением пяти последних выбранных инструментов. Если нажать на кнопку со стрелкой, расположенную на полосе под значками, открывается «ящик» с другими инструментами, а стрелка на кнопке меняет направление на обратное. Но и тогда палитра раскрыта не полностью.

Именно в нижней части палитры представлено все разнообразие самих инструментов и их возможностей. Здесь расположены два раскрывающихся меню (рис. 6.3), содержащих типы инструментов и варианты инструментов.

Рис. 6.3. Палитра Brush Creator

Инструменты палитры Brushes

Рассмотрим инструменты палитры Brushes (рис. 6.4a и 6.4b). В меню типов инструментов Brush Popup (Варианты наиболее попупярных кистей) входит 15 инструментов.

Рис. 6.4a. Палитра Brush Creator полностью свернута

Рис. 6.4b. Палитра Brush Creator полностью развернута

Из них 8 имитируют традиционные художественные средства, а семь (image Hose, Liquid, Artists, Cloners, Photo F\X, Impasto) — не имеют аналогов среди современных художественных средств:

  • Image Hose (Шланг, разбрызгивающий изображения) — кисть, с помощью которой вы можете создавать заливку изображениями, то есть полностью покрывать выделенный фрагмент изображения одним и тем же рисунком. Подробно работа с этим инструментом рассмотрена в главе 12.
  • Liquid (Жидкость) — кисть, имитирующая разведение краски жидкостью так, что краска перетекает, но при этом эффект совершенно не похож на кисть Water (Вода) и Water Color (Акварель).
  • Cloners (Клоны) — кисти, создающие штрихи, имеющие определенный рисунок.
  • Artists (Художники) — кисти, которые предлагают вам либо готовые варианты штриха, такие как Impressionist (Импрессионист), Auto Van Gogh (Авто Ван Гог), Seurat (Сера), либо кисти со специально подобранными параметрами, например, имитирующая стиль Ван Гога (Van Gogh, Van Gogh2) или Sargent brush, рисующая подобно кисти Piano Keys, описанной ниже в категории F\Х, Tubism, создающая трубчатый штрих.
  • Photo (Фото) — кисть, предназначенная для коррекции фотографий. Painter предлагает огромное количество вариантов и способов изменения изображения. Вы можете не только ретушировать, высветлить или затенить отдельные фрагменты изображения, но и добавить интересные эффекты, придающие изображению иной смысл.
  • F\Х — кисть, придающая необыкновенные эффекты изображению. Вариант Confusion (Беспорядок) создает размытость, напоминающую пушистую поверхность; Fairy dust (Пыльца феи) покрывает изображение волшебными звездочками любого заданного цвета; Fair (Блестки) покрывает изображение отблесками; Furry brush (Пушистая кисть) накладывает красно-черные пушистые остроконечные цветы, подобные иглистым хризантемам; Glow (Жар) придает изображению красноватый оттенок, не меняя его качества; Hair spray (Распылитель волос) покрывает изображение пушистыми шарами, цвет которых определяется направлением движения кисти (со стороны изображения — пушистые шары имеют цвет изображения, со стороны фона — преобладает цвет фона); Neon Pen (Неоновая ручка) рисует линиями установленного цвета, напоминающими светящиеся трубки неона; Piano Keys (Клавиши фортепиано) создает штрих, состоящий из перпендикулярных к его направлению линий заданного цвета, напоминающих клавиши; Shattered (Разрушенный) создает эффект осколков стекла поверх изображения, рисует только в движении; Squeegee (Резиновая швабра) размазывает влажной поверхностью изображение. На рис. 6.5 приведено изображение, полученное путем обработки фотографии шимпанзе вариантами кистей F\Х.
  • Impasto — кисти с разного типа штрихами, рисующие как, подобно обычным масляным кистям, толстым рельефным штрихом, так и, подобно F\X кистям, необычными эффектами. Например, несколько вариантов этой категории рисуют различного рода пузырьками Acid Etch (Кислотная гравировка), Grain Emboss (Зернистая чеканка), а также Texturizer Fine, Texturizer Clear, Texturizer Variable (Тонкая текстурирующая, Чисто текстурирующая, Изменяющаяся текстурирующая). Вариант Fiber (Волокна) создает эффект коротких перепутанных волокон установленного цвета. Pattern Emboss (Шаблонная чеканка) покрывает изображение чешуйчатой сеткой. Все эти кисти объединяет в одну категорию их эффект выпуклости (подробно о свойствах кистей Impasto см. в главе 18).

Рис. 6.5. Результат обработки фотографии шимпанзе различными вариантами кисти F\Х

Самая последняя команда меню, Load Library (Загрузить библиотеку), позволяет загрузить библиотеку инструментов.

Каждому типу инструментов соответствует отдельное меню Brush Variant Popup (Варианты наиболее популярных кистей). Например, при выборе инструмента Pencil (Карандаш) вы устанавливаете в меню Brush Variant Popup, какой именно карандаш вам нужен. В данном случае предлагается любой из 6 вариантов карандашей.

А установив инструмент Eraser (Резинка), можно выбрать любой из 14 вариантов. В дальнейшем при смене инструментов будет устанавливаться вариант, использовавшийся последним. Помимо вариантов кистей имеет значение метод использования кисти и субкатегория метода. Эти характеристики устанавливаются в секции General, вложенной в сложную палитру Brush Controls. Мы рассмотрим их позже.

Палитра Brush Controls

Основные установки по настройке кистей сведены в отдельную сложную палитру Brush Controls (Управление кистью), которая открывается путем выбора команды Windows > Show Brush Controls (Окно > Показать палитру управления кистью) главного меню или команды Control > Show Brush Controls (Управление > Показать палитру управления кистью) меню палитры Brushes (рис. 6.6). Теперь вы можете сделать все установки по настройке кистей, переходя от одной секции палитры к другой.

Рис. 6.6. Палитра Brush Controls

Каждая вложенная палитра-секция соответствует различным характеристикам штриха. Когда внесено очень много изменений в параметры кисти, установленные по умолчанию, Painter предлагает построить новую кисть и открывает соответствующее окно. Команды, изменяющие свойства кисти, мы рассмотрим далее.

Палитра Brush Controls, предоставляет пользователю богатейшие возможности в построении кистей. Функции вложенных палитр будут рассмотрены в этой главе, подробное же освоение их возможностей предоставим читателям, так как, с нашей точки зрения, это уже творческий момент.

Секция General

Первой секцией, продолжающей установки, сделанные ранее, является General (Главная) (рис. 6.7). Оба параметра — метод и субкатегория, устанавливаются с ее помощью.

Рис. 6.7. Секция General

Для каждого из инструментов есть свойственный ему метод, соответствующий его особенностям. Но вы можете изменить метод применения инструмента. Возьмем, к примеру, вариант использования гуаши в реальной жизни. Если гуашь высохла, ею можно рисовать подобно мелкам, а если ее сильно развести водой, то получится подобие акварели. Таким образом, мы имеем три метода использования гуаши. Или возьмем акриловые краски. Их можно накладывать густым мазком, застывающим подобно масляным краскам, можно сильно развести, подобно акварели, а можно умеренно, тогда получается их собственная консистенция.

В меню Method представлены восемь различных методов, характерных для разных инструментов:

  • Buildup (Наращивание) характерен для инструментов, рисующих чернилами и краской. Каждый последующий слой, нанесенный на текущий, делает изображение темнее. Интенсивность цвета при этом усиливается.
  • Cover (Покрытие) имитирует непрозрачные материалы, такие как Chalk (Мел), Charcoal (Уголь). Но при повторном нанесении его интенсивность цвета так же усиливается. Этот метод применяется, когда нужно рисовать более светлым тоном по темному.
  • Eraser (Ластик) установлен по умолчанию для резинок разного типа. Помимо того, что он просто удаляет изображение до белого цвета, даже если вы используете цветную бумагу в качестве основы, он может затемнять или осветлять изображение.
  • Drip (Капля) установлен по умолчанию для кисти Liquid (Жидкость). При использовании этого метода частицы жидкой краски как бы смещаются, но не перетекают, как в акварели, а застывают. Это больше напоминает рисование сильно разбавленной масляной краской.
  • Mask (Маска) относится к созданию масок. Если вы установите этот метод, то в меню категорий автоматически будет установлен параметр Layer (Слой), а если вы откроете собственно меню категорий, то увидите в нем всего два пункта — Layer и Load Library. К использованию масок мы вернемся в главе 13.
  • Cloning (Клонирование) установлен по умолчанию для кисти Cloners (см. главу 7).
  • Wet (Мокрый) установлен по умолчанию для кисти Water color.
  • Plug-in (Фильтры) применяется для кистей из дополнительных библиотек Painter. К методу Plug-in мы вернемся в главе 16 и главе 17 (в текущей версии термин Plug-in заменен на Dynamic Layer).

Конечно, проще всего воспользоваться методом, установленным по умолчанию для любого инструмента, но, изучив возможности раскрывающихся меню Method (Метод) и Subcategory (Подкатегория), вы сможете получить совершенно неожиданные, удивительные результаты.

Пункты меню Subcategory характеризуют свойство самого инструмента, а также зависят от метода, установленного в меню Method.

Например, установлен метод Buildup, и это же название присутствует в пункте меню субкатегорий последним словом. Части названия Soft (Мягкий), Hard (Жесткий), Edge (Острый), Flat (Плоский), Variable (Изменяющийся) характеризуют край штриха, a Grainy (Зернистый) — чувствительность к текстуре бумаги.

Как только вы выберете новый инструмент в меню категорий, автоматически изменятся метод и пункт в меню Subcategory.

Однако это не все свойства кистей. Полученный штрих зависит от толщины кисти (ее размера), от угла, под которым этот штрих наносится. А в Painter результат зависит еще от множества причин, которые мы рассмотрим далее.

В начале этого урока, где речь шла о настройке стилуса, говорилось о настройке скорости проведения линии. При этом вы не могли не отметить, что если очень быстро провести линию в окне настройки Scratch Pad, то получается даже не линия, а траектория, состоящая из точек. Очевидно, что сам штрих зависит от единичных элементов, из которых он складывается. Такой элемент мы в дальнейшем будем называть следом.

Таким образом, след — это пятно (Dab), которое оставляет единичное прикосновение любого инструмента к рабочей области.

Как вы увидите, у любого следа довольно много характеристик, которые можно изменять, создавая тем самым новый вариант штриха.

Но в дальнейшем нам понадобится наблюдать, чем отличается один штрих от другого, поэтому мы на некоторое время отвлечемся от темы и рассмотрим специальное пробное окно для демонстрации работы различных кистей.

Просмотр создания штриха

В процессе освоения палитры Brushes вам придется постоянно пробовать всевозможные кисти, сравнивать их действие. Но работа может быть несколько упрощена. В Painter есть специальное окно для просмотра кистей. Для его открытия выберите команду основного меню палитры Brush > Brush Looks > Brush Look Designer (Кисть > Просмотр кисти > Просмотр выполнения). Откроется окно Brush Look, в котором видно, как выглядит штрих, выполненный той или иной кистью.

Попробуйте менять категории кистей, варианты, методы и подкатегории метода. Все эти изменения отразятся в просмотровом окне.

Переключая кнопки цветов, расположенные под окном, вы увидите, как будет выглядеть штрих на белом или темном фоне, на полосатом.

При желании поменять цвета фона и штриха:

  1. Откройте палитру цветов Color Set (Цветовой набор), если она не представлена на экране, выбрав команду Window > Show Color Set (Окно > Показать цветовой набор).
  2. Откройте окно просмотра создания кисти Brush Look (Просмотр кисти), выбрав команду Brush > Brush Looks > Brush Look Designer (Кисть > Просмотр кисти > Просмотр выполнения).
  3. Выберите в палитре Color Set цвет фона. А в панели Controls: Brush (Управление кистью) нажмите значок в виде угловых стрелок [image]. При этом выбранный цвет будет установлен для фона.
  4. Снова выберите в палитре Color Set (Цветовой набор) цвет, теперь для штриха — передний прямоугольник в панели Controls: Brush (Управление: Кисть) примет выбранную окраску.
  5. Нажмите кнопку Set Colors (Установить цвета) в окне Brush Look. Выбранные цвета будут установлены.

Чтобы применить понравившуюся вам кисть, нажмите кнопку Done (Применить). Окно закроется, и вы сможете работать с выбранным инструментом.

Параметр Dab Type

Палитра General позволяет установить 13 вариантов следа, четыре из которых перешли из прежних версий Painter, а девять — новых.

В предыдущих версиях штрих складывался из единичных прикосновений инструмента по аналогии с происходящим в действительности процессом. Такие следы (Dab Type) в настоящей версии называются dab based. К ним относятся:

  • Circular — круглый след, управляемый с палитры Size и Angle.
  • Single-Pixel — однопиксельный след, не меняет размера, используется для редактирования при значительном увеличении изображения.
  • Static Bristle — щетинистый след, настраивается с помощью палитр Size и Bristle. Изменение расстояния между щетинками позволяет получить различную конфигурацию штриха.
  • Capture — захваченный, фиксированный след позволяет сделать следом маленький фрагмент любого изображения, из него будет складываться штрих.

Остальные варианты Dab Type, предложенные в Painter 8, называются Rendered (Предоставленные). Они создают более естественный штрих — непрерывный, гладкий с ровными краями, реагируют на наклон стилуса, его давление на холст, направление движения.

Camel hair (Верблюжий волос) — кисть с круглым следом. Цвет поддерживается каждой щетинкой независимо от тина загруженной кисти. Регулируется в секции Size, параметр Feature (Размытость). Перемещение ползунков вправо увеличивает расстояние между элементами штриха, превращая их в отдельные линии. В секции Color Variability (Изменение цвета) палитры Art Materials (Художественные средства) можно подобрать такое положение движков HSV, при котором каждый элемент штриха будет иметь свой оттенок цвета (рис. 6.8a и 6.8b).

Рис. 6.8a. Dab Type варианта Camel Hair

Рис. 6.8b. Dab Type варианта Camel Hair

Flat (Плоский) — плоская кисть, создающая след, подобный малярной кисти. Изменяет ширину штриха в зависимости от направления: горизонтальный штрих широкий, под углом — уже, вертикальный — еще уже. Регулируется в секции Size, параметр Feature (Размытость). Перемещение ползунков вправо расширяет расстояние между отдельными следами каждой щетинки (рис. 6.9a и 6.9b).

Рис. 6.9a. Штрих, полученный с использованием Dab Type варианта Flat. Параметр Feature со значением, установленным по умолчанию

Рис. 6.9b. Штрих, полученный с использованием Dab Type варианта Flat. Значение параметра Feature равно 35%

Palette Knife (Мастихин) — след, дающий штрих, изменяющийся противоположно вышеописанному, то есть вертикальное направление дает широкий штрих, горизонтальное — сужает. Перемещение ползунков параметра Feature вправо расширяет расстояние между отдельными следами каждой щетинки (рис. 6.10a и 6.10b).

Рис. 6.10a. Штрих, полученный с использованием Dab Type варианта Palette Knife. Параметр Feature со значением, установленным по умолчанию

Рис. 6.10b. Штрих, полученный с использованием Dab Type варианта Palette Knife. Значение параметра Feature равно 35%

Bristle Spray (Разбрызгиватель щетинок) — след, дающий штрих в виде хаотично расположенных щетинок. Этот тип следа предназначен для использования с аэрографом. Перемещение ползунков параметра Feature вправо расширяет расстояние между щетинками (рис. 6.11a и 6.11b).

Рис. 6.11a. Dab Type вариант Bristle Spray. Параметр Feature со значением, установленным по умолчанию

Рис. 6.11b. Dab Type вариант Bristle Spray. Значение параметра Feature равно 6,9%

Airbrush (Аэрограф) — след, подобный аэрографу, служит для создания кисти, аналогичной реальному аэрографу. Вы можете регулировать размер капель аэрографа с помощью параметра Feature. Перемещение ползунков вправо увеличивает размер точек, влево — уменьшает его. Однако при больших значениях Feature результат становится непредсказуемым. При критических углах наклона капли могут разбрызгиваться очень далеко от места приложения. Также проблемы могут возникнуть при установке параметра Spread (Распространение) в секции Airbrush; оптимальные значения этой установки 30-40%. Кроме того, новый стилус Intuos имеет специальное колесико, с помощью которого регулируется поток краски, имитируя работу с реальным аэрографом.

Pixel Airbrush (Пиксельный аэрограф) — след, подобный аэрографу, разбрызгивающему пиксельные капли, размер которых не меняется (рис. 6.12a и 6.12b).

Рис. 6.12a. Штрих, полученный с использованием Dab Type варианта Pixel Airbrush. Установлено минимальное значение параметра Size

Рис. 6.12b. Штрих, полученный с использованием Dab Type варианта Pixel Airbrush

Line Airbrush (Линейный аэрограф) — позволяет создать кисть, разбрызгивающую линии, расположенные под углом друг к другу (рис. 6.13a, 6.13b и 6.13c). Длина линий регулируется параметром Size одноименной секции.

Рис. 6.13a. Штрих, полученный с использованием Dab Type варианта Line Airbrush

Рис. 6.13b. Штрих, полученный с использованием Dab Type варианта Line Airbrush. Установлено минимальное значение параметра Size

Рис. 6.13c. Штрих, полученный с использованием Dab Type варианта Line Airbrush

Projected (Спроектированный) — след, с помощью которого можно создать кисть типа аэрографа. Работа этой кисти напоминает аэрограф первых версий Painter. Но теперь она реагирует на направление, наклон, давление стилуса.

Rendered (Предоставленный) — след, с помощью которого можно создать кисти, использующие градиенты или шаблоны в качестве источника. В списке Source (Изображение-источник клонирования, подробно о клонировании в главе 7) представлено несколько вариантов (рис 6.14a и 6.14b).

Рис. 6.14a. Dab Type варианта Rendered. Из списка Source выбран параметр Color

Рис. 6.14b. Dab Type варианта Rendered. Из списка Source выбран параметр Pattern

Параметр Stroke Types (Типы штрихов) содержит раскрывающийся список, в котором представлены следующие варианты различных типов штрихов:

  • Single (Одинарный) — штрих, состоящий из одного ряда следов;
  • Multi (Множественный) — штрих, состоящий из нескольких рядов следов, переплетающихся беспорядочно между собой;
  • Rake (Зубцы) — штрих, состоящий из нескольких рядов следов, расположенных параллельно, подобно следу от грабель:
  • Hose (Шланг) — штрих, состоящий из множества повторяющихся изображений.

Рис. 6.15. Примеры установки различных типов штрихов, расположенных по порядку слева направо: Single, Multi, Rake, Hose

ВНИМАНИЕ. Когда вы рисуете штрих кистью типа Multi, сначала на экране появляются точки, из которых скоро сложится линия. Кисти типа Multi требуют большего объема памяти и, следовательно, большего времени для создания штриха.

Все остальные кисти рисуют гораздо быстрее. Даже тип Rake практически равен по скорости типу Single.

Эффекты, подобные-кистям типа Multi и Rake, можно создавать сложными кистями. У таких кистей при просмотре в окне палитры Size в режиме Soft, позволяющем видеть форму центральной части следа, структура множественная, то есть след состоит из множества мелких элементов. Примерами таких сложных кистей могут служить инструменты из категории Brush следующих вариантов: Brushy (Щетинистая), Fine Brush (Тонкая кисть), Load Oils (Масляная), Sable-Chisel (Колонковая кисть), Tip Water (Водяная с тонким наконечником), Big Dry Ink (Большая сухая чернильная), Big Load Oils (Большая масляная), Big Wet Oils (Большая влажная масляная), Big Wet Ink (Большая влажная чернильная), Ultra-fine Wash Brush (Ультратонкая размывочная кисть), Coarse Hair (Грубая волосяная). У кистей Multi и Rake след одинарный.

Параметр Source (изображение-источник клонирования) подпалитры General становится доступной при установке Dab Type вариантов Line Airbrush (Линейный аэрограф), Projected (Спроектированная), Rendered (Представленная). Раскрывающпйся список Source (Источник) содержит следующие варианты (рис. 6.16a, 6.16b и 6.16c):

  • Color (Цвет) — устанавливает в качестве источника первичный или вторичный цвета;
  • Gradient (Градиент) — устанавливает градацию, окрашивающую штрих по всей длине;
  • Gradient Repeat (Повторяемый градиент) — устанавливает градацию, повторяющуюся по всей длине штриха;
  • Pattern (Шаблон) — устанавливает в качестве источника изображения шаблон;
  • Pattern With Mask (Шаблон с маской) — устанавливает в качестве источника маску изображения;
  • Pattern As Opacity (Шаблон как непрозрачный) — делает шаблон контрастным, светлые части становятся прозрачными, а темные, наоборот, непрозрачными. Это создает эффект витиеватой решетки, сквозь которую видно другое изображение. Однако этот параметр работает только при установленных параметрах: Computed Dab Type (Вычисленные кисти), лучше Rendered (Пересчет изображения в заданных параметрах кисти), установленный метод — Methods Cover или Buildup.

Рис. 6.16a. Изменение параметра Source при создании штриха. Штрих Gradient

Рис. 6.16b. Изменение параметра Source при создании штриха. Штрих Gradient Repeat

Рис. 6.16c. Изменение параметра Source при создании штриха. Штрих Pattern

В качестве примера рассмотрим создание штриха с использованием установки Pattern As Opacity. Для этого:

  1. Выберите категорию кистей Dry Media (Сухой материал), вариант Charcoal (Уголь).
  2. Выберите команду Window > Show Brush Controls (Окно > Показать палитру управления кистью). Откроется палитра Brush Controls.
  3. Откройте секцию General (Основная).
  4. Установите Dab Type > Rendered (Тип следа > Представленный), вариант Methods > Cover (Метод > Покрывающий), Source > Pattern as Opacity (Источник > Шаблон как непрозрачный) (см. рис. 6.17a, 6.17b и 6.18).
  5. Выберите команду Windows > Show > Art Materials (Окно > Показать палитру > Художественные средства) или нажмите комбинацию клавиш Ctrl+З, откроется палитра Art Materials.
  6. Откройте секцию Pattern и выберите шаблон, который легко сделать контрастным, например Filagree (Филигрань).
  7. Установите масштаб шаблона с помощью ползунка Scale.

Рис. 6.17a. Изменение параметра Source при создании штриха. Pattern With Mask

Рис. 6.17b. Изменение параметра Source при создании штриха. Pattern As Opacity

Рис. 6.18. Пример использования опции Source вариант Pattern As Opacity

ПРИМЕЧАНИE. При установлении масштаба следует иметь в виду, что изображение в малом масштабе при увеличении будет выглядеть расплывчато. При установлении масштаба меньше 50% и дальнейшей перезаписи на гибкие диски, компакт-диски и другие устройства происходит потеря информации, особенно цветовой.

Все эти параметры можно связать с направлением движения стилуса или давлением на него в секции Expressions (Выразительность), которую мы рассмотрим в конце урока. При этом для параметра Color можно создать двухцветную кисть, которая изменяет цвет в зависимости от направления. Для параметров Gradient, Gradient Repeat и Pattern, Pattern with mask создается эффект зеркального отражения градиента или шаблона при изменении направления движения кисти или нажима на нее.

Параметр Opacity (Непрозрачность) позволяет изменить непрозрачность штриха с помощью соответствующего ползунка. Это свойство так же связано с давлением на стилус: чем сильнее давление, тем выше непрозрачность штриха.

Параметр Grain (Зерно) становится доступным только для некоторых вариантов инструментов. С помощью ползунка регулируется степень проявления бумажной текстуры в штрихе. Яркость и контрастность бумажной текстуры устанавливается в секции Paper палитры Art Materials.

Секция Size меню Control

Следующая важная секция — Size (Размер).

В этой секции можно изменять различные характеристики следа, наблюдая за производимыми изменениями большинства его характеристик в окне просмотра Brush Dab Preview Window (Окно просмотpa следа кисти), расположенном в верхней части секции Size. Имеются два режима просмотра характера следа. Основной режим — Hard View (Жесткий просмотр) [image] представляет общий размер наконечника инструмента, другой режим, Soft View (Мягкий просмотр) [image] — его форму. Разница диаметров следа в обоих режимах характеризует зависимость толщины штриха от давления на стилус. Есть кисти, у которых разница между диаметрами следа в обоих режимах очень незначительна, например Pencil.

Переключение из одного режима просмотра в другой осуществляется щелчком в центре следа. Это и есть тот самый след, из которого складывается штрих.

В правой части секции расположены значки, изображающие кривые распределения краски при использовании различных инструментов. Для каждого инструмента характерен тот или иной тип распределения краски в следе. Вы можете поэкспериментировать с профилями распределения, однако нет смысла пытаться настроить характеристики карандаша под соответствие мелу или акварели — вы располагаете обширным запасом кистей.

Параметр Size регулирует размер наконечника кисти, а в конечном счете — толщину штриха.

Чтобы изменить размер наконечника, нажмите и удерживайте комбинацию клавиш Ctrl+Alt. При этом курсор примет крестообразную форму. Как только курсор будет установлен и вы начнете движение стилуса, курсор станет круглым и начнет увеличиваться. Отпустите нажатые клавиши в тот момент, когда диаметр курсора достигнет нужного размера кисти.

Параметры секции Size и их назначение приведены в табл. 6.1.

Таблица 6.1. Параметры секции Size

Параметр | Назначение
(Точечный профиль) | Максимальная плотность краски в центральной части мазка с быстрым понижением плотности к периферии
(Усредненный профиль) | Большая плотность краски в центральной части мазка с понижением к периферии
(Линейный профиль) | Максимальная плотность краски в центральной части мазка с равномерным снижением плотности к периферии
(Тупоконечный профиль) | Максимальная плотность краски в центральной части с медленным снижением к периферии мазка
(Акварельный профиль) | Максимальная плотность краски на периферии, средняя плотность в центральной части мазка
(Равномерный профиль) | Равномерная плотность по всему мазку
Build (Построить кисть) | Кнопка, завершающая построение кисти
Size (Размер) | Размер следа
Min Size (Дополнительный размер) | Размер центральной части следа
Size Step (Размер шага) | Плавность перехода между узкой и широкой частями штриха
Feature (Размытость) | Изменяет расстояние между отдельными траекториями следов, созданными сложными кистями

Параметр Min Size позволяет связать толщину штриха с каким-нибудь параметром, например, с давлением стилуса на планшет. Легкое давление дает минимальную толщину кисти, увеличение давления ведет к утолщению штриха. Таким образом, устанавливая Min Size, вы задаете диапазон, в котором может колебаться толщина штриха в зависимости от давления, оказываемого на стилус.

Все инструменты имеют определенные параметры, установленные по умолчанию. Если вы меняете несколько параметров, то Painter должен построить новую кисть. В прежних версиях Painter в таких ситуациях предупреждал о необходимости сделать это.

В Painter 8 есть возможность автоматического создания кисти. Для этого:

  1. Выберите команду Windows > Show Brushes (Окно > Показать кисти). Откроется палитра Brushes.
  2. Выберите команду Brush > Auto Build Brush (Кисть > Автоматическое построение кисти). Напротив выбранной команды будет установлена галочка. Теперь Painter, не запрашивая вашего согласия на построение кисти, будет создавать ее автоматически.

Аналогичный результат дает нажатие комбинации клавиш Ctrl+B.

Секция Spacing

Следующая секция — Spacing (Расстояние).

Она также предназначена для изменения параметров штриха кисти и актуальна в основном для кистей, использующих dab based (Dab Type). При работе с кистями Rendered (Dab Type) установки параметров этой секции не требуются и даже замедляют работу.

Параметры секции приведены в табл. 6.2.

Таблица 6.2. Параметры секции Spacing

Параметр | Назначение
Spacing (Расстояние) | Регулирует расстояние между следами. При значении 100% расстояние равно размеру следа. Уменьшение расстояния ведет к сглаженности липни штриха
Min Spacing (Минимальное расстояние) | Регулирует минимальное расстояние между следами. При перемещении ползунка вправо расстояние увеличивается, при перемещении влево — уменьшается
Damping (Уменьшение амплитуды колебаний) | Регулирует сглаженность края штриха с помощью математического аппарата. Перемещение ползунка вправо создает сглаженность края штриха, влево — зубчатость. Оптимальное значение — 50%
Continuous Time Deposition (Продолжительность времени воздействия) | Регулирует продолжительность воздействия изобразительного средства на холст. Если флажок установлен, достаточно касания инструментом для появления штриха. Если флажок снят, штрих появляется после его проведения
Cubic Interpolation (Кубическая интерполяция) | Регулирует сглаженность края штриха путем добавления дополнительных точек

Флажок Continuous Time Deposition (Продолжительность времени воздействия) обычно используется для управления кистями типа аэрографов.

Пример результата различных установок секции Spacing приведен на рис. 6.19. Левый штрих исходный, далее увеличивалось значение параметра Spacing, в последнем штрихе увеличен параметр Min Spacing.

Рис. 6.19. Изменения штриха в зависимости от установок в секции Spacing

Секция Angle

Секция Angle (Угол) используется только с Circular (Круглый) и Captured (Фиксированный) вариантами Dab Types.

С помощью этой палитры осуществляется различной степени сжатие следа кисти, то есть, окружность становится эллипсом. Вы легко можете в этом убедиться, установив курсор для рисования. Он сразу же принимает форму будущего следа кисти. Параметры данной секции и их назначение приведены в табл. 6.3.

Таблица 6.3. Назначение параметров секции Angle

Параметр | Назначение
Squeeze (Сжатие) | Сжатие окружности. Перемещение ползунка влево усиливает сжатие
Angle (Угол) | Угол наклона эллипса. Перемещение ползунка вправо поворачивает эллипс по часовой стрелке, влево — против
Angle Range (Диапазон угла) | Диапазон угла поворота следа
Angle Step (Шаг угла) | Шаг поворота следа при изменении направления штриха. Параметр определяется при значении Angle Range, отличном от 0

Все изменения параметров с помощью секции Angle отражаются на форме и расположении курсора.

На рис. 6.20a, 6.20b и 6.20c приведены штрихи, выполненные кистью варианта Circular Dab Types.

Рис. 6.20a. Результат изменения параметра Squeeze. Установлено максимальное сжатие

Рис. 6.20b. Результат изменения параметра Squeeze. Сжатие уменьшено до 45%

Рис. 6.20c. Результат изменения параметра Angle. Фрагменты линий, которые на рисунке 6.20a были тонкими, стали широкими, и наоборот

Параметры Angle Range и Angle Step предназначены для связи различных параметров в секции Expression, например направления движения линии и наклон штриха.

Секция Random

Секция Random (Случайное распределение) регулирует случайное распределение следов в штрихе.

Изменяя параметр Jitter (Флуктуация), можно из четкой линии сделать распыление, подобно аэрографу.

Остальные параметры этой секции становятся доступными при применении инструмента Cloners.

Эффект случайного распределения, полученного с помощью палитры Random:

Три первых штриха выполнены инструментом Dry Media (Сухой материал), вариант Large Chalk (Большой мел), Dab Type (Тип следа) — Circular (Круглый), Stroke Туре (Тип штриха) — Single (Единичный). Параметр Jitter в первом штрихе минимальный, во втором — средний, штрих при этом становится неровным, в третьем — максимальный, штрих распадается на отдельные следы.

Три следующих штриха выполнены инструментом Реn (Перо), вариант Calligraphy (Каллиграфический), Dab Type — Bristle (Щетина), Stroke Type — Singie (Единичный). Параметр Jitter в первом штрихе минимальный, во втором — средний, штрих стал расплывчатым, в третьем — максимальный, штрих стал широким и неровным.

Секция Bristle

Секция Bristle (Щетина) становится доступной, когда вы работаете с кистью типа Static Bristle (Стоящая щетина). Помимо кистей, принадлежащих к этому типу по умолчанию, многие другие инструменты можно настроить подобным образом. С помощью ползунков вы можете менять параметры щетинок, наблюдая за изменениями в окне просмотра Brush Dab Preview Window секции Size. Для наглядности увеличьте размер кисти перемещением ползунка Size и переключитесь в режим просмотра Soft щелчком в центре следа кисти.

Параметры секции Bristle и их назначение приведены в табл. 6.4.

Таблица 6.4. Параметры секции Bristle

Параметр | Назначение
Thickness (Толщина) | Изменяет толщину отдельных волосков, не меняя их количества
Clumpiness (Слипание) | Объединяет волоски в группы. При этом отдельные волоски становятся крупнее и образуют группы, остальные остаются без изменений
Hair Scale (Масштаб волосков) | Меняет соотношение между толщиной волосков, расстоянием между ними и их количеством. При увеличении этого параметра волоски, как под лупой, становятся крупней, расстояние между ними увеличивается, но количество волосков при этом становится меньше
Scale/Size (Диапазон/Размер) | Устанавливает диапазон изменений всех прочих параметров

В качестве примера результата изменения параметров секции Bristle приведен вид окна просмотра секции Size в режиме Soft для кисти категории Brush, вариант Captured Bristle, Dab Type — Static Bristle.

Рис. 6.21. Исходные параметры кисти: вид следа кисти, секция Bristle, полученный штрих

Рис. 6.22. Увеличен параметр Thickness (толщина волосков кисти)

Рис. 6.23. Толщина волосков исходная, увеличено значение dumpiness (слипание щетинок)

Рис. 6.24. Слипание щетинок уменьшено, изменено соотношение между толщиной, расстоянием между щетинками и количеством Hair Scale (масштаб волосков)

Секция Rake

Секция Rake (Зубцы) позволяет управлять отклонением щетинок кисти при касании кистью холста, повороте и изменении направления штриха.

Секция Rake (Зубцы) доступна, только если в секции General установлен Stroke Туре (Тип штриха) Rake или Multi. Эти секции связаны между собой. В секции Rake вы можете изменять параметры, приведенные в табл. 6.5.

Таблица 6.5. Параметры секции Rake

Параметр | Назначение
Contact Angle (Угол контакта) | Установка количества щетинок, касающихся холста. При перпендикулярном положении кисти по отношению к холсту все щетинки касаются бумаги. При появлении наклона, число касающихся щетинок уменьшается
Brush Scale (Масштаб кисти) | Установка расстояния между следами каждого зубца. При этом меняется ширина штриха
Turn .Around (Смещение при повороте) | Установка смещения щетины при повороте кисти
Bristle (Щетина) | Установка количества щетинок (следов) в штрихе
Spread Bristle (Раздвигание щетины) | Настройка связи между нажимом на электронное перо и шириной штриха

Зависимость получаемого штриха от изменения параметров секции Rake приведена в табл. 6.6.

Таблица 6.6. Зависимость штриха от изменения параметров секции Rake

Установлены | Вид секции Rake | Вид штриха
Исходные параметры кисти, тип штриха Single | Секция Rake недоступна |
Минимальное значение Bristle, вид штриха почти не отличается от исходного |  |
Значение Bristle увеличено, воздействие многих щетинок как бы складывается, при этом усиливается интенсивность окраски |  |
Увеличено расстояние между щетинками с помощью параметра Brush Scale, теперь видно, что штрих состоит из многих линий |  |
Параметр Brush Scale увеличен, все линии отделены друг от друга, как следы грабель |  |
Параметр Brush Scale снова такой же, как на четвертом рисунке, установлен угол контакта, но при этом штрих стал вдвое шире |  |
Параметр Brush Scale снова без изменения, угол контакта небольшой. Turn Around (смешение при повороте) делает край штриха неравномерным |  |
Параметр Brush Scale снова без изменения, угол контакта небольшой, смешение при повороте мини- мальное, установлен флажок Spread Bristle, увеличивается расстояние между отдельными линиями штриха |  |

Секция Well

Секция Well (Источник) предназначена для создания эффектов размазывания подлежащей краски. Ползунки этой секции функционируют взаимосвязанно. Настройка каждого из них влияет на состояние другого. С помощью этой секции можно создать много интересных эффектов. Назначение ползунков приведено в табл. 6.7.

Таблица 6.7. Назначение ползунков параметров секции Well

Ползунок | Назначение
Resat (Восстановление насыщенности) | Регулирует насыщенность наносимого тона
Bleed (Растекание) | Размазывает цвет фона
Dryout (Высыхание) | Регулирует размазывание фона

Результат действия ползунков зависит от выбранной кисти и может преподнести немало сюрпризов.

В приведенном примере (табл. 6.8) представлены изменения штриха в зависимости от установок параметров секции Well.

При нулевом значении Resat кисть рисует не установленным цветом, а размазывает цвет фона, особенно это заметно при использовании шаблона в качестве фона. Аналогичная картина получается при изолированной установке увеличенного значения одного из параметров. При сочетании каких-либо параметров начинает включаться и установленный цвет.

Таблица 6.8. Зависимость получаемого штриха от изменения параметров

Установ- лены | Вид секции Rake | Вид штриха
При нулевом значении Resat инстру- мент рисует не установ- ленным цветом, а размазы- вает цвет фона |  |
При увели- чении значе- ния Resat в штрихе появля- ется выбран- ный цвет, смешан- ный с фоном |
При увели- чении значений параметра Bleed происхо- дит размазы- вание фона |
При увели- чении значения Dryout уменьша- ется размазы- вание краски |
Примесь размазан- ного цвета в основном сохраня- ется |
Преобла- да ние основного фона |
Смешение прекраща- ется, и при переходе на белый фон штрих остается выполнен- ным чистым основным тоном |
При установ- ленном флажке Brush Loading размазы- вание фона происхо- дит замедлен- но, с сохране- нием очертаний рисунка |

При увеличении значения Resat в штрихе появляется выбранный цвет, наложенный на фоновый тон. При переходе на неокрашенную поверхность смешения выбранного цвета с цветом фона не происходит, цвет остается чистым.

При увеличении значений параметра Bleed (Растекание) (Resat отлично от нуля) происходит размазывание краски фона.

При увеличении значения Dryout (Высыхание) (Resat отлично от нуля) смешение основного и фонового тонов прекращается, и при переходе на белый фон штрих остается выполненным чистым основным тоном. При средних значениях Dryout можно получить очень естественный штрих, содержащий градацию основного и размазываемого цвета, постепенно переходящих в чистый тон. Установка параметра Dryout 20-30% позволяет придать естественный вид штриховке, например мелом (Chalk), создавая более бледный конец штриховой линии.

Установка флажка Brush Loading ведет к сохранению фонового рисунка в штрихе при невысоких значениях Resat.

Секция Airbrush

Секция Airbrush (Аэрограф) управляет работой аэрографов, регулирует поток краски, наносимый на холст с помощью аэрографа, область распространения и т. д. (табл. 6.9).

Рис. 6.25. Секции Airbrush

Таблица 6.9. Параметры секции Airbrush

Параметр | Назначение
Spread (Распространенность) | Регулирует величину области распространения. Чем уже диапазон распространения, тем дальше от курсора попадает краска
Min Spread (Минимальная распространенность) | Регулирует величину минимального распространения краски
Flow (Поток) | Регулирует поток краски, служит для связи через палитру Expression между скоростью нанесения краски и давлением или направлением
Min Flow (Минимальный поток) | Определяет минимальное количество краски, которое может быть нанесено в области пятна

Оптимальный диапазон распространения в большинстве случаев — около 30-40%. При малых значениях Spread уменьшается угол наклона аэрографа к холсту, поэтому краска оказывается далеко oт места приложения.

Зависимость получаемого штриха от изменения параметра Spread (Распространенность) приведена на рис. 6.26a, 6.26b, 6.26c, 6.26d и 6.26e.

Рис. 6.26a. Значение Spread равно 14

Рис. 6.26b. Значение Spread равно 30

Рис. 6.26c. Значение Spread равно 50

Рис. 6.26d. Значение Spread равно 70

Рис. 6.26e. Значение Spread равно 90

При увеличении значений Spread область распространения увеличивается и принимает коническую форму. При максимальных значениях область распространения сужается до небольшого пятна, как будто вы поднесли аэрограф очень близко к холсту практически перпендикулярно.

Секция Expression

Секция Expression (Выразительность) предназначена для совместной регулировки различных параметров штриха. Она состоит из трех рядов параметров. Первый ряд представляет собой свойства инструментов, назначение которых представлено в табл. 6.10. Следующий ряд, Controller (Регулятор), содержит поля параметров. Щелчок на поле раскрывает меню, одинаковые для каждого поля. Вы можете выбрать в меню любой признак, с которым требуется связать свойства инструмента для создания более реалистичных работ. Третий ряд, Invert (Обратный), содержит флажки, при установке которых действие меняется на обратное. В табл. 6.10, 6.11 и 6.12 представлены параметры инструментов, их назначение и свойства, с которыми их можно связать.

Рис. 6.27. Секция Expression

Таблица 6.10. Свойства инструментов и их назначение

Свойство | Назначение
Size (Размер) | Толщина штриха
Jitter (Разброс) | Разброс следов, из которых состоит штрих
Opacity (Непрозрачность) | Плотность нанесения краски
Grain (Зернистость) | Чувствительность к текстуре бумаги

Таблица 6.11. Параметры свойств инструментов и их назначение

Параметр | Назначение
Color (Цвет) | Переходы между основным цветом и фоновым
Angle (Угол) | Угол, под которым располагается след кисти
Resat (Восстановление насыщенности) | Насыщенность наносимого тона
Bleed (Растекание) | Смазывание тона фона
Flow (Поток) | Поток краски из иглы аэрографа
Feature (Признак) | Расстояние между отдельными траекториями следов, созданными сложными кистями
Depth (Глубина) | Глубина эффекта выпуклости кисти Impasto
Rank 1, 2, 3, (Уровень) | Последовательность изображений для кистей типа Image Hose
Direction (Направление) | Угол наклона штриха

Таблица 6.12. Параметры раскрывающихся меню

Параметр | Назначение
None | Связь не установлена
Velocity (Скорость перемещения) | Со скоростью движения электронного пера (стилуса)
Direction (Направление) | С направлением движения кисти
Pressure (Давление) | С нажимом на электронное перо (стилус)
Wheel (Колесо) | С перемещением колесика стилуса типа Intuos, с работой инструмента Airbrush. Увеличение потока краски вызывается поворотом колесика вперед, уменьшение — назад
Tilt (Наклон) | С углом наклона электронного пера
Bearing (Опора) | С положением электронного планшета
Source (Источник клонирования) | С изображением-источником при клонировании (основано на вариациях яркости клона)
Random (Случайный разброс) | Случайным образом с любым параметром

Последние шесть параметров раскрывающегося меню связаны со стилусом и планшетом. Однако отметим, что возможностью управлять параметрами Bearing и Tilt (Опора и Наклон) пока обладают немногие дорогие профессиональные модели стилусов, a Wheel — только специальный стилус типа Intuos.

Параметр Pressure у многих инструментов по умолчанию связан с параметрами Opacity (Непрозрачность) и Size (Толщина штриха). Это значит, что при усилении давления на стилус усиливается тон штриха и его толщина. Понятно, что эта зависимость актуальна для стилуса, но не для мыши.

Ползунок Direction также связан с Angle (Угол наклона штриха). Если установлена связь размера с направлением, ползунок позволяет установить угол направления движения, тогда при приближении к установленному значению будет меняться толщина штриха. Это свойство очень полезно при создании эффекта каллиграфии.

Скорость перемещения, Velocity, связана с Size (Размер) и Opacity (Непрозрачность). Эта связь также актуальна при отсутствии стилуса для работы с мышью.

Source связывает яркости клона с каким-нибудь параметром, величину которого можно регулировать, например, с размером штриха: чем больше размер, тем ярче клон.

Параметр Rank актуален только для кистей типа Image Hose. Если связь не определена, то изображения выходят из шланга в порядке, установленном по умолчанию. Если вы определили связь, например, с давлением, то при увеличении давления из шланга выходят изображения третьего уровня, а при уменьшении — второго (см. главу 12).

Параметр Size позволяет установить связь между давлением или направлением движения и толщиной штриха. При этом диапазон, в котором изменяется толщина штриха, зависит от разницы между параметрами Size и Min Size. Например, Size — 20, Min Size — 10, толщина штриха будет колебаться от 10 до 20.

Как вы, наверное, уже отметили, в этой палитре встречаются параметры, знакомые вам по другим секциям, например: Size и Angel из одноименных секций; Resat и Bleed из секции Well; Opacity, Grain, Size из палитры Controls и т. д. С помощью сведенных воедино нескольких палитр вы сможете изменять работу привычных инструментов, создавая новые эффекты.

Чтобы установить связь между какими-либо параметрами, необходимо выбрать в первом ряду свойство кисти, для которого вы хотите установить связь, затем в правом поле раскрыть меню и выбрать фактор, с которым можно связать свойство кисти. Если вы установили связь, но получили обратную зависимость, установите флажок Invert, тогда зависимость будет прямой.

В качестве упражнения создадим двухцветную кисть с помощью палитры Expression.

Упражнение. Двухцветная кисть

При работе с двухцветной кистью линия, проведенная любым инструментом из палитры Brushes, будет менять цвет в зависимости от направления, нажима на инструмент, скорости перемещения инструмента и других параметров.

Для создания двухцветной кисти:

  1. Выберите кисть и ее вариант в палитре Brushes.
  2. Выберите команду Window > Show Art Materials, откройте секцию Color, щелкните на индикаторе основного цвета. На цветовом круге выберите нужный оттенок, а затем подберите насыщенность и интенсивность цвета. Щелкните на индикаторе вторичного цвета и подберите необходимые цветовые параметры.
  3. Выберите команду Window > Show Brush Controls. Откроется палитра Brush Controls, откройте секцию Expression, выберите параметр Color и в раскрывшемся меню установите флажок рядом с параметром, с которым вы собираетесь связать цвет кисти, например, Direction.
  4. С помощью ползунка Direction поэкспериментируйте с величиной угла направления штриха, при котором изменяется цвет. Двухцветная кисть создана.

На рис. 6.28 представлено изображение, созданное с помощью двухцветной кисти, вариант Random. Использован также инструмент Custom Tile из меню Effects, вариант Brick.

Рис. 6.28. Изображение, созданное с помощью двухцветной кисти

Секция Water

Секция Water (Водный) предназначена для работы с акварельными кистями — Water Color и становится доступной только при выборе этой категории.

Данная секция имеет всего два ползунка: Wet Fringe (Влажная кайма) и Diffusion (Диффузия).

Ползунок Wet Fringe регулирует степень скопления краски по наружным краям штриха. Перемещая его вправо, вы увеличиваете концентрацию краски по краям.

Ползунок Diffusion определяет качество бумаги. При увеличении значения Diffusion краска расплывается на бумаге, создавая впечатления пористости, подобно промокательной бумаге.

СОВЕТ. Будьте внимательны! Увеличение концентрации краски на краях штриха распространяется на все штрихи, выполненные во влажном слое, независимо от того, сохранили вы предыдущий результат или нет. При этом неэффективно сохранение штрихов с помощью закрытия документа с последующим его открытием. Сохранить отдельные штрихи без скопления краски лучше с помощью команды Canvas > Dry.

Особенность кистей этой категории состоит в том, что они рисуют в специальном влажном слое. В нем не работают некоторые инструменты, например Dropper (Пипетка) и Eraser (Ластик). Но в этой группе кистей есть собственный ластик — Wet Eraser (Влажный ластик). Учитывая тот факт, что все другие инструменты рисуют в другом слое, можно использовать эффект кальки, но при этом как бы подкладывать ее под изображение в качестве заготовки. В конце работы вы без труда удаляете набросок. Однако для печати слои необходимо объединить. Это можно осуществить с помощью уже знакомой вам команды Canvas > Dry.

Ниже приведены примеры зависимости изменения штриха от установок палитры Water.

Штрихи сделаны кистью Water Color, вариант Simple Water (Простая водяная), метод Wet (Влажный), субкатегория Grainy Wet Abrasive (Зернистая влажная царапающая); установлены исходные параметры.

Увеличено значение диффузии с помощью ползунка.

Увеличено значение параметра Wet Fringe (Влажная кайма), отчетливо видно скопление краски по краям штриха.

Работа с мышью

Возможно, вам иногда приходится работать не только стилусом, но и мышью. Никто не спорит, что рисование с ее помощью довольно проблематично. Но если у вашего компьютера только одно гнездо, к которому вы можете подключить либо мышь, либо стилус, а работа не очень продолжительная и кропотливая, можно попробовать выполнить ее мышью. И в прежних версиях Painter была попытка реализовать эту возможность с помощью палитры Slaiders (Движки), предшествовавшей секции Expression. В новой версии введена дополнительная секция Mouse, позволяющая отрегулировать параметры кисти сообразно стилусу. Как видите, она не содержит новых незнакомых параметров.

Для создания штриха, наиболее близкого к выполненному стилусом, «Руководство пользователя» рекомендует сделать следующие установки ползунков: Pressure (Давление) - 100%, Tilt (Наклон) - 90°, Wheel (Колесо) - 100%, Bearing (Опора) — 0°.

Кроме того, с помощью секции Expression вы можете попытаться настроить мышь, например, установив связь между толщиной штриха и направлением, подобно рассмотренному выше примеру с двухцветной кистью. Есть и другая возможность настройки мыши. Если часть времени вы выполняли работу стилусом, можно записать штрих, сохранить его, а затем использовать данные штриха для создания подобного эффекта мышью. Эти действия выполняются с помощью палитры Brush.

  1. Выберите команду Stroke > Record Stroke (Штрих > Записывать штрих).
  2. Выполните штрих, проверьте осуществление записи, выбрав команду Stroke > Playback Stroke (Штрих > Проигрывать штрих).
  3. Выберите команду Stroke > Save Stroke (Штрих > Сохранить штрих). Откроется окно Save Stroke (рис. 6.29). Введите имя штриха, нажмите кнопку ОК.
  4. После того как штрих сохранен, можно использовать его характеристики для получения подобного штриха с помощью мыши.
  5. Выберите команду Stroke > Use Stroke Data (Штрих > Использовать данные штриха), теперь вы можете рисовать мышью с использованием параметров штриха, созданного стилусом.

Рис. 6.29. Диалоговое окно Save Stroke


Клонирование

  • Техника клонирования
    • Использование клонирующих кистей
    • Использование автоклонирования
    • Создание клонирующих кистей
    • Использование секции Random для настройки клонирующих кистей
    • Клонирование внутри одного документа
  • Многоточечное клонирование
    • Выбор типа клонирования
    • Установка точек клонирования
    • Тип клонирования
    • Использование выделений при клонировании
  • Упражнение. Клонирование изображения из одного документа в другой
  • Упражнение. Клонирование фрагмента изображения из одного документа в другой

Клонирующие кисти позволяют воспроизвести изображение- источник с помощью традиционных художественных средств, таких как масло, акварель, пастель, тушь, карандаш и т. д.

Клонирование — это точное повторение изображения или его части. Это больше чем просто копия, потому что при этом происходит попиксельное считывание информации и перенос ее в другую область.

Процесс клонирования осуществляется в два этапа: определение источника клонирования — Clone Sourse, и получение клона изображения в обозначенном месте. Клонирование может производиться как внутри одного документа, так и из одного документа в другой.

С помощью клонирования вы можете:

  • создавать точную копию изображения или его участка;
  • трансформировать изображение (масштабировать, поворачивать, наклонять, устанавливать перспективу);
  • редактировать изображение (убрать определенный объект, добавить большой фрагмент из другого изображения, например сложный пейзажный фон).

Кроме того, для обработки фотографии существуют специальные клонирующие кисти, с помощью которых создается имитация графических или живописных средств.

Техника клонирования

При клонировании происходит формирование связей между документами (клонирование в другой документ) или между фрагментами одного документа (клонирование внутри документа).

Для создания клона в другом документе достаточно открыть изображение и выбрать команду File > Clone (Файл > Клонировать). Painter автоматически создает клон изображения в новом документе и дает ему название Clone of....

ПРИМЕЧАНИЕ. При создании клона документа Painter игнорирует многослойную структуру изображения. В клоне со сложного изображения отсутствует возможность редактировать отдельные слои. Но это свойство клонов используют при печати, так как гораздо быстрее можно сделать клон, чем опускать каждый слой отдельно на поверхность холста.

Использование клонирующих кистей

Клонирующие кисти — категория кистей палитры Brush, которая позволяет воспроизвести изображение-источник с помощью традиционных художественных средств, таких как масло, акварель, пастель, тушь, карандаш и т. д.

ПРИМЕЧАНИЕ. Помимо специальных клонирующих кистей для этой цели вы можете использовать практически любую кисть, предварительно установив в секции Color палитры Art Materials флажок Clone Color.

Чтобы воспроизвести клонируемое изображение с помощью клонирующих кистей:

  1. Откройте изображение-источник, например несложную фотографию.
  2. Выберите команду File > Clone. Painter автоматически создает клон изображения в новом документе и дает ему название Clone of....
  3. Выберите команду Select > All. Нажмите клавишу Delete или Backspace. Изображение клона исчезнет.
  4. Painter предоставляет вам возможность видеть ослабленное изображение, словно через кальку. Для этого выберите команду Canvas > Tracing Paper (Холст > Калька) или нажмите сочетание клавиш Ctrl+T. Если плохо видны детали изображения, выберите команду Edit > Fade (Правка > Ослабить).
  5. Откройте палитру Brushes, выберите в списке категорий кисть Cloners и любую из предложенных кистей в списке вариантов. Категория клонирующих кистей одна из самых многочисленных.

ПРИМЕЧАНИЕ. Кисти, расположенные в нижней части списка, название которых начинается с х. например x-Bilinear, x-Perspective и т, д., повторяют изображение, не стилизуя его под художественные средства. Они создают копию изображения, трансформируя его различным образом (к ним мы вернемся в конце урока).

При выборе некоторых кистей категории Cloners Painter автоматически устанавливает флажок Clone Color (Клонировать цвет) в секции Color палитры Art Materials. При этом сама секция Color палитры Art Materials становится недоступной, а цветовая информация берется из изображения-источника. В других случаях вам придется следить за этим флажком самостоятельно.

ВНИМАНИЕ. Не забывайте устанавливать флажок Clone Color при изменении кисти.

Для усиления цветового эффекта рекомендуется установить флажок Brush Loading (Загрузка кисти) в секции Well (Источник) палитры Brush Controls. При этом считывание цветовой информации производится попиксельно. При изолированном использовании параметра Clone Color в секции Color палитры Art Materials берется усредненный, аппроксимированный, цвет. При работе с кистями импрессионистов лучше установить только флажок Clone Color без установки флажка Brush Loading в секции Well палитры Brush Controls.

Сделав эти установки, вы можете рисовать в клоне изображения, ориентируясь по просвечивающему изображению. В процессе рисования параметры выбранной кисти можно менять с помощью секций палитры Brush Controls (см. главу 6).

По окончании рисования клонирующими кистями выберите команду Canvas > Tracing Paper или нажмите сочетание клавиш Ctrl+T.

Изображение-источник исчезнет. При выборе Tracing Paper изображение-источник и клон могут быть только одного размера.

Пример стилизованного клонирования изображения приведен на рис. 7.1. Источник клонирования справа, клонирование выполнено кистью Cloners, вариант Melt Cloner (Тающая).

Рис. 7.1. Справа — изображение-источник, слева — результат клонирования

Использование автоклонирования

Painter позволяет осуществить клонирование изображения с помощью клонирующих кистей в автоматическом режиме. Для этого:

  1. Откройте изображение-источник, например, несложную фотографию.
  2. Выберите команду File > Clone. Painter автоматически создает клон изображения в новом документе и дает ему название Clone of....
  3. Выберите команду Select > All. Нажмите клавишу Delete или Backspace. Изображение клона исчезнет.
  4. Откройте палитру Brushes, выберите вариант кисти категории Cloners.
  5. Установите флажок Clone Color в секции Color палитры Art Materials.
  6. Выберите команду Effects > Esoterica > Auto Clone (Эффект > Эзотерика > Автоклонирование).

Painter начнет постепенно заполнять изображение-клон автоматически.

ВНИМАНИЕ. Не все кисти категории Cloners могут автоматически клонировать изображение, при выборе некоторых команда Auto Clone становится недоступной.

Когда вы применяете инструменты Pens, Felt pens, Pencils и другие, использующие по умолчанию метод Buildup, ваша работа может получиться сильно затемненной. В этом случае необходимо заранее уменьшить непрозрачность с помощью палитры Controls.

Процесс автоклонирования может сильно затянуться. Если видимых изменений уже не происходит, а процедура все еще не закончилась, можно прервать этот процесс, щелкнув мышью в рабочем поле. Для его возобновления необходимо снова выбрать команду Effects > Esoterica > Auto Clone.

В качестве примера на рис. 7.2, 7.3, 7.4 приведено изображение, подвергнутое автоматической обработке клонирующими кистями типа Watercolor Cloner (Акварель) и Driving Rain Cloner (Идущий дождь).

Рис. 7.2. Исходное изображение

Рис. 7.3. Обработка кистью Watercolor Cloner

Рис. 7.4. Обработка кистью Driving Rain Cloner

Создание клонирующих кистей

Как вы уже знаете, можно превратить почти любую кисть в клонирующую. Для этого в Painter есть два способа:

  • установка флажка Clone Color в секции Color палитры Art Materials;
  • установка метода Cloning в секции General палитры Control Brush.

Второй способ создания клонирующих кистей имеет преимущество перед первым. Дело в том, что при использовании клонирующих методов происходит перенос каждого пиксела изображения из источника в клон.

При этом копия получается точнее, чем при установке флажка Clone Color. Кроме того, устанавливая субкатегорию метода, можно добавить определенные свойства текстуры, что также расширяет ваши возможности.

Особенности клонирующих методов приведены в табл. 7.1.

Таблица 7.1. Клонирующие методы и их возможности

Метод | Создает
Hard Cover Cloning (Жесткий покрывающий) | Неразмытый ровный штрих
Soft Cover Cloning (Мягкий покрывающий) | Наполовину размытый штрих
Grainy Hard Cover Cloning (Зернистый жесткий покрывающий) | Четкий ровный штрих, но чувствительный к фактуре бумаги
Grainy Soft Cover Cloning (Зернистый мягкий покрывающий) | Размытый штрих, чувствительный к фактуре бумаги
Drip Cloning (Капельный) | Размытый влажный штрих с искажениями во влажном слое

Вы наверняка обратили внимание, что для некоторых кистей установка метода недоступна.

Использование секции Random для настройки клонирующих кистей

Применяя метод Cloning для создания клонирующих кистей, удается получить любопытные эффекты с помощью разнообразных вариантов настроек. Одним из таких вариантов может быть применение секции Random для настройки кистей.

Основные параметры этой секции мы подробно рассмотрели в главе 6.

Смещение ползунка Variability (Изменение) вправо создает некоторую воздушность, легкость штриха, импрессионистский эффект.

Одновременное небольшое смещение ползунков Variability — вправо и How Often (Как часто) — влево создает впечатление быстрого наброска, эскиза (рис. 7.5 в центре).

Рис. 7.5. Исходный рисунок и измененные с помощью секции Random

Установка флажка Random Clone Source (Разброс источника) рассеивает изображение на множество деталей, в нем уже не найти ничего похожего на источник, кроме общего сочетания цветов.

Флажок Random Brush Stroke Grain (Разброс кисти с зернистым штрихом) делает штрих зернистым, но изображение при этом не теряется.

На рис. 7.5 приведены изображения, полученные с помощью настроек секции Random. Первое — исходное, затем проведено клонирование кистью категории Dry Media, вариант Soft Charcoal (Мягкий уголь). В среднем образце ползунок Variability установлен на средних значениях. Последний образец получен с помощью установки флажка Random Clone Source (Случайное отклонение от источника клонирования).

На рис. 7.6 приведен пример клонирования. Исходное изображение (слева) преобразовано путем клонирования с помощью кисти Opaque Bristle Spray (Непрозрачная водяная щетинистая разбрызгивающая) (Size — 20%, Min. Size — 10%), а затем обработано с помощью ластика Flat Eraser (Плоский ластик), подкатегории Soft Grain Colorize (Мягкая зернистая раскрашивающая) и Soft Alfa Colorize (Мягкая альфа раскрашивающая).

Рис. 7.6. Пример клонирования. Исходное изображение (вверху), внизу — результат

Клонирование внутри одного документа

Клонирование внутри одного документа применяется для редактирования изображения. Например, в изображении, которое вы планируете использовать для создания другой работы, требуется удалить лишнюю деталь. Это сделать совсем не трудно.

На рис. 7.7 приведена фотография пейзажа, которую мы планируем использовать в дальнейшем. Но в центре изображения присутствует непонятная деталь. Попытаемся ее убрать.

Рис. 7.7. Исходное изображение долины

Для этого необходимо скопировать цветовое соотношение в точке с цветовой гаммой, наиболее близкой к гамме места корректировки. А затем, используя полученный клон изображения, закрасить им нужное место. Эта манипуляция подобна работе с инструментом штамп в Photoshop. Для этого:

  1. Установите указатель мыши в точку копирования, нажмите клавишу Shift, указатель мыши примет форму строчной буквы i с зеленой точкой над символом. Клон получен.
  2. Выберите кисть для клонирования изображения из категории Cloners, например, Soft Cloner.
  3. Установите флажок Clone Color в секции Color палитры Art Materials.
  4. Аналогичный эффект получается, если при нажатой комбинации клавиш Ctrl+Shift установить курсор в нужное место и щелкнуть кнопкой мыши, но стилизованная буква i будет иметь красную точку над символом.
  5. Теперь можете закрасить выбранное место. Лучше делать это медленно, регулируя параметр Opacity в палитре Controls.

Если маскируемый фрагмент достаточно протяженный, необходимо после закрашивания некоторой части снова устанавливать образец клона следующих точек и продолжать процесс, пока выбранный участок не будет закрыт полностью.

Результат обработки полученного изображения приведен на рис. 7.8. Предмет, находившийся в центре изображения, удален.

Рис. 7.8. Откорректированное изображение

Клонирование фрагмента изображения из одного документа в другой уместно, например, для создания фона. В качестве примера рассмотрим следующую ситуацию. На рис. 7.8 приведено откорректированное в предыдущем разделе изображение долины. Мы попробуем использовать его как фон к изображению овец, приведенному на рис. 7.9.

Рис. 7.9. Изображение, в которое будет клонироваться фон из рис. 7.8

Для этого:

  1. Выберите команду File > Clone Source и выберите изображение, из которого вы хотите взять фон или другой фрагмент.
  2. Выберите кисть категории Cloners; если вы хотите, чтобы фон в точности соответствовал изображению на рис. 7.8, можно выбрать кисть x-Bilinear (х-Двухлинейная).
  3. Начинайте закрашивать фон, выбранной кистью (рис. 7.10). По мере приближения к объекту, вокруг которого вы создаете фон, переключитесь на другой уровень увеличения объекта для аккуратной его обрисовки. Меняйте размер кисти и непрозрачность, чтобы более естественно вписать объект в фон.

Рис. 7.10. Процесс клонирования фона

Окончательный вариант изображения приведен на рис. 7.11.

Рис. 7.11. Итоговое изображение

Многоточечное клонирование

Нижняя часть меню категории кистей клонирования Cloner представлена кистями Super Clone. Особенность этих кистей в том, что помимо собственно клонирования, они создают различные эффекты трансформации. Именно в работе этих кистей использован принцип многоточечного клонирования.

Выбор типа клонирования

Как вы уже поняли, в Painter может использоваться несколько типов клонирования. Тип клонирования определяется количеством точек, используемых при клонировании. Clone Type (Тип клонирования) устанавливается в секции Cloning палитры Brush Control.

Наверное, вы уже обратили внимание, что в раскрывающемся списке Clone Type рядом с типом клонирования в скобках стоят цифры. Это и есть количество точек, используемых при клонировании. При нормальном клонировании из документа в документ изображение переносится без смещения. Поэтому рядом с типом Normal в скобках стоит 0.

При клонировании внутри документа применяется смещение. Этот метод называется Offset (Смещение). При смещении используется одна точка, а принцип офсетного клонирования называется «из точки в точку». Его мы рассмотрели при ретушировании дефекта в предыдущем разделе (см. рис. 7.7 и рис. 7.8).

СОВЕТ. Если размер изображения-клона должен быть больше источника, использовать офсетное клонирование нерационально. Дело в том, что при клонировании из точки в точку изображение-источник будет перенесено в левый верхний угол, остальное пространство останется незаполненным (рис. 7.12).

Рис. 7.12. Офсетное клонирование из меньшего источника в больший документ

Все остальные типы клонирования требуют участия специальных кистей — категории Super Cloner Brush (Суперклонирующие кисти). Теперь они входят в список клонирующих кистей. Эти кисти позволяют создавать при клонировании любопытные эффекты. И процессы, связанные с их участием, мы рассмотрим ниже.

ПРИМЕЧАНИЕ. Тип клонирования, выбираемый из раскрывающегося списка Clone Type в секции Cloning палитры Brush Control, может устанавливаться не только для кистей категории Cloners, но и для любых других клонирующих кистей, полученных с помощью установки метода Cloning в секции General палитры Brush Control.

Устанавливая тип клонирования, можно получать не только трансформированное изображение, но и эффект имитации художественных средств. Допустим, вы выбрали категорию Dry Media, вариант Soft Charcoal, установили для кисти метод Cloning в секции General и Clone Type (Тип клонирования), например Bilinear (4) в секции Cloning палитры Brush Control. Эффекты, которые вы можете получить, мы рассмотрим далее.

Установка точек клонирования

Для клонирования с помощью клонирующих кистей категории Super Cloner Brush используются точки, связывающие источник и клон. Поэтому после выбора кисти необходимо установить точки в соответствии с выбранным типом клонирования. Painter по умолчанию сам устанавливает точки клонирования в изображении-источнике. При двухточечном клонировании — это горизонтальная линия, занимающая всю длину рабочей области вверху под самой полосой заголовка документа. Она обнаруживается сразу при нажатии комбинации клавиш Shift+Ctrl. Но вы можете переустановить пли переместить точки в зависимости от ваших намерений.

ВНИМАНИЕ. Если вы забыли установить источник клонирования с помощью команды File > Clone Source > название изображения-источника, Painter автоматически клонирует шаблон, установленный по умолчанию.

Для установки точек клонирования:

  1. Выберите в категории Cloners вариант кисти, например Rotate (Поворот) (рис. 7.13).
  2. Выберите соответствующий ему тип клонирования в секции Cloning палитры Brush Control.
  3. Установите указатель мыши в нужной точке на изображении-источнике и нажмите комбинацию клавиш Shift-Ctrl, переместите указатель в следующую точку и снова нажмите комбинацию клавиш Shift+Ctrl. Точки при этом будут обозначены красным цветом, пронумерованы и соединены между собой желтой линией. Таким образом, вы установили точки в изображении-источнике.
  4. Переместите указатель мыши в область, где вы собираетесь расположить клон изображения, и точно так же обозначьте точки.
  5. Точки в изображении-источнике исчезнут. Теперь при нажатии комбинации клавиш Shift+Ctrl будут появляться точки, обозначенные последними, то есть точки клона. Чтобы увидеть точки источника, нужно нажать клавишу Shift. При этом точки источника будут выделены уже зеленым цветом (в то время как точки клона исчезнут). Но одновременно видеть и те и другие точки невозможно.
  6. Теперь, когда установлены точки клонирования для источника и клона, начинайте рисовать.

Рис. 7.13. Клонирование с помощью кисти Rotate (2); слева изображение-источник с установленными точками клонирования, справа — клон

СОВЕТ. Будьте внимательны! Следите за расположением и нумерацией точек. Именно они определяют результат. Если вы не следите за точками, то результаты клонирования будут для вас неожиданными и случайными.

На рис. 7.13 в левой части установлены точки изображения-источника, в правой части — клонированное изображение и точки, по которым производилось клонирование.

Для перемещения имеющихся точек установите указатель мыши на одной из них, нажмите комбинацию клавиш Shift+Ctrl и, удерживая ее, переместите точку в нужное место. Отпустите кнопку мыши и клавиши. В процессе перемещения точки черные и обозначены цифрами и линией для наблюдения за перемещением. После перемещения они снова окрашены.

Тип клонирования

Выше мы уже говорили о выборе типа клонирования. Сейчас, когда вы научились устанавливать точки клонирования, вернемся к этому вопросу снова.

В предыдущем примере мы рассмотрели тип клонирования Rotate (Поворот) (см. рис. 7.13). Это двухточечный тип клонирования. Следующий двухточечный тип клонирования — Scale (Масштабирование). С помощью этого типа клонирования можно получить серию уменьшающихся изображений (рис. 7.14).

Рис. 7.14. Клонирование с помощью кисти Scale: слева изображение-источник с установленными точками клонирования, справа — клон

Тип клонирования Rotate&Scale (Поворот и масштабирование) позволяет уменьшить и повернуть объект одновременно (рис. 7.15).

Рис. 7.15. Клонирование с помощью кисти Rotate&Scale: слева изображение-источник с установленными точками клонирования, справа — клон

Тип клонирования Rotate&Mirror (Поворот и отражение) позволяет отразить и повернуть объект одновременно (рис. 7.16). Можно исключить функцию поворота, если установить точки строго перпендикулярно.

Рис. 7.16. Клонирование с помощью кисти Rotate&Mirror: слева изображение-источник с установленными точками клонирования, справа — клон

Трехточечный тип клонирования Rotate, Scale&Shear (3) (Поворот, масштабирование, обрезка) позволяет создавать искаженные (трансформированные) клоны, поворачивать их под углом (рис. 7.17). При этом имеет значение не только расположение трех точек, но и порядок их следования.

Рис. 7.17. Клонирование с помощью кисти Rotate, Scale&Shear

Нижеследующие типы клонирования требуют установки четырех точек.

Тип Bilinear (4) — билинейное клонирование. С помощью этого типа клонирования вы можете получить как одно, так и несколько изображений сразу (рис. 7.18). На первом рисунке слева (см. рис. 7.18) представлено исходное изображение с точками клонирования, установленными по умолчанию. На втором — в центре — исходная бутылка, в правой и левой частях — изображения, клонированные с помощью билинейного типа с измененными точками клонирования.

Рис. 7.18. Клонирование с помощью кисти Bilinear (4)

На рис. 7.19. представлено исходное изображение — самая крупная бабочка и несколько изображений, клонированных с помощью кисти Bilinear (4).

Рис. 7.19. Клонирование с помощью кисти Bilinear (4)

Тип Perspective (Перспектива) (4) позволяет создавать эффекты перспективы, причем близко расположенные точки можно увеличить очень сильно, до получения нереальных и утрированных изображений (рис. 7.20, 7.21).

Рис. 7.20. Клонирование с помощью кисти Perspective (4)

Рис. 7.21. Клонирование с помощью кисти Perspective (4)

Последний тип клонирования 4-Point Tiling (Четырехточечная черепица) фактически превращает изображение в шаблон. При этом создается множество повторяемых изображений. Вы можете уменьшить изображение, тогда все пространство будет заполнено уменьшенным изображением. Так же как и во всех других типах клонирования, для клонирования 4-Point Tiling необходимо задать точки клонирования.

  1. Откройте секцию Cloning палитры Brush Control.
  2. Выберите тип клонирования: Bilinear (4) или Perspective (4).
  3. Установите флажок Clone Color.
  4. Установите флажок 4-Point Tiling.
  5. Установите точки клонирования, последовательно нажимая комбинацию клавиш Shift+Ctrl.
  6. Выберите команду Effect > Fill.
  7. В диалоговом окне Fill установите переключатель Clone Source. Нажмите кнопку ОК.

Если вы не изменили точки клонирования, то получите изображение, подобное приведенному на рис. 7.22.

Рис. 7.22. Тип клонирования 4-Point Tiling без искажений

С измененными точками клонирования может получиться совершенно неожиданный эффект, возможно, подобный представленному на рис. 7.23.

Рис. 7.23. Использование типа 4-Point Tiling с изменением точек клонирования

На рис. 7.24 в центре — неизмененное изображение бутылки, остальное пространство заполнено рисунком с измененными точками клонирования при установленном флажке 4-Point Tiling.

Рис. 7.24. Использование типа 4-Point Tiling с изменением точек клонирования

Использование выделений при клонировании

При клонировании вы можете создавать клон не всего изображения, а только части его. Painter предлагает два варианта клонирования выделенной области:

  • клонирование только выделенного фрагмента — Obey Source Selection (Придерживаться выделения в источнике);
  • клонирование всего изображения с выделенной областью — Copy Source Selection (Копировать источник с выделением).

Клонирование только выделенного фрагмента — Obey Source Selection — используется при клонировании изображения без фона. На рис. 7.25 слева — исходный вариант изображения, справа — результат клонирования выделенной области. Как видите, изображение полностью свободно от фона. Чтобы произвести такое клонирование, достаточно выделить нужное изображение и установить флажок Obey Source Selection в секции Cloning палитры Brush Control.

Рис. 7.25. Установлен флажок Obey Source Selection

При установке другого флажка — Copy Source Selection — все изображение переносится в клон с сохранением выделения (рис. 7.26). Если в одном документе вы несколько раз повторите изображение с сохраненным выделением, у вас будет несколько выделенных областей одновременно. При этом Painter будет их рассматривать как одно выделение.

Рис. 7.26. Установлен флажок Copy Source Selection

СОВЕТ. Чтобы увидеть выделение, необходимо переключиться в режим Draw inside (Рисовать внутри).

Можно установить сразу оба эти флажка, тогда вы будете иметь в клоне выделенный фрагмент с сохранением выделения (рис. 7.27).

Рис. 7.27. Установлены сразу оба флажка, клонируется только выделенная область и сохраняется выделение

Упражнение. Клонирование изображения из одного документа в другой

В качестве исходного изображения используется фотография двух мальчиков на фоне стены с характерной рельефной текстурой (рис. 7.28). Цель упражнения — перенести на стену портрет старика, сохранив текстуру стены и не исказив переднего плана.

Рис. 7.28. Исходное изображение

  1. Раскройте исходное изображение, имеющее размер 333 х 500 пикселов, и создайте его копию, выбрав команду File > Clone.
  2. Раскройте изображение-источник клонирования. Это фотография пожилого мужчины, лицо которого изрезано морщинами (рис. 7.29). Размер источника клонирования также 333 х 500 пикселов.

Рис. 7.29. Изображение-источник клонирования

Перед тем как начать клонирование, надо разобраться, где окажется клон на исходном изображении. Главное, надо запомнить, что при клонировании начало координат расположено в левом верхнем углу изображения.

  1. Клон требуется расположить справа от мальчиков. Для этого размер клона необходимо изменить, выбрав команду Canvas > Canvas Size. Источник клонирования надо уменьшить сверху и увеличить слева. Для этого в поле Adjust Size (Регулировать размер) задайте Add 135 pixels to top, Add 85 pixels to left. Измените размеры рамки источника клонирования, чтобы она соответствовала новым размерам, выбрав команду Window > Zoom to Fit (Окно > Подходящий масштаб).
  2. В меню Brushes выберите кисть Cloners, а затем её вариант Soft Cloner. В палитре Brush Controls задайте размер кисти, установив ползунок Size в положение 100 пикселов. Ползунок Opacity установите в положение 25%.
  3. Обратитесь к исходному изображению. Задайте источник клонирования — фотографию пожилого мужчины, выбрав File > Clone Source. Приступайте к клонированию. При таком размере кисти достаточно нескольких касаний, чтобы лицо пожилого мужчины проступило на фоне стены.
  4. При работе с кистью Soft Cloner большого размера обязательно будет искажен передний план. Клонируемое изображение попадет на лица мальчиков и их одежду. Чтобы восстановить изображение переднего плана, выберите вариант Straight Cloner, задайте размер кисти в несколько пикселов, например 3. Ползунок Opacity установите в положение 100%. В качестве источника клонирования задайте ранее созданную копию исходного изображения, выбрав команду File > Clone Source. Увеличьте размер исходного изображения, выбрав Window > Zoom in. Аккуратно обработайте лица мальчиков и детали одежды. В результате изображение переднего плана восстановлено.
  5. Работа завершена. Результат — фотография двух мальчиков на фоне стены, сквозь рельефную текстуру которой проступает улыбающееся морщинистое лицо пожилого мужчины (рис. 7.30).

Рис. 7.30. Результат клонирования

Упражнение. Клонирование фрагмента изображения из одного документа в другой

В качестве исходного изображения используем фотографию девушки, приведенную на рис. 7.31. Цель упражнения — с помощью клонирования создать портрет девушки, нарисованный мелом или пастелью, и расположить исходное изображение на фоне этого портрета.

Рис. 7.31. Исходное изображение — фотография девушки

  1. Раскройте исходное изображение с размерами 333 х 500 пикселов и создайте две копии этого изображения, выбрав File > Clone.
  2. Обратитесь к одной из копий исходного изображения. Активизируйте инструмент Crop (Кадр) и с его помощью ограничьте центральную часть исходного изображения — лицо девушки и ее прическу.
  3. Раскройте новое изображение с размерами, равными вырезанному кадру, например 270 х 350 пикселов. Активизируйте инструмент Brush (Кисть). В меню Brushes выберите кисть Cloners, а затем ее вариант Chalk Cloner. В палитре Controls: Brush задайте размер кисти, установив ползунок Size в положение 50 пикселов. Ползунок Opacity установите в положение 25%. Ползунок Grain, задающий эффект рельефной поверхности бумаги, установите в положение 10%.
  4. Установите источник клонирования — вырезанный кадр с лицом девушки, выбрав File > Clone Source. Обратитесь к вновь созданному изображению и выполните клонирование мазками от центра к периферии. Чтобы сделать более четкими черты лица и детали прически, обработайте центральную часть изображения кистью Cloner Spray, задав размер кисти равным 30 пикселам и установив движок Opacity в положение 60%. Портрет девушки готов.
  5. Осталось сделать для него рамку. Выберите Select > All (Выделить > Все), Select > Modify > Contract (Выделить > Изменить > Сжать) и задайте уменьшение выделенной области на 10 пикселов. Выберите Select > All, Select > Modify > Border (Выделить > Изменить > Рамка) и задайте ширину выделенной области равной 10 пикселам. Примените к выделенной области динамичный слой Bevel World (Призматический мир) с параметрами по умолчанию, не забудьте при этом задать подходящий цвет рамки с помощью окна Light Color (Легкий цвет). Слой с рамкой совместите с портретом девушки, нажав на кнопку Drop (Опустить) в секции Layers (Слои) палитры Objects (Объекты). Портрет девушки в рамке приведен на рис. 7.32.
  6. Следующий шаг — подготовка пространства, где будет расположен портрет девушки. Обратитесь к исходному изображению. Поместите портрет в правой части композиции. Для этого надо расширить исходное изображение вправо. Выберите Canvas > Canvas Size и в поле Adjust Size задайте Add 150 pixels to right. В результате исходное изображение расширено вправо на 150 пикселов.
  7. Выберите инструмент Brush (Кисть). В меню Brushes выберите кисть Cloners, а затем ее вариант xScale (2 point). В меню панели Controls: Brush задайте размер кисти, установив ползунок Size в положение 50 пикселов. Ползунок Opacity установите в положение 100%. Установив курсор в область клонирования, щелкните кнопкой мыши при нажатой клавише Shift на точке — источнике клонирования. Аналогично определите область, где будет расположен клон. Аккуратно закрасьте добавленное справа белое поле.
  8. Обратитесь к портрету девушки в рамке. Выделите все изображение, выбрав Select > Аll и занесите его в буфер, выбрав Edit > Copy. Обратитесь к расширенному вправо исходному изображению и наложите на это изображение портрет девушки в рамке, выбрав Edit > Paste. Разместите его в правой части исходного изображения так, чтобы портрет слегка закрывал лицо и прическу девушки на исходном изображении. Создайте тень от портрета на стене, выбрав команду Effects > Objects > Create Drop Shadow (Эффекты > Объекты > Создать, опустить тень). Параметры задания тени примите по умолчанию. Слой с портретом совместите с исходным изображением, нажав кнопку Drop (Опустить) в секции Layers (Слои) палитры Objects (Объекты).
  9. Восстановите части лица и прически, закрытые портретом. Для этого активизируйте инструмент Brush (Кисть). В палитре Brushes выберите кисть Cloners и ее вариант Straight Cloner. В палитре Controls: Brush задайте размер кисти 10 пикселов. Ползунок Opacity установите в положение 100%. В качестве источника клонирования задайте одну из копий исходного изображения, выбрав команду File > Clone Source. Аккуратными движениями обработайте лицо и прическу девушки на исходном изображении. Работа завершена (рис. 7.33).

Рис. 7.32. Портрет девушки в рамке

Рис. 7.33. Итоговое изображение девушки на фоне ее портрета

Перед вами фотография девушки на фоне ее портрета, повторяющего прическу и наклон головы девушки.


Настройка цвета

  • Палитра Art Materials
  • Секция Colors
    • Палитра Standard Colors
    • Индикаторы основного и вторичного цветов
  • Секция Small Colors
  • Секция Color Variability
    • Секция RGB Color (Палитра RGB)
    • Соотношение цветовых параметров палитр HSV и RGB
    • Выбор цвета с помощью инструмента Dropper
  • Цветовой набор
    • Секция Color Set
    • Изменение порядка цветов в цветовом наборе
    • Изменение размеров ячеек, строк, столбцов набора
    • Текстовая строка и название цвета
    • Поиск цвета
    • Создание цветового набора
    • Добавление, удаление и замещение цвета
    • Аннотирование цветов

Painter поможет вам безошибочно определить нужный цвет

Палитра Art Materials

Как вы уже знаете, Painter содержит шесть основных палитр, каждая из которых включает в себя несколько секций. Устройство этих палитр однотипно. Мы подробно рассмотрим его, разбирая палитру Art Materials (Художественные средства).

Палитра Art Materials является одной из основных палитр Painter. Она входит в состав меню Window и открывается с помощью команды Window > Show Art Materials. Палитра Art Materials является комплексной. Она содержит следующие секции:

  • Colors — цвета;
  • RGB Color — палитра RGB (красный, зелёный, синий);
  • Color Set — набор цветов;
  • Color Variability — изменяемость цвета;
  • Papers — текстура бумаги;
  • Grad — градиентная заливка;
  • Patterns — орнамент;
  • Weave — тканевый узор (ткацкое плетение, шотландка или ковбойка);
  • Nozzles — заливка готовыми изображениями;
  • Looks — виды (линия, проводимая готовыми изображениями).

Основные составляющие палитры Art Materials будут рассмотрены в следующих главах.

Для работы с цветом в Painter предусмотрено несколько средств, большинство из которых находится в палитре Art Materials. К ним относятся следующие секции палитры Art Materials:

  • Colors;
  • RGB Color;
  • Color Set;
  • Color Variability.

Помимо секций палитры Art Materials имеется цветовой набор Color Set, открываемый командой Window > Show Color Set, и панель управления Controls. Все средства для работы с цветом мы подробно рассмотрим далее в этой главе.

Секция Colors

Секция Colors включает два варианта палитры: Standard Colors — стандартная палитра и Small Colors — уменьшенная, или компактная, палитра.

Выбор палитры осуществляется в меню Colors, открывающемся нажатием кнопки-стрелки в правом углу секции Colors (рис. 8.1).

Рис. 8.1. Палитра Art Materials и меню Colors

Палитра Standard Colors

Палитра Standard Colors открывается выбором команды Standard Colors в меню секции Colors.

В главе 3 мы уже говорили о цветовой модели HSV. Стандартная палитра построена на модели HSV и позволяет создать любой цвет, комбинируя три параметра:

  • Н — Hue — цветовой тон;
  • S — Saturation — насыщенность;
  • V — Value — интенсивность.

Стандартная палитра (рис. 8.2) состоит из цветового кольца, на котором выбирается основной цветовой тон (Н), и треугольника, с помощью которого выбирается соотношение между насыщенностью (S) и интенсивностью (V) тона.

Рис. 8.2. Палитра Standard Colors, или палитра HSV

Для выбора необходимого цветового тона достаточно щелкнуть левой кнопкой мыши в выбранном месте цветового кольца (правая кнопка мыши в Painter не работает, так как контекстные меню здесь отсутствуют, поэтому мы для краткости будем говорить просто кнопка мыши). Указатель тона — маленькое черное кольцо — переместится в данную точку, а индикатор основного цвета — передний прямоугольник в левом нижнем углу палитры — примет окраску выбранного тона. То же самое произойдет с индикатором тона на палитре Controls.

Соотношение между насыщенностью (S) и интенсивностью (V) тона определяется положением маленького белого кольца в треугольнике. Перемещая его влево или вправо, вы изменяете насыщенность. Максимальная насыщенность (S) — в вершине треугольника справа. Перемещая его вверх или вниз, вы изменяете интенсивность. Максимальная интенсивность (V) слева вверху — белый цвет. Минимальная интенсивность слева внизу — черный цвет.

Числовые значения выбранных параметров указаны в окне, расположенном в правой нижней части палитры. Значения каждого параметра даны в процентах от длины шкалы:

  • Н — тон, значения даны в процентах от длины цветового кольца. Начало и конец отсчета находятся в центре нижней части кольца, в середине синего поля.
  • S — насыщенность, значения даны в процентах от длины перпендикуляра, опущенного из правой вершины на противоположную сторону. Начало отсчета — слева.
  • V — интенсивность, значения даны в процентах от длины стороны треугольника. Начато отсчета — левая нижняя вершина треугольника.

Если в меню Colors выбрать команду Display as RGB, числовые значения выбранных параметров модели HSV заменяются соответствующими данному оттенку параметрами модели RGB.

Индикаторы основного и вторичного цветов

В левом нижнем углу палитры расположен индикатор основного и вторичного цвета. Его дублирует индикатор, расположенный на палитре управления Controls: Brush.

Индикатор основного цвета — передний прямоугольник, находится в активном состоянии по умолчанию и окрашен в черный цвет.

В дальнейшем он окрашивается в выбранный вами цвет. О его активном состоянии свидетельствует узкая черная рамка.

Индикатор вторичного цвета — это прямоугольник, расположенный на заднем плане.

Вторичный цвет используется при работе в многоцветном режиме, например с фоном, или при работе с двухцветной кистью. Чтобы активизировать индикатор, достаточно щелкнуть на нем или на значке в виде стрелок [image], расположенных под углом, под вторым прямоугольником.

Секция Small Colors

Если в меню Colors выбрать команду Small Colors, на экране появится палитра Small Colors (рис. 8.3), которая принципиально ничем не отличается от палитры Standard Colors. Единственное отличие в том, что цветовой крут заменен горизонтальной цветовой шкалой.

Рис. 8.3. Палитра Small Colors

Секция Color Variability

Секция Color Variability палитры Art Materials представлена тремя ползунками для установки вариаций параметров Н, S, V — тона, насыщенности и интенсивности.

Вариации, то есть допустимое отклонение от выбранного значения для тона, насыщенности и интенсивности, определяются положением ползунков:

  • +/- Н — вариация тона;
  • +/- S — вариация насыщенности;
  • +/- V — вариация интенсивности.

Вариации каждого параметра даны в процентах от длины соответствующей шкалы и меняются от 0% до 50%. Перемешая движок вправо, вы увеличиваете допустимые отклонения от установленных параметров.

Изменение результатов при установке различных вариаций цветовых параметров можно наблюдать в работе с двухцветными кистями, о создании которых мы рассказывали в главе 6. В качестве примера на рис. 8.4. приведены штрихи, выполненные двухцветной кистью, вариант Loaded Oil (Насыщенная кисть). Эффект от изменения вариации цветовых параметров секции Color Variability очевиден.

Рис. 8.4. Штрихи, выполненные кистью Brush, вариант Loaded Oil

Один и тот же мазок повторен с различными значениями вариаций цветовых параметров Н, S, V (0, 25, 50% слева направо).

Секция RGB Color (Палитра RGB)

Секция RGB Color предназначена для получения любого необходимого оттенка путем смешивания в различных пропорциях трех основных цветов: красного, зеленого и синего.

Как вы помните (см. главу 3), RGB — это три первичных, или базовых, цвета: R — red (красный), G — green (зеленый), В — blue (синий). Смешивая эти цвета в разных пропорциях, вы получите практически любой цвет видимого спектра. Эти цвета также называют аддитивными, поскольку в результате их слияния можно получить белый цвет. Именно таким образом создается изображение на сетчатке человеческого глаза и на экране монитора. Это наиболее простая и понятная цветовая модель.

Секция RGB Color представлена тремя ползунками для регулирования интенсивности красного, зеленого и синего тона. Смешивая эти цвета в разных пропорциях, вы получите практически любой цвет видимого спектра. Диапазон ползунков задан в условных единицах от 0 до 255.

Соотношение цветовых параметров палитр HSV и RGB

Точные значения цветов в модели RGB нужны для печати, когда вы, имея образцы системы соответствия цветов и зная числовые значения параметров RGB, можете узнать точные значения параметров цветов в модели CMYK.

Работая в двух палитрах, можно в любой момент определить, в какой пропорции необходимо взять цветовые параметры палитры RGB, чтобы повторить цвет, полученный в палитре Standard Colors (HSV).

Но постоянно переключаться из одной палитры в другую — не самый удобный способ работы. Для того чтобы, работая в палитре Standard Colors (HSV), ориентироваться в модели RGB, не обращаясь к палитре RGB, переключите палитру, выбрав команду Colors > Display as RGB. Теперь на палитре Standard Colors в окне, в правой нижней части, вместо числовых параметров HSV появятся числовые значения параметров RGB в абсолютных единицах. Щелкните в этом окне, и значения параметров RGB изменятся на HSV.

Установив во время следующего сеанса работы указанные параметры с помощью ползунков в палитре RGB, вы получите тот же цвет, с которым работали в палитре Standard Colors (HSV).

Выбор цвета с помощью инструмента Dropper

Инструмент Dropper (Пипетка) позволяет автоматически создать необходимый цвет, указав его в любой точке изображения.

Активизируйте инструмент Dropper. Если вы работаете с инструментом Brush (Кисть) или Paint Bucket (Заливка), для активизации инструмента Dropper достаточно нажать клавишу Ctrl. Курсор изменит форму на изображение пипетки. Не отпуская клавиши Ctrl, подведите курсор к месту, окрашенному в нужный вам цвет, и нажмите кнопку мыши. Один из активизированных прямоугольников — индикаторов основного или вторичного цвета — окрасится в указанный цвет, а цветовые индикаторы на круге и в треугольнике автоматически займут положение, соответствующее параметрам указанного цвета. Числовые значения параметров также будут приведены в секции палитры Art Materials: Colors.

Отпустите клавишу Ctrl. Вы можете продолжать работу инструментами Brush или Paint Bucket с выбранным цветом.

ВНИМАНИЕ. Инструмент Dropper (Пипетка) не воспринимает цвета динамичных слоев (Dynamic Layers).

Цветовой набор

Если вам неудобно работать с цветовым кольцом, воспользуйтесь другим средством — цветовым набором Color Set (рис. 8.5).

Рис. 8.5. Цветовой набор Color Set

При запуске пакета по умолчанию всегда устанавливается цветовой набор Color Set Painter Colors. Для открытия цветового набора выберите команду: Window > Show Color Set (Окно > Показать цветовой набор).

Активизируйте индикатор основного или вторичного цвета и выберите ячейку с необходимым цветом. Цвет готов к работе.

В ходе работы вы можете воспользоваться несколькими цветовыми наборами: Macintosh, Windows, Pantone Matching System или любыми другими.

Для загрузки необходимого цветового набора:

  • В меню палитры Art Materials: Colors выберите команду Colors > Load Color Set (Цвета > Загрузить цветовой набор). Откроется диалоговое окно Select Color Set (Выбрать цветовой набор).
  • Выберите имя файла, в котором хранится необходимый цветовой набор, и нажмите кнопку Open (Открыть). Новый цветовой набор будет загружен.

Секция Color Set

Секция Color Set (рис. 8.6) палитры Art Materials служит вспомогательным инструментом для палитры.

Рис.8.6. Секция Color Set

При работе с цветом вы можете:

  • изменять порядок цветов в имеющемся встроенном цветовом наборе;
  • создавать свой набор цветов;
  • добавлять к нему цвета;
  • давать название каждому цвету;
  • осуществлять поиск цветов по имени или путем подбора цвета, ближайшего по параметрам;
  • изменять порядок цветов в наборе;
  • задавать нужные размеры ячеек;
  • изменять число строк и столбцов;
  • вводить текстовую строку;
  • убирать сетку, разделяющую ячейки с образами цветов.

Все эти действия выполняются с помощью секции Color Set.

Назначение параметров секции Color Set приведено в табл. 8.1.

Таблица 8.1. Параметры секции Color Set

Параметр | Позволяет
Library (Библиотека) | Загрузить библиотеку
New Set (Новый набор) | Создать новый набор
Find Color (Поиск цвета) | Найти нужный цвет
Add Color (Добавить цвет) | Добавить новый цвет в набор
Delete Color (Удалить цвет) | Удалить цвет из набора
Sort Order (Порядок сортировки) | Изменить порядок расположения цветов в наборе
Color Square Size (Размер ячейки) | Изменить размеры ячейки набора
Color Set Size (Размер набора) | Изменить количество строк и столбцов
Display Text (Текстовая строка) | Ввести/убрать текстовую строку
Display Grid (Отображать сетку) | Внести/убрать сетку, разделяющую ячейки цветов в наборе

Изменение порядка цветов в цветовом наборе

Для изменения порядка цветов в наборе:

  1. Откройте секцию Color Set и щелкните на значке в виде висячего замка в центральной части палитры, он должен раскрыться.
  2. В области Sort Order диалогового окна расположены четыре переключателя: Saved, HLS, LHS, SHL. По умолчанию установлен переключатель Saved. Установите нужный переключатель в области Sort Order — порядок цветов в наборе изменится на заданный.
  3. Различные типы сортировки цветов в цветовом наборе:

Saved

HLS

LHS

SHL

Изменение размеров ячеек, строк, столбцов набора

Изменение размеров ячейки цветового набора осуществляется в поле Color Square Size (Размер цветовой ячейки), в котором схематически приведен рисунок ячейки и указаны ее размеры в пикселах. Нажимая стрелки, расположенные горизонтально и вертикально, вы изменяете размер ячейки. Одиночная стрелка изменяет размер на один пиксел. Двойная стрелка изменяет площадь ячейки вдвое, растягивая ее по вертикали или горизонтали (рис. 8.7).

Рис. 8.7. Вариант изменения размеров ячейки в цветовом наборе

В поле Color Set Size (Размер цветового набора) приведено схематическое изображение набора, а также количество строк или столбцов в нем. Нажимая горизонтальную или вертикальную стрелку, вы изменяете число столбцов или число строк. Одиночная стрелка изменяет число столбцов или строк на единицу. Двойная стрелка изменяет число строк или столбцов вдвое.

Текстовая строка и название цвета

Глядя на цветовой набор Painter, вы понимаете, что уловить нюансы цвета достаточно сложно. Если вы работали ранее с какими-то цветами, а затем вам потребовалось воспроизвести один из них, немудрено ошибиться. Однако Painter поможет безошибочно определить нужный цвет. Для этого нужно ввести в цветовой набор текстовую строку, а затем ввести в нее названия ваших цветов.

  1. Установите флажок Display Text (Отображать текст), и появится текстовая строка (рис. 8.8).
  2. С помощью вертикальных стрелок в поле Color Square Size установите необходимую ширину строки.
  3. Дважды щелкните на ячейке с цветом, которому вы собираетесь дать название. Откроется диалоговое окно Color Name (Название цвета) (рис. 8.9).
  4. Введите название цвета в поле Name и нажмите кнопку ОК. Под выделенной ячейкой в текстовой строке появится название цвета (см. рис. 8.8).

Рис. 8.8. Созданный цветовой набор с текстовой строкой

Рис. 8.9. Окно Color Name

В целях экономии места вы можете не держать текстовую строку все время на экране — снимите флажок Display Text, и она исчезнет.

Иногда, чтобы почувствовать различия между рядом расположенными цветами, имеет смысл убрать сетку, разделяющую цвета. Это легко сделать, сняв флажок Display Grid (Отображать сетку). Сетка так же легко восстанавливается установкой того же флажка.

Поиск цвета

Если, работая со сложным многоцветным произведением, вы нашли цвет, который понадобится в дальнейшем, введите в цветовой набор текстовую строку и дайте ему название. Затем, сохранив свой собственный цветовой набор, вы легко найдете нужный вам цвет по названию.

В Painter предусмотрено два способа поиска цвета — по названию и путем подбора.

Для поиска цвета по названию:

  1. На палитре Color Set нажмите кнопку Find Color (Найти цвет), откроется диалоговое окно Find Color (рис. 8.10). В области Method (Метод) установите переключатель By name (По имени).
  2. Введите название искомого цвета.
  3. Нажмите кнопку Search (Поиск).

Рис. 8.10. Окно Find Color

Для поиска цвета путем подбора из цветового набора образца, параметры которого наиболее близки заданному цвету:

  1. На палитре Art Materials: Colors выберите нужный оттенок на цветовом круге, а затем подберите насыщенность и интенсивность цвета.
  2. Откройте секцию Color Set и нажмите кнопку Find Color. Откроется диалоговое окно Find Color (см. рис. 8.10).
  3. Установите переключатель Closest to current color (Ближайший по параметрам).
  4. Нажмите кнопку Search (Поиск). В результате должен активизироваться (обозначиться рамкой) образец цвета, ближайшего по параметрам.
  5. Нажмите кнопку ОК, окно диалога Find Color закроется.

Создание цветового набора

Удобно создать собственный цветовой набор, состоящий из цветов, часто используемых или свойственных определенному документу. Для этого выполните следующее:

  1. Подготовьте первый образец цвета для нового цветового набора.
  2. Откройте секцию Color Set и щелкните на значке замка.
  3. Нажмите кнопку New Set (Новый набор).
  4. Подготовьте образец цвета, выбрав его в палитре или захватив пипеткой. Нажмите кнопку Add Color (Добавить цвет). Первая ячейка с образцом цвета создана.
  5. Чтобы дать название этому образцу цвета, дважды щелкните на созданной ячейке. Откроется окно Color Name (рис. 8.11).
  6. Введите название цвета в поле Name и нажмите кнопку ОК. Под выделенной ячейкой в текстовой строке появится название цвета.
  7. Аналогично добавьте остальные образцы цвета.
  8. Закончив создание набора, нажмите кнопку Library (Библиотека). Откроется стандартное диалоговое окно для сохранения файла, в данном случае имеющее название Enter Color Set Name (Ввод названия цветового набора) (рис. 8.12).
  9. Укажите папку и введите имя файла для нового цветового набора. Нажмите кнопку Save (Сохранить). Раскроется стандартное окно для открытия файла, в данном случае имеющее название Select Color Set (Выбрать цветовой набор).
  10. При желании оставить созданный цветовой набор в активном состоянии, нажмите кнопку Cancel (Отменить).

Рис. 8.11. Создаваемый набор и диалоговое окно Color Name

Рис. 8.12. Окно диалога Enter Color Set Name

Добавление, удаление и замещение цвета

Для добавления нового образца цвета к созданному цветовому набору:

  1. Откройте секцию Color Set и нажмите кнопку Library. В окне Select Color Set откройте цветовой набор.
  2. Подготовьте образец цвета, создав его или захватив пипеткой.
  3. Щелкните на значке, изображающем замок.
  4. Нажмите кнопку Add Color. Новый образец цвета добавлен к набору.
  5. Дайте название цвету, дважды щелкнув на добавленном образце и введя название цвета в поле Name окна Color Name. Нажмите кнопку ОК. Под добавленной ячейкой в текстовой строке набора появилось название цвета.

Для удаления цвета из цветового набора откройте нужный цветовой набор и выполните следующее:

  1. Откройте секцию Color Set и щелкните на значке замка.
  2. Выделите удаляемый образец цвета.
  3. Нажмите кнопку Delete Color (Удалить цвет). Появится запрос (рис. 8.13), действительно ли вы желаете удалить выделенный образец цвета. В случае утвердительного ответа выделенный образец цвета удаляется из набора.

Рис. 8.13. Запрос об удалении цвета из набора

Для замены образца цвета:

  1. Подготовьте новый образец цвета для замены, создав его или захватив пипеткой.
  2. Откройте секцию Color Set и щелкните на значке замка.
  3. Откройте цветовой набор, нажав кнопку Library и выбрав его в окне Select Color Set.
  4. Выделите образец цвета, который вы хотите заменить.
  5. Нажав и удерживая клавишу Alt, щелкните на выделенной ячейке. Замена произведена.

Аннотирование цветов

При длительной работе с изображением иногда возникает необходимость в каких-либо коротких заметках. Например, вы можете написать краткие комментарии к отдельным фрагментам работы. Они могут присутствовать на экране, и при необходимости их можно убрать. Их можно даже напечатать. Аннотация располагается в плавающем слое над изображением. При записи сценария с низким разрешением и воспроизведении его с высоким аннотация также включается в сценарий.

Для создания аннотации:

  1. Создайте изображение, используя цветовой набор с названиями цветов.
  2. Выберите команду Canvas > Annotations > Annotate (Холст > Комментарии > Записывать). Откроется маленькое окно Annotate (Записывать) с кнопкой Done (Применить). Нажмите ее. Окно закроется.
  3. Установите указатель на выбранном цвете, нажмите кнопку мыши, и не отпуская ее, перейдите в ту часть рисунка, где будет расположена аннотация. Отпустите кнопку.
  4. На экране появится название цвета или любые другие сведения, заданные вами в текстовой строке. Если аннотируемый цвет по своим параметрам не полностью соответствует исходному образцу цвета, то аннотация завершается звездочкой справа вверху над последним словом.
  5. Завершив аннотирование, нажмите кнопку ОК.

Чтобы убрать аннотации с экрана, выберите команду Canvas > Annotations > Hide Annotations (Холст > Комментарии > Спрятать комментарии).

Для вывода аннотации на экран выберите команду Canvas > Annotations > Show Annotations (Холст > Комментарии > Показать комментарии).

ВНИМАНИЕ. Если вы аннотировали цвета отдельного плавающего объекта, будьте внимательны. Аннотации к цветам перемещаются вместе с объектами.


Использование градаций

  • Секция Gradients
  • Управление градацией
  • Создание коллекции образцов
  • Создание простейшей градации
  • Редактирование градации
    • Упражнение. Создание градации Rainbow
  • Заимствование градации из изображения
  • Техника заливки градацией
    • Наложение градации на изображение
    • Использование инструмента Paint Bucket для заливки градацией
  • Упражнение. Заливка изображения без выделения
    • Заливка незамкнутой области
    • Защита от заливки
    • Заливка анимационного элемента

Градация — это чрезвычайно эффектное средство, которое малыми усилиями гарантирует хороший результат

Следующая секция в составе палитры Art Materials, которую мы рассмотрим, - Gradients, или Градации.

Средство Градация или плавный переход (художники называют этот прием растяжкой) есть во всех графических программах и даже в обычных текстовых редакторах, где присутствуют хотя бы самые простые средства оформления документа. И это не случайно. Градация предоставляет большие возможности при работе с изображением. Прежде всего — это чрезвычайно эффектное средство, которое малыми усилиями гарантирует хороший результат.

С помощью градации закрашивают выделенную область разными цветами с плавным переходом одного цвета в другой. Это средство позволяет осуществлять всевозможные цветовые переходы: линейный, радиальный, спиральный, концентрический и др. Инструмент незаменим при создании эффектов светотени, радужных переливов, сияний и тому подобного. Хорошо имитирует эффекты поп-арта.

Секция Gradients

Секция Gradients открывается, как и другие входящие в состав палитры Art Materials секции, нажатием кнопки, расположенной слева от названия.

Нажатием правой кнопки-стрелки открывается меню секции. Команды меню позволяют создавать, редактировать градации, сохранять и пополнять их коллекции.

Под строкой кнопок секции расположены образцы градаций, доступные непосредственно. Достаточно выделить любой понравившийся образец, и он готов к применению.

Нажатием длинной горизонтальной кнопки со стрелкой открывается доступ к другим образцам загруженной коллекции градаций. Это напоминает открытие ящика комода. Образец, выбранный из ящичка, занимает место в витрине образцов, готовых к применению.

Ниже расположено текстовое поле с названием выбранного образца. Щелчок на этом поле открывает список названий всех образцов загруженной коллекции, что облегчает поиск нужной градации по названию. Последний пункт в этом списке — команда, позволяющая загрузить библиотеку градаций.

Управление градацией

Большую часть палитры занимают средства управления градацией, это можно назвать панелью управления палитры. Разберем подробнее ее состав (рис. 9.1).

Рис. 9.1. Секция Gradients палитры Art Materials в свернутом (слева) и развернутом (справа) видах

Основной элемент панели — кольцо вращения (Rotation Ring), на нем задается угол наклона линии максимального градиента. Угол измеряется от горизонтальной линии, проведенной слева направо через центр круга.

Для задания угла наклона градиентной линии подведите указатель мыши к красному шарику и перетащите его в нужное положение (градиентная линия следует за шариком), либо просто щелкните в нужном месте кольца.

Внутри кольца расположено окно предварительного просмотра градации. Вид образца градации, помещенный в окне, помогает ориентироваться в текущих установках. Под окном указан угол поворота, то есть угол, под которым будет наклонена выбранная градация.

Для выбора угла наклона щелкните на изображении в окне просмотра. Градиентная линия начнет вращение без вашего участия. Остановить ее вращение можно щелчком за пределами окна предварительного просмотра.

Если линия градиентного перехода имеет спиральную форму, то с помощью кольца вращения вы можете повернуть спираль, не меняя число витков.

Если при этом нажать и удерживать клавишу Ctrl, то, вращая спираль против часовой стрелки, вы будете ее закручивать, увеличивая число витков. Напротив, вращая спираль по часовой стрелке при нажатой клавише Ctrl, вы будете ее раскручивать, уменьшая число витков.

В поле справа от окна предварительного просмотра задается тип градации: линейный, радиальный, концентрический и спиральный. Выбранный тип градации отображается и в окне предварительного просмотра.

В нижней части панели расположены шесть значков, с помощью которых задается порядок градации. Эти значки отделены от остальной части панели полосой предварительного просмотра. Заданный порядок градации отражается в полосе и в окне предварительного просмотра.

Таким образом, используя только средства панели управления, вы можете создать больше десяти вариаций одной и той же градации.

Создание коллекции образцов

Как вы уже знаете, новая библиотека образцов градаций загружается командой Load Library (Загрузить библиотеку), последней в списке названий градаций загруженной коллекции. Эта команда открывает стандартное окно открытия файла, в котором требуется указать местоположение загружаемой библиотеки.

Библиотека градаций состоит из 20 изображений. Кроме того, там же находится изображение одного из вариантов двухцветной градации. Его изображение идентично индикатору основного и вторичного цвета, находящегося на панели управления или, как ее еще называют,— контрольной панели секции Colors.

Однако всегда есть образцы, практически не используемые, и их хотелось бы заменить другими. Специально для этой цели предназначен сортировщик Gradient Mover (Сортировщик градаций), с помощью которого вы можете создать свою коллекцию образцов, состоящую из любых понравившихся вам градаций.

Для создания коллекции из имеющихся образцов:

  1. Откройте секцию Gradients.
  2. Выберите в меню секции команду Gradient Mover. Откроется диалоговое окно Gradient Mover (рис. 9.2).
  3. В левой части окна расположена загруженная библиотека образцов градаций. Правая часть окна свободна. В нее можно загрузить другую библиотеку.
  4. Нажмите кнопку Open, появится окно New Grad Library (Новая библиотека градаций) (рис. 9.3). Выделите новую библиотеку градаций. Нажмите кнопку Открыть. Библиотека будет загружена в правую область окна Gradient Mover.
  5. Выделите образец, который хотите перенести в свою коллекцию. В средней части окна появится название выделенного образца.
  6. Установите указатель мыши на выделенном образце и перетащите образец из правой библиотеки в левую. Отпустите кнопку мыши. Перемещение закончено.
  7. Для закрытия окна сортировщика градаций нажмите кнопку Quit (Выход).

Рис. 9.2. Диалоговое окно Grad Mover

Рис. 9.3. Окно New Grad Library

Теперь вы можете загружать различные библиотеки градаций с дисков, из Интернета и т. д. и создавать свою коллекцию понравившихся образцов. Далее мы рассмотрим, как создать новые образцы для коллекции.

Создание простейшей градации

Вы можете создать градацию самостоятельно из любых двух цветов, выбрав Two-Point (Двухцветная градация) [image] в списке названий образцов:

  1. Откройте секцию Colors и задайте основной и вторичный цвета. Два заданных цвета определяют окраску градации.
  2. В списке образцов панели управления секции Gradients выберите вариант Two-Point. В окне предварительного просмотра появится созданный двухцветный плавный переход от основного цвета к вторичному.
  3. Выберите любой понравившийся тип градации; соответственно измените, тип градации в окне предварительного просмотра.
  4. Выберите в меню команду Save Grad (Сохранить градацию). Откроется диалоговое окно Save Grad (Сохранить градацию). Введите название градации и нажмите кнопку ОК. Созданная градация внесена в загруженную библиотеку.

Редактирование градации

Для создания более сложного цветового перехода, чем двухцветная градация, используется редактирование имеющейся градации. Для этого предназначено диалоговое окно Edit Gradient (Редактирование градации) (рис. 9.4), открывающееся командой Grad > Edit Gradient. В верхней части окна расположена цветовая полоса, на которой приведен плавный переход от основного цвета (справа) к вторичному (слева). Над полосой находится квадратный маркер, отмечающий середину диапазона. На нижней части полосы расположены треугольные маркеры — контрольные точки, отмечающие границы данного цветового диапазона.

Рис. 9.4. Окно диалога Edit Gradient

Добавление цвета к исходной двухцветной градации осуществляется следующим образом.

  1. Щелкните мышью в той части диапазона, где вы планируете ввести новый цвет. В указанном месте на цветовой полосе появится новая контрольная точка (треугольный маркер).
  2. С помощью секции Colors задайте новый цвет. На цветовой полосе появится новая градация. Это плавный цветовой переход от новой контрольной точки к заданным ранее. Задавая дополнительные контрольные точки, можно сколько угодно усложнить исходную двухцветную градацию.
  3. Чтобы установить полосу постоянного цвета, надо добавить еще одну контрольную точку, не задавая нового цвета. Для этого установите указатель мыши в нужной точке цветовой полосы и при нажатой клавише Alt щелкните кнопкой мыши. Чтобы убрать контрольную точку, установите указатель в контрольной точке, выделите ее и нажмите клавишу Backspace.
  4. По умолчанию плавный переход от одного цвета к другому осуществляется по линейному закону, флажок Linear (Линейная) установлен. Если вы хотите задать нелинейный цветовой переход, снимите флажок Linear.
  5. Установите указатель мыши на контрольной точке и выделите ее. Под цветовой полосой появится ползунок Color Spread (Цветовой диапазон). Задайте с его помощью подходящую зависимость цветового перехода (рис. 9.5).

Рис. 9.5. Нелинейный цветовой переход, заданный с помощью движка Color Spread (слева), меню Color (справа)

Способ создания градации задается для каждого интервала, ограниченного контрольными точками. Над каждым заданным цветовым интервалом находится маркер, имеющий форму маленького квадрата.

  1. Обозначьте выбранный интервал, нажав соответствующий маркер. В центральной части окна появляется раскрывающееся меню Color (см. рис. 9.5, справа).
  2. Меню Color содержит три варианта создания градации:

    • RGB (Красный, Зеленый. Синий) задает градацию простым смешиванием трех основных компонентов.
    • Hue Clockwise (Тон по часовой стрелке) задает градацию в соответствии с движением по часовой стрелке по цветовому кольцу.
    • Hue Counterclockwise (Тон против часовой стрелки) задает градацию в соответствии с движением против часовой стрелки по цветовому кольцу.

  3. Раскройте меню Color. По умолчанию установлена палитра RGB. Выберите нужный вариант. Нажмите кнопку ОК.

Упражнение. Создание градации Rainbow

  1. С помощью секции Colors задайте основной и вторичный цвета.
  2. В секции Gradients выберите вариант Two Point (Двухцветная).
  3. Выберите в меню секции команду Edit Gradient. Откроется диалоговое окно Edit Gradient.
  4. Задайте способ создания градации, установив или сняв флажок Linear (Линейный).
  5. Нажмите квадратный маркер над серединой цветового интервала. В центральной части окна появится меню Color. Откройте меню и выберите способ Hue Clockwise (Тон по часовой стрелке).
  6. Выберите команду Save Gradient, в открывшемся диалоговом окне введите название градации Rainbow в поле Save As и нажмите кнопку ОК (рис. 9.6).

Рис. 9.6. Диалоговое окно Save Grad

Теперь ваша градация внесена в библиотеку, и ее можно использовать для заливки выделенного объекта (рис. 9.7).

Рис. 9.7. Градация Rainbow (Радуга)

Заимствование градации из изображения

С помощью средств Painter вы можете не только создавать и редактировать градацию, но воспользоваться готовым плавным переходом, позаимствовав его из какого-либо изображения. Рассмотрим этот процесс подробнее:

  1. Откроте документ, где содержится готовая градация, которой вы хотите воспользоваться.
  2. Выберите инструмент Rectangular Selection (Прямоугольное выделение) и обозначьте область градации.
  3. Это должна быть очень узкая полоса, как можно уже, горизонтальная или вертикальная. Если полоса горизонтальная, в качестве градации берутся цвета первого верхнего ряда пикселов слева направо. Если полоса вертикальная, в качестве градации берутся цвета первого левого ряда пикселов сверху вниз.
  4. Выберите команду Capture Gradient (Фиксировать градацию). Откроется диалоговое окно Save Grad (Сохранить градацию). Присвоите название выделенной градации и нажмите кнопку ОК. Выделенная градация занесена в библиотеку под данным названием (рис. 9.8).

Рис. 9.8. Использование готовой градации

Техника заливки градацией

Теперь, когда вы умеете воспользоваться градацией, мы расскажем о том, как ее применить.

  1. Выделите область для заливки градацией.
  2. Откройте секцию Gradients.
  3. Выберите образец из представленных на палитре.
  4. Выберите команду Effects > Fill (Эффект > Заполнить) или нажмите комбинацию клавиш Ctrl + F. Откроется диачоговое окно Fill with (Заполнить чем).
  5. Установите переключатель Gradient. В окне предварительного просмотра — выбранная вами градация (рис. 9.9).
  6. Установите подходящее значение параметра Opacity (Непрозрачность), нажмите кнопку ОК. Выделенная область залита выбранным плавным переходом.

Рис. 9.9. Диалоговое окно Fill

Наложение градации на изображение

Эффектное применение градации — это наложение плавных переходов на уже готовое изображение, например, на контурный эскиз. В результате можно получить контрастное рельефное изображение, напоминающее фотографию, получаемую специальной технологией обработки негатива. В этом примере мы использовали фотографию с изображением закатного африканского пейзажа.

  1. Раскройте документ с изображением, которое вы хотите залить градацией и выделите необходимую область. При наложении градации на все изображение можно не пользоваться выделением.
  2. Выберите среди образцов секции Gradients созданный в предыдущем упражнении вариант Rainbow (Радуга) (см. рис. 9.7).
  3. Выберите в меню секции команду Express in Image (Выразить в изображении). Откроется диалоговое окно Express in Image (рис. 9.10).
  4. С помощью ползунка Bias (Смещение) подберите подходящее соотношение цветов в градации. Влияние соотношения цветов проследите в окне просмотра. В нашем примере регулятор установлен на значении 23%. Завершив подбор, нажмите кнопку ОК.

Рис. 9.10. Окно Express in Image

Результат наложения градации на изображение Africa приведен на рис. 9.11.

Рис. 9.11. Результат наложения градации на фотографию Africa

Использование инструмента Paint Bucket для заливки градацией

Для работы с вложенными палитрами Art Materials помимо уже рассмотренной команды Effects > Fill, используется инструмент Paint Bucket (Заливка) [image].

Пользоваться заливкой чрезвычайно просто, и в то же время этот инструмент позволяет создать любопытные графические и цветовые эффекты. Поэтому мы остановимся на его действии подробно.

Рассмотрим работу с инструментом Paint Bucket (Заливка).

Инструмент Paint Bucket расположен на панели инструментов Tools.

Управление заливкой осуществляется с помощью панели управления Control: Paint Bucket (рис. 9.12).

Рис. 9.12. Палитра управления Paint Bucket (Заливка)

Раскрывающийся список Fill With содержит способы заливки:

  • Current Color — цвет текущий (основной, но не вторичный);
  • Grad (Градация);
  • Weave (Плетение);
  • Clone Source (Клонируемое изображение). Если источник клонирования не задан, то по умолчанию способ Clone Source обеспечивает заливку шаблоном.

На панели управления Control: Paint Bucket присутствуют следующие параметры:

Параметр | Описание
What to Fill (Что заливать) | Поле с раскрывающимся списком из двух параметров Image (Изображение), Cartoon Cel (фон). Определяет объект заливки
Fill With (Чем заполнить) | Поле с раскрывающимся списком способов заливки
Tolerance (Допустимое отклонение) | Ползунок. Задает допустимое отклонение от цвета в точке выделения. В крайнем левом положении ползунка, когда допустимое отклонение равно нулю, заливается единственный пиксел, на котором установлен указатель. По мере перемещения ползунка вправо область заливки расширяется и может охватить все изображение
Feather (Размытость) | Ползунок. Определяет размеры области плавного перехода от выделенной части к остальному изображению. В крайнем левом положении ползунка область плавного перехода отсутствует. По мере перемещения ползунка вправо область плавного перехода расширяется
Anti-Alias (Сглаживание границы) | Флажок. Задает состояние границы между выделяемой областью и остальной частью изображения. По умолчанию флажок Anti-Alias установлен, то есть наблюдается плавный цветовой переход к невыделенной части изображения. Для создания контрастной границы снимите флажок Anti-Alias

Итак, для того чтобы произвести заливку, необходимо определить:

  • что заливать (выделить фрагмент для предполагаемой заливки);
  • чем заливать (градацией, шаблоном, цветом, плетением);
  • область заливки — Tolerance (Допустимое отклонение);
  • области плавного перехода — Feather (Размытость);
  • состояние границ — Anti-Alias (Сглаживание границы).

Приведем простейшую последовательность действий:

  1. Выделите изображение или его часть, предназначенную для заливки.
  2. На панели инструментов выберите инструмент Paint Bucket (Заливка).
  3. На панели Control: Paint Bucket в поле What to Fill выберите Image.
  4. В поле Fill With укажите способ заливки Grad.
  5. Установите указатель мыши в пределах выделенной области и щелкните кнопкой. Выделенная область залита.

СОВЕТ. Если вы установите указатель вне выделенной области и щелкнете мышью, будет залито все изображение, кроме выделенной области.

Простейшая заливка — без предварительного выделения — охватывает область, определяемую цветом в месте установки указателя мыши, подобно инструменту Magic Wand (Волшебная палочка). Результат ее приведен на рис. 9.13. Параметры заливки приведены на панели Controls: Paint Bucket. Исходное изображение — документ Clouds — приведен слева. Флажок Anti-Alias установлен, о чем свидетельствует желтая линия, ограничивающая линию заливки.

Рис. 9.13. Заливка цветом изображения без выделения

Упражнение. Заливка изображения без выделения

  1. Раскройте изображение (рис. 9.14).
  2. Выведите на экран линейки с помощью команды Canvas > Rulers > Show Rulers, в качестве единиц измерения установите пикселы, выбрав команду Canvas > Rulers > Ruler Options.
  3. На панели инструментов Tools выберите Paint Bucket.
  4. Откройте секцию Gradients палитры Art Materials и выберите вариант Three Rings.
  5. На панели Control: Paint Bucket в поле What to Fill выберите Image. В поле Fill With укажите Grad. С помощью движков Tolerance и Feather задайте допустимое отклонение и размеры области растушевки, как показано на рис. 9.15. Флажок Anti-Alias снимите.
  6. Выполните первую заливку. Установите указатель в точку с координатами 100 по горизонтальной оси и 100 по вертикальной оси. Нажмите кнопку мыши — заливка произведена (рис. 9.16).
  7. Выберите вариант Browns (Коричневые). Параметры заливки остаются без изменения.
  8. Выполните вторую заливку. Установите указатель в точку с координатами 200 по горизонтальной оси и 220 по вертикальной оси. Нажмите кнопку мыши — заливка произведена (рис. 9.17).
  9. Выберите вариант Metallic (Металл). Параметры заливки остаются без изменения.
  10. Выполните третью заливку. Установите указатель мыши в правом нижнем углу. Нажмите кнопку мыши — заливка произведена (рис. 9.18).
  11. Выберите вариант Bright (Яркий). Параметры заливки остаются без изменения.
  12. Выполните четвертую заливку. Установите указатель на нижней границе изображения и выполните ряд заливок с шагом 10-15 пикселов. Заливка произведена (рис. 9.19).

Рис. 9.14. Исходное изображение Clouds

Рис. 9.15. Параметры первой заливки — вариант Three Rings

Рис. 9.16. Результат первой заливки

Рис. 9.17. Результат второй заливки

Рис. 9.18. Результат третьей заливки

Рис. 9.19. Результат четвертой заливки

Как видите, работа с заливками чрезвычайно проста.

Изменяя варианты градации, легко получить совершенно разные цветовые и графические решения на основе того же исходного документа Clouds (Облака) (рис. 9.20).

Рис. 9.20. Результат заливки изображения Clouds различными вариантами градаций

Заливка незамкнутой области

Если область заливки задана незамкнутой линией, может произойти «вытекание заливки», то есть она выйдет за пределы установленной области.

Чтобы залить незамкнутую область и предотвратить вытекание заливки, необходимо выполнить следующее:

  1. Установите указатель в пределах заливаемой области, обозначенной незамкнутым контуром. Нажмите кнопку мыши и, не отпуская ее, увеличивайте размеры прямоугольного выделения до тех пор, пока в нем не окажется весь незамкнутый контур.

    2. ВНИМАНИЕ. Прямоугольное выделение осуществляется инструментом Paint Bucket (Заливка).

  2. Отпустите кнопку мыши. Незамкнутая область залита.

Если вы не удовлетворены заливкой, отмените предыдущее действие, выбрав команду Edit > Undo Paint Bucket Fill или нажав сочетание клавиш Ctrl+Z. После чего повторите заливку.

СОВЕТ. Прямоугольное выделение должно чуть превышать размеры незамкнутого контура. Если размеры прямоугольного выделения слишком велики, заливается вся область, обозначенная прямоугольным выделением.

Защита от заливки

При работе с изображением возможна ситуация, когда вы хотите предохранить от заливки какую-то область. Для этого необходимо выполнить следующее:

  1. Определите цвет данной области с помощью инструмента Dropper (Пипетка).
  2. Дважды щелкните на инструменте Paint Bucket (Заливка) на панели инструментов. Откроется диалоговое окно (рис. 9.21) с флажком Lock out color (Предохранять от заливки).
  3. Установите флажок Lock out color.
  4. Нажмите кнопку Set. В окне просмотра установлен текущий цвет. Нажмите кнопку ОК. Область, окрашенная заданным цветом, предохранена от заливки.

Рис. 9.21. Диалоговое окно с флажком Lock Out Color

Для отмены защиты от заливки снимите флажок Lock out color.

Заливка анимационного элемента

Заливка широко используется при созлании рисунков для анимационных клипов, когда нужно оперативно закрашивать отдельные элементы, оставляя нетронутым контур.

Заливка анимационного элемента осуществляется в три этапа:

  • создание маски;
  • задание порога маски;
  • заливка элемента.

Подробно маски и выделения мы будем рассматривать в главе 13.

Чтобы создать маску:

  1. После того как созданы контуры анимационного рисунка, выберите команду Select > Auto Select. Откроется диалоговое окно Auto Select (рис. 9.22).
  2. В меню Using выберите параметр Image Luminance (Освещение изображения) Нажмите кнопку ОК. В результате создана автомаска, предохраняющая от заливки линии контура. Однако линии контура имеют различный уровень яркости, поэтому заливка может охватить область, находящуюся за пределами контура. Чтобы предохранить от заливки область за пределами контура, необходимо задать порог маски.
  3. Дважды щелкните на инструменте Paint Bucket (Заливка). Откроется уже известное вам по предыдущему примеру окно с флажком Lock out color (рис. 9.21). Установите порог маски ползунком Mask Threshold (Порог маски). В крайнем левом положении порог маски равен нулю, поэтому заливается область за пределами контура маски. Перемещая ползунок вправо, вы поднимаете порог маски и тем самым ограничиваете заливку контурами маски, оставляя нетронутыми линии контура. Нажмите кнопку ОК. Порог маски установлен.

Рис. 9.22. Окно диалога Auto Select

Для заливки анимационного элемента:

  1. В секции Gradients выберите вариант заливки. На панели инструментов выберите инструмент Paint Bucket.
  2. На панели Controls: Paint Bucket в поле What to Fill выберите Cartoon Cel (Фон). В поле Fill With (Заполнить с помощью) укажите способ заливки: Current Color (Цветом), Grad (Градацией), Weave (Плетением) или Clone Source (Клонированным изображением). Если источник клонирования не задан, то по умолчанию способ Clone Source обеспечивает заливку шаблоном.
  3. Установите указатель мыши в пределах заливаемого контура, нажмите кнопку мыши.

ПРИМЕЧАНИЕ. Учтите, что высота порога маски зависит от нескольких факторов — цвета линии контура, инструмента, с помощью которого создан контур, фона и подбирается опытным путем после нескольких актов заливки.


Шаблоны и плетения

  • Секция Patterns
    • Панель управления секции Patterns
    • Библиотека шаблонов
  • Создание шаблона
    • Редактирование шаблона
    • Бесшовный шаблон
  • Упражнение. Создание бесшовного шаблона из отдельных элементов
    • Создание фрактального шаблона
  • Секция Weaves
    • Панель управления Weaves
    • Изменение цвета нитей
    • Создание и редактирование тканевого узора

Вы научитесь использовать готовые шаблоны, создавать библиотеки шаблонов, создавать собственные и редактировать готовые шаблоны и плетения

В данной главе мы рассмотрим устройство и работу следующих секций палитры Art Materials: Patterns и Weaves.

Pattern (шаблон) — это элемент узора или ячейка с фрагментом изображения, повторяющиеся в узлах регулярной сетки, составляющей целый узор. Такие шаблоны используются для заливки фона или самого изображения.

Weave (плетение, тканевый узор или шотландка) представляет собой разновидность шаблона, выделенную в отдельный инструмент, благодаря единому достаточно сложному принципу создания рисунков и их разнообразию.

Шаблон и плетение, также как градация, прежде всего используется для заливки.

Секция Patterns

Как и прочие рассмотренные нами секции, входящие в состав палитры Art Materials, секция Patterns может быть представлена в двух видах (рис. 10.1a и 10.1b). Устроена она также подобно всем остальным секциям. Как вы помните, для того чтобы открыть палитру Art Materials, следует выбрать команду Window > Show Art Materials или нажать комбинацию клавиш Ctrl+3.

Рис. 10.1a. Секция Patterns в свернутом виде

Рис. 10.1b. Секция Patterns с раскрытой библиотекой шаблонов

Сама секция Patterns открывается нажатием кнопки, расположенной слева от названия секции. Правая кнопка-стрелка открывает меню секции.

Ниже расположены пять образцов шаблонов. Под ними — длинная горизонтальная кнопка, нажатием которой открывается дополнительная часть секции, содержащая коллекцию образцов загруженной библиотеки. В нижней части секции расположена панель управления секции Patterns, предназначенная для редактирования образцов шаблонов.

Панель управления секции Patterns

Разберем подробнее состав панели управления Patterns. Собственно панель, как вы уже знаете, расположена под образцами шаблонов загруженной библиотеки.

В верхней части панели расположена текстовая строка с названием выбранного образца. Щелкнув на ней, вы откроете список названий образцов загруженной библиотеки. Тот же список образцов библиотеки открывается щелчком на изображении шаблона в строке заголовка секции.

В окне предварительного просмотра представлено изображение узора.

Справа от окна обозначен размер шаблона: количество пикселов в строке и столбце.

В области Pattern Type (Тип узора) вы можете выбрать любой из трех типов шаблонов в зависимости от вида сетки:

  • Rectangular (Прямоугольный) — изображение располагается в узлах прямоугольной сетки;
  • Horizontal (Горизонтальный) — изображение наносится горизонтальными полосами со смещением;
  • Vertical (Вертикальный) — изображение располагается вертикальными полосами со смещением.

Величина смещения задается перемещением ползунка Offset (Смещение) и меняется от 0 до 100%.

Размер шаблона задается перемещением ползунка Scale (Масштаб).

Библиотека шаблонов

Загруженная библиотека открывается нажатием длинной горизонтальной кнопки. В ней хранится достаточный набор шаблонов, однако вы можете пополнить текущую библиотеку, создав свое изображение для шаблона или позаимствовав изображение в другой библиотеке.

Для доступа в другую библиотеку шаблонов, входящую в стандартный комплект выберите последнюю строку в списке названий шаблонов загруженной библиотеки — Load Library. При этом раскроется стандартное окно открытия файла (рис. 10.2). Выбрав нужный файл, нажмите кнопку Открыть. В секцию будет загружена новая библиотека шаблонов.

Рис. 10.2. Окно диалога для открытия библиотеки шаблонов

Если вы хотите сформировать собственную коллекцию шаблонов из образцов, входящих в различные библиотеки, это легко сделать с помощью команды Pattern Mover (Сортировщик шаблонов) и одноименного диалогового окна (рис. 10.З).

Рис. 10.3. Диалоговое окно Pattern Mover

Для этого:

  1. Выберите в меню секции команду Pattern Mover. Откроется окно Pattern Mover. В левой части окна представлена загруженная библиотека, правая — свободна.
  2. Нажмите кнопку Open, откроется диалоговое окно Open Pattern Library (рис. 10.4).
  3. Выберите нужный файл, нажмите кнопку Открыть. В свободное правое окно будет загружена другая библиотека.
  4. Выберите нужный образец и перетащите его из правого окна в левое. Отпустите кнопку мыши. Образец теперь будет находиться в левом окне, то есть в текущей коллекции.

Рис. 10.4. Окно Open Pattern Library

При желании удалить ненужный образец выделите его и нажмите клавишу Delete.

Если вам кажется, что образец имеет неудобное, возможно, длинное название, вы можете его переименовать.

Для этого:

  1. Выделите образец и нажмите кнопку Change Name (Изменение названия). Откроется диалоговое окно Change Patterns Name (Изменение названия шаблона), где в поле ввода указано название образца.
  2. Введите новое название и нажмите кнопку ОК. Название будет изменено на новое.

Создание шаблона

Получить практически новый шаблон можно несколькими способами:

  • изменить имеющийся шаблон;
  • заимствовать фрагмент любого изображения;
  • создать новый шаблон с помощью диалогового окна Make Fractal Patterns (Создание фрактального шаблона).

Мы рассмотрим все эти способы получения нового шаблона.

Редактирование шаблона

Редактирование шаблона можно осуществлять по-разному. Условно, это могут быть:

  • ограниченные изменения, вносимые в него с помощью средств секции Patterns палитры Art Materials;
  • значительные изменения, вносимые всеми средствами Painter.

Однако и те и другие средства могут изменить имеющийся шаблон до неузнаваемости.

При редактировании шаблона, а также при его создании, вы столкнетесь с проблемой повторяемого фрагмента. Эта проблема заключается в наличии швов при соединении одинаковых элементов узора. Только узор с однотонным фоном, состоящий из элементов, расположенных на некотором отдалении друг от друга, делающем эти элементы независимыми друг от друга, может автоматически стать бесшовным. В некоторых случаях швы могут включаться в орнамент.

В большинстве же случаев нежелательные швы следует удалять.

Редактирование шаблона средствами панели управления

  1. Откройте секцию Patterns.
  2. Нажатием длинной горизонтальной кнопки откройте загруженную библиотеку образцов шаблонов.
  3. Выберите нужный образец. Он появится среди пяти образцов в верхней части секции. Выбранный образец представлен в окне просмотра.
  4. С помощью ползунка Scale (Масштаб) установите минимальные размеры фрагмента. Если изображение достаточно крупное, лучше взять небольшую его часть.
  5. В области Pattern Type (Тип шаблона) установите переключателем тип сетки. Ползунком Offset (Смещение) установите величину сдвига.

На рис. 10.5, 10.6 представлены четыре варианта одного и того же шаблона с разными параметрами.

Рис. 10.5. Два варианта одного шаблона

Рис. 10.6. Два варианта одного шаблона

ПРИМЕЧАНИЕ. Результат заливки, приведенный в окне предварительного просмотра — только качественный контроль. Размер узора в окне предварительного просмотра отличается от размера на холсте.

Чтобы иметь представление о полученном шаблоне, следует его применить.

  1. Создайте новый документ с помощью команды File > New. Установите размеры образца, лучше небольшие, например 200 х 200.
  2. Выберите команду Effects > Fill или нажмите комбинацию клавиш Ctrl+F. Откроется диалоговое окно Fill с установленным по умолчанию переключателем Pattern (рис. 10.7). Если он снят, установите его. В окне предварительного просмотра представлен выбранный шаблон.
  3. Ползунком Opacity (Непрозрачность) подберите необходимую прозрачность.
  4. Нажмите кнопку ОК. Выделенная область залита указанным шаблоном.

Рис. 10.7. Диалоговое окно Fill

ПРИМЕЧАНИЕ. Поскольку в окне Fill шаблон активизирован по умолчанию, он используется в качестве источника клонирования или при создании рельефной карты для эффектов, связанных с некоторыми плавающими объектами. Это значит, что в тех случаях, когда не указан источник клонирования или не определено изображение для создания рельефной карты, для этих целей будет использован выделенный в данный момент шаблон.

Редактирование шаблонов с помощью меню секции

Painter предлагает вам несколько способов редактирования шаблонов.

Первый способ — внести изображение в библиотеку шаблонов, затем вызвать его вновь, выбрав команду Check Out Pattern (Управление шаблоном) и отредактировать в окне шаблона.

  1. Раскройте документ с изображением или выделите необходимую область с помощью инструмента Rectangular Selection (Прямоугольное выделение). Это и будет ячейка шаблона.
  2. Выберите в меню секции команду Define Pattern (Определить шаблон). При этом никаких видимых изменений не произойдет.
  3. Затем выберите команду Add Image to Library (Занести изображение в библиотеку). Откроется диалоговое окно Save Pattern. В поле Save As введите название шаблона и нажмите кнопку ОК. Шаблон внесен в текущую библиотеку. Теперь вы можете его открыть для редактирования.

Другой способ — использование команды Capture Pattern (Фиксировать шаблон). С помощью этого способа вы можете сделать шаблоном любой фрагмент изображения.

  1. Выделите изображение или его часть с помощью инструмента Rectangular Selection (Прямоугольное выделение) и отредактируйте шаблон.
  2. Выберите команду Capture Pattern. Откроется диалоговое окно Capture Pattern. В окне предварительного просмотра появится фрагмент выделенного изображения.
  3. Установите переключатель типа сетки: Rectangular, Horizontal, Vertical.
  4. Для типов Horizontal и Vertical задайте величину смещения с помощью ползунка Bias.
  5. В поле ввода введите название шаблона и нажмите кнопку ОК. Созданный шаблон занесен в текущую библиотеку.

В качестве примера простейшего редактирования выполните следующее:

  1. Выберите шаблон из текущей библиотеки. Мы выбрали в библиотеке шаблонов Filagree (Филигрань).
  2. Увеличьте его с помощью ползунка Scale. Выберите в меню секции команду Capture Pattern.
  3. В диалоговом окне Capture Pattern с просмотровым окном установите наиболее приемлемые параметры с помощью переключателей Rectangular, Horizontal или Vertical и ползунка Bias. Отредактируйте шаблон по своему усмотрению (рис. 10.8). Нажмите кнопку ОК.
  4. Значок отредактированного шаблона появится среди других значков. Создайте новый документ и залейте его новым шаблоном.
  5. Закончив редактирование, выберите команду Add Image To Library (Занести изображение в библиотеку). Откроется диалоговое окно Save Pattern.
  6. Введите в поле ввода название измененного шаблона, нажмите кнопку ОК. Ваш шаблон внесен в текущую библиотеку.

Рис. 10.8. Редактирование шаблона с помощью простейших средств Painter

Бесшовный шаблон

При запивке бесшовным шаблоном границы ячеек не видны. Для создания бесшовного шаблона вы можете:

  • закрасить шов, пользуясь прокруткой, при этом след кисти на границе шаблона с одной стороны автоматически переносится на другую сторону;
  • переместить шов между ячейками в центр рабочей области, где отчетливо видны все различия между ячейками, и с помощью различных вариантов клонирующей кисти Cloners сделать бесшовные переходы между ячейками;
  • стереть шов между ячейками шаблона с помощью кисти Photo варианта Scratch Remover (Перемещатель царапин).

В качестве примера рассмотрим несколько бесшовных шаблонов, созданных с помощью клонирования (рис. 10.9, 10.10 и 10.11). Техника клонирования подробно рассмотрена в главе 7.

Рис. 10.9. Исходная фотография для создания бесшовного шаблона

Рис. 10.10. Выделен фрагмент для создания бесшовного шаблона

На рис. 10.9 приведено исходное изображение для бесшовного шаблона Цветы. На рис. 10.10 в средней части исходного изображения выделена область, из которой путем офсетного клонирования создан шаблон. В выделенную область добавлено несколько цветов.

Периодичность по вертикали и по горизонтали обеспечена клонированием на расстоянии, равном соответственно высоте и ширине шаблона. Клонирование выполнено в полосе, равной по ширине линейному размеру преобладающих элементов композиции. Для клонирования использована кисть Cloners, вариант Straight Cloner (Прямое клонирование). Размер кисти — несколько пикселов. В библиотеку шаблон занесен с помощью команды Capture Pattern. На рис. 10.11 приведен результат заливки бесшовным шаблоном Цветы в масштабе 75%.

Рис. 10.11. Рабочая область залита созданным бесшовным шаблоном

На рис. 10.12 приведено исходное изображение для бесшовного шаблона Аперитив. В верхней части рисунка приведено исходное изображение. На рис. 10.13 в исходном изображении выделена область, использованная для создания шаблона. Из выделенной области путем клонирования фона убраны лишние предметы. Гранины шаблона заполнены фоном, нанесенном на расстоянии, равном высоте и ширине шаблона.

Рис. 10.12. Исходное изображение для создания шаблона Аперитив

Рис. 10.13. Выделена центральная часть для создания шаблона

Для клонирования использована кисть Cloners, вариант Straight Cloner (Прямое клонирование). Размер кисти несколько пикселов. В библиотеку шаблон занесен с помощью команды Capture Pattern. Результат заливки полученным шаблоном приведен на рис. 10.14.

Рис. 10.14. Результат заливки бесшовным шаблоном Аперитив

Упражнение. Создание бесшовного шаблона из отдельных элементов

В этом упражнении мы продемонстрируем еще один способ создания шаблона - из отдельных готовых элементов.

Для создания шаблона воспользуемся заготовками из плавающих объектов библиотеки Image Portfolio, хранящимися в папке Fruits.

Сначала создадим холст для шаблона.

  1. Выберите File > New и задайте размеры холста 256 х 256 пикселов. Для создания бесшовного шаблона на его границе необходимо расположить элементы, совпадающие при периодическом повторении шаблона по горизонтали и вертикали (рис. 10.15). Для этого создадим у шаблона поля, соизмеримые по ширине с плавающими объектами, используемыми при создании шаблона. Максимальный размер плавающих объектов, применяемых при создании шаблона, 200 пикселов. В таком случае ширину полей можно задать равной половине этого размера, то есть ста пикселам.
  2. Выберите Canvas > Canvas Size и задайте в поле Add to увеличение размеров холста на 100 пикселов сверху, снизу, слева и справа.
  3. Обозначим границы шаблона. Выберите команду Canvas > Rulers > Show Rulers. В качестве единицы измерения задайте пикселы. Выберите команду Canvas > Rulers > Ruler Options и в поле Ruler Units укажите Pixels.
  4. Выведите на холст направляющие, выбрав команду Canvas > Guides > Show Guides. На горизонтальной линейке установите указатель мыши ориентировочно на метке 100 пикселов и щелчком выведите на холст направляющую линию. Двойным щелчком рядом с меткой направляющей вызовите панель Guide Position и задайте Х=100. Вторую направляющую задайте с координатой 356. Повторите указанные действия для вертикальной координаты и задайте направляющие с Y = 100 и Y = 356. В результате на исходном холсте обозначены границы шаблона (см. рис. 10.15).

Рис. 10.15. Холст для создания шаблона. Направляющими отмечены границы шаблона

Теперь займемся элементами рисунка, расположенными по границе шаблона. Чтобы изображение, создаваемое с помощью шаблона, было бесшовным, все элементы рисунка шаблона должны повторяться с периодом, равным размерам шаблона, то есть с периодом 256 пикселов.

  1. Обратитесь к палитре Objects и откройте секцию Image Portfolio (Коллекция изображений). Из группы под названием Fruits (Фрукты) выберите изображение сладкого перца.
  2. Выбрав команду Effects > Orientation > Rotate (Эффекты > Положение > Поворот), разверните изображение перца по горизонтали и расположите его по углам шаблона.
  3. Займемся изображением перца в левом верхнем углу. Задайте направляющие с координатами X = 50, Y = 80. Увеличьте изображение перца в несколько раз, чтобы были хорошо видны отдельные пикселы, выберите на хвостике перца характерный участок и расположите его в точке с указанными координатами. В результате координаты данного объекта заданы с точностью до пиксела (рис. 10.16).
  4. Повторите указанную операцию для каждого из изображений перца и расположите их с периодом 256 пикселов по горизонтали и вертикали. Координаты характерного участка для перца, находящегося в правом верхнем углу: Х=306, Y = 80. Координаты характерного участка для перца, находящегося в левом нижнем углу: X = 50, Y = 336. Координаты характерного участка для перца, находящегося в правом нижнем углу: X = 306, Y = 336. В результате угловой элемент шаблона расположен с периодом 256 пикселов по горизонтали и вертикали (рис. 10.17).
    Элементы трафарета, расположенные на горизонтальных границах, должны иметь для характерного участка общую координату X, а координата Y должна отличаться на 256 пикселов. Элементы трафарета, расположенные на вертикальных границах, должны иметь для характерного участка общую координату Y, а координата X должна отличаться на 256 пикселов (рис. 10.18). Для каждой пары элементов удобно задавать свой цвет направляющих.
  5. Таким образом расположите элементы трафарета по его границам с периодом, равным 256 пикселам по горизонтали и вертикали (рис. 10.19).

Рис. 10.16. Задание координат плавающего объекта с точностью до пиксела

Рис. 10.17. Элемент трафарета, расположенный с периодом 256 пикселов по горизонтали и вертикали

Рис. 10.18. К трафарету добавлен элемент, расположенный с периодом 256 пикселов по горизонтали

Рис. 10.19. По границе шаблона расположены элементы рисунка с периодом 256 пикселов по горизонтали и вертикали

После того как граничные элементы выставлены, остается заполнить центральную часть шаблона. Пользуясь плавающими объектами и библиотекой Image Portfolio, сделать это довольно просто (рис. 10.20).

Рис. 10.20. Центральная часть шаблона заполнена элементами рисунка

  1. Осталось с точностью до пиксела убрать поля шаблона. Выберите Canvas > Canvas Size и в поле Add to задайте отрицательную величину -100 пикселов. Бесшовный шаблон готов (рис. 10.21). Занесите созданный шаблон в библиотеку шаблонов.
  2. Выделите шаблон, выбрав команду Select > All. Откройте секцию Patterns палитры Art Materials. Выберите Capture Pattern, в поле Name введите название шаблона, например Fruits, убедитесь, что в изображении отсутствуют швы, и внесите его в библиотеку шаблонов.

Рис. 10.21. Готовый бесшовный шаблон

Полученное изображение можно использовать дальше как основу для различных вариантов шаблона с помощью клонирования исходного, и применяя к нему различные команды меню Effects. Например, созданный шаблон Fruits можно обработать кистью Artist (Художники), вариант Seurat (Сера), и провести цветовую коррекцию, выбирая команду Effects > Tonal Control > Color Correction.

Создание фрактального шаблона

Кроме обычных способов создания шаблона из отдельных элементов или преобразованием выделенного фрагмента Painter предоставляет возможность создать шаблон с помощью фрактальных средств. Подобный шаблон представляет собой узор, состоящий из различных неправильных форм, но в отличие от обычных шаблонов он не требует дополнительных действий для ликвидации шва.

Специально для создания фрактального шаблона предназначено диалоговое окно Make Fractal Pattern (Создать фрактальный шаблон), открываемое выбором команды Make Fractal Pattern (рис. 10.22).

Рис. 10.22. Окно диалога Make Fractal Pattern

В левой части окна расположено окно предварительного просмотра. В правой части — ползунки настройки. Параметры диалогового окна и их назначение приведены в табл. 10.1.

Таблица 10.1. Описание параметров диалогового окна Make Fractal Pattern

Параметр | Описание
Power (Увеличение) | Ползунок. Действует аналогично инструменту Лупа. Перемещение влево увеличивает изображение фрактального рисунка. Вправо - уменьшает от 300 до 100%
Feature Size (Размер элементов) | Ползунок. Изменяет размер элементов элементов шаблона. Перемещение влево уменьшает размеры элементов и увеличивает число повторений узора в ячейке. Диапазон - от 0 до 100%
Softness (Размытость) | Ползунок. Регулирует контрастность границ между элементами узора. Диапазон - от 0 до 100%
Angle (Угол) | Ползунок. Имитирует изменение угла зрения на фрактальный узор. Диапазон - от 0 до 360 градусов
Thinness (Нелинейность) | Ползунок. Регулирует нелинейность элементов фрактального узора. Диапазон регулятора Thinness - от 0 до 100%
Size (Размер) | Область переключателей. Позволяет установить 5 вариантов размера фрактального узора
Channel (Канал) | Раскрывающийся список. Позволяет задать различные карты рельефа для создания фрактального шаблона

Ползунок Thinness (Нелинейность) в крайнем левом положении изменяет фрактальный узор до неузнаваемости. Узор превращается в чередование линий. Ползунок Angle меняет их наклон. При перемещении ползунка вправо линии разделяются на элементы фрактального узора, очертания элементов усложняются. Фрактальный узор становится более прихотливым.

Раскрывающийся список Channel задает информацию об изображении, используя четыре цветовых канала: Синий, Зеленый, Красный, а также Альфа (или Маска в градации серого).

Список Channel содержит следующие варианты:

  • Height as Luminance (Высота пропорциональна яркости) — представляет фрактальный шаблон в черно-белом изображении, создающем эффект рельефа, где более высокие области соответствуют более ярким элементам карты. Такая форма представления фрактального шаблона хороша при создании рельефного рисунка для образца текстуры бумаги.
  • Gradient Bearing (Градиентный переход) — использует Красный канал для отображения понижений в рельефе с градиентным переходом к более высоким частям рельефа, отображаемым Синим каналом.
  • Surface Normal (Нормаль к поверхности) — использует Зеленый и Синий каналы для представления X и Y компонент, образующих горизонтальную составляющую нормали к поверхности фрактального рельефа в данной точке. Синий канал — компонента X. Зеленый канал — компонента Y.

Для создания фрактального шаблона:

  1. Выберите команду Make Fractal Pattern. Откроется диалоговое окно Make Fractal Pattern. В просмотровом окне вы увидите ничем не примечательный исходный вариант шаблона.
  2. Изменяя положение ползунков и устанавливая различные настройки, вы можете создать подходящий рисунок фрактального шаблона.
  3. После получения устраивающего вас варианта нажмите кнопку ОК. Изображение созданного фрактального шаблона автоматически появится в виде нового документа. Теперь его необходимо сохранить.
  4. Выберите команду Define Pattern (Определить шаблон), затем выберите Add Image to Library, откроется окно Save Pattern, введите название в поле ввода, и ваш образец будет занесен в библиотеку.

На рис. 10.23 приведены примеры фрактальных шаблонов с различными параметрами, установленными в диалоговом окне Make Fractal Pattern.

Рис. 10.23. Пример фрактальных шаблонов, полученных из одного исходного образца

Секция Weaves

Как мы уже говорили в начале главы, действие секций Weaves и Patterns очень схоже. А благодаря пропорциям и эффектным сочетаниям цветов изображения, созданные с помощью секции Weaves (Плетения), сами по себе способны привлечь внимание (рис. 10.24).

Рис. 10.24. Изображение Старый Плед, созданное с помощью секции Weaves

Своим устройством секция Weaves практически ничем не отличается от предыдущих секций палитры Art Materials, поэтому мы не будем останавливаться на ней подробно, а отправляем вас к предыдущим разделам.

Рис. 10.25a. Секция Weaves в свернутом виде

Рис. 10.25b. Секция Weaves с раскрытой библиотекой образцов

Секция Weaves представлена на рис. 10.25a и 10.25b в обычном виде и с раскрытой библиотекой образцов.

Загрузить другую библиотеку можно, как обычно, с помощью списка названий образцов, в котором команда Load Library расположена последней. Список служит для удобства поиска нужного изображения по названию, поэтому рекомендуем обращать внимание на названия выбираемых образцов.

Меню команд секции представлено обычными вариантами.

Сортировщик образцов открывается выбором команды Weave Mover (Сортировщик плетений). С его помощью вы можете собрать удобную вам библиотеку образцов.

Панель управления Weaves

Разберем подробнее состав панели управления Weaves.

В верхней части панели расположено поле с названием выбранного образца. В окне предварительного просмотра — изображение плетения. Справа от окна - размер плетения: количество пикселов в строке и столбце (Rows, Columns). Состав панели управления Weaves приведен в табл. 10.2.

Таблица 10.2. Состав панели Weaves

Параметр | Описание
Fiber Type (Тип волокна) | Окно, где задаются два типа волокна: двумерное и трехмерное. Для изменения типа волокна достаточно щелкнуть мышью в пределах окна
Н Scale (Горизонтальный масштаб) | Ползунок. Задает горизонтальный размер узора. Диапазон движения ползунка — от 1 до 20 пикселов
V Scale (Вертикальный масштаб) | Ползунок. Задает вертикальный размер узора. Диапазон движения ползунка — от 1 до 20 пикселов
Н Thick (Толщина горизонтальной нити) | Ползунок. Задает размер горизонтальных нитей. Диапазон движения ползунка — от 1 до 100%
V Thick (Толщина вертикальной нити) | Ползунок. Задает размер вертикальных нитей. Диапазон движения ползунка — от 1 до 100%

С помощью панели управления можно менять тип волокна, пропорции плетения и толщину нити. При этом плетение может измениться до неузнаваемости, но вряд ли вы захотите ограничиться этим.

На рис. 10.26, 10.27 приведены модификации одного и того же узора, выполненные с помощью средств панели управления Weaves.

Рис. 10.26. Пример изменений, внесенных с помощью панели управления

Рис. 10.27. Пример изменений, внесенных с помощью панели управления

Помимо изменений, вносимых в плетение с помощью панели Weaves, вы можете отредактировать плетение, применяя команды меню секции.

Изменение цвета нитей

Изменение цветовой гаммы плетения выполняется следующим образом:

  1. Откройте секцию Weaves и выберите команду Get Color Set (Получить цветовой набор). Откроется сокращенный цветовой набор Color Set из семи цветов, используемых при создании плетения (рис. 10.28).
  2. Откройте секцию Color и подберите основной (или первичный) цвет.

    3. ВНИМАНИЕ. Вторичный цвет не переносится в сокращенную цветовую панель, используемую при плетении.

  3. Выберите образец цвета, который вы планируете заменить в сокращенном наборе цветов Color Set. Нажмите клавишу Alt и, не отпуская ее, щелкните мышью на заменяемом образце цвета. Замена произведена. Выбранный вами основной цвет включен в сокращенный цветовой набор.
  4. Выберите команду Put Color Set (Вставить цветовой набор). Новый цвет включен в состав плетения, и рисунок в окне предварительного просмотра изменил цветовую гамму.
  5. Для занесения нового образца плетения в библиотеку плетений выберите Save Weave (Сохранить плетение). Откроется диалоговое окно Save Weave.
  6. Введите название созданного образца плетения и нажмите кнопку ОК. Созданный образец плетения занесен в текущую библиотеку.

Рис. 10.28. Исходный (слева) и изменений (справа) цветовые наборы

На рис. 10.29 приведены варианты одного рисунка плетения с измененным цветовым набором. Количество цветов в цветовом наборе зависит от рисунка.

Рис. 10.29. Варианты, полученные путем изменения цветовых наборов; исходный вариант вверху

Создание и редактирование тканевого узора

Создание или редактирование тканевого узора представляется более сложной задачей. Дело в том, что, выбрав команду Edit Weave (Редактирование плетения), вы откроете диалоговое окно Edit Weave (рис. 10.30), предназначенное для редактирования. Но само редактирование выполняется на специальном языке.

Рис. 10.30. Окно диалога Edit Weave

На рис. 10.31, 10.32 приведены примеры композиций с использованием плетения. Элементы, наложенные на плетение, были нарисованы и обработаны с применением динамичного слоя Bevel World.

Рис. 10.31. Композиция с использованием плетения

Рис. 10.32. Композиция с использованием плетения


Текстура и бумага

  • Секция Paper палитры Art Materials
  • Панель управления секции Paper
    • Библиотека текстур и сортировщик
  • Создание текстуры бумаги
    • Создание текстуры бумаги из фрактального шаблона
  • Заимствование текстуры из изображения
  • Работа с текстурой бумаги
  • Упражнение. Создание бумаги с логотипом курьерской фирмы City Express

Вы сможете не только использовать готовые текстуры, но и создавать новые

Каждый художник знает, какое значение имеет текстура бумаги, ее рельеф, способность впитывать краску. Хорошая высококачественная бумага в достойной рамке — это уже произведение искусства. Вам предстоит убедиться в том, какие эффекты можно передать с помощью бумаги и каково ее значение в вашей работе.

Представление о бумажных текстурах за последнее десятилетие значительно изменилось. Бумажные коллекции различных фирм обогатились удивительными текстурами, имитирующими разнообразные поверхности и материалы, которые никак, казалось бы, не связаны с бумагой. Например, знаменитая коллекция бумажных текстур Tatiana имитирует всевозможные ткани от грубого сурового полотна до тончайшего шелка.

В качестве примера использования различных бумажных текстур на рис. 11.1 приведена композиция, выполненная в градации серого.

Рис. 11.1. Изображение, выполненное в градации серого, с использованием различных текстур

Секция Paper палитры Art Materials

В этой главе мы рассмотрим устройство и работу следующей секции палитры Art Materials — Paper. Как вы помните, чтооы открыть палитру Art Materials, следует выбрать команду Window > Show Art Materials или нажать комбинацию клавиш Ctrl+3.

Секция Paper открывается нажатием стрелки [image], расположенной слева от названия секции. Меню секции открывается правой кнопкой-стрелкой.

В верхней части секции находятся пять образцов фактуры бумаги.

Под ними — длинная горизонтальная кнопка, открывающая дополнительную часть палитры с коллекцией образцов загруженной библиотеки (рис. 11.2a и 11.2b). Ниже расположена панель управления секции Paper, используя которую вы сможете отредактировать образцы текстуры бумаги.

Рис. 11.2a. Секция Paper палитры Art Materials открыта не полностью

Рис. 11.2b. Секция Paper палитры Art Materials с открытой коллекцией образцов

Панель управления секции Paper

Разберем подробнее состав панели управления (см. рис. 11.2a и 11.2b). В верхней части панели расположено поле с названием выбранного образца текстуры, щелчок на котором открывает список текстур загруженной библиотеки. Такой же список текстур открывается щелчком на текущем образце текстуры, расположенном справа от названия секции.

В окне предварительного просмотра представлено изображение выбранного образца, позволяющее детально рассмотреть его текстуру.

Под окном — ползунок Scale (Масштаб), с помощью которого можно выбрать необходимый размер параметров текстуры, например размер зерна. Масштаб зерна меняется от 25 до 400%. Справа от окна — информация о количестве строк и столбцов, формирующих структуру.

С помощью ползунка Contrast (Контрастность) регулируется контрастность фактуры; при перемещении ползунка вправо контрастность усиливается.

Ползунок Brightness (Яркость) позволяет отрегулировать яркость. Перемещение вправо осветляет образец, влево — затемняет его.

Внизу, справа от окна предварительного просмотра — флажок Invert Paper (Вывернуть бумагу), позволяющий как бы вывернуть бумагу, то есть выпуклые части текстуры опустить, сделать понижениями в рельефе. Флажок Invert Paper дублируется одноименной командой в меню секции Paper.

Такой же список текстур открывается при щелчке на текущем образце текстуры, расположенном справа от названия секции в закрытом состоянии.

Библиотека текстур и сортировщик

Доступ к библиотеке текстур открывается из списка текстур.

В конце списка находится команда Load Library, раскрывающая стандартное окно открытия файла. Когда библиотека выбрана и загружена, она появляется на палитре в виде новых образцов коллекции.

При желании иметь определенную коллекцию образцов из различных библиотек воспользуйтесь средством Paper Mover — сортировщиком. Диалоговое окно сортировщика Paper Mover (Сортировщик бумажных текстур) содержит два окна, одно из которых заполнено образцами текущей библиотеки, другое свободно.

Чтобы пополнить коллекцию образцами из другой библиотеки или создать свою собственную коллекцию из образцов различных библиотек:

  1. Выберите в меню секции команду Paper Mover, откроется диалоговое окно Paper Mover.
  2. Нажмите кнопку Open, откроется диалоговое окно Open Paper Library File (Открыть библиотеку текстур).
  3. Выберите библиотеку, нажмите кнопку ОК. Правое окно заполнят образцы открытой библиотеки (рис. 11.3).
  4. Выберите понравившийся образец, установите указатель мыши на нем, нажмите кнопку мыши и переместите выбранный образец в левое окно. Отпустите кнопку мыши.

Рис. 11.3. Диалоговое окно Paper Mover

Для удаления ненужного образца выделите его и нажмите кнопку Delete.

Создание текстуры бумаги

Если в текущей библиотеке не нашлось подходящей текстуры, у вас есть возможность создать текстуру из набора текстурных заготовок, представленных в диалоговом окне Make Paper (Создать бумагу).

Техника создания текстуры с помощью окна Make Paper такова:

  1. Выберите команду Make Paper. Откроется диалоговое окно Make Paper (рис. 11.4).
  2. В поле Pattern приведено название шаблона — заготовки текстуры. Открыв список, выберите нужный шаблон. Оценить выбранный шаблон можно в окне предварительного просмотра.
  3. С помощью ползунка Spacing (Интервал) задайте расстояние между элементами шаблона. Расстояние задается в пикселах, оно меняется от 1 до 100.
  4. Задайте угол наклона линий, вдоль которых располагаются элементы шаблона с помощью ползунка Angle. Угол задается в градусах и меняется от 0 до 180.
  5. Введите название образца текстуры в текстовое поле Save As. Нажмите кнопку ОК. Текстура перенесена в текущую библиотеку образцов.

Рис. 11.4. Диалоговое окно Make Paper

Создание текстуры бумаги из фрактального шаблона

Вы можете создать новые необычные текстуры, выбрав команду Make Fractal Pattern (Создать фрактальный шаблон). Рассмотрим создание текстуры с помощью фрактального изображения, используемого в шаблонах.

Выполните следующее:

  1. Откройте секцию Pattern палитры Art Materials.
  2. Выберите в меню секции команду Make Fractal Pattern. Откроется одноименное диалоговое окно (рис. 11.5).
  3. С помощью ползунков подберите подходящий рисунок текстуры бумаги. Задайте размер образца (сначала лучше минимальный, 128 х 128 пикселов).
  4. Выберите канал Height as Luminance (Высота как освещение) и нажмите кнопку ОК. В рабочей области появится образец текстуры бумаги нужного размера (рис. 11.6).
  5. Выберите Select > All.
  6. Откройте секцию Paper и в меню секции выберите команду Capture Paper. Откроется диалоговое окно Save Paper.
  7. Введите название текстуры бумаги и нажмите кнопку ОК. Созданный вами образец текстуры занесен в текущую библиотеку.

Рис. 11.5. Диалоговое окно Make Fractal Pattern

Рис. 11.6. Образец фрактальной текстуры

Заимствование текстуры из изображения

Для создания текстуры можно воспользоваться любым изображением, даже не имеющим отношения к текстурам и бумаге.

Если вы хотите воспользоваться текстурой, отсутствующей в вашей текущей библиотеке:

  1. Откройте необходимое изображение и выделите ту часть, которую хотите использовать для создания текстуры бумаги. На рис. 11.7 приведена выделенная часть изображения Озеро для создания текстуры Water.
  2. Выберите команду Capture Paper. Откроется диалоговое окно Save Paper. Введите в поле Save As название текстуры бумаги.
  3. Задайте состояние границы шаблона текстуры с помощью ползунка Crossfade (Ослабление перехода). Нажмите кнопку ОК. Текстура внесена в библиотеку образцов и может использоваться для создания текстуры бумаги (рис. 11.8).

Рис. 11.7. Изображение Озеро с выделенной областью и диалоговым окном Save Paper

Рис. 11.8. Текстура Water, заимствованная из изображения Озеро

Кроме готовых изображений для создания текстуры применяются различные эффекты Painter. Рассмотрим подробнее процесс заимствования текстуры на примере изображения, созданного с помощью инструмента Maze (Лабиринт):

  1. Создайте новый документ небольшого размера, например, 200 х 200 пикселов.
  2. Выберите команду Effects > Esoterica > Maze. Откроется диалоговое окно Maze. Задайте параметры, которые вам поправятся, и нажмите кнопку ОК. Получаем заготовку для текстуры Maze (рис. 11.9).
  3. Выберите Select > All, а затем в меню секции Paper команду Capture Paper. Откроется диалоговое окно Save Paper. Введите название текстуры бумаги в поле Save As, например Maze.
  4. С помощью ползунка Crossfade задайте состояние границы шаблона. Если ползунок установлен в нулевом положении, то при создании текстуры бумаги получаем четкую границу между шаблонами. При перемещении регулятора вправо граница становится менее четкой (рис. 11.10).
  5. Нажмите кнопку ОК. Текстура внесена в библиотеку образцов и может использоваться для создания текстуры бумаги.

Рис. 11.9. Создание заготовки для текстуры Maze

Рис. 11.10. Примеры текстур, полученных с различными положениями ползунка Crossfade

На рис. 11.10 приведен пример настройки ползунком Crossfade. На левом образце четко видна граница фрагмента узора текстуры (левый верхний угол первого образца занимает полный фрагмент, слева внизу и справа оба фрагмента неполные). Здесь ползунок Crossfade стоит на нулевой отметке.

В среднем образце граница между фрагментами менее заметна. Здесь ползунок стоит в положении 4.

На правом образце границ фрагментов практически не различить. Ползунок Crossfade установлен на значении 8.

Работа с текстурой бумаги

Мы рассмотрели способы создания текстуры бумаги, теперь рассмотрим технику ее применения.

Для использования текстуры, то есть для наложения ее на объект, предназначено диалоговое окно Apply Surface Texture (Покрыть поверхность текстурой) (рис. 11.11), открываемое командой Effects > Surface Controls > Apply Surface Texture (Эффект > Управление поверхностью > Покрыть поверхность текстурой).

Рис. 11.11. Диалоговое окно Apply Surface Texture

В левом верхнем углу окна Apply Surface Texture расположено окно предварительного просмотра, где приведен выбранный образец текстуры.

Справа от области Light Controls (Управление светом) расположено окно визуального контроля параметров освещения. Освещенная сфера позволяет наблюдать влияние каждого параметра. Щелчком в пределах сферы вы можете увеличивать число источников света.

Щелчком в окне Light Color (Цвет луча) вызывается панель Цвет, в которой задаются цветовые параметры освещения.

С помощью диаграммы Light Direction (Направление луча) вы можете свести несколько заданных источников света к одному.

Состав диалогового окна Apply Surface Texture и назначение параметров приведены в табл. 11.1.

Таблица 11.1. Назначение параметров диалогового окна Apply Surface Texture

Назначение | Параметр
Меню Using (Используемое меню) | Содержит параметры, настраивающие основу для построения рельефной карты: Paper, 3D Brush Strokes, Image Luminence, Original Luminence
Paper (Бумага) | Устанавливает текстуру бумаги
3D Brush Strokes (Объемный штрих кисти) | Задает объемный рельеф, созданный кистями
Image Luminence (Освещение изображения) | Устанавливает яркость изображения, к которому применяется текстура
Original Luminence (Освещение оригинала) | Устанавливает яркость оригинала, используемого в качестве источника клонирования
Ползунок Softness (Мягкость) | Регулирует размытость текстуры
Флажок Inverted (Обратное) | Задает изменение рельефа бумаги на обратный
Область Material | Ползунки Amount, Picture, Shine, Reflection
Amount (Количество) | Регулирует глубину рельефа
Picture (Картина) | Регулирует освещенность
Shine (Светить) | Регулирует яркость
Reflection (Отражение) | Устанавливает коэффициент отражения
Область Light Controls (Управление светом) | Содержит ползунки, регулирующие параметры освещения: Brightness, Conc, Exposure
Brightness (Яркость) | Регулирует интенсивность освещения
Conc (Концентрация) | Регулирует размеры освещающего луча
Exposure (Экспозиция) | Устанавливает размеры освещенной области
Диаграмма Light Direction (Направление луча) | Устанавливает положение источника света
Ползунок Display (Отображать) | Настраивает яркость окна визуального контроля
Флажок Show Light Icons (Показывать пиктограмму луча) | Показывает метку центра светового пятна на условной сфере в окне предварительного просмотра

Используя параметры, приведенные в таблице, выполните следующее:

  1. Создайте новый документ. Выберите в секции Paper текстуру, которую планируете применить в документе.
  2. Выберите команду Effects > Surface Controls > Apply Surface Texture. Откроется диалоговое окно Apply Surface Texture (см. рис. 11.11).
  3. Установите необходимые параметры бумаги, освещения и выберите масштаб текстуры, используя приведенные в таблице сведения. Нажмите кнопку ОК.

Наибольший эффект текстура дает для изображений, созданных акварелью или пастелью. В качестве примера приведен рисунок, выполненный кистями категории Water-Color, наложенный на три различные текстуры: Eggs cape (Яичная скорлупа), Ribbed pastel (Ребристая пастель) и Hatching (Гравировка) (слева направо) (рис. 11.12).

Рис. 11.12. Рисунок акварелью, наложенный на три различные текстуры

На рис. 11.13 приведены варианты, полученные при наложении текстуры на изображение, выполненное кистью категории Dry Media, вариантом Oil Pastel (Жирная пастель). При этом использовались три различные текстуры: Water (Водная) (слева), Ribbed pastel (Ребристая пастель) (в центре) и Smooth (Гладкая) (справа).

Рис. 11.13. Рисунок масляной пастелью, наложенный на три различные текстуры

В качестве основы для построения рельефной карты можно использовать текстуру бумаги как непосредственно, так и применив к ней настройки параметров, предлагаемых в меню Using:

  • Image Luminence — яркость изображения;
  • Original Luminence — яркость источника клонирования;
  • 3D Brush Strokes — объемный эффект.

Пример рельефного изображения, при создании которого использована настройка яркости этого же изображения, задаваемая параметром Image Luminence, приведен на рис. 11.14. Параметры диалогового окна Apply Surface Texture установлены по умолчанию. Параметр Shine задан равным нулю.

Рис. 11.14. Пример создания рельефного изображения с помощью параметров окна диалога Apply Surface Texture

При создании текстуры также можно использовать яркость источника клонирования. Для этого в раскрывающемся меню Using необходимо настроить параметр Original Luminence. В результате исходное изображение имитирует рельеф, построенный пропорционально яркости источника клонирования.

Пример создания рельефного изображения, для которого в качестве основы для построения рельефной карты использована яркость источника клонирования, приведен на рис. 11.15. В изображении Зима в качестве основы применена текстура. Для построения рельефной карты в качестве источника клонирования взято изображение с текстом. В раскрывающемся меню Using установлен параметр Original Luminence. Для задания источника клонирования применена команда File > Clone Source. Параметры диалогового окна Apply Surface Texture установлены по умолчанию. Параметр Shine задан равным нулю.

Рис. 11.15. Пример использования в качестве основы для построения рельефной карты яркости источника клонирования

Текстуру бумаги можно применить не только ко всему документу, но и к выделенной области. Пример использования нескольких текстур к разным фрагментам одного изображения приведен в самом начале этой главы (см. рис. 11.1).

Текстура бумаги может также применяться при работе с инструментом Paint Basket (Заливка) или при выборе команды Effects > Fill. Для этого необходимо создать отдельно документ с выбранной текстурой бумаги и использовать его в качестве источника клонирования. В свою очередь, на панели управления инструмента Paint Basket или в диалоговом окне Fill в области Fill with нужно установить флажок Clone Source. Размеры источника клонирования и текущего изображения должны быть строго одинаковыми.

Любопытные эффекты могут быть получены, если применить к текстурам специальные эффекты с помощью средства Dynamic Layers (в прежних редакциях - встроенных плавающих объектов Plug-in Floaters). В качестве примера приведена текстура, полученная в результате применения эффекта Bevel World к текстуре Crackle (Растрескивающийся) (рис. 11.16). Параметры эффекта Bevel World установлены по умолчанию.

Рис. 11.16. Текстура, полученная в результате применения эффекта Bevel World к текстуре Crackle

На рис. 11.17 приведен логотип Your Choice (Твой выбор). Фон изображения получен путем наложения двух текстур Pavement (Мозичный) и Crackle (Растрескивающийся) и использован для заливки букв и звезд, к которым применен эффект Bevel World (параметры установлены по умолчанию).

Рис. 11.17. Логотип Your Choice

Упражнение. Создание бумаги с логотипом курьерской фирмы City Express

В предлагаемом вашему вниманию упражнении используются представления и понятия, которые мы будем рассматривать в главе 14 и главе 15.

  1. С помощью инструмента Реn (Перо) создайте отдельные элементы логотипа, имитируя переход от буквы к букве без отрыва пера (рис. 11.18). Каждый элемент логотипа — это векторный объект, представленный в списке секции Layers палитры Objects.
  2. Объедините отдельные элементы в логотип (рис. 11.19). Для этого при нажатой клавише Shift выделите в списке секции Layers палитры Objects все элементы логотипа.
  3. В секции Layers нажмите кнопку Group (Сгруппировать), а затем кнопку Collapse (Опустить).
  4. На запрос о преобразовании векторных объектов в растровые дайте утвердительный ответ, то есть нажмите кнопку Commit (Совершить), что означает выполнение преобразования. В итоге все векторные плавающие объекты объединены в группу и превращены в растровый плавающий объект.
  5. Для того чтобы создать тень от букв логотипа выберите команду Effects > Objects > Create Drop Shadow. Параметры диалогового окна Drop Shadow (Опустить тень) можно принять по умолчанию. При желании можно изменить непрозрачность, например, увеличить ее до 100%.
  6. После создания тени, если вы довольны результатом, в секции Layers выберите команду Drop All (Опустить все).
  7. С помощью инструмента Crop (Обрезка) удалите лишние участки холста и уменьшите размер логотипа так, чтобы он был в несколько раз меньше листа бумаги. Для изменения размера логотипа выберите команду Canvas > Resize и задайте новые размеры.
  8. Выберите команду Select > All.
  9. Выберите команду Capture Paper (Фиксировать текстуру) в секции Paper палитры Art Materials. Откроется диалоговое окно Save Paper. В поле Save As введите название бумаги, например, Cityexpress (рис. 11.20). Положение ползунка Crossfade оставьте принятым по умолчанию.
  10. Создайте новый документ. Выберите команду Effects > Apply Surface Texture. В окне Apply Surface Texture, изменяя параметры, подберите подходящий рисунок текстуры. Возможный вариант приведен на рис. 11.21.
  11. Неплохой эффект дает сложная текстура бумаги. Создайте новый документ. В библиотеке текстур секции Paper выберите текстуру, например Smooth (Гладкая).
  12. Выберите команду Effects > Apply Surface Texture и примените текстуру Smooth к документу.
  13. Теперь задайте текстуру Cityexpress, выберите команду Effects > Apply Surface Texture и наложите текстуру Cityexpress на текстуру Smooth. Результат приведен на рис. 11.22.
  14. Текстуру бумаги можно сделать более эффектной, если подобрать размеры элементов логотипа так, чтобы они формировали бесшовный шаблон (рис. 11.23) (см. главу 10).
  15. На палитре Art Materials в секции Pattern выберите команду Pattern > Capture Pattern. В диалоговом окне Capture Pattern задайте тип регулярной сетки и сдвиг, а затем, присвоив имя шаблону, занесите его в библиотеку. Залейте данным шаблоном чистый холст и, выбрав команду Capture Paper, внесите его в библиотеку текстур. Примените созданную текстуру к новому документу.

Рис. 11.18. Отдельные элементы логотипа, внесенные в палитру Objects:Layers

Рис. 11.19. Отдельные элементы, объединенные в логотип

Рис. 11.20. Логотип после создания тени от букв. Диалоговое окно Save Paper

Рис. 11.21. Задание параметров текстуры бумаги с помощью диалогового окна Apply Surface Texture

Рис. 11.22. Создание бумаги со сложной текстурой. Текстура Cityexpress наложена на текстуру Smooth

Рис. 11.23. Вариант текстуры, созданной с помощью бесшовного шаблона

Рис. 11.24. Вариант текстуры, созданной с помощью бесшовного шаблона. Заливка по горизонтали со сдвигом 50%

Возможные варианты текстур изображены на рис. 11.23 и 11.24. Параметры создания текстур приведены на рисунках.


Инструмент Image Hose

  • Секция Image Hose
  • Варианты кисти Image Hose
    • Выбор параметров кисти
    • Эффект фона и вторичного цвета
    • Разброс изображений
    • Библиотека Nozzles
  • Создание одномерной матрицы
    • Создание двумерной матрицы
    • Создание трехмерной матрицы
    • Создание заготовки из кадров фильма
  • Упражнение. Создание простой композиции с помощью Nozzles
  • Упражнение. Создание поздравительной открытки с помощью кисти Image Hose

Инструмент Image Hose рисует изображениями — готовыми элементами Nozzles

Инструмент Image Hose относится к кистям и входит в палитру Brushes (Кисти). Но эта кисть рисует не цветом, а изображениями, называемыми Nozzles (Заготовками). Таким образом, это кисть, рисующая готовыми элементами Nozzles, вместо Dab — следа кисти. Из этих элементов складывается штрих. При этом параметры элементов Nozzles зависят от направления, степени нажима на стилус, его ориентации, а также от многих других факторов и могут меняться в очень широких пределах.

Это очень удобный инструмент для создания самых разнообразных композиций, особенно для создания однообразных массивов, например из листьев — листвы, из деревьев — леса, из цветов и травы — луга, из строений — города и т. д. В качестве элементов берется желаемый фрагмент изображения, преобразуется соответствующим образом и становится Nozzle. Библиотека заготовок Nozzles входит в палитру Art Materials в виде секции Nozzles.

Этимология оригинального английского названия этого инструмента такова: Hose — это шланг или соответственно глагол — поливать из шланга, a Nozzles — это насадки на садовый шланг, чтобы менять параметры разбрызгиваемой струи. В таком случае Image Hose буквально переводится как рисование изображениями, a Nozzles — заготовки этих изображений.

Заготовка — это последовательность изображений, объединенных по смыслу и имеющих общее название. Количество элементов в заготовке может быть каким угодно. Заготовка представляет собой 24-битовое изображение с 8-битовой маской, позволяющей оперировать этим изображением как слоем.

Элементы в Nozzle должны быть расположены определенным образом, чтобы могла соблюдаться зависимость величины от давления или угла поворота от направления.

Секция Image Hose

Инструмент Image Hose [image] чрезвычайно прост в работе, а его параметры очень легко меняются, так же как и параметры остальных кистей.

В качестве примера на рис. 12.1 приведено изображение, созданное из готовых элементов, предлагаемых Painter.

Рис. 12.1. Пример изображения, созданного с помощью инструмента Image Hose и стандартных заготовок библиотеки Painter

Для доступа к инструменту Image Hose:

  1. Выберите инструмент Brush (Кисть) в палитре инструментов; в палитре Brushes выберите инструмент Image Hose.
  2. Откройте палитру Art Materials и секцию Nozzles. Выберите соответствующую заготовку в загруженной библиотеке секции Nozzles палитры Art Materials (рис. 12.2).

Рис. 12.2. Секция Nozzles в свернутом и развернутом состояниях

Устройство и работа секции Nozzles полностью аналогична всем прочим секциям, рассмотренным в предыдущих главах.

Под строкой с названием палитры расположены образцы заготовок, доступных непосредственно. Достаточно выделить любой понравившийся образец, и он готов к применению.

Нажатием длинной горизонтальной кнопки со стрелкой открывается доступ к другим образцам загруженной коллекции заготовок.

Щелчком в поле с названием образца открывается список образцов с командой Load Library в самом конце списка. С помощью этой команды загружается библиотека Nozzles из комплекта поставки Painter или из Интернета.

Меню с управляющими командами раскрывается при нажатии на стрелку, находящуюся справа в строке с названием палиры. Такое же меню раскрывается при выборе команды Nozzle на палитре Brushes: Image Hose.

Команды меню позволяют создавать, редактировать заготовки, сохранять и пополнять коллекции заготовок.

Выбрав команду Nozzle Mover (Сортировщик насадок), вы откроете одноименное окно сортировщика (рис. 12.3), с помощью которого можно создать свою библиотеку заготовок. Работает он аналогично другим сортировщикам, рассмотренным нами ранее, поэтому мы не будем говорить о нем подробно.

Рис. 12.3. Диалоговое окно Nozzle Mover

Детально рассмотреть или отредактировать заготовку вы можете, выбрав в меню секции команду Check Out Nozzle (Проверка заготовки). При этом открывается изображение заготовки. Оно представляет собой так называемую матрицу изображений. Это значит, что изображения заполняют клетки таблицы. При заливке отдельные изображения могут извлекаться из заготовки самым разным образом. Например так, чтобы размер изображения был пропорционален скорости перемещения мыши или степени нажатия на стилус. Изображения могут извлекаться случайным образом или последовательно, то есть по правилу чтения, слева направо и сверху вниз. Все эти варианты мы рассмотрим ниже.

Варианты кисти Image Hose

Варианты кисти Image Hose, подобно вариантам любой другой кисти, задаются в раскрывающемся списке палитры Brushes: Image Hose.

Сложные названия вариантов кисти включают в себя определенные параметры кисти.

Термины Linear (Линейно) и Spray (Разброс) обозначают соответствие положению курсора. Например, если вы выбираете вариант Linear — элементы заготовки будут расположены по направлению движения кисти линейно. Если вы выбираете вариант Spray — элементы будут разбрызгиваться хаотично (рис. 12.4).

Рис. 12.4. Пример использования Linear (вверху) и Spray (внизу)

Степень отклонения от положения курсора регулируется положением ползунка Jitter, находящегося в секции Random палитры Brush Controls.

В табл. 12.1 приведены параметры, входящие в состав названия варианта кисти, и их значение.

Таблица 12.1. Параметры, входящие в состав названия варианта кисти

Параметр | Значение в названии
Size (Размер) | Размер изображения
Angle (Угол) | Угол наклона изображения
D (Direction) (Направление) | Варианты, зависящие от направления движения стилуса
Р (Pressure) (Давление) | Варианты, зависящие от степени нажатия на стилус
В (Bearing) (Азимут) | Варианты, зависящие от ориентировки стилуса относительно планшета
W (Wheel) (Колесо) | Варианты, зависящие от направления вращения колеса распылителя (только для стилуса Intuos)
R (Random) (Случайность) | Варианты с беспорядочно изменяющимися параметрами
Linear (Линейно) | Направление изображения строго по линии курсора
Spray (Разброс) | Направление изображения со случайными отклонениями от линии курсора, как бы разбрызгивающиеся

Например, вариант Linear-Size/RAngle/D означает, что изображения располагаются по линии перемещения курсора, размер их меняется случайным образом, а угол наклона зависит от направления (см. рис. 12.4, вверху). Вариант Spray-Size/PAngle/R означает, что изображения располагаются с разбросом от положения курсора, размер их меняется пропорционально степени нажатия на стилус, а угол наклона меняется случайным образом (см. рис. 12.4, внизу).

Выбранные варианты дублируются в секции Expressions палитры Brush Controls. Параметры кисти регулируются, как обычно, с помощью секций палитры Brush Controls.

Выбор параметров кисти

Большая часть параметров кисти определяет размер изображений, расстояние между ними, угол наклона и т. д., задаются они в различных секциях палитры Brush Controls. Степень прозрачности изображений и их насыщенность вторичным цветом задаются на панели управления Controls: Brush. Масштаб изображений устанавливается в меню Nozzles.

Рассмотрим, как задаются параметры заливки в различных секциях палитры Brush Controls (см. главу 6).

В секции Size задается размер изображения. Если размер — переменная величина, например, зависящая от давления, задается также минимальный размер (в процентах от заданного размера и может принимать значения от 0 до 100%).

Кроме того, размер заготовки с изображениями можно задать также в процентах от размера исходной заготовки, хранящейся в библиотеке заготовок. Для этого надо выбрать команду Set Nozzle Scale (Установить масштаб заготовки) в меню секции Nozzle.

В результате на экране появляется диалоговое окно Nozzle Scale (рис. 12.5), где в поле Current Scale (Текущий масштаб) приведен текущий масштаб заготовки. В поле Scale задается необходимый масштаб заготовки.

Рис. 12.5. Диалоговое окно Nozzle Scale

В секции Spacing устанавливается интервал между элементами. Этот параметр представляет собой выраженное в процентах отношение расстояния между изображениями к диаметру кисти. Обратите внимание, что параметр Size задается размером кисти в секции Size палитры Brush Controls. При малых значениях параметра Spacing можно получить эффект накладывающихся друг на друга изображений (рис. 12.6).

Рис. 12.6. Изображение трех капель и сплошная линия, проведенная этим изображением при минимальных параметрах ползунка Spacing

На расстояние между изображениями также влияет положение ползунка Min Spacing (Минимальное расстояние между изображениями). Шкала этого ползунка задана в пикселах. Перемещая ползунок Min Spacing вправо, удается избежать наложения изображений.

Установив ползунок Spacing в области малых значений в левой части шкалы и сместив влево ползунок Min Spacing, можно добиться эффекта сплошной линии, проведенной выбранным изображением (рис. 12.7).

Рис. 12.7. Эффект, получаемый при уменьшении Min Spacing

На рис. 12.8. приведено изображение, полученное с помощью нескольких заготовок в виде капель при минимальных параметрах Spacing палитры Brush Controls и при небольших вариациях вторичного цвета.

Рис. 12.8. Изображение, полученное с помощью заготовок в виде капель

В секции Angle устанавливается угол наклона элементов. Если угол — переменная величина, задаются также Ang Rng (Диапазон изменения углов) и Ang Step (Шаг изменения угла).

Эффект фона и вторичного цвета

С помощью панели управления также можно повлиять на результат изображения. Вы можете придать нужный оттенок как каждому изображению в отдельности, так и всему рисунку с помошью ползунков Opacity и Grain.

В крайнем правом положении ползунка Opacity изображение полностью перекрывает фон (рис. 12.9) (верхний ряд — ползунок Opacity в положении 100%), в крайнем левом — изображение практически неотличимо от фона. Второй ряд — положение ползунка 75%, третий — 50%, нижний ряд — ползунок Opacity в положении 25%.

Рис. 12.9. Изменение прозрачности изображения

Ползунок Grain (Зерно) задает окрашивание изображения вторичным цветом (рис. 12.10). В крайнем правом положении ползунка вторичный цвет совершенно не влияет на окраску изображения, в крайнем левом — изображение полностью окрашено вторичным цветом. Напомним, что вторичный цвет — это цвет второго, фонового прямоугольника на панели управления Controls: Brush. На рис. 12.10 верхний ряд — ползунок Grain в положении 100%, второй ряд — 75%, третий — 50%, четвертый — 25%, нижний ряд — ползунок Grain в положении 0%.

Рис. 12.10. Окрашивание изображений цветами радуги, взятыми в качестве вторичного цвета

Примеры изображений, полученных при изменении прозрачности заготовок и их окраски вторичным цветом, приведены на рис. 12.11 и 12.12.

Рис. 12.11. Постер для конференции уфологов

Рис. 12.12. Изображение, отредактированное с помощью кисти Image Hose

На рис. 12.11 приведен постер для конференции уфологов. На фотографию зимнего горного пейзажа наложена надпись UFO (неопознанный летающий объект), а также полупрозрачные шары, ассоциирующиеся с летающими тарелками. При создании надписи UFO использована заготовка из капель жидкого металла, окрашенных градиентной заливкой различной прозрачности. Шары на переднем плане также представляют собой заливку заготовкой капли, различной прозрачности и окрашенной голубым цветом, взятым в качестве вторичного.

На рис. 12.12 изображен сфинкс, обвитый плющом. В качестве исходного изображения взята фотография сфинкса. Исходное изображение сфинкса обработано заливкой Image Hose с помощью стандартной заготовки lvy-2. В процессе заливки менялась прозрачность заготовки, а также окраска вторичным цветом.

Разброс изображений

Степень отклонения от положения курсора задается в секции Random палитры Brush Controls. Положение ползунка Jitter (Дрожание), расположенного в верхней части секции Random, определяет степень отклонения изображения от положения курсора. Разброс изображений задается в пикселах. В крайнем левом положении ползунка элементы ложатся строго в месте, указанном курсором. В крайнем правом положении — отклонение от положения курсора максимально и составляет 4 пиксела. Пример действия ползунка Jitter в крайних положениях приведен на рис. 12.13.

Рис. 12.13. Действие ползунка Jitter. Верхняя линия — ползунок в крайнем левом положении, нижняя — в крайнем правом

Порядок элементов

Как вы уже знаете, элементы в заготовке, называемой Nozzle, расположены в определенном порядке. Если элементы в заготовке изменяются по одному признаку, например по размеру, они формируют одномерную матрицу, или матрицу первого порядка (Rank 1, или R 1).

Элементы, изменяющиеся по двум параметрам, например по размеру и цвету, формируют двумерную матрицу, или матрицу второго порядка (Rank 2, или R 2) (рис. 12.14).

Рис. 12.14. Пример двумерной матрицы — матрицы второго порядка (R 2). Листья ранжированы по наклону и по величине

Элементы в заготовке, изменяющиеся по трем параметрам, например по размеру, цвету и углу наклона, формируют трехмерную матрицу, или матрицу третьего порядка (Rank 3, или R 3) и т. д.

Чтобы рассмотреть матрицу изображений, выведите на экран увеличенное изображение файла заготовки. Для этого выберите команду Nozzle > Check Out Nozzle. Откроется увеличенное изображение заготовки (см. рис. 12.14).

Порядок извлечения изображений из заготовок задается в секции Expressions палитры Brush Controls в разделах R 1, R 2, R 3 для заготовок, представленных матрицами соответственно первого, второго и третьего порядка.

Изображения могут извлекаться последовательно (Sequential), то есть слева направо, сверху вниз, и случайным образом (Random), пропорционально давлению, направлению, яркости источника клонирования и т. д. None означает, что из заготовки будет извлекаться только одно, последнее изображение, расположенное справа внизу. В секции Expressions палитры Brush Controls регулируются и другие параметры кисти.

В табл. 12.2 приведены параметры кисти, расположенные в правом вертикальном столбце секции Expressions.

Таблица 12.2. Параметры кисти секции Expressions

Параметр | Регулирует
Size (Размер) | Размер элемента
Jitter (Дрожание) | Разброс
Opacity (Непрозрачность) | Непрозрачность
Grain (Зерно) | Окраску вторичным цветом
Angle (Угол) | Угол наклона элемента
Rank 1 (Порядок) | Порядок извлечения изображений из одномерной матрицы изображений или для первой размерности двумерной или трехмерной матрицы
Rank 2 | Порядок извлечения изображений для второй размерности
Rank 3 | Порядок извлечения изображений для третьей размерности

В центральном столбце Controller (Регулятор) для каждого из указанных параметров находятся раскрывающиеся списки показателей, влияющих на параметры рисования.

В правом столбце — флажок Invert, установка которого меняет зависимость от данного показателя на обратную.

Рассмотрим создание дополнительных вариантов кисти на примере влияния указанных параметров на порядок извлечения изображений из файла заготовки.

Как указывалось выше, в каждом файле Nozzle (Заготовки) находится ряд изображений, отличающихся друг от друга.

Порядок извлечения изображений — последовательно, случайно или в зависимости от того или иного параметра (направления или скорости курсора, нажима на инструмент, яркости источника и других) — задается в раскрывающихся меню R 1, R 2, R 3 секции Expression палитры Brush Controls.

Варианты извлечения изображений из файла заготовки, предлагаемые в раскрывающемся меню, приведены в табл. 12.3.

Таблица 12.3. Варианты извлечения изображений из файла заготовки

Пункт меню | Вариант извлечения изображений
Sequential (Последовательно) | Извлечение происходит в порядке, в котором изображения располагаются в заготовке слева направо, сверху вниз
Random (Случайно) | Беспорядочно. Такой порядок извлечения эффективен в том случае, если изображения в заготовке располагаются в определенной последовательности, то есть ранжированы по размеру, цвету или любому другому признаку
Source (Источник) | Изображения извлекаются в зависимости от яркости источника клонирования. Первые члены последовательности изображений соответствуют более освещенным, светлым частям источника, последние члены — менее освещенным, темным частям. Не забудьте выбрать File > Clone Source и указать источник клонирования
Bearing (Ориентация) | Изображения извлекаются в зависимости от того, как ориентирован стилус относительно планшета. Если инструмент ориентирован вдоль страницы, то заливка производится первыми членами последовательности изображений. Если инструмент ориентирован поперек страницы, то заливка производится последними членами последовательности изображений
Tilt (Наклон) | Изображения извлекаются в зависимости от угла наклона стилуса относительно планшета. Если инструмент ориентирован вертикально, то заливка производится первыми членами последовательности изображений. Если инструмент наклонен, то заливка производится последними членами последовательности изображений
Pressure (Давление) | Изображения извлекаются в зависимости от нажима на инструмент, при условии, что вы работаете с электронным альбомом. При слабом нажиме заливка производится первыми членами последовательности изображений. При относительно сильном нажиме заливка производится последними членами последовательности изображений
Direction (Направление) | Изображения извлекаются в зависимости от направления линии. Если линия проводится горизонтально, то заливка производится первыми членами последовательности изображений. Если вертикально, то заливка производится последними членами последовательности изображений
Velocity (Скорость) | Изображения извлекаются пропорционально скорости перемещения инструмента. Если инструмент перемещается медленно, то заливка производится первыми членами последовательности изображений. Если быстро, то заливка производится последними членами последовательности изображений
None (Никакой) | Ни один из параметров не влияет на порядок извлечения изображений из файла. Извлекается только одно последнее изображение, находящееся в правом нижнем углу матрицы изображений

Библиотека Nozzles

Вы сами в процессе работы можете создавать заготовки Nozzles и вносить их в библиотеку, создавать новые библиотеки Nozzles и использовать сортировщик.

  1. Чтобы внести заготовку в библиотеку секции Nozzles палитры Art Materials, выберите команду Load Nozzle (Загрузить заготовку) или нажмите комбинацию клавиш Ctrl+9. Откроется окно Select Image (Выбрать изображение). Выберите заготовку и нажмите кнопку Открыть.
  2. В секции Nozzles выберите команду Add Nozzle to Library (Поместитьзаготовку в библиотеку). Откроется диалоговое окно Save Nozzle, где указанно имя файла заготовки, заносимой в библиотеку. Нажмите кнопку ОК. Файл занесен в библиотеку заготовок, и его значок появится в загруженной библиотеке секции Nozzle палитры Brush Controls.

Чтобы изменить имя файла, хранящегося в библиотеке, удалить заготовку, сохранить заготовку в любом каталоге или внести в библиотеку новую заготовку, в секции Nozzles выберите команду Nozzle Mover (Сортировщик заготовок). Откроется окно сортировщика, устроенное аналогично окнам всех других сортировщиков.

Для изменения имени файла в секции Nozzle Mover (Название заготовки) выделите заготовку и нажмите кнопку Change Name (Выбрать название). В открывшемся окне Change Nozzle Name (Выбрать название заготовки) введите новое имя файла.

Для удаления заготовки из библиотеки в секции Nozzle Mover выделите заготовку и нажмите клавишу Delete.

Чтобы сохранить заготовку в любом каталоге, в секции Nozzle Mover нажмите кнопку New. Откроется диалоговое окно New Nozzle Library (Новая библиотека заготовок), где вы должны указать локализацию заготовки.

ВНИМАНИЕ. Файлы заготовок имеют расширение NOZZLE LIB'S (NZL).

Для внесения новой заготовки в библиотеку в окне Nozzle Mover нажмите кнопку Open. Откроется диалоговое окно Open Nozzle Library (Открыть библиотеку заготовок). Для занесения в библиотеку файлы заготовок должны иметь расширение NOZZLE LIB'S (NZL).

Создание одномерной матрицы

Рассмотрим детально, как создается самая простая стандартная заготовка — одномерная, или одноранговая, матрица изображений. Заготовка создается из отдельных изображений — слоев.

  1. Откройте документ, откуда вы хотите заимствовать элемент изображения. Мы взяли в качестве примера для создания заготовки фотографию набора мраморных шариков. Выберите команду Canvas > Resize и задайте размеры холста (мы взяли размеры 500 х 353 пикселов). Не забудьте задать разрешение.
  2. В исходном документе с помощью инструмента Oval Selection (Круговое выделение) выделите первый член матрицы изображений и выберите команду Edit > Copy (рис. 12.15).
  3. Создайте новый документ размером 300 х 200 пикселов с тем же разрешением и установите черный фон. Выберите Edit > Paste. Первый член матрицы изображений создан (рис. 12.16).
  4. Повторите указанные действия еще несколько раз, скопировав несколько шариков. В итоге сформирована матрица изображений, образующих заготовку (рис. 12.17).
  5. Откройте палитру Objects, выбрав команду Window > Show Objects. Откройте секцию Layers. В списке слоев секции выделите все объекты, удерживая клавишу Shift в нажатом состоянии, и нажмите кнопку Group. Вы объединили выделенные объекты в группу.
  6. В меню секции Nozzles выберите команду Make Nozzle from Group (Сделать заготовку из группы). Откроется новая заготовка — это файл, названный Untitled (Неозаглавленный) (рис. 12.18).
  7. Выберите команду File > Save as, сохраните данный файл, присвоив ему имя Marble Spherules (Мраморные шарики). Обратите внимание, что файл имеет расширение .RIF.
  8. Чтобы внести созданную заготовку из нескольких изображений в библиотеку секции Nozzles, откройте меню секции Nozzles и выберите команду Load Nozzle или нажмите комбинацию клавиш Ctrl+9. Откроется диалоговое окно Select Image. Выделите имя созданной заготовки и откройте ее.
  9. Выберите команду Add Nozzle to Library. Откроется диалоговое окно Save Nozzle, где указано имя созданного файла, заносимого в библиотеку. Нажмите кнопку ОК. Созданный вами файл занесен в библиотеку заготовок, и его значок появится в загруженной библиотеке секции Nozzles палитры Art Materials.

Рис. 12.15. Создание одномерной матрицы изображений. Выделен шарик — первый член матрицы

Рис. 12.16. Первый член матрицы изображений

Рис. 12.17. Матрица изображений из шести элементов

Рис. 12.18. Заготовка из шести элементов-шариков

Изображение, созданное с помощью заготовки Marble Spherules (Мраморные шарики), приведено на рис. 12.19. Вариант кисти Linear — Size/R при изменении положения ползунка Scale от 6 до 150%, Spacing Size 16%, Min. Spacing 7.

Рис. 12.19. Изображение, полученное с помощью заготовки Мраморные шарики

Создание двумерной матрицы

Заготовка, представляющая собой двумерную матрицу, состоит из строк и столбцов. Количество строк определяет число элементов последовательности, ранжированной по первому признаку, а количество столбцов — по второму. Например, количество строк определяет число изображений, расположенных в порядке возрастания размера. Количество столбцов определяет число элементов, расположенных в порядке изменения угла наклона изображений.

ПРИМЕЧАНИЕ. Напомним, что заготовки создаются из изображений, созданных в форме отдельных слоев, ни в коем случае не объединенных в группу.

Для построения такой матрицы необходимо расположить исходные изображения в узлах равномерной сетки. Для этого выполните следующее:

  1. Выберите какой-либо исходный элемент в изображении (рис. 12.20). Выделите, скопируйте его по аналогии с предыдущим упражнением. Это будет первый элемент последовательности.
  2. Определите размер изображения. На панели управления Controls: Select указаны размеры выделенного изображения, например: W — 100, Н — 100.
  3. Определите количество элементов в столбце матрицы, например 3. Умножьте количество элементов на высоту наибольшего изображения. Результат — высота заготовки: 100 х 3 = 300 пикселов. Определите количество элементов в строке матрицы, например 3. Умножьте количество элементов на ширину наибольшего изображения. Результат — ширина заготовки 100 х 3 = 300 пикселов.
  4. Создайте новый документ с соответствующими размерами — 300 х 300 пикселов. В меню выберите команду Canvas > Grid > Show Grid, а затем Grid > Grid Options. Откроется диалоговое окно Grid Options. В области окна Dimensions, в поле Horizontal Spacing введите ширину ячейки — 100, а в поле Vertical Spacing — высоту: 100. Нажмите кнопку ОК. На экране — сетка заданного размера (рис. 12.21).
  5. Для создания более естественного элемента дополните его тенью. Выберите команду Effects > Objects > Create Drop Shadow. Откроется диалоговое окно Drop Shadow (рис. 12.22). Задайте параметры тени и нажмите кнопку ОК. Теперь у исходного элемента есть тень.

Рис. 12.20. Изображение цветка — исходный элемент матрицы

Рис. 12.21. Сетка для создания заготовки, представляющей собой двумерную матрицу изображений

Рис. 12.22. Создание тени. Диалоговое окно Drop Shadow

Изменяя масштаб и ориентировку исходного элемента, с помощью команд Effects > Orientation (Rotate, Scale, Flip Vertical, Flip Horizontal) (Эффект > Положение: Вращение, Масштаб, Поворот вокруг вертикальной, горизонтальной осей) создайте остальные элементы заготовки. В строках разместите одинаковые по размеру элементы, но с различной ориентировкой. В верхней строке — исходный элемент. В средней — элемент меньшего размера, составляющий в масштабе 90% от исходного. В нижней — 80% от исходного.

  1. Для изменения масштаба исходного элемента выберите Effects > Orientation > Scale. Откроется диалоговое окно Scale Selection. Задайте масштаб и нажмите кнопку ОК. Масштаб элемента изменен (рис. 12.23).
  2. Для изменения ориентировки исходного элемента выберите Effects > Orientation > Rotate. Откроется диалоговое окно Rotate Selection (Поворот выделения). Задайте угол поворота и нажмите кнопку ОК. Ориентировка исходного элемента изменена (рис. 12.24).
  3. Расположите изображения в ячейках сетки, ранжируя их по масштабу и ориентировке.
  4. Откройте секцию Layers палитры Objects. Выделите все изображения в списке и выберите команду Drop and Select (Опустить и выделить).
  5. Сохраните созданный файл. Выберите команду File > Save as, сохраните данный файл, присвоив ему имя. Обратите внимание, что файл имеет расширение .RIF.
  6. Чтобы внести созданную заготовку в библиотеку секции Nozzle, выберите команду Load Nozzle или нажмите комбинацию клавиш Ctrl+9. Откроется окно Select Image.
  7. Выделите название только что созданной заготовки и нажмите кнопку Открыть. Откроется окно Nozzle Definition (Параметры заготовок) (рис. 12.25).
  8. В поле Item width (Ширина ячейки) укажите ширину ячейки исходной сетки, а в поле Item height (Высота ячейки) — высоту. В поле Index rank (Метка порядка) укажите ранг матрицы изображений, то есть 2. В поле Rank 1 укажите число членов последовательности по первому признаку (число строк), то есть 3. В поле Rank 2 укажите число членов последовательности по второму признаку (число столбцов), то есть 3. В поле Rank 3 укажите число элементов по третьему признаку (число двумерных матриц), то есть 1. Нажмите кнопку ОК.
  9. В секции Nozzles выберите команду Add to Library. Откроется окно Save Nozzle. Нажмите кнопку ОК. Заготовка, представляющая собой двумерную матрицу изображений, создана.

Рис. 12.23. Изменение масштаба исходного элемента. Диалоговое окно Scale Selection

Рис. 12.24. Изменение ориентировки исходного элемента. Диалоговое окно Rotate Selection

Рис. 12.25. Диалоговое окно Nozzle Definition

На рис. 12.26 представлена итоговая заготовка в виде двумерной матрицы.

Рис. 12.26. Заготовка, представляющая собой двумерную матрицу

На рис. 12.27 приведен еще один пример двумерной заготовки, полученной с помощью динамичного слоя Liquid Metal (Жидкий металл). В этой заготовке элементы ранжированы по количеству и размеру капель. Эту заготовку в дальнейшем мы используем в упражнении для создания текста, выполненного каплями.

Рис. 12.27. Двумерная заготовка, созданная с динамичного слоя Liquid Metal. Элементы ранжированы по количеству и размеру капель

Создание трехмерной матрицы

Особенно интересные эффекты при рисовании кистью Image Hoses можно получить с помощью заготовки в виде трехмерной матрицы.

Рассмотрим построение трехмерной матрицы изображений. Основой для построения трехмерной матрицы является двумерная матрица, ранжирующая изображения по двум признакам. Эта матрица представляет собой элемент в последовательности изображений, ранжированных по третьему признаку.

Число двумерных матриц должно равняться числу членов последовательности, ранжирующих изображения по третьему признаку.

Создадим заготовку, позволяющую рисовать наконечником с элементами в виде звезд различной формы. Воспользуемся для этой цели выделениями в форме звезд, хранящимися в секции Selection Portfolio (Коллекция выделений) палитры Objects.

  1. Откройте палитру Objects и в ней секцию Selection Portfolio. Выберите четыре выделения в форме пяти-, шести-, семи- и восьмиконечных звезд (рис. 12.28). Задайте изменение элементов заготовки по трем признакам: форме звезд; их размеру; количеству звезд в элементе. Элементы должны содержать звезды четырех указанных форм, каждая размером 20, 25 и 30 пикселов. Для каждого размера задайте элементы с одной, двумя и тремя звездами каждой формы.
  2. Установите размер элементарной ячейки, равный 60x60 пикселов, размеры холста, равные 240 х 510 пикселов.
  3. Ширина холста равна размеру одномерной заготовки, содержащей четыре звезды разной формы, то есть 4 х 60 = 240 пикселов.
  4. Двумерная заготовка должна содержать три одномерных, различающихся по количеству звезд в каждом элементе. В таком случае высота холста для двумерной заготовки равна 3 х 60 = 180 пикселов. Трехмерная заготовка должна содержать три двумерных, различающихся по величине звезд в каждой заготовке. В таком случае высота холста для трехмерной заготовки равна 3 x 180 = 540 пикселов.
  5. Создайте новый документ. Выберите File > New и установите размеры холста 240 х 540 пикселов.
  6. Задайте сетку для элементов трехмерной заготовки. Выберите Canvas > Grid > Show Grid.
  7. Задайте размеры ячейки. Выберите Canvas > Grid > Grid Options. В поле Grid type выберите Rectangular Grid. В области Dimensions (Измерение) задайте Horizontal Spacing (Горизонтальный интервал) — 60 pixels, Vertical Spacing (Вертикальный интервал) — 60 pixels, Line Thickness (Толщина) — 1 pixel (рис. 12.29).
  8. Заполните ячейки для одномерной заготовки.
  9. Создайте новый документ размером 200 х 200 пикселов. Установите указатель мыши на пятиконечной звезде и при нажатой клавише переместите выделение в новый документ.
  10. Откройте секцию Gradients в палитре Art Materials (вариант — двухцветная градация) и задайте основной и вторичный цвета различными оттенками желтого. Выберите Effects > Fill, откроется диалоговое окно Fill With, установите переключатель Gradient. В результате осуществлена заливка звезды (рис. 12.30).
  11. Выберите Canvas > Resize и задайте новые размеры холста равные 20 х 20 пикселов. Звезда уменьшена в размере. Теперь восстановите выделение, выбрав команду Select > Reselect (Выделить > Повторить выделение). Это изображение можно вставлять в заготовку (рис. 12.31).
  12. Выберите Edit > Copy, перейдите в документ с сеткой для заготовки и выберите Edit > Paste. Расположите плавающий слой с изображением звезды в центре ячейки. Проделайте эти действия для всех четырех звезд. В итоге получена одномерная заготовка, элементы которой меняются только по одному признаку, по форме звезды (рис. 12.32).

Рис. 12.28. Секция Selection Portfolio палитры Objects: выделения в форме звезд различной формы

Рис. 12.29. Сетка для трехмерной заготовки. Параметры панели Grid Options

Рис. 12.30. Создание элемента заготовки с помощью выделений из раздела Selection Portfolio и заливки градацией

Рис. 12.31. Изображение после изменения размера и восстановления выделения

Рис. 12.32. Одномерная заготовка

Теперь заполните ячейки для двумерной заготовки:

  1. Выберите инструмент Layer Adjuster и щелкните мышью на плавающем слое с пятиконечной звездой. Выберите Edit > Copy, а затем Edit > Paste. Расположите плавающий объект в ячейке следующей строки для пятиконечных звезд. Повторите эти действия еще раз и поместите в эту же ячейку еще одну звезду. Готов элемент с двумя звездами.
  2. Повторите эти действия еще три раза и поместите в следующую ячейку три звезды. Готов элемент с тремя звездами.
  3. Повторите описанные действия для звезд другой формы. В итоге получена двумерная заготовка, элементы которой меняются по двум признакам: по форме и по количеству звезд в элементе (рис. 12.33).

Рис. 12.33. Двумерная заготовка

Заполним ячейки для трехмерной заготовки:

  1. Перейдите в документ с пятиконечной звездой, уменьшенной до размера 20 х 20 пикселов. Выберите Canvas > Resize и задайте новые размеры холста равными 25 х 25 пикселов. Выберите Select > Reselect. Выберите Edit > Copy. Перейдите в документ с сеткой для заготовки и выберите Edit > Paste. Расположите плавающий слой с изображением звезды в центре следующей вниз ячейки в столбце, где располагаются звезды пятиконечной формы. Продвигаясь вниз по сетке, заполните ячейки с двумя и тремя звездами. Еще раз пересчитайте размеры холста, создайте пятиконечную звезду размером 30 х 30 пикселов и заполните последние три ячейки в столбце с пятиконечными звездами. Повторите описанные действия для звезд другой формы.
  2. В итоге получена трехмерная заготовка, элементы которой меняются по трем признакам: форме, размеру и количеству звезд в элементе заготовки (рис. 12.34).

Рис. 12.34. Трехмерная заготовка

Создайте трехмерную заготовку:

  1. Откройте секцию Layers палитры Objects и при нажатой клавише Shift активизируйте все слои. Выберите команду Drop and Select (Опустить и выделить).
  2. Сохраните данный файл в формате RIFF. Выберите команду Nozzle > Load Nozzle. Откроется стандартное окно открытия файла. Выберите созданный и сохраненный файл с элементами заготовки. Нажмите кнопку Открыть. Откроется диалоговое окно Nozzle Definition (Параметры заготовки). Укажите параметры созданной заготовки (рис. 12.35).
  3. Перед загрузкой файла в библиотеку заготовок на экране появляется диалоговое окно Save Nozzle, укажите имя данного документа в библиотеке заготовок, где он будет сохранен в формате NZL.

Рис. 12.35. Диалоговое окно Nozzle Definition для трехуровневой матрицы

Заготовка создана и внесена в библиотеку. Пример заливки с созданной заготовкой приведен на рис. 12.36.

Рис. 12.36. Результат применения кисти Image Hose с трехмерной заготовкой Stars

Создание заготовки из кадров фильма

Вы можете создать заготовку из кадров фильма и выполнить работу с помощью изображений, входящих в эти кадры. Если заготовка представляет собой одномерную матрицу изображений, это совсем просто. Чтобы создать заготовку го кадров фильма:

  1. Раскройте кадры, которые вы планируете использовать для создания заготовки. При выполнении этой операции могут быть трудности, связанные с форматом кадров.

    2. ВНИМАНИЕ. Painter может открывать кадры в формате Frame Stacks (*. FRM), Quick Time Movies (*. MOV), Video for Windows (*. AVI).

  2. Откройте секцию Nozzle палитры Art Materials и в меню секции выберите команду Make nozzle from Movie (Сделать заготовки из клипа).
  3. Откроется диалоговое окно Untitled с представленными кадрами фильма. Выделите последовательность кадров для заготовки.
  4. Сохраните выделенную последовательность с расширением .RIF. Затем выполните операции для создания простой одномерной заготовки из серии рисунков в формате RIF.

Аналогичным образом из нескольких простых одномерных заготовок создаются заготовки 2 или 3 уровня. Для этого вам необходимо продумать, по какому принципу надо ранжировать кадры.

ВНИМАНИЕ. При создании заготовок 2 или 3 уровня после выполнения команды Make nozzle from Movie вам необходимо выполнить команду File > Get Info и отредактировать информацию, появившуюся в окне File Information, указав число элементов матрицы в виде произведения. Например, для двумерной матрицы это должно быть произведение числа строк на число столбцов.

Упражнение. Создание простой композиции с помощью Nozzles

Для того чтобы оценить удобство кистей Image Hose, рассмотрим простейший пример работы с Nozzles. Создадим композицию, используя фрагмент фотографии. Мы хотим получить горный пейзаж и в качестве основы воспользуемся изображением гор.

  1. Создайте новый документ размером 400 х 400 пикселов. Выберите инструмент Rectangular Selection (Прямоугольное выделение) и выделите верхнюю половину рабочей области. Выбрав команду Effect > Fill, залейте выделенную область бледно-голубым цветом или подберите подходящую градацию (мы использовали двухцветную градацию для создания заливки).
  2. Выделите таким же образом нижнюю половину холста и залейте ее зеленым тоном или подходящей градацией (рис. 12.37).
  3. Откройте исходное изображение (фотография с горами), выберите инструмент выделения Lasso, обведите границы гор. Выберите команду Edit > Copy. Закройте исходный документ с горами.
  4. Перейдите в основной документ, выберите команду Edit > Paste. Откройте секцию Layer палитры Objects. В списке выделите Layer 1 и нажмите кнопку Drop (рис. 12.38). Вы опустили вставленный слой на холст, теперь можно работать кистью Image Hose.
  5. Выберите инструмент Brush (Кисть) на панели инструментов, категорию Image Hose, вариант Spray-Size/P Angle/R.
  6. В секции Nozzles выберите вариант Stones. Работайте кистью, меняя размер наконечника; учитывая перспективу, набросайте камней, чтобы получились отроги гор (рис. 12.39).
  7. Далее работайте вариантами Small Forest (Подлесок), Green Fronds (Зеленая ветвь). Меняйте размер наконечника, снижайте параметр Opacity на панели управления для удаленных предметов, чтобы не было четких контуров деревьев. Для придания более естественного вида создайте облака и слегка затуманьте горы с помощью варианта Cumulus Clouds (Влажные облака). На переднем плане можно слегка проработать вариантами Green grass Bunch (Пучок травы) и Poppies (Маки). Итоговое изображение приведено на рис. 12.40.

Рис. 12.37. Создание фона с помощью заливки

Рис. 12.38. Наложено изображение гор

Рис. 12.39. Создание каменной гряды

Рис. 12.40. Итоговое изображение, созданное с помощью различных вариантов Nozzles

Упражнение. Создание поздравительной открытки с помощью кисти Image Hose

На предыдущих примерах вы уже могли убедиться в удобстве использования кистей Image Hose. В этом примере мы продолжаем любоваться возможностями этого инструмента.

Создадим рисунок поздравительной открытки, используя практически только кисть Image Hose. Сюжет — поздравление с днем рожденья.

  1. Создайте новый документ. Размеры холста 500 х 500 пикселов. Выберите инструмент Rectangular Shape (Прямоугольная форма), обведите с его помощью границы холста. Выберите команду Shape > Convert to Layer (Форма > Превратить в слой). В секции Dynamic Layers (Динамичные слои) выберите эффект Bevel World (Призматический мир), нажмите кнопку Apply (Применить). Откроется диалоговое окно Bevel World, в котором с помощью ползунков отрегулируйте положение, форму и освещение рамки. Повторите те же действия для второй рамки.
  2. Область, ограниченную внутренней рамкой, залейте с помощью градации, вариант — двухцветный градиент от голубого к белому. Выберите Effects > Fill, откроется диалоговое окно Fill with, установите переключатель Gradient. Результат на рис. 12.41.
  3. Введите текст: Happy Birthday (С днем рожденья), расположите его по центру в нижней части рисунка. Параметры текста: шрифт: Arial Black, размер — 160, трекинг — 0,180. Откройте секцию Layers палитры Objests и выделите все буквы каждого из слов, затем объедините в группу, нажав кнопку Group. Для удобства присвойте группам имена Happy и Birthday. Выделите группу. В меню секции выберите команду Layer Attributes (Параметры слоя). Появится диалоговое окно Layer Attributes. В поле Name введите имя группы (рис. 12.42). Выделите обе группы и выберите в меню секции команду Layers Drop and Select (Опустить и выделить).
  4. Выберите кисть Image Hose, вариант Linear-Size/R. Заполните нижнюю половину области, ограниченной внутренней рамкой заготовкой Ivy. Сначала заполняйте область вне текста, то есть внешнюю часть области, ограниченной выделением. Установите режим Draw inside (Рисовать внутри выделения). Для листьев в верхней части заполняемой области уменьшите размер кисти до 50 пикселов, а для переднего плана увеличьте до 75 пикселов.
  5. Затем заполните текст, то есть внутреннюю часть области, ограниченной выделением. Перейдите в режим Draw outside (Рисовать снаружи выделения). Ползунок Grain установите в положение 50%, в качестве вторичного цвета задайте белый или светло-зеленый. Закончив заполнение, отмените выделение, выбрав команду Select > None (Выделение > Удалить). Результат приведен на рис. 12.43. Среди листьев разбросайте цветы плюща с помощью двумерной заготовки, созданной ранее (рис. 12.44).
  6. С помощью инструмента Реn (Перо) создайте контур радуги. Залейте его градацией, созданной на основе двухцветной, где в качестве первичного — синий цвет, а в качестве вторичного — фиолетовый. Отредактируйте градацию с помощью диалогового окна Edit Gradient. Выберите Effects > Fill, а в диалоговом окне Fill with установите переключатель Gradient. Выделенная область окрашена в цвета радуги (рис. 12.45).
  7. Введите слово Darling с помощью инструмента Text (Текст), используя те же параметры, что в словах «Happy Birthday». Объедините буквы в группу и выберите команду Effects > Orientation > Distort (Эффекты > Положение > Искажение). Установив указатель на маркерах и нажав кнопку мыши, увеличьте размеры текста по вертикали, а затем разверните его веером (рис. 12.46).
  8. Расположите текст по центру в верхней части холста. В секции Layers палитры Objects выберите Drop and Select. Заполните выделенную область с помощью варианта Linear-Size/R кисти Image Hose двумерной заготовкой Drops, созданной с помощью динамичного слоя Liquid Metal (рис. 12.47). Вторичный цвет белый. Ползунок Grain установите в положении 28%.
  9. Залейте выделенную область цветами радуги, используя двухцветную градацию. Отмените выделение, выбрав Select > None. Используйте заготовку Cumulus Clouds для создания облаков, разбросайте их в беспорядке по небу. С помощью варианта Drops, созданного с помощью динамичного слоя Liquid Metal, разбросайте на переднем плане капли, окрашенные цветами радуги, эдакую «манну небесную», установив ползунок Grain в положение 50% и используя в качестве вторичных цвета радуги. Для большего эффекта по мере заливки уменьшайте размер кисти.

Рис. 12.41. Заготовка для поздравительной открытки

Рис. 12.42. Текст в виде двух групп слоев

Рис. 12.43. Заливка выделенной области с использованием вторичного цвета

Рис. 12.44. Результат заливки цветами плюща

Рис. 12.45. Создание радуги с помощью двухцветной градации

Рис. 12.46. Деформация текста веером

Рис. 12.47. Результат заливки текста двумерной заготовкой Drops, созданной с помощью динамичного слоя Liquid Metal

Можно считать, что работа закончена. Вы получили на день рожденья вполне приличную поздравительную открытку (рис. 12.48).

Рис. 12.48. Поздравительная открытка Darling! Happy Birthday


Слои

  • Общее представление о плавающих объектах
  • Управление слоями
  • Состояние и доступность объекта
    • Создание слоев
    • Выделение слоя
    • Библиотека слоев (Image Portfolio)
    • Удаление и переименование
    • Порядок расположения слоев
    • Перемещение слоев
    • Группировка слоев
    • Окончательное объединение слоев
    • Слияние с холстом
  • Совмещения плавающих объектов
    • Соответствие методов совмещения Painter и PhotoShop
  • Редактирование слоев
    • Операции с плавающими объектами
    • Reference Layer
    • Преобразования RL
    • Редактирование с помощью инструмента Brush
    • Взаимодействие методов рисования и совмещения слоев
    • Использование флажка Preserve Transparency
    • Взаимодействие выделения и слоя
  • Маска плавающего объекта
  • Упражнение. Создание изображения с помощью слоев

Удобство работы с Painter связано с наличием в нем плавающих объектов

Представьте себе, что вы работаете над изображением и уже прорабатываете детали, когда вдруг понимаете, что композиция не очень удачна и главный объект композиции нужно сместить. Вы выделяете главный объект, и тут начинаются проблемы: как его сместить, что останется вместо смещенного объекта (ясно, что белый холст, а не фон) и т. д.

Для удобной работы создателями Painter были предусмотрены так называемые плавающие объекты, которые расположены не на самом холсте, а как бы во взвешенном состоянии над ним. Заметим, что даже в простом графическом редакторе предусмотрено несколько слоев, в которых может располагаться изображение. В Painter их много.

Плавающие объекты — это изображения в слоях над холстом, свободно перемещающиеся и сохраняющие свои свойства до тех пор, пока не изменен формат документа. Они существуют только в формате RIF. Каждый из них располагается в отдельном слое. Их можно независимо преобразовывать, редактировать, копировать, собирать в группы. Подобные свойства плавающих объектов позволяют легко редактировать основное изображение и изменять его композицию.

Общее представление о плавающих объектах

Все плавающие объекты имеют общие черты:

  • каждый плавающий объект располагается в отдельном слое и при этом вносится в список слоев палитры Object отдельной позицией;
  • способы вырезания, копирования, перемещения их совпадают;
  • одинаково взаимодействуют с нижележащими изображениями или фоном.

Среди плавающих объектов выделяют векторные и растровые. Векторные объекты представлены формами — Shape.

Растровые плавающие объекты называют слоями изображения — Layers.

Среди растровых плавающих объектов принято выделять следующие типы:

  • собственно слой изображения (Layer);
  • ссылочный слой (Reference Layer);
  • динамичные слои — встроенные модули или фильтры (Dynamic Layers).

Все эти объекты имеют много общего, но создаются различными способами и отличаются некоторыми свойствами.

Shape (форма) — векторный объект, созданный с помощью следующих инструментов: Pen, Quick Curve, Rectangular Shape, Oval Shape, Text, с заданными атрибутами — обводкой и заливкой. Форма не содержит информации в пиксельном виде, но при работе с инструментом Brush (Кисть) или градациями этот объект преобразуется в растровое изображение (Layer).

Reference Layer (ссылочный слой) — временно образуемый при ряде операций слой низкого разрешения. Ссылочный слой легко преобразуется в обычный слой.

Dynamic Layers (динамичные слои) — встроенные модули или фильтры, позволяющие создавать удивительные эффекты, преобразуя отдельные образы или все изображение.

В главе 6, где речь шла о кистях и их настройке, мы рассказывали о кисти Watercolor, ее способности работать в отдельном слое. Однако этот слой не относится к категории истинных слоев, он не заносится в список слоев палитры Object, а является частью рабочей области или холста Canvas.

В этой главе мы рассмотрим только слои. Остальные типы плавающих объектов — в соответствующих, посвященных только им, главах (главе 15, главе 16 и главе 17).

Слой состоит из двух частей — прямоугольного изображения в формате RGB и маски, определяющей видимую часть прямоугольного изображения. Слои можно перемещать в пределах документа или переносить из документа в документ. Кроме того, на основе слоев можно легко создавать Image Hose (Заготовки) (см. главу 12).

Управление слоями

Для работы со слоями предназначена специальная секция Layers палитры Objects (рис. 14.1). Помимо списка слоев секция содержит несколько кнопок для выбора наиболее часто встречающихся команд.

Рис. 14.1. Секция Layers палитры Objects

В каждой строке списка присутствуют следующие значки:

  • условный значок, характеризующий тип плавающего объекта;
  • изображение глаза, характеризующее состояние объекта;
  • изображение висячего замка, характеризующее доступность объекта;
  • название плавающего объекта.

Условные значки, определяющие тип плавающего объекта:

— Shape (Форма);

— Layer (Слой);

— Reference Layer (Ссылочный слой);

— Floating Object (Плавающий объект);

— Dynamic Layer (Динамичный слой).

Состояние и доступность объекта

Состояние объекта или его доступность меняется при щелчке мышью на строке списка объектов. Объект доступен для инструментов или редактирования, а также для перемещения с помощью клавиш со стрелками, только если он активизирован, то есть выделен (строка становится голубой).

Если необходимо оценить основное изображение или фон без данного плавающего объекта, можно спрятать объект, то есть, сделать его невидимым. Для этого достаточно щелкнуть на значке с изображением открытого глаза рядом с названием данного объекта. Изображение на значке меняется: открытый глаз превращается в закрытый, это значит — объект невидим.

— Глаз открыт — объект видим.

— Глаз закрыт — объект невидим.

Однако состояние, в котором имеются скрытые слои, делает изображение недоступным для сохранения в ряде форматов. Только форматы RIF и PCD позволяют сохранить невидимыми слои. Кроме того, печать изображения, имеющего скрытые слои, невозможна.

Если несколько слоев расположены очень близко друг к другу, то при манипуляциях объектами с помощью инструмента Layer Adjuster (Регулятор слоя) могут возникнуть сложности. Избежать их позволяет выбор в меню секции команды Lock (Замок), делающей данный образ недоступным для инструмента Layer Adjuster. Такое же действие производит кнопка с изображением висячего замка на строке, соответствующей данному слою в списке секции.

— Замок открыт — объект доступен для инструмента Layers Adjuster (Регулятор слоя).

— Замок закрыт — объект недоступен.

Чтобы слой стал вновь доступен для инструмента Layers Adjuster, необходимо повторить команду Lock или снова щелкнуть мышью на изображении висячего замка.

С помощью команд и кнопок секции Layers палитры Objects можно выполнить ряд действий со слоями изображения:

  • создавать новые слои;
  • удалять;
  • переименовывать;
  • группировать и разгруппировывать;
  • объединять или сливать между собой;
  • сливать с основным изображением.

Создание слоев

Слоем может стать любое изображение. Создать слой можно разными способами:

  • выбрать команду New Layer (Новый слой) или нажать кнопку New секции Layers;
  • создать слой из существующего изображения, выбрав команду File > Place;
  • использовать изображения, содержащиеся в библиотеке слоев Image Portfolio (Коллекция изображений);
  • вставить изображение из буфера;
  • вырезать выделение и вставить его;
  • применить выделение и инструмент Layer Adjuster;
  • применить выделение и команду Select > Float (Выделить > Всплыть);
  • выбрать команду Effect > Orientation (Эффекты > Положение).

В первом случае вы можете взять любое изображение для создания из него слоя:

  1. Выберите команду File > Place (Файл > Поместить), откроется диалоговое окно Select image (Выбрать изображение).
  2. Выберите изображение, которое хотите сделать слоем, нажмите кнопку ОК. Откроется диалоговое окно Place (Поместить) (рис. 14.2), где следует установить параметры нового слоя.

Рис. 14.2. Диалоговое окно Place

Если для создания слоя требуется выделение:

  1. Выберите на панели инструментов любой инструмент выделения Rectangular, Oval, Lasso, Magic Wand (Прямоугольник, Овал, Лассо или Волшебную палочку).
  2. Выделите необходимую область. Выделенная область ограничена бегущей пунктирной линией («муравьиной тропой»).
  3. Выберите инструмент Layer Adjuster (Регулятор слоя). Щелкните мышью в пределах выделенной области. Или выберите команду Select > Float.

Любые преобразования, включающие в себя команды Cut (Вырезать), Сору (Копировать) и Paste (Вставить), связаны с созданием слоев.

Вы можете создать копию слоя, не прибегая к команде Сору, а лишь используя инструмент Layer Adjuster. Для этого выполните следующее:

  1. Выделите необходимый слой.
  2. Выберите инструмент Layer Adjuster.
  3. Установите указатель мыши в пределах выделенного слоя и, нажав и удерживая клавишу Alt, щелкните левой кнопкой мыши. Копия при этом заносится в список слоев секции Layers.

Выделение слоя

Чтобы активизировать или выделить слой:

  1. Выберите инструмент Layer Adjuster (Регулятор слоя).
  2. Щелкните левой кнопкой мыши в пределах слоя. Образ выделен и ограничен прямоугольной черно-желтой рамкой.

Можно поступить иначе. Достаточно выделить строку с названием данного слоя в списке секции Layers. После выполнения этой операции, независимо от применяемого типа инструмента, автоматически активизируется инструмент Layer Adjuster.

СОВЕТ. Если вы установите флажок Auto Select Layer на панели инструмента Layer Adjuster, то любой объект, на котором установлен указатель мыши, становится активным. При этом не нужно выделять слои, вы просто перемещаете указатель на нужный слой и работаете с ним.

При желании убрать с экрана прямоугольную рамку, ограничивающую выделенный слой:

  • выберите в меню секции команду Hide Layer Marquee (Убрать обозначение образа);
  • нажмите комбинацию клавиш Ctrl+Shift+H.

Библиотека слоев (Image Portfolio)

Библиотека слоев Image Portfolio — коллекция изображений, как и библиотека выделений Selection Portfolio, — это специальная секция палитры Objects (рис. 14.3). Вы можете использовать имеющуюся коллекцию слоев-образов, а также поместить в нее слои, которые хотели бы сохранить.

Рис. 14.3. Секция Image Portfolio

Для внесения слоя изображения в коллекцию Image Portfolio выделите данный объект, установите указатель мыши в его границах, нажмите левую кнопку мыши и, не отпуская ее, перетащите изображение в пределы секции. При этом оно приобретает те же размеры, что и у других объектов, хранящихся в библиотеке. После перемещения объекта в библиотеку место, где он находился, остается пустым. Чтобы избежать этого, необходимо перемещать объект при нажатой клавише Alt.

При занесении изображения в библиотеку появляется диалоговое окно Save Image (Сохранить изображение) (рис. 14.4), в котором вы можете дать название плавающему объекту. Иначе изображение сохраняется под своим порядковым номером. Точно так же из библиотеки изображение перемещается на холст.

Рис. 14.4. Диалоговое окно Save Image

В нижней части секции расположено название выделенного изображения. Как и в других аналогично устроенных палитрах, при нажатии на эту область раскрывается список всех изображений, содержащихся в текущей коллекции. В последней строке списка расположена команда Load Library. С ее помощью загружается другая библиотека.

Можно создать сколько угодно своих библиотек с изображениями. Для этого:

  1. Раскройте список названий изображений и выберите команду Load Library. Откроется стандартное диалоговое окно открытия документа.
  2. Нажмите кнопку New Library. На экране появится диалоговое окно New Image Portfolio (Новая коллекция изображений) (рис. 14.5). Дайте название новой библиотеке, укажите ее местоположение и нажмите кнопку ОК.
  3. Точно так же, как вы сохраняли отдельные объекты в готовой библиотеке, помещайте в нее все нужные вам объекты. Таким образом постепенно вы создадите библиотеку объектов.

Рис. 14.5. Диалоговое окно New Image Portfolio

ВНИМАНИЕ. В библиотеку вы можете поместить только слой изображения (Layer) и динамичный слой (Dynamic Layer), а форма (Shape) перед внесением должна быть трансформирована в Layer.

Удаление и переименование

Для удаления неудачного слоя достаточно его выделить и нажать кнопку Delete в секции Layers палитры Objects или выбрать команду Layer > Delete Layer (Слои > Удалить слой).

При создании слоя Painter автоматически дает ему имя, например layer 1. Но это не очень удобно, особенно если слоев много. Лучше давать слоям имена, соответствующие их сути, например река, дерево, лодка и т. д.

Для переименования слоя:

  1. Выделите нужный слой.
  2. Выберите команду Layer > Layer Attributes (Слой > Параметры слоя). При этом откроется диалоговое окно Layer Attributes (рис. 14.6).
  3. Введите название в поле Name и нажмите кнопку ОК.

Рис. 14.6. Диалоговое окно Layer Attributes

Кроме того, вы можете ввести пояснения, связанные с созданием или назначением вашего слоя, в поле Note.

Порядок расположения слоев

Плавающие объекты располагаются в списке так же, как и на экране, то есть в порядке их создания. Каждый последующий объект располагается над предыдущими. Это значит, что при совмещении каждый последующий объект закрывает собой предыдущие слои. Однако можно изменить порядок расположения слоев. Для этого существуют два способа:

  • перемещение выделенного слоя в списке секции Layers палитры Objects;
  • с помощью панели управления Controls: Adjuster (рис. 14.7).

Рис. 14.7. Палитра Controls: Adjuster

Для изменения порядка расположения с помощью секции Layers палитры Objects:

  1. Выделите перемещаемый слой.
  2. Установите указатель мыши в списке секции Layers палитры Objects на строке перемещаемого слоя. Перетащите строку в нужное место списка. Установив строку, отпустите кнопку мыши.

Чтобы изменить порядок расположения слоев с помощью панели Controls: Adjuster (см. рис. 14.7):

  1. Выберите инструмент Layer Adjuster.
  2. Выделите перемещаемый слой.
  3. На панели управления Controls: Adjuster нажмите одну из кнопок:
  • Back (Назад) — при перемещении слоя на задний план;
  • Front (Вперед) — при перемещении слоя на передний план;
  • кнопку со стрелками, находящуюся под Back или Front, — при перемещении слоя в промежуточное положение.

С помощью панели управления Controls: Adjuster удается изменить прозрачность любого слоя. Например, добиться того, чтобы сквозь него был виден фон. Для этого предназначен ползунок Opacity (Непрозрачность), можно также ввести в поле, расположенное справа от него, требуемое значение непрозрачности в процентах.

В правой части панели управления отображаются точные координаты слоя (табл. 14.1).

Таблица 14.1. Параметры координат слоя на панели управления Controls: Adjuster

Буквенное обозначение | Назначение | Буквенное обозначение | Назначение
W (Width) | Ширина | В (Bottom) | Основание
Н (Height) | Высота | L (Left) | Левая сторона
Т (Тор) | Вершина | R (Right) | Правая сторона

Перемещение слоев

Существует несколько способов изменения положения слоев в документе. Для этого используются:

  • инструмент Layer Adjuster;
  • клавиши со стрелками;
  • ввод координат объекта в соответствующее поле панели управления.

Инструмент Layer Adjuster позволяет оперативно задать положение объекта на экране, при этом точные координаты объекта всегда отображены на панели управления.

Для перемещения объекта с помощью инструмента Layer Adjuster:

  1. Выделите объект.
  2. Выберите инструмент Layer Adjuster.
  3. Перетащите мышью контур объекта в нужное место экрана и отпустите кнопку мыши.

Клавиши со стрелками при каждом нажатии перемещают объект только на один пиксел и используются для того, чтобы уточнить положение слоя.

  1. Выделите объект.
  2. Нажимая соответствующие клавиши со стрелками, следите за перемещением его в заданное место холста.

Для точного расположения или совмещения объектов удобно воспользоваться диалоговым окном Layer Attributes (см. рис. 14.6). Для этого:

  1. Выделите объект.
  2. Выберите в меню секции команду Layer Attributes или дважды щелкните на строке с названием данного объекта в списке слоев секции. Откроется диалоговое окно Layer Attributes.
  3. В поле Position (Положение) укажите координаты левого верхнего угла прямоугольника, ограничивающего слой. Начало координат — верхний левый угол документа. Положительные значения отсчитываются вниз и вправо.

    • Тор (Верх) — вертикальная координата;
    • Left (Слева) — горизонтальная координата.

  4. Если вы зададите отрицательные значения координат, объект будет вынесен за пределы документа.
  5. Нажмите кнопку ОК. Объект займет указанную позицию.

Группировка слоев

Чтобы работать с несколькими слоями как с одним объектом, целесообразно объединить их в группу. Объекты, объединенные в группу, удобно преобразовывать, перемещать в пределах документа или переносить в другой документ. Группе можно дать свое название, задать общие параметры, например размер, прозрачность, или установить эффект тени, сделать недоступной для инструмента Layer Adjuster или сделать невидимой на экране.

Группа может объединять в себе плавающие объекты различного типа (формы, слои, динамичные слои).

ПРИМЕЧАНИЕ. Если слои объединены в группу, они становятся недоступны для инструмента Brush (Кисть) и применения эффектов, за исключением эффекта тени. При попытке применить Brush к группе на экране появляется сообщение о недопустимости этой операции. Для работы с Brush группа должна быть разделена на отдельные объекты.

Для объединения нескольких плавающих объектов в группу необходимо их выделить на холсте или в списке при нажатой клавише Shift и нажать кнопку Group (Группировка) секции Layers палитры Objects либо выбрать команду Layer > Group (команду Group заменяет комбинация клавиш Ctrl+G).

После объединения в группу значки отдельных объектов, характеризующие их тип, заменяются значком группы — треугольной стрелкой, указывающей направо.

Для отмены объединения нескольких плавающих объектов в группу необходимо выделить данную группу и нажать кнопку Ungroup (Разгруппировка) секции Layers палитры Objects или выбрать команду Layer > Ungroup, или нажать сочетание клавиш Ctrl+U.

При работе с группой вы можете раскрыть ее и контролировать каждый объект в отдельности. К раскрытой группе можно добавлять объекты (рис. 14.8).

Рис. 14.8. Объекты объединены в группу (слева), группа открыта (в центре), выполнена команда Collapse (справа)

Для раскрытия группы достаточно нажать значок в виде стрелки, направленной вправо. В результате под строкой группы появляется список входящих в нее объектов, а стрелка разворачивается вниз, превращаясь, таким образом, в значок раскрытой группы. На рис. 14.8 стрелка нераскрытой группы — строка Group 1, слева, в центре — группа раскрыта, и стрелка развернута вниз.

Вы можете добавлять любой объект к группе и удалять его из нее, для этого:

  1. Откройте группу, при этом строка данной группы автоматически выделяется.
  2. Установите указатель мыши на названии объекта, который вы планируете добавить к группе, нажмите левую кнопку мыши и переместите строку на нужную позицию в группе. Отпустите кнопку мыши. Объект включен в группу.
  3. Для удаления объекта из группы выделите строку с удаляемым объектом и нажмите кнопку Delete.

Окончательное объединение слоев

Если вы закончили работу с группой объектов и уверены, что они вам больше не понадобятся, имеет смысл объединить все эти объекты в один слой с помощью команды Collapse или одноименной кнопки секции. При этом вместо названия группы (см. рис. 14.8) появляется название Layer 1 (см. рис. 14.8, справа). Если в группу входят разные объекты, например формы и слои, появится запрос о подтверждении ваших действий, так как при выполнении этой команды векторное изображение переходит в растровое.

Отменить это действие можно командой Edit > Undo.

Слияние с холстом

Мы уже говорили, что объект существует в отдельном слое независимо от основного изображения до тех пор, пока вы не опустите его на холст. Обычно когда работа над объектом закончена и вы не намерены изменять объект в дальнейшем, имеет смысл опустить плавающий объект на холст. Это особенно важно при подготовке работы к печати. Лучше это делать постепенно.

СОВЕТ. Помните, что всегда следует оставлять копии всех важных этапов работы, чтобы можно было восстановить исходный материал при неудачном результате.

Если необходимо осуществить слияние формы (Shape) с основным изображением, то сначала следует трансформировать ее в слой, выбрав команду Shape > Convert to Layer (Форма > Преобразовать в слой), а затем уже опустить на холст.

Для слияния слоя с основным изображением необходимо его выделить и нажать кнопку Drop (Опустить) или выбрать команду Layer > Drop. При слиянии с холстом объект исчезает из списка секции. Он перестает быть плавающим объектом.

Для слияния всех слоев с основным изображением необходимо выделить при нажатой клавише Shift все объекты в списке палитры или в документе, а затем выбрать команду Drop All (Опустить все).

В некоторых случаях требуется, чтобы после слияния слой оставался выделенным Для этого выберите команду Layer > Drop and Select (Слой > Опустить и выделить).

Совмещения плавающих объектов

Обычно в работе используется несколько различных плавающих объектов. Для совмещения их в Painter предусмотрен метод наложения. Различные режимы (всего их 22) задают цветовое решение при совмещении плавающих объектов с находящимся под ними изображением. При этом вы можете получить различные цветовые эффекты. Для задания совмещения используется раскрывающееся меню Composite Method (Метод совмещения) панели управления Controls: Adjuster или раскрывающийся список Composite Method секции Layer.

Каждый раз метод наложения будет вас радовать неожиданными эффектами при различных режимах совмещения.

В табл. 14.2 приведено описание различных режимов наложения.

Таблица 14.2. Режимы совмещения плавающих объектов

Режим | Описание
Default (По умолчанию) | Плавающий объект покрывает подстилающее изображение. Цвета плавающего объекта не изменяются
Gel (Желеобразный) | Цвета подстилающего изображения видимы сквозь покрывающие
Colorize (Раскрашивающий) | Цвета и насыщенность подстилающего изображения заменяются покрывающими
Revers-Out (Обратный снаружи) | Цвета изменяются на противоположные, расположенные напротив на цветовом кольце палитры Color
Shadow Map (Карта затенений) | Создает цветную тень для заданного объекта
Magic Combine (Волшебное сочетание) | Выбирает наиболее яркий цвет среди используемых для итогового изображения
Pseudocolor (Ложный цвет) | Значение тона итогового изображения соответствует значению Luminance (Яркость)
Normal | Режим, установленный по умолчанию в программе PhotoShop
Dissolve (Растворение) | Усиливает растушевку краев, если она установлена, если растушевки нет — вид Default
Screen (Преграда) | Перемножаются инвертированные цвета, итоговый цвет обычно светлее исходного
Overlay (Перекрытие) | Осветляет светлые участки и затемняет темные. Overlay, Soft Light, Hard Light разные степени одного режима, из которых Overlay самая слабая степень
Soft Light (Мягкий свет) | То же, но сильнее
Hard Light (Жесткий свет) | То же, но сильнее. При яркости больше 50% подобен режиму Screen, при яркости меньше 50% подобен Multiply
Darken (Затемнение) | Цвета покрывающего изображения используются для затемнения. Если они светлее подстилающего, то цвет не меняется
Lighten (Осветление) | Цвета покрывающего изображения используются для осветления, но в сравнении с Magic Combine эффект другой
Difference (Различие) | Вычитает цвета, имеющие меньшее значение яркости, из цветов, имеющих большее значение яркости
Hue (Тон) | Покрывающее изображение — источник тона (Н), подстилающее — насыщенности (S) и яркости (В)
Saturation (Насыщенность) | Покрывающее изображение — источник насыщенности (S), подстилающее — тона (Н), яркости (В)
Color (Цветность) | Покрывающее изображение — источник тона (Н) и насыщенности (S), подстилающее — яркости (В)
Luminosity (Яркость) | Покрывающее изображение — источник яркости (В), подстилающее — тона (Н) и насыщенности (S)

Чтобы разобраться в особенностях каждого из режимов наложения, выполните простое упражнение. Для него потребуются два изображения (рис. 14.9 и 14.10), можно фотографии, которые мы будем совмещать.

Рис. 14.9. Исходное подстилаемое изображение

Рис. 14.10. Исходное покрывающее изображение

  1. Определите, какое изображение будет подстилающим, то есть внизу, а какое - покрывающим.
  2. Выберите команду Select > All для покрывающего изображения.
  3. Для него же выберите команду Edit > Copy, Edit > Paste. Покрывающее изображение будет вставлено в подстилающее изображение, но, скорее всего, ничего любопытного вы при этом не увидите.
  4. Выберите инструмент Layer Adjuster и обратитесь к панели Controls: Adjuster.
  5. В нижней части панели располагается поле Composite Method (Метод совмещения). Щелкните на этом поле, раскроется список режимов. Выбирайте варианты один за другим и замечайте особенности того или иного режима (рис. 14.11-14.13).

Рис. 14.11. Совмещение, режим Differens

Рис. 14.12. Совмещение, режим Darken

Рис. 14.13. Совмещение, режим Rivers-Out

Соответствие методов совмещения Painter и PhotoShop

Мы уже говорили о том, что слои в том виде, в котором созданы, сохраняются только в формате RIFF. Это значит, что все действия со слоями, описанные в этой главе, возможны только в Painter. Однако если вы сохраняете работу в формате PSD (PhotoShop), то слои Painter конвертируются в слои PhotoShop.

Теперь вы можете работать с ними дальше, используя свойства слоев программы PhotoShop. Соответствие методов приведено в табл. 14.3.

Таблица 14.3. Соответствие методов совмещения слоев Painter и PhotoShop

Painter Composite Method | Photoshop Blend Mode
Gel | Darken
Colorize | Color
Reverse-Out | Normal
Shadow Map | Multiply
Magic Combine | Lighten
Pseudocolor | Normal
Normal | Normal
Dissolve | Dissolve
Multiply | Multiply
Screen | Screen
Overlay | Overlay
Soft Light | Soft Light
Hard Light | Hard Light
Darken | Darken
Lighten | Lighten
Difference | Difference
Hue | Hue
Saturation | Saturation
Color | Color
Luminosity | Luminosity

Редактирование слоев

Painter предоставляет различные средства для редактирования слоев. Вы можете пользоваться почти всеми вариантами инструмента Brush (Кисть), изменять непрозрачность слоев, создавать область плавного перехода с помощью растушевки, усиливать впечатление с помощью большинства команд меню Effects.

Вы можете редактировать слой, изменяя его маску, скрывая или делая видимыми отдельные его части. Работая с маской слоя, вы также можете пользоваться множеством вариантов инструмента Brush и командой Auto Mask.

Операции с плавающими объектами

Итак, любое изображение может стать слоем (плавающим объектом), для этого оно должно быть выделено и выбрана команда Select > Float (Выделить > Всплыть) или инструмент Layer Adjuster. К плавающему объекту применимо множество эффектов и действий.

С помощью инструмента Layer Adjuster и команд меню Effect можно:

  • вращать объект;
  • изменять размер объекта;
  • деформировать объект;
  • отражать объект;
  • выравнивать группу объектов;
  • добавлять тень.

Рассмотрим далее эти и другие действия со слоями (плавающими объектами). Обращаем ваше внимание на то, что все действия, обозначенные выше, выполняются однотипно для всех плавающих объектов, включая формы.

Вращение объекта

Чтобы повернуть объект:

  1. Выберите слой, дважды щелкнув мышью в пределах изображения или выделив строку в списке слоев.
  2. Выберите команду Effect > Orientation > Rotate (Эффекты > Положение > Поворот). Откроется диалоговое окно Rotate Selection (рис. 14.14).
  3. Введите величину угла поворота в поле Angle. Нажмите кнопку ОК. Объект будет повернут на заданный угол (рис. 14.15).

Рис. 14.14. Диалоговое окно Rotate Selection, установлен угол поворота

Рис. 14.15. Изображение повернуто

Изменение размеров

Для изменения размера объекта:

  1. Выделите объект.
  2. Выберите команду Effect > Orientation > Scale (Эффекты > Положение > Масштаб). Откроется диалоговое окно Scale Selection (Масштаб выделения) (рис. 14.16).
  3. Введите нужные размеры в процентах в поля Horizontal Scale и Vertical Scale. Если установлен флажок Constrain Aspect Ratio (Сохранять пропорции), вы не сможете ввести разные значения вертикального и горизонтального размеров. Установленный флажок Preserve Center (Сохранять положение центра) не позволит сместить центр при изменении пропорций. Нажмите кнопку ОК (рис. 14.17).

Рис. 14.16. Диалоговое окно Scale Selection, внутренняя рамка показывает размеры уменьшенного изображения

Рис. 14.17. Готовое уменьшенное изображение, масштаб — 50%

Создание искажения

Для создания искажения:

  1. Выделите объект.
  2. Выберите команду Effect > Orientation > Distort (Эффекты > Положение > Искажение). Откроется диалоговое окно Distort Selection (Исказить выделение) (рис. 14.18). Вокруг объекта появится дополнительная рамка. Установите указатель мыши на одну из сторон рамки (в эту сторону будет направлено искажение), переместите ее, не отпуская кнопки мыши. По достижении эффекта отпустите кнопку мыши и нажмите кнопку ОК. Объект искажен (рис. 14.18).

Рис. 14.18. Верхний левый рисунок исходный, внизу — после применения искажения

Отражение

Для создания отражения:

  1. Выделите объект.
  2. Выберите команду Effect > Orientation > Flip Vertical (Эффекты > Положение > Переворот вокруг вертикальной оси). Объект отразится вокруг вертикальной оси (рис. 14.19).

Рис. 14.19. Отражение по вертикальной оси

Выравнивание объектов

В процессе создания композиции важно иметь возможность задать положение объектов относительно друг друга по горизонтали или вертикали. Это можно сделать с помощью процедуры выравнивания.

Выравнивание можно произвести:

  • по центрам;
  • по сторонам прямоугольных контуров, ограничивающих слой (левым, правым, верхним, нижним).

Для проведения выравнивания:

  1. Выделите выравниваемые объекты (рис. 14.20).
  2. Выберите команду Effects > Objects > Align (Выровнять). Откроется окно Align Shapes (Выровнять формы) (рис. 14.21).
  3. Задайте параметры выравнивания, они приведены в табл. 14.4.
  4. Нажмите кнопку ОК. Выравнивание выполнено в соответствии с заданными параметрами по нижней стороне (рис. 14.22).

Рис. 14.20. Исходные изображения для выравнивания

Рис. 14.21. Диалоговое окно Align Shapes

Рис. 14.22. Выравнивание произведено по нижней стороне

Таблица 14.4. Параметры выравнивания

Параметр | Выравнивает по
Horizontal | горизонтали
Left | левой стороне
Center | центру
Right | правой стороне
None | не выравнивает
Vertical | вертикали
Тор | верхним сторонам
Middle | середине
Bottom | по нижним сторонам

Создание тени

Painter дает возможность создавать тень, падающую от предмета. Создание тени оживляет изображение и делает его более естественным. При этом вы можете задавать различные параметры тени в соответствии с вашими замыслами.

Для создания тени:

  1. Выделите объект.
  2. Выберите команду Effects > Objects > Create Drop Shadow (Эффекты > Объекты > Создать опустить тень). Откроется диалоговое окно Drop Shadow (рис. 14.23).
  3. Установите параметры тени (табл. 14.5), нажмите кнопку ОК.

Рис. 14.23. Диалоговое окно Drop Shadow

Таблица 14.5. Параметры тени

Параметр | Устанавливает
X-Offset (Смещение) | Смещение по горизонтали
Y-Offset (Смещение) | Смещение по вертикали
Opacity (Непрозрачность) | Непрозрачность тени
Radius (Радиус) | Размер области плавного перехода от тени к фону. При нулевом значении тень имеет резкую границу
Angle (Угол) | Угол расположения тени
Thinness (Тонкость) | Насыщенность тени. При низких значениях тень густая, при высоких — насыщенность падает, тень светлеет
Collapse to one layer (Объединить в один слой) | Расположение тени в одном слое с объектом

На рис. 14.24 приведены изображения с разными параметрами тени (сверху вниз).

Рис. 14.24. Изменение параметров тени

Painter создает тень в дополнительном слое и при этом группирует изображение с тенью. Таким образом, тень можно изменять совершенно независимо и одновременно как группу с основным изображением. Если вы не планируете изменять тень отдельно от объекта, можете установить флажок Collapse to one layer (Объединить в один слой). В этом случае в списке слоев секции Layer будет та же запись, но не будет значка группы в виде стрелки, позволяющей раскрыть группу и работать с объектом и тенью отдельно (рис. 14.25).

Рис. 14.25. Влияние установки флажка Collapse to one layer

При создании тени к первой птичке флажок не был установлен, поэтому группа Birdy and Shadow (Птичка и тень) раскрывается и вы можете отдельно работать как с птичкой, так и с ее тенью. При создании тени для правой птички флажок Collapse to one layer был установлен, поэтому птичка и тень объединены в один слой, о чем свидетельствует значок слоя в левой части списка.

Reference Layer

Reference Layer (ссылочный или временный слой, далее для краткости мы будем называть его RL) — это специальный слой, представляющий собой копию слоя-оригинала, но с низким разрешением. RL создается для выполнения различных преобразований над оригиналом. Благодаря низкому разрешению преобразования временного слоя требуют меньшего времени, чем те же преобразования слоя-оригинала.

Конвертирование слоя в RL имеет смысл только в том случае, если имеющийся слой обладает высоким разрешением.

Преобразования RL выполняются с помощью команд меню Effects перемещением маркеров на экране. После выполнения преобразований RL необходимо конвертировать в исходный слой с высоким разрешением.

ПРИМЕЧАНИЕ. RL не редактируется с помощью инструмента Brush (Кисть).

Вы также можете получить RL конвертированием исходного слоя или поместить в документ в качестве RL, если слой-объект существует в виде отдельного файла.

Чтобы преобразовать слой в RL:

  1. Выделите слой.
  2. Выберите команду Effects > Orientation > Free Transformation. Выделенный слой конвертирован в RL.

После конвертирования изображение данного слоя заключается в прямоугольную рамку с маркерами по углам и на серединах сторон. В списке секции Layer RL обозначается значком в виде квадрата из восьми маркеров.

Выбрав инструмент Layer Adjuster и установив указатель мыши на маркере, вы можете преобразовать RL.

RL не доступен для инструмента Brush. Попытка редактировать RL с помощью кистей приведет к появлению на экране запроса: Commit Reference Layer to a Layer? (Конвертировать RL в слой?). По окончании действия с временным плавающим объектом нажмите Commit (Конвертировать) и можете приступить к редактированию.

Если вы планируете редактировать несколько объектов, установите флажок Commit and do not ask again (Конвертировать и далее с запросом не обращаться).

Вы можете поместить слой в документ в качестве RL. Для этого:

  1. Откройте документ, куда вы планируете поместить слой в качестве RL.
  2. Выберите команду File > Place. Откроется диалоговое окно Select Image (Выделить изображение).
  3. Выберите файл, который вы собираетесь преобразовать в RL. Откроется диалоговое окно Place (Поместить). Если указатель мыши находится за пределами диалогового окна Place, на экране появляется прямоугольная рамка, соответствующая размерам перемещаемого слоя.

Теперь необходимо установить параметры перемещаемого слоя.

  1. В категории Scaling (Задание масштаба) в полях Horizontal и Vertical задайте горизонтальный и вертикальный масштабы в процентах от размеров оригинала.
  2. Установите следующие флажки:

    • Constrain Aspect Ratio, чтобы сохранить соотношение размеров по горизонтали и вертикали.
    • Retain Alpha (Поддерживать главное), чтобы сохранить маску данного объекта.
    • Create Pyramid (Создать пирамиду), чтобы создать пирамидальную структуру данных, содержащую изображения с различным разрешением.

  3. Нажмите кнопку ОК или щелкните в пределах рамки. Объект помещен в документ в качестве RL.

Преобразования RL

Напомним, что RL заключен в прямоугольную рамку с маркерами по углам и на серединах сторон. В списке секции Layer RL обозначается значком из восьми
маркеров.

Выбрав инструмент Layer Adjuster и установив указатель мыши на одном из маркеров, можно выполнять различные преобразования с RL:

  • Для изменения размера объекта установите указатель мыши на угловом маркере и при нажатой кнопке мыши перемещайте его.
  • Чтобы растянуть или сжать изображение по вертикали или горизонтали, установите указатель мыши на маркере середины стороны рамки и при нажатой кнопке мыши перемещайте его.
  • Для поворота объекта установите указатель мыши на угловом маркере, нажмите и удерживайте клавишу Ctrl и при нажатой кнопке мыши перемещайте указатель.
  • Чтобы деформировать объект по типу «скос», установите указатель мыши на маркере на середине стороны рамки, и при нажатой клавише Ctrl перетаскивайте указатель.

Точные параметры преобразования RL можно установить в диалоговом окне Set Transform (Задать преобразование) (рис. 14.26), которое открывается выбором команды Effects > Orientation > Set Transform.

Рис. 14.26. Диалоговое окно Set Transform

Вы можете установить следующие параметры:

Таблица 14.6. Параметры преобразования RL

Параметр | Устанавливает
Vertical (Вертикальный) Horizontal (Горизонтальный) | Горизонтальный и вертикальный масштабы в процентах от размеров оригинала
Constrain Aspect Ratio (Сохранять пропорции) | Сохраняет соотношение размеров по горизонтали и вертикали
Rotation (Поворот) | Угол поворота, положительные значения задают поворот в направлении против часовой стрелки
Slant (Скос) | Угол скоса. Положительные значения задают скос вправо
Quality (Качество) | Качество считывания изображения объекта
Fast (Быстрое) | Быстрое воспроизведение объекта с низким разрешением
Clean (Хорошее) | Изображение, идентичное оригиналу
Retain Alpha (Сохранить альфа-канал) | Сохранение маски данного оригинала объекта

Завершив преобразования, RL необходимо конвертировать в слой. Обратное конвертирование выполняется автоматически, если вы приступите к редактированию RL с помощью кистей или различных эффектов. Если же вы не собираетесь работать кистями, тогда выделите RL и выберите команду Effects > Orientation > Commit > Transform. Выделенный RL снова преобразован в слой.

Обратите внимание, что после выполнения обратного преобразования улучшилось качество изображения данного объекта, а в списке секции значок RL заменен на значок слоя.

На рис. 14.27 приведены варианты изменения изображения с помощью RL.

Рис. 14.27. Преобразование изображения с помощью RL

Редактирование с помощью инструмента Brush

Чтобы воспользоваться инструментом Brush для редактирования слоя, достаточно выделить данный объект в списке секции.

Выбрав нужный вариант инструмента Brush, вы можете приступать к работе. Учтите, что Brush работает только в пределах выделенного слоя.

Если слой представляет собой несколько объектов, объединенных в группу, то он недоступен для инструмента Brush. При попытке применить Brush к такому образованию, на экране появляется сообщение о том, что работа с кистью в группе невозможна. Поэтому для работы с кистью данный объект необходимо предварительно разгруппировать на отдельные элементы, выбрав команду Ungroup (Отменить группировку).

Можно иначе обойти это условие. Для этого надо свести все элементы группы в один слой, как бы сплющить группу, объединить все объекты, входящие в группу, в единый плавающий объект. Для этого служит специальная кнопка Collapse или одноименная команда. В результате слияния группа превращается в единый слой и невозможно разделить группу на составляющие ее объекты с помощью команды Ungroup.

При работе со слоями из всех вариантов кистей исключение составляет вариант Water Color (Акварель), так как специальный слой Wet (Влажный), соответствующий этому варианту, является принадлежностью холста (Canvas). Поэтому необходимо воспользоваться временным промежуточным документом, куда перенести плавающий объект и сделать его не плавающим, то есть опустить на холст.

Для редактирования слоя кистями Water Color:

  1. Выделите данный слой, выберите команду Edit > Copy.
  2. Создайте новый документ и выберите команду Edit > Paste > Into New Image. Объект вставлен в новый документ, теперь необходимо объединить его с холстом.
  3. Выберите команду Drop and Select. В результате слой трансформируется в выделенное изображение.
  4. Выберите инструмент Brush (Кисть) и вариант Water Color (Акварель), укажите тип кисти. Раскройте палитру Brushes: Water Color, выберите метод Wet (По-мокрому) и подкатегорию.
  5. Приступайте к редактированию акварелью.
  6. Завершив редактирование, выберите команду Canvas > Dry (Высушить).
  7. Выберите команду Select > Float. Отредактированное изображение вновь трансформировано в слой.
  8. Теперь вы снова можете его скопировать и вставить в исходный документ.

Взаимодействие методов рисования и совмещения слоев

Painter обладает широким спектром возможностей рисования, однако, как вы помните, в секции General палитры Brush Control устанавливается метод рисования. Иногда при установке метода рисования и метода совмещения слоев может получиться неудовлетворительный результат. Чтобы избежать неприятностей, следует иметь в виду некоторые ограничения.

Метод Build-Up (Надстраивание), который применяется для категорий Pencil и Felt Pen, хорошо соотносится с методом совмещения Gel. Фактически, если вы начинаете рисовать «с чистого листа», используя метод Build-Up, Painter автоматически применяет метод совмещения Gel.

Метод Cover хорошо работает с режимом совмещения Default.

Использование флажка Preserve Transparency

В верхнем отделе секции Layers расположен флажок Preserve Transparency (Предохранение прозрачности). Установив этот флажок, вы можете рисовать только в маске слоя, не боясь затронуть остальную часть изображения (рис. 14.28, слева). Если флажок не установлен, то кисть рисует по всему изображению (рис. 14.28, справа). Используя это средство, вы можете заливать маску изображения шаблоном, градацией, применять изолированно различные эффекты.

Рис. 14.28. Эффект от установки флажка Preserve Transparency, в правом изображении флажок снят, в левом — установлен

Взаимодействие выделения и слоя

При работе со слоями можно пользоваться выделением. Выделение создается обычными средствами. По умолчанию сохраняется активным только маркер выделения в слое. Вы можете применять выделение, так же как и при работе с холстом, для заливки градацией, шаблоном, применять эффекты динамичных слоев, просто рисовать в выделении. Вы можете перемещать выделение с помощью инструмента Selection Adjuster. При этом можно применять эффект и перемещать выделение дальше, нанося эффекты одной формы на разные участки. При перемещении выделение становится также плавающим объектом, в списке секции слоев появляется под названием Floating Object и обозначается символом в виде звезды. Все свойства плавающих объектов сохраняются за выделением. Выделение также может перемещаться между слоями. При перемещении используют инструмент Selection Adjuster или клавиши-стрелки.

Любой слой может иметь только одно выделение в данный момент. Выделение сохраняется только в RIFF-формате, при сохранении в другом формате плавающий объект автоматически опускается.

Существует ряд действий, снимающих активность выделения в слое:

  • новое выделение;
  • применение эффекта или рисование в выделенной области;
  • редактирование видимой маски;
  • вставка изображения из буфера;
  • перемещение изображения из библиотеки Image Portfolio.

Маска плавающего объекта

Каждый слой имеет маску, которая определяет размеры и видимость RGB-слоя. Напомним, что маска — это 8-битное изображение в градациях серого. Для создания полностью маскируемой области используется черный цвет. Белый цвет отменяет маскирование. Оттенки серого создают частично маскируемую область.

Чтобы увидеть маску слоя, достаточно открыть секцию Masks (рис. 14.29) на палитре Objects и щелкнуть в строке с маской нужного слоя на значке в виде закрытого глаза.

Рис. 14.29. Одновременное представление слоя и его маски с помощью одноименных секций палитры Object

Появится значок открытого глаза — и одновременно на экране в рамке данного объекта появляется прямоугольник маски в градациях серого, оконтуренный белым полем (рис. 14.30). Сделав маску видимой, вы можете приступить к ее редактированию.

Рис. 14.30. Типы масок сверку вниз: Disabled, Normal, Inverted

Если вы хотите увидеть изображение слоя, установите значок с закрытым глазом для данной маски, сделав ее невидимой.

При редактировании маски слоя используются почти все варианты инструмента Brush, особенно удобны варианты Air brush. Наиболее подходящий метод — Cover.

Можно создать плавный переход между маской и слоем, выбрав команду Mask > Feather Mask, которая произведет растушевку границ маски.

Различают три формы маски слоя:

  • Disabled (Пассивная) — маска отключена, то есть не выполняет своих функций, несмотря на то что изображение маски присутствует на экране.
  • Normal (Нормальная) — маска активизирована, то есть скрывает находящееся под ней изображение.
  • Inverted (Обращенная) — функции маски несет часть изображения, находящаяся за пределами маски, но ограниченная контуром объекта.

Изменить форму маски можно с помощью диалогового окна Layer Attributes, в котором вы можете выбрать нужную форму маски Disabled, Normal, Inverted.

Упражнение. Создание изображения с помощью слоев

В следующем упражнении мы рассмотрим создание изображения, что называется, с нуля. Вы поймете, что это не так уж сложно. Основным средством заливки будут градации (см. главу 9).

  1. Выберите команду File > New и задайте размеры рабочей области: ширину — 500 и высоту — 800 пикселов.
  2. Тонким карандашом или пером сделайте набросок исходного рисунка (рис. 14.31).
  3. Разбейте рисунок на отдельные элементы и продумайте их порядок относительно переднего плана. Передний план — это волны и облако на вершине горы. Далее идет линия берега, холмы, гора, снежная вершина и луна. Задний план — небо. Элементы композиции удобней создавать в порядке их удаления от переднего края.
  4. Техника создания рисунка проста. Для создания каждого элемента композиции выполните нижеперечисленное.
  5. Выберите инструмент Реn (Перо). Создайте с его помощью элемент композиции, представляющий собой замкнутый контур.
  6. Откройте секцию Layer палитры Objects.
  7. Выберите команду Drop and Select. В результате создано выделение.
  8. Выполните заливку выделения градацией с помощью секции Gradients палитры Art Materials.
  9. Выберите вариант Two-Point (Двухцветная градация).
  10. Откройте секцию Color и укажите два цвета, между которыми создается цветовой переход при заливке, — это цвета переднего и заднего плана.
  11. Выберите команду Effects > Fill. Откроется диалоговое окно Fill, где в поле Fill with установите переключатель Gradient. Заливка выделения выполнена.
  12. Выберите команду Select > Float. Выделение преобразовано в плавающий объект, который вы можете перемещать с помощью клавиш со стрелками или с помощью мыши по всей плоскости рисунка и менять последовательность остальных элементов. Чтобы изменить последовательность элементов, достаточно в секции Layers на палитре Objects выбрать данный элемент в списке плавающих объектов и с помощью мыши перетащить на другую позицию (рис. 14.32).
  13. Каждому элементу композиции, трансформированному в плавающий объект, удобно дать название. Для этого выберите команду Layer Attributes или дважды щелкните мышью на нужной позиции в списке секции. Откроется окно Layer Attributes, где в поле Name необходимо ввести название элемента.
  14. Не забудьте про задний план. Чтобы закрасить небо, необходимо выбрать команду Select > All, а далее вновь воспользоваться вариантом двухцветной заливки.
  15. Последняя деталь — звезды. Создайте новый холст небольшого размера, например 200 х 200 пикселов.
  16. Откройте секцию Selection Portfolio и выберите подходящее выделение, а затем с помощью мыши переместите его на новый холст.
  17. Залейте выделение желтым цветом, уменьшите его с помощью инструмента Selection Adjuster, или выбрав команды: Select > Transform Selection, затем — Effect > Orientation > Scale.
  18. Выберите команду Edit > Copy.
  19. Вернитесь к почти завершенной композиции и выберите команду Edit > Paste. Последнюю операцию повторите столько раз, сколько звезд на вашем небосклоне.
  20. После того как вы создали все элементы композиции, правильно расположили их на экране, в последний раз убедитесь, что композиция завершена и ничего в ней не нужно изменять.
  21. Вспомните упражнение, приведенное в главе 10. В упражнении «Создание бесшовного шаблона из отдельных элементов» были использованы плавающие изображения.
  22. Вернитесь к этому моменту, подробно рассмотрите секцию Layer, сгруппируйте элементы композиции и объедините слои, попробуйте различные методы совмещения элементов композиции в местах перекрытия изображений.
  23. В секции Layer выберите команду Drop All. В результате все плавающие объекты сольются с холстом. Восстановить прежнее состояние можно, только выбрав команду Undo.
  24. Чтобы завершить рисунок, попробуйте применить к нему один из инструментов меню Effects.
  25. Выберите Effects > Tonal Control > Negative (рис. 14.33).

Рис. 14.31. Исходный набросок, выполненный с помощью пера

Рис. 14.32. Промежуточный этап с открытой секцией Layers

Рис. 14.33. Применение эффекта Negative

Еще один вариант для завершения композиции.

  1. Выберите команду Effects > Tonal Control > Brightness/Contrast. Предварительно вы можете изменить форму рисунка. Воспользуйтесь инструментом Oval Selection (Эллиптическое выделение).
  2. Выберите команду Select > Feather (Растушевка). Ширину области плавного перехода или растушевки можно задать равной 20-25 пикселам.
  3. Выберите команду Edit > Сору. Создайте новый холст соответствующего размера и выберите Edit > Paste. Хорошее впечатление производит результат применения команды Effects > Tonal Control > Correct Colors.

Так или иначе, завершение композиции существенно не изменит сути рисунка (рис. 14.34).

Рис. 14.34. Итоговый рисунок


Формы

  • Понятие формы
  • Создание форм
    • Инструменты создания форм
    • Формы в списке плавающих объектов
    • Создание формы из выделения
    • Группировка форм
  • Параметры форм
  • Редактирование форм
    • Выделение формы
    • Перемещение закрепленных точек
    • Добавление закрепленной точки
    • Удаление закрепленной точки
    • Замена угловой точки на точку плавного изгиба
    • Разрезание формы
    • Соединение конечных точек
  • Преобразование форм
    • Изменение размеров
    • Вращение формы
    • Наклон
    • Горизонтальный и вертикальный переворот
  • Дупликация
    • Преобразование в плавающий объект
  • Операции с формами
    • Сложная форма
    • Переходные формы
    • Создание усредненной формы
    • Эффект тени

Векторные объекты в Painter — это попытка
расширить возможности программы

Форма — это векторный плавающий объект (контур или текст). Плавающий — значит расположенный не на самом холсте, а в отдельном слое. В предыдущей главе мы уже говорили о плавающих объектах. Векторные объекты создаются с помощью математически точных построений, и потому обладают рядом преимуществ: точностью формы, легкостью перемещения и изменения формы.

Понятие формы

Как вы помните, для векторных объектов характерно еще одно очень важное свойство — точность при печати в Post Script, однако это преимущество не распространяется на векторные объекты, созданные в Painter, так как при печати из Painter любое изображение растрируется. При построении форм в Painter в отличие от традиционно векторных программ, таких как Adobe Illustrator, Corel Draw, Macromedia Free hand, векторные объекты создаются не в среде Post Script, а в собственной среде. В Painter плавающие объекты разного свойства и происхождения (растровые и векторные) безболезненно сосуществуют и взаимодействуют.

Формы могут создаваться из контуров. Контур может состоять из прямых отрезков и кривых Безье. Он может быть замкнутым или разомкнутым. Контур можно обвести и залить. Однако если к форме применить эффект, свойственный растровому объекту, она автоматически становится растровым плавающим объектом, называемым в Painter слоем — Layer.

Формы поддерживаются форматом RIF. В других форматах формы сливаются с холстом (рабочей плоскостью). В пакете Photoshop формы превращаются в плавающие объекты, соответствующие отдельным слоям.

Итак, какие же преимущества имеют плавающие объекты формы? С формами можно производить действия, которые не удается произвести с другими объектами Painter, по крайней мере, с такой скоростью и легкостью, а именно:

  • изменять размеры;
  • поворачивать;
  • размножать;
  • создавать сложные, переходные и усредненные формы.

Далее мы рассмотрим все эффекты, применимые к формам.

Создание форм

Для создания форм существует несколько способов:

  • импорт готовых векторных изображений из векторных программ;
  • преобразование выделения в форму;
  • создание формы специальными инструментами.

Painter изначально не принадлежит к числу векторных программ. По сути, векторные объекты в Painter — это попытка расширить возможности программы. Безусловно, чисто векторным пакетам в этом отношении Painter — не конкурент. Однако без особых трудностей можно импортировать векторные изображения из этих программ и редактировать их в Painter.

Чтобы импортировать векторное изображение:

  1. Предварительно сохраните векторное изображение в формате Adobe Illustrator.
  2. Выберите команду File > Acquire > Adobe Illustrator File (Файл > Приобрести > Adobe Illustrator файл).
  3. Выберите импортируемый файл в открывшемся диалоговом окне Adobe Illustrator File.
  4. Нажмите кнопку Открыть.

Инструменты создания форм

Для создания форм в Painter предусмотрены следующие инструменты:

— Rectangular Shape (Прямоугольная форма) — создает объекты прямоугольной и квадратной формы;

— Oval Shape (Овальная форма) — создает овальные и круглые формы;

— Реn (Перо) — рисует прямые линии и кривые Безье;

— Quick Curve (Быстрая кривая) — свободное рисование формы;

— Text (Текст) — создает текстовые формы.

Создание форм с помощью Rectangular Shape и Oval Shape (прямоугольного и овального контуров) очевидно. Совершенно аналогичные процедуры осуществляются во всех графических программах, даже с помощью панели рисования Microsoft Office.

  1. Выберите инструмент на панели инструментов Tools. В пределах рабочей области указатель мыши принимает форму перекрестья.
  2. Подведите указатель к месту создания формы, нажмите левую кнопку мыши и, не отпуская клавиши, ведите указатель по диагонали до тех пор, пока контур формы не достигнет нужного размера. Получив нужный размер, отпустите кнопку мыши.

В момент отпускания кнопки мыши контур заливается основным цветом и заключается в прямоугольник, обозначающий отдельный плавающий объект. Одновременно созданная форма заносится в список плавающих объектов секции Layers палитры Objects.

Если в процессе создания контура формы держать нажатой клавишу Shift, контур принимает форму квадрата или круга.

При работе с инструментами Rectangular Shape или Oval Shape на панели управления Controls: Selection фиксируются координаты левого верхнего и правого нижнего углов прямоугольника (рис. 15.1).

Рис. 15.1. Палитра управления Controls: Shape Object

Параметры координат левого верхнего угла: Т (Верх) и L (Слева), координат правого нижнего угла — D (Низ) и R (Справа). Начало координат — левый верхний угол. По разности координат определены ширина — W и высота — Н прямоугольника.

При выборе инструмента Oval Selection создание формы производится с помощью овала, вписанного в тот же прямоугольник, поэтому параметры, указанные на панели управления, остаются теми же.

Реn

Инструмент Реn (Перо) позволяет создавать контур формы из прямоугольных отрезков или из плавных кривых — кривых Безье.

При выборе инструмента Реn панель управления заменяется на Controls: Shape Design (Проектирование форм) (рис. 15.2), на которой приведены:

Рис. 15.2. Палитра управления Controls: Shape Design

  • индикатор цвета линии и заливки контура;
  • значение параметра инструмента Magnifier (Лупа);
  • координаты указателя мыши;
  • кнопка Close (Закрыть), замыкающая контур формы;
  • кнопка Make Selection (Выделить), выделяющая контур.

При создании прямолинейных отрезков с помощью инструмента Реn (Перо) форма также заносится в список плавающих объектов секции Layers палитры Objects. Но применяя инструмент Реn, можно создавать и кривые. Для этого:

  1. Выберите инструмент. В пределах рабочей области указатель принимает форму перекрестья.
  2. Установите указатель в точке начала контура формы. Нажмите левую кнопку мыши. Не отпуская ее, задайте направляющую линию — это касательная к кривой в закрепленной точке. Отпустив кнопку, вы задаете на конце линии направляющую точку. Длина отрезка, ограниченного закрепленной и направляющей точками, пропорциональна радиусу кривизны создаваемой линии в закрепленной точке.
  3. Отпустите кнопку. Создана первая закрепленная точка. Одновременно создаваемая форма заносится в список плавающих объектов секции Layers палитры Objects.
  4. Установив указатель мыши в следующей точке контура, повторите операции. Не отпуская кнопки, задайте направление подхода линии и ее кривизну.

Рис. 15.3. Процесс рисования кривых с помощью инструмента Реn

Суть построения контура из криволинейных отрезков, плавно переходящих один в другой, состоит в том, что в закрепленной точке угол между кривой и направляющей равен нулю. Поскольку у двух соседних отрезков одна направляющая, эти отрезки плавно переходят один в другой. В угловой точке между соседними криволинейными отрезками угол не равен нулю.

Для создания угловой точки постройте первый из соседних отрезков. Следующая направляющая задается при нажатой клавише Alt.

Для удаления части незавершенного контура формы установите указатель на последней активной закрепленной точке и нажмите клавишу Backspace. В результате будет удален отрезок между последней и предыдущей закрепленными точками. Последняя точка автоматически становится активной.

Каждое нажатие клавиши Backspace удаляет очередную закрепленную точку и соответствующий ей отрезок.

Удалив первую закрепленную точку, вы автоматически удаляете неудачный контур из списка плавающих объектов секции Layers панели Objects.

Для завершения контура формы нужно совместить первую и последнюю закрепленные точки или воспользоваться следующими способами:

  • Нажать мышью кнопку Close на панели управления Controls: Shape Design.
  • Нажать клавишу Ctrl, панель управления при этом заменится на панель Controls: Shapes, затем щелкнуть мышью вне пределов созданной формы, чтобы отменить ее выделение.
  • Выбрать инструмент Shape Selection (Выделение формы) и щелкнуть в пределах рабочей области — контур завершен.

Для продолжения незамкнутого контура:

  1. Нажмите клавишу Ctrl, панель управления при этом изменится на панель Controls: Shapes.
  2. Установите указатель на контуре и щелкните мышью при нажатой клавише Ctrl. Контур выделен.
  3. Не отпуская клавишу Ctrl, установите указатель на конечной точке контура и щелкните мышью. Конечная точка выделена. Продолжайте создание контура.

Quick Curve

При работе инструментом Quick Curve (Быстрая кривая) контур создается от руки, также как и при работе инструментом Brush (Кисть). Проведенная линия автоматически разбивается на узловые точки и связывается отрезками кривых Безье. Особых проблем при работе с этим инструментом не возникает.

Если вы закончили создание контура и хотите замкнуть его, нажмите кнопку Close на панели управления. Контур замкнется и по умолчанию будет окрашен черным цветом.

Если вы хотите продолжить работу над контуром, с которого снято выделение, нажмите клавишу Ctrl, панель управления при этом заменится на панель Controls: Shapes. He отпуская клавиши, установите указатель в нужной точке контура и щелкните мышью. Контур будет выделен, а закрепленная точка активна.

Text

Инструмент Text используется для создания текстовых форм. Текстовые формы иногда просто незаменимы в дизайнерских или рекламных проектах. Работать с текстом несложно:

  1. Выберите инструмент Text на панели инструментов. Панель управления при этом трансформируется в палитру Controls: Text (рис. 15.4).
  2. Раскройте список Font (Шрифт) на панели управления и выберите нужный вам шрифт.
  3. Последней строкой списка является команда Other Font (Другой шрифт), с помощью которой список шрифтов существенно расширяется. При выборе этой команды открывается диалоговое окно Choose Font (рис. 15.5) со списком шрифтов, установленных на вашем компьютере.
  4. Установите с помощью ползунка Point Size размер шрифта, который вы можете увеличивать до 300 кегля.
  5. С помощью ползунка Tracking регулируется межсимвольный интервал.
  6. Установите указатель в месте начала ввода и введите нужный текст.

Рис. 15.4. Палитра Controls: Text

Рис. 15.5. Диалоговое окно Choose Font

Для перехода на новую строку, как и в любом текстовом редакторе, пользуйтесь клавишей Enter.

В Painter каждая буква представляет собой отдельную форму и при вводе текста заносится в список секции Layers палитры Objects (рис. 15.6).

Рис. 15.6. Секции Layers палитры Objects со списком форм. Верхние строчки, окрашенные голубым, выделены, слева с текстом, справа — с формами

ПРИМЕЧАНИЕ. Формы, как и другие объекты, нумерованы снизу вверх, то есть первые буквы опускаются вниз, последние остаются вверху списка. Это связано с тем, что, как вы уже знаете, формы являются плавающими векторными объектами, каждый последующий слой располагается над предыдущим.

Для удаления ошибочной буквы пользуйтесь клавишей Backspace. Если вы обнаружили ошибку не сразу, выберите команду Undo. Удалить ошибочную форму можно, нажав кнопку Delete секции Layers палитры Objects.

К текстовым формам мы вернемся позже в этой главе и рассмотрим всевозможные преобразования с формами на примере текста. Работе с текстом целиком посвящена глава 19.

Формы в списке плавающих объектов

Любая созданная форма автоматически заносится в список плавающих объектов и нумеруется на палитре Objects (рис. 15.6). Значок в виде маленького круга и треугольника [image] обозначает форму. Дело в том, что в один и тот же список заносятся все имеющиеся плавающие объекты, как векторные, так и растровые.

Активная строка, как вы помните, голубого цвета, неактивная — зеленого.

Возле каждой формы в списке расположен знакомый вам значок в виде глаза, который может быть как открыт, так и закрыт. Когда на значке изображен открытый глаз — объект виден, а если еще и строка голубая, то его можно редактировать.

Активная форма автоматически обводится черно-желтой пунктирной рамкой, контур помечается красными точками и синей линией, соединяющей их, а на панели инструментов становится активным инструмент Layer Adjuster [image], управляющий плавающими объектами и формами.

Если на значке изображен закрытый глаз при активной (голубой) строке, то контур формы окрашен синим и помечен красными точками построения формы, но рамки нет. При попытке начать работу с ней форма исчезает с экрана, а в списке строка становится зеленой — неактивной. Таким образом, если форма неактивна и имеет значок в виде закрытого глаза, она не видна на экране.

Когда работа над формой закончена, и вы хотите защитить ее от случайных изменений, возможных при редактировании других объектов, удобно это сделать с помощью значка в виде замка [image]. Нажатием на значок открытый замок закрывается [image], и форма не подлежит редактированию, хотя и будет видна на экране. Точно так же выполняется обратное действие — открытие замка.

Создание формы из выделения

Любое выделение можно превратить в форму. Кроме специально созданных выделений используются готовые выделения из коллекции Selection Portfolio. Painter позволяет трансформировать выделение в форму, работать с ней, как с векторным объектом, а по окончании трансформировать форму в слой, с тем, чтобы воспользоваться эффектами, свойственными только растровым объектам.

Для создания формы из выделения:

  1. Выделите некоторую область на изображении или откройте секцию Selection Portfolio и воспользуйтесь заготовками, хранящимися там.
  2. Выберите команду Select > Convert to Shape (Выделение > Преобразовать в форму). Выделенный контур превращен в форму. Форма занесена в список секции Layers (рис. 15.7).

Рис. 15.7. Форма, созданная из выделения и занесенная в список секции

Можно приступить к редактированию контура с помощью инструментов Реn и Quick Curve.

В Painter предусмотрена и обратная процедура — преобразование формы в выделение. При этом сохраняется плавающий контур, с которым можно работать, однако эффект, примененный к форме, его внутренняя часть, опускается на холст и больше не подлежит перемещению. Таким образом, при изменении размеров формы контура он может не совпасть с окраской, уже закрепленной на холсте.

Кроме того, поскольку в пакете Painter не предусмотрена библиотека форм, нужные в дальнейшем формы сохраняются в библиотеке выделений.

Для того чтобы сохранить форму в библиотеке выделений:

  1. Выберите форму в списке секции Layers.
  2. Выберите команду Shapes > Convert to Selection (Форма > Преобразовать в выделение).
  3. Откройте секцию Selection Portfolio (Коллекция выделений).
  4. На панели инструментов выберите инструмент Selection Adjuster (Управление выделением).
  5. Установите указатель мыши в пределах полученного выделения и нажмите левую кнопку мыши. Выделение преобразуется в пунктирный прямоугольник.
  6. Перетащите прямоугольник в секцию Selection Portfolio и отпустите кнопку. Откроется диалоговое окно Save Selection (Сохранить выделение).
  7. В окне Save As (Сохранить как) введите название выделения и нажмите кнопку ОК. Форма, преобразованная в выделение, занесена в библиотеку.

Группировка форм

При работе над объектами удобно объединять их в группы. При этом все формы, входящие в группу, обрамляются одной пунктирной рамкой и участвуют в редактировании как один объект. Это позволяет избежать повторения одинаковых действий, поскольку дает возможность одновременно оперировать несколькими формами. Это особенно удобно при работе с текстом, так как в процессе набора каждый символ первоначально задается как отдельная форма. Объединив буквы. образующие слово или фразу, в группу, вы существенно упрощаете работу с текстом, если необходимо переместить его, изменить масштаб, повернуть, наклонить и т. п.

Для объединения отдельных форм в группу:

  1. Выделите формы, объединяемые в группу, с помощью инструмента Layer Adjuster, удерживая нажатой клавишу Shift, или соответствующие им строки списка секции, также при нажатой клавише Shift.
  2. Нажмите кнопку Group (Объединить в группу) секции Layer палитры Objects или выберите в меню секции команду Group.

Выделенные формы в списке секции будут заменены одной группой с указанием ее номера (рис. 15.8).

Рис. 15.8. Формы сгруппированы

Однако объединение в группу не мешает вам редактировать каждую форму, входящую в группу, отдельно. Чтобы выбрать форму для самостоятельного редактирования ее, достаточно нажать значок в виде стрелки слева от слова Group. При этом раскрывается список входящих в группу форм. Вы можете выбрать любую и редактировать ее.

Для отмены объединения в группу предназначена кнопка Ungroup. Группа при этом заменяется входившими в нее формами.

Параметры форм

Форму можно редактировать как с помощью инструментов редактирования, так и в диалоговом окне Set Shape Attributes (Установить параметры формы) (рис. 15.9), открываемом командой Set Shape Attributes меню Shapes.

Рис. 15.9. Диалоговое окно Set Shape Attributes

С помощью этого окна вы можете установить обрамление формы и его характеристики и осуществить заливку формы.

Рассмотрим подробнее работу с этим диалоговым окном.

  1. Создайте новый документ, выбрав команду File > New.
  2. Откройте секцию Selection Portfolio.
  3. Выберите подходящее выделение и перетащите его в ваш документ.
  4. Выберите команду Select > Convert To Shape. Выделение превратится в форму, обретя цвет и контур, установленные по умолчанию, а также автоматически будет занесено в список форм секции.
  5. Выберите команду Shapes > Set Shape Attributes. Откроется диалоговое окно Set Shape Attributes. Теперь вы можете установить параметры формы, ориентируясь по описаниям, приведенным в табл. 15.1.
  6. В поле Name приведено название выделенной формы. Введите новое имя, если данное по умолчанию вам не подходит.

Таблица 15.1. Параметры, устанавливаемые в диалоговом окне Set Shape Attributes

Параметр | Назначение
Параметры обводки
Stroke (Обводка) | Задает обводку контуром
 | Вызывает диалоговое окно Цвет, где устанавливается цвет обводки
Opacity (Непрозрачность) | Непрозрачность обводки
Width (Ширина) | Задает ширину линии обводки
Кнопки, устанавливающие форму крайних частей линии обводки
 | Срез на крайней точке
 | Округлый срез
 | Срез до начальной точки
Кнопки, устанавливающие характеристику углов
 | Угол
 | Округлый угол
 | Срезанный угол
Name (Имя) | Позволяет дать название форме
Miterlimit (Ограничение части) | Задает ширину среза для варианта Срезанный угол
Параметры заливки
Fill (Заливка) | Устанавливает заливку формы
 | Вызывает диалоговое окно Цвет, где задается цвет заливки
Кнопки, устанавливающие тип заливки
 | Области перекрытия контуров заливаются выбранным цветом
 | Области перекрытия контуров не заливаются
Opacity (Непрозрачность) | Задает непрозрачность заливки
General (Общие установки)
Flatness (Спрямление) | Задает количество прямолинейных отрезков, используемых для аппроксимации линии при печати. Чем меньше значение, тем точнее аппроксимация
Set New Shape Attribute (Установить новые атрибуты формы) | Позволяет применить заданные параметры к выделенной форме

Установите параметры обводки:

  1. Установите флажок Stroke для возможности работы с обводкой.
  2. Дважды щелкните в цветном поле справа от флажка Stroke, откроется окно Цвет, в котором вы можете установить цвет обводки.
  3. Установите степень непрозрачности контура с помощью ползунка Opacity.
  4. С помощью ползунка Width установите толщину контура обводки.
  5. С помощью кнопок схематичным изображением форм углов установите нужную вам форму.

Перейдите в правую половину диалогового окна и установите параметры заливки:

  1. Установите флажок в поле Fill для осуществления заливки.
  2. Дважды щелкните в цветном поле справа от флажка Fill, откроется окно Цвет, в котором вы можете установить цвет заливки.
  3. С помощью кнопок со звездами установите тип заливки.
  4. Ползунком Opacity установите непрозрачность заливки.
  5. Ползунком Flatness задайте количество прямолинейных отрезков, используемых для аппроксимации линии при печати.
  6. Нажмите кнопку Set New Shape Attribute (Установить новые атрибуты формы) для применения к форме установленных параметров. Нажмите кнопку ОК.

Редактирование форм

Для редактирования форм используются пять инструментов: собственно инструменты редактирования, перечисленные в табл. 15.2, и инструмент Shape Selection (Выделение формы).

Таблица 15.2. Инструменты редактирования форм

Кнопка | Название | Назначение
 | Scissors (Ножницы) | Вырезает сегмент формы в любом месте контура; активная часть инструмента — перекрестье лезвий
 | Add Point (Добавить точку) | Добавляет закрепленную точку в любом месте контура
 | Delete Point (Удалить точку) | Удаляет закрепленную точку
 | Convert Point (Преобразовать точку) | Преобразует угловую точку в точку плавного изгиба, и наоборот

Инструмент Shape Selection (Выделение Формы) [image] — перемещает закрепленные точки и контрольные маркеры; при работе с любым редактирующим инструментом он активизируется нажатием клавиши Ctrl.

Далее мы подробнее остановимся на действии этих инструментов.

Выделение формы

Выделить форму — это значит вывести на экран контур формы и закрепленные (контрольные) точки.

Выделить форму можно несколькими способами:

  • Выберите инструмент Shape Selection (Выделение формы) и щелкните мышью в пределах формы.
  • Пересеките форму при нажатой кнопке мыши.
  • Выделите данную форму в списке секции Layers.

Перемещение закрепленных точек

Для перемещения закрепленной точки:

  1. Выберите инструмент Shape Selection (Выделение формы).
  2. Выделите форму. На экране — контур формы. Все закрепленные точки активны.

Активизировать только одну, нужную вам, точку можно следующим образом:

  1. Установите указатель мыши рядом с данной точкой, нажмите левую кнопку мыши и переместите указатель через точку.
  2. Отмените активность точек, не участвующих в перемещении. Для этого при нажатой клавише Shift щелкните на точке, которую хотите сделать неактивной. Повторите это для всех остальных точек, не участвующих в перемещении.
  3. Установите указатель мыши в активизируемую точку. Нажмите правую кнопку мыши и перемещайте точку на новое место.

Добавление закрепленной точки

Для добавления закрепленной точки к контуру:

  1. Выделите форму.
  2. Выберите инструмент Add Point (Добавить точку).
  3. Щелкните в нужном месте контура. На контуре — новая закрепленная точка (рис. 15.10, слева).

Рис. 15.10. Добавление (слева) и удаление (справа) закрепленных точек

Удаление закрепленной точки

Для отмены закрепленной точки:

  1. Выделите форму.
  2. Выберите инструмент Delete Point (Убрать точку).
  3. Щелкните мышью на удаляемой точке. Данная закрепленная точка удалена. Контур автоматически замыкается между ближайшими закрепленными точками (см. рис. 15.10, справа).

Замена угловой точки на точку плавного изгиба

Для замены угловой точки на точку плавного изгиба или наоборот:

  1. Выделите форму.
  2. Выберите инструмент Convert Point (Преобразовать точку).
  3. Установите указатель мыши на преобразуемой точке и нажмите кнопку мыши (рис. 15.11).
  4. Если вы преобразуете угловую точку в точку плавного изгиба, то, не отпуская кнопки мыши, задайте направляющую. Замена произведена.

Рис. 15.11. Исходная форма, преобразование первой точки, вся форма изменена

Разрезание формы

Процедура разрезания контура — это добавление новых закрепленных точек. В момент разреза к существующей закрепленной точке добавляется еще одна. Закрепленные точки располагаются одна над другой. Чтобы разделить их, надо выбрать инструмент Shape Selection (Выделение формы).

Для того чтобы разрезать форму, то есть отделить сегмент от формы:

  1. Выделите форму с помощью инструмента Shape Selection (Выделение формы).
  2. Выберите инструмент Scissors (Ножницы). Указатель мыши принимает форму ножниц.
  3. Щелкните мышью на закрепленной точке в месте разреза. Контур разомкнут, поэтому заливка контура исчезает (рис. 15.12).

Рис. 15.12. Форма выделена, разрезана, концы разъединены на месте разреза (справа)

Если в месте разреза нет закрепленной точки, добавьте ее с помощью инструмента Add Point (Добавить точку). После этого снова щелкните мышью в следующей точке разреза. Сегмент отрезан. В списке секции Layers добавляется еще одна форма с тем же названием.

Для разделения контуров выберите инструмент Shape Selection (Выделение формы). Установите указатель мыши на первой точке разреза. Нажмите кнопку мыши и сместите закрепленную точку. Учтите, что очертания контура при этом будут искажены.

Чтобы разделить оба контура, не внося искажений:

  1. Выберите инструмент Layer Adjuster (Управление плавающим объектом).
  2. Щелкните мышью на одном из контуров. Контур преобразован в плавающий объект.
  3. Переместите его с помощью клавиш со стрелками.

Соединение конечных точек

При создании форм может возникнуть ситуация, когда необходимо соединить конечные точки одного или нескольких контуров. Для этой цели в меню Shapes существует команда Join Endpoints (Соединить конечные точки).

Чтобы соединить конечные точки одного или нескольких контуров:

  1. Выберите инструмент Shape Selection (Выделение формы).
  2. Выделите пару конечных точек, которые требуется соединить. Вторая точка в паре выделяется при нажатой клавише Shift.
  3. Выберите команду Shapes > Join Endpoints (Соединить конечные точки).

Выделенные конечные точки соединены прямыми линиями.

Преобразование форм

Формы, как и другие объекты Painter, можно изменять и преобразовывать. Вы можете изменить:

  • размеры;
  • наклон;
  • разворот относительно вертикали или горизонтали.

Эти преобразования осуществляются с помощью инструмента Layer Adjuster (Регулировка плавающего объекта) или с помощью команд меню Effects. Эти действия полностью аналогичны действиям со слоями.

Изменение размеров

Изменить размер формы или нескольких форм, объединенных в группу, можно с помощью инструмента Layer Adjuster или выбрав команду Effects > Scale.

Для изменения размеров формы с помощью Layer Adjuster:

  1. Выберите инструмент Layer Adjuster.
  2. Выделите форму. Выделенная форма заключается в прямоугольную рамку с маркерами на углах и серединах сторон.
  3. Установите указатель мыши на маркере. При правильной установке маркер должен принять форму двунаправленной стрелки.
    Для изменения размеров формы только в одном направлении указатель мыши устанавливается на маркерах, расположенных на серединах сторон.
    Для изменения размеров формы в двух направлениях одновременно указатель мыши устанавливается на угловых маркерах. На рис. 15.13 и 15.14 приведены примеры текстовой и обычной форм, измененных с помощью инструмента Layer Adjuster.
  4. Нажмите левую кнопку мыши и, не отпуская ее, перемешайте указатель. По достижении нужного размера отпустите кнопку мыши.

Рис. 15.13. Вверху исходная группа форм, в середине — растянутая в ширину и высоту, внизу — в высоту

Рис. 15.14. Исходная форма (слева) и измененные формы

Для отмены выделения щелкните мышью в любом месте рабочей области вне выделенной формы.

Для изменения размеров формы с помощью команд:

  1. Выделите форму. Выделенная форма заключается в прямоугольную рамку с маркерами на углах и серединах сторон.
  2. Выберите команду Effects > Orientation > Scale. Появится диалоговое окно Scale Selection (рис. 15.15).
  3. Укажите новые размеры изображения в полях Vertical Scale (Вертикальный масштаб) и Horizontal Scale (Горизонтальный масштаб) в процентах. Размеры исходного изображения приняты за 100%.
  4. Установите флажок Constrain Aspect Ratio (Сохранить соотношение сторон), в этом случае горизонтальный и вертикальный масштабы равны.
  5. Установите флажок Preserve Center (Сохранить положение центра). В этом случае положение центра формы остается неизменным при изменении масштаба. Нажмите кнопку ОК. Масштаб изменен.

Рис. 15.15. Диалоговое окно Scale Selection

Вращение формы

Повернуть форму можно также с помощью инструмента Layer Adjuster и с помощью команд меню Effects.

  1. Выберите инструмент Layer Adjuster.
  2. Выделите форму. Выделенная форма заключается в прямоугольную рамку с маркерами на углах и серединах сторон.
  3. Установите указатель мыши на угловом маркере и нажмите клавишу Ctrl. Маркер примет форму стрелки, изогнутой по окружности.
  4. Нажмите правую кнопку мыши и, не отпуская ее, перемещайте указатель, поворачивая форму. Достигнув нужного положения, отпустите кнопку. Поворот завершен (рис. 15.16).

Рис. 15.16. Поворот с помощью инструмента Layer Adjuster

Для осуществления поворота с помощью команды:

  1. Выделите форму. Выделенная форма заключается в прямоугольную рамку с маркерами на углах и серединах сторон.
  2. Выберите команду Effects > Orientation > Rotate. Откроется диалоговое окно Rotate Selection (рис. 15.17).
  3. Укажите угол поворота в поле Angle (Угол) в градусах. Положительные значения — поворот против часовой стрелки, отрицательные — по часовой. Нажмите кнопку ОК. Форма повернута.

Рис. 16.17. Диалоговое окно Rotate Selection

Наклон

  1. Выберите инструмент Layer Adjuster.
  2. Выделите форму.
  3. Установите указатель на маркере, расположенном на середине горизонтальной стороны рамки, и нажмите клавишу Ctrl. Маркер должен принять форму наклонной стрелки.
  4. Нажмите правую кнопку мыши и, не отпуская ее, перемещайте указатель, изменяя форму. Достигнув нужного положения, отпустите кнопку. Наклон завершен (рис. 15.18).

Рис. 15.18. Наклон формы

Чтобы осуществить деформацию с помощью команды:

  1. Выделите форму.
  2. Выберите команду Effects > Orientation > Distort. Открылось диалоговое окно Distort Selection (рис. 15.19).
  3. Вокруг выделения появляется дополнительная прямоугольная рамка с маркерами на углах и на серединах сторон. Устанавливая указатель на маркерах и перемещая их при нажатой кнопке мыши, задайте новое положение рамки, в которую будет вписана выделенная форма.
  4. Для закрытия диалогового окна нажмите кнопку ОК. Форма деформирована (рис. 15.19, справа).

Рис. 15.19. Исходный вариант слева, результат деформации справа

Горизонтальный и вертикальный переворот

Для выполнения горизонтального или вертикального переворота:

  1. Выделите форму. Выделенная форма заключается в прямоугольную рамку с маркерами на углах и серединах сторон.
  2. Выберите команду Effects > Orientation > Horizontal Flip или Vertical Flip. Форма перевернута (рис. 15.20).

Рис. 15.20. Результаты вертикального и горизонтального переворота

ВНИМАНИЕ. Горизонтальный переворот осуществляется вокруг вертикальной оси. Напротив, вертикальный переворот осуществляется вокруг горизонтальной оси.

Дупликация

При дупликации происходит копирование выделенной формы. Причем копированная форма может преобразовываться, то есть могут быть изменены такие параметры формы, как положение на экране, размер и наклон. Эти параметры задаются в диалоговом окне Set Duplicate Transform (Задать преобразование при удвоении) (рис. 15.21), открываемом выбором команды Shapes > Set Duplicate Transform.

Рис. 15.21. Диалоговое окно Set Duplicate Transform

Чтобы задать параметры удвоения:

  1. Выберите команду Shapes > Set Duplicate Transform. Откроется диалоговое окно Set Duplicate Transform.
  2. Задайте параметры удвоения, приведенные в табл. 15.3.
  3. Нажмите кнопку ОК.
  4. Выделите форму, которую вы хотите размножить.
  5. Выберите команду Shapes > Duplicate.

В табл. 15.3 приведены параметры диалогового окна и их назначение.

Таблица 15.3. Состав диалогового окна Set Duplicate Transform

Параметр | Настраивает
Translation (Перемещение) |
Horizontal Offset (Смещение no горизонтали) | Горизонтальное положение копии
Vertical Offset (Смещение по вертикали) | Вертикальное положение на экране. Если данные параметры задать равными нулю, копия располагается поверх оригинала
Scaling (Изменение размеров) |
Horizontal (Горизонтальный) | Горизонтальный размер копии в процентах к соответствующим размерам оригинала
Vertical (Вертикальный) | Вертикальный размер копии
Constrain Aspect Ratio (Сохранить соотношение размеров) | Задаст одинаковое изменение размеров как по вертикали, так и по горизонтали
Rotation (Вращение) | Поворот формы. Положительные значения задают поворот в направлении против часовой стрелки
Slant (Наклон) | Относительное смещение верха и низа формы. Положительные значения задают наклон направо, отрицательные — налево. Меняется от +90 до -90. При значениях, близких к предельным, форма преобразуется в отрезок прямой

Дупликацию можно осуществить и с помощью комбинации клавиш. Нажмите комбинацию клавиш Ctrl+j. Многократное повторение этой операции при установленных параметрах позволяет получить любопытные эффекты (рис. 15.22).

Рис. 15.22. Эффект, полученный при многократном повторении дупликации

Преобразование в плавающий объект

Форма имеет много общего как с выделением, так и со слоем. С выделением форму объединяет механизм создания контура. Форма подчиняется тем же преобразованиям, что и плавающий объект, и имеет тот же механизм создания слоя. Разница между ними заключается в том, что форма — это векторное изображение, а слой — растровое изображение. Форма легко преобразуется как в выделение, так и в слои.

Мы уже говорили о том, что формы автоматически преобразуются в плавающие объекты (Layers), если к ним применить эффект, свойственный растровым объектам, например градацию.

Но это преобразование можно осуществить и другим путем. Чтобы преобразовать форму в слой:

  1. Выделите преобразуемую форму с помощью инструмента Shape Selection.
  2. Выберите команду Shapes > Convert to Layer (Формы > Преобразовать в слой).
  3. Выделенная форма преобразована в слой.

При применении растрового эффекта к форме, например инструментом Brush, на экране появляется запрос: Commit shape to an image layer? (Поместить форму в слой?). Если вы продолжаете работу с кистью, нажмите кнопку Commit (Поместить). Если вы планируете работу с другими формами, установите флажок Commit and do not ask again (Поместить и не спрашивать в дальнейшем). В этом случае при переходе к следующим формам все они будут преобразованы в плавающие объекты.

Операции с формами

Помимо преобразования форм вы можете создавать совершенно новые эффекты, которые нельзя воспроизвести с другими объектами Painter, кроме форм. Это создание сложных, переходных и усредненных форм, о которых мы расскажем далее в этой главе.

Сложная форма

Мы уже рассматривали форму, созданную из нескольких, в разделе о преобразовании выделения в форму и обратно. Но формы можно компоновать различными способами, например можно вкладывать одну форму в другую. Тогда получается сложная форма, состоящая из нескольких форм. В частности, это может быть буква с вырезанной замкнутой частью. Сама буква — это внешняя форма, замкнутая часть внутри буквы (например, внутри букв О, А, Р и других) — это внутренняя форма.

ПРИМЕЧАНИЕ. Для создания сложных форм необходимо, чтобы одна форма полностью находилась внутри другой, то есть была чуть меньших размеров.

Создадим сложную форму из библиотеки стандартных выделений. Для этого:

  1. Создайте новый документ.
  2. Откройте секцию Selections Portfolio, выберите любое выделение и перетащите его на холст.
  3. Выберите команду Select > Convert To Shape. Получится форма, залитая цветом, установленным по умолчанию.
  4. Измените установки. Выберите команду Shapes > Set Shape Attributes. Установите цвет заливки, окантовки, ширину окантовки, форму углов. Нажмите кнопку ОК.
  5. Для создания второй формы повторите шаги, начиная с пункта 2, но окрасьте для наглядности другую форму иначе.
  6. Итак, у нас две формы (рис. 15.23), однако для получения сложной формы необходимо, чтобы внутренняя форма полностью входила во внешнюю. Поэтому одну из форм следует уменьшить.
  7. Для удобства слежения за размерами и точным совмещением фигур установите сетку, выбрав команду Canvas > Grid > Show Grid.
  8. Выберите инструмент Layer Adjuster и выделите им объект, который требуется уменьшить. Установите указатель мыши на маркере середины горизонтальной стороны. При появлении двунаправленной стрелки укоротите объект. Аналогично поступите и с вертикальным размером.
  9. После того как достигнут нужный размер, необходимо переместить объект для наложения форм (рис. 15.24, слева). Установите указатель мыши на одном из красных маркеров и перетащите объект, аккуратно совместив обе формы, ориентируясь по сетке.
  10. При нажатой клавише Shift выделите обе формы, выбрав инструмент Shape Selection (Выделение формы) (рис. 15.24, справа).
  11. Выберите команду Shapes > Make Compound. Теперь формы будут объединены (рис. 15.25), а в списке секции Layer останется только одна форма — сложная, которой присвоено название или номер внешней формы.

Рис. 15.23. Исходные формы

Рис. 15.24. Формы совмещены (слева), справа формы выделены

Рис. 15.25. Результат объединения форм: слева — выделенный, справа — без сетки и выделения

Чтобы выполнить обратное действие и заменить сложную форму несколькими простыми, надо выделить сложную форму и выбрать команду Shapes > Release Compound (Разъединить). Сложная форма заменена составлявшими ее простыми формами.

Переходные формы

Переходные формы представляют собой постепенную трансформацию одной формы в другую. В процесс трансформации может быть вовлечено несколько форм. При этом трансформируются не только контуры, но и заливка форм. Создание трансформированной формы происходит в специальном диалоговом окне Blend (рис. 15.26), открываемом командой Shapes > Blend (Смесь). Опции и их назначение приведены в табл. 15.4.

Рис. 15.26. Диалоговое окно Blend

Таблица 15.4. Состав диалогового окна Blend

Параметр | Устанавливает
Number of Steps (Число шагов) | Число переходных форм
Туре(Тип) | Частоту расположения переходных форм: на равном расстоянии друг от друга, чаще в конце, чаще в начале, чаще и в начале, и в конце
Color Space (Цветовое пространство) | Цветовую модель, в которой создаются переходные формы
RGB | Цвет переходных форм задается путем смешивания цветов первой и последней форм
Hue CW (Оттенки по часовой стрелке) | Цвет переходных форм задается но цветовому кругу: от первой формы к последней по часовой стрелке
Perspective Factor (Коэффициент перспективы) | Контролирует расстояние между переходными формами независимо от типа перехода: диапазон значений от 0,1 до 100: при значениях, равных 1, формы располагаются равномерно; при значениях меньше 1 расстояние между переходными формами увеличивается от первой к последней; при значениях больше 1 расстояние между переходными формами уменьшается от первой к последней
Arc Length Matching (Соответствие длин дуг) | Обязательно должна быть включена, если исходные формы имеют разное количество закрепленных точек; активизируется по умолчанию

Для создания переходных форм:

  1. Создайте новый документ размером 200 x 400 пикселов.
  2. В секции Selections Portfolio выберите любое выделение, переместите его на холст.
  3. Выберите команду Select > Convert To Shape. Получится форма, залитая цветом, установленным по умолчанию.
  4. Измените установки. Выберите команду Shapes > Set Shape Attributes. Установите цвет заливки, окантовки, ширину окантовки, форму углов и нажмите кнопку ОК.
  5. Для создания второй формы повторите шаги начиная с пункта 2, но окрасьте для наглядности другую форму иначе (рис. 15.27).
  6. Расположите формы на холсте в нужном порядке. Учтите, что переходные формы создаются снизу вверх, то есть трансформация начинается с формы, расположенной в самом нижнем слое.
  7. Выберите инструмент Shape Selection и выделите формы, которые предполагаете трансформировать. При выделении нескольких форм нажмите и удерживайте клавишу Shift.
  8. Выберите команду Shapes > Blend. Откроется диалоговое окно Blend (см. рис. 15.26).
  9. Задайте параметры трансформации в окне Blend.
  10. Нажмите кнопку ОК. Переходные формы созданы в соответствии с заданными параметрами перехода (рис. 15.28, 15.29).

Рис. 15.27. Исходные формы, полученные преобразованием выделений из Selection Portfolio. Обратите внимание, у левой звезды меньше лучей

Рис. 15.28. Процесс создания переходных форм из 10, формы еще выделены

Рис. 15.29. Результат создания переходных форм

Создание усредненной формы

Из двух или нескольких форм можно создать усредненную. При этом получаются эффекты, схожие с калейдоскопом. Это осуществляется с помощью диалогового окна Average (Усреднение) (рис. 15.30), открывающегося выбором команды Shape > Average Points.

Рис. 15.30. Диалоговое окно Average

Чтобы выполнить усреднение точек формы:

  1. Создайте новый документ.
  2. Создайте две формы из библиотеки стандартных выделений.
  3. С помощью инструмента Layer Adjuster совместите обе формы. (Формы совмещать необязательно, но при наложении форм результаты получаются эффектнее.)
  4. Выделите обе формы с помощью инструмента Shape Selection при одновременном нажатии клавиши Shift (рис. 15.31, справа).
  5. Выберите команду Shape > Average Points.
  6. В открывшемся диалоговом окне Average (рис. 15.30) установите нужный переключатель: Both (Оба), Horizontal (Горизонтально), Vertical (Вертикально). Нажмите OK.

Рис. 15.31. На левом рисунке исходные формы, на правом — формы наложены друг на друга и выделены

Полученный от усреднения точек результат в трех вариантах показан на рис. 15.32.

Рис. 15.32. Усреднение точек по вертикали (слева), по горизонтали (в центре), в обоих направлениях (справа)

Эффект тени

Помимо уже перечисленных команд меню Effect (об этом шла речь в разделе о преобразованиях форм) к формам применим эффект наложения тени. Это как раз тот самый случай, когда форма автоматически превращается в слой. Для этих целей предусмотрена команда Effects > Objects > Create Drop Shadow, открывающая диалоговое окно Drop Shadows. Предварительно вы получите запрос о том, надо ли помешать форму в слой.

Для того чтобы создать эффект тени:

  1. Выделите форму в списке секции или с помощью инструмента Layer Adjuster (рис. 15.33, слева).
  2. Выберите команду Effects > Objects > Create Drop Shadow. Откроется диалоговое окно Drop Shadows. Установите параметры тени в соответствии с пояснениями, приведенными в предыдущей главе.
  3. Нажмите кнопку ОК (рис. 15.33. справа).

Рис. 15.33. Исходная форма слева, форма с наложенной тенью


Динамичные слои Burn, Tear, Bevel World, Liquid Metal

  • Типы динамичных слоев
  • Динамичный слой Burn
    • Параметры динамичного слоя
    • Создание эффекта обожженного края
  • Динамичный слой Tear
    • Создание эффекта оборванного края
    • Использование эффекта Tear
  • Динамичный слой Bevel World
    • Параметры эффекта Bevel World
    • Создание различных эффектов с помощью динамичного слоя Bevel World
    • Упражнение. Применение динамичного слоя Bevel World при создании рельефного изображения
  • Динамичный слой Liquid Metal
    • Параметры динамичного слоя Liquid Metal
    • Инструменты динамичного слоя Liquid Metal
    • Упражнение. Использование динамичного слоя Liquid Metal при работе с текстом
  • Упражнение. Создание изображения из серии «Искусственные атмосферные явления»

Динамичный слой не меняет само изображение, он «плавает» над ним, вы можете легко отменить его действие

Динамичные слои (в прежних редакциях Plug-In) — это набор разнообразных фильтров или модулей, создающих уникальные эффекты, но при этом не искажающих исходное изображение, поскольку они находятся в отдельном слое и как бы «плавают» над исходным изображением.

Типы динамичных слоев

Динамичные слои разделяются на три категории:

  • Эффекты, применяемые к активному выделению или слою: Burn (Обожженный край), Tear (Рваный край) и Bevel World (Призматический мир).
  • Эффект, создающий активный динамичный слой вслед за указателем или при помощи инструментов рисования, — Liquid Metal (Жидкий металл).
  • Эффекты, при которых динамичный слой создается надо всем холстом. За основу берется исходное изображение или Layer: Posterize (Постер), Brightness/Contrast (Яркость/Контрастность), Equalize (Выравнивание), Glass Distortion (Сквозь стекло), Kaleidoscope (Калейдоскоп), Liquid Lens (Текучая линза).

При сохранении изображения в формате RIF динамичные слои продолжают оставаться объектом, плавающим над основным изображением, и сохраняют свои свойства.

Все варианты динамичных слоев находятся в секции Dynamic Layers палитры Objects (рис. 16.1).

Рис. 16.1. Секция Dynamic Layers палитры Objects в свернутом и развернутом состояниях

Общие принципы работы с динамичными слоями предполагают следующие действия:

  1. Раскройте исходное изображение или выделите часть данного изображения.
  2. Откройте секцию Dynamic Layers палитры Objects и выберите динамичный слой.
  3. Нажмите кнопку со стрелкой справа от названия секции Dynamic Layers, откроется меню секции. Выберите команду Apply. Откроется диалоговое окно, содержащее параметры настройки эффекта. Установите нужные параметры, нажмите кнопку ОК. Эффект будет применен. Если вы хотите повторить применение, нажмите кнопку Apply (Применить) или перетащите изображение данного варианта за пределы панели, щелкните на изображении выбранного модуля. В открывшемся диалоговом окне установите параметры варианта и нажмите кнопку ОК.

После применения данного динамичного слоя его название заносится в список слоев секции Layers палитры Objects.

ПРИМЕЧАНИЕ. Для отмены действия динамичного слоя нажмите клавишу Delete или Backspace или выберите в меню команду Edit > Undo. Для отмены действия динамичных слоев Burn, Tear или Bevel World выберите команду Revert to Original (Вернуться к оригиналу).

Одно из преимуществ динамичных слоев состоит в том, что вы в любой момент можете изменить параметры модуля. Для этого:

  1. Выделите данный модуль в списке секции Dynamic Layers палитры Objects.
  2. Выберите в меню секции команду Options (Параметры). Откроется диалоговое окно, где устанавливаются параметры данного слоя.
  3. Получив окончательный вариант изображения, выберите команду Commit (Совершить) в меню секции, чтобы конвертировать данный динамичный слой в обычный. Только после этих действий можно редактировать изображение, но уже нельзя изменить эффект, вызываемый динамичным слоем.

Конвертирование динамичного слоя в обычный может быть выполнено по запросу автоматически при применении инструментов или операций, для которых динамичный слой недоступен, а именно:

  • инструмента Реn;
  • команд меню Effect;
  • любого другого динамичного слоя;
  • команды Layer > Drop (Опустить);
  • команды Collapse (Объединить), примененной к группе, содержащей динамичный слой — модуль;
  • сохранения документа в любом формате, кроме формата RIF.

Рассматривать работу каждого из динамичных слоев мы будем по порядку, указанному в начале урока. Сначала рассмотрим первый тип эффектов, применяемых к активному выделению или активному слою.

Динамичный слой Burn

Динамичный слой Burn (Обожженный край) имитирует обожженные края выделенного изображения (рис. 16.2).

Рис. 16.2. Диалоговое окно Burn Options и результат применения динамичного слоя Burn

Параметры динамичного слоя

Параметры динамичного слоя устанавливаются в диалоговом окне Burn Options. Все параметры окна приведены в табл. 16.1.

Таблица 16.1. Параметры, устанавливаемые в окне Burn Options

Параметр | Устанавливает
Burn Margin (Край ожога) | Размеры области между границей выделения и каймой ожога
Flame Breadth (Ширина пламени) | Ширину опаленной каймы по отношению к размеру области, не затронутой пламенем
Flame Strength (Сила пламени) | Размеры области, обработанной пламенем
Wind Direction (Направление ветра) | Эффект ожога в зависимости от направления
Jaggedness (Неровность) | Неровность границы ожога
Wind Strength (Сила ветра) | Ширину области, контролируемом параметром Wind Direction
Use paper texture (Использовать текстуру бумаги) | Текстуру бумаги на обожженной области
Burn Interior edges (Ожог внутренней кромки) | Распространение ожога на внутренние выделенные области при выделениях сложной формы
Burn Color (Цвет ожога) | Цвет обожженной каймы
Preview (Предварительный просмотр) | Обеспечивает предварительный просмотр
Off (Отменить) | Отмену применения данного встроенного модуля аналогично команде Revert to Original меню секции
Save As Default (Сохранить по умолчанию) | Применение заданных параметров к следующим объектам по умолчанию
Reset (Установить заново) | Применение предыдущих параметров

Создание эффекта обожженного края

Эффект обожженного края создается следующим образом:

  1. Выделите все изображение или нужную область.
  2. Откройте секцию Dynamic Layers палитры Objects.
  3. Выберите динамичный слой Burn и нажмите кнопку Apply или выберите команду Apply в меню секции. Откроется диалоговое окно Burn Options (см. рис. 16.2).
  4. Установите параметры обожженного края (см. табл. 16.1). Нажмите кнопку ОК.

Динамичный слой Burn может применяться как ко всему выделенному изображению, так и к отдельным выделенным объектам, например к буквам.

На рис. 16.3 приведен пример изображения, где к тексту применен динамичный слой Burn с минимальными размерами параметра Burn Margin (3%) и Flame Breadth (2%). Остальные параметры взяты по умолчанию. Флажок Burn Interior edges установлен. Фон получен применением текстуры Pavement из стандартной библиотеки секции Paper палитры Art Materials. Отпечатки рук получены применением эффекта Bevel World к слою (Layer) с изображением руки из стандартной библиотеки секции Image Portfolio.

Рис. 16.3. Результат применения динамичного слоя Burn к тексту

Ниже приведен пример использования динамичного слоя Burn при обработке фотографии. Обработка выполнена в два этапа.

Первый этап — применение динамичного слоя Burn.

  1. Откройте изображение, сделайте клон, чтобы всегда оставалось исходное изображение.
  2. Выберите инструмент Magic Wand, установите параметры на панели управления Controls (Tolerance — 4, Feather — 0).
  3. Выделите несколько областей при нажатой клавише Shift.
  4. Выберите в секции Dynamic Layers слой Burn. Откроется диалоговое окно Burn Options.
  5. В диалоговом окне установите следующие параметры: Burn Margin — 0, Flame Breadth — 30%, Flame Strength - 50%, Wind Direction — 0, Jaggedness — 100%, Wind Strength — 100%, Burn Color — оранжевый.
  6. После применения динамичного слоя Burn соответствующий слой совместите с холстом, выбрав команду Layer > Drop.

На рис. 16.4 слева — исходная фотография. Справа — результат последовательного применения динамичного слоя Burn к нескольким частичным выделениям. После пяти последовательных применений динамичного слоя Burn получено изображение, приведенное на рис. 16.4 справа.

Рис. 16.4. Пример использования динамичного слоя Burn, слева — исходная фотография

На втором этапе:

  1. Выделите изображение, выбрав команду Select > All. Выберите команду Edit > Сору.
  2. Изображение трансформируется в слой (Layer). Совместите его с исходным изображением, выбрав команду Edit > Paste. При совмещении установите параметры Opacity — 64%, Composite Method — Difference.
  3. Затем с помощью инструмента Rectangular Selection (Прямоугольное выделение) выделите нижнюю часть изображения — от поверхности воды до нижней границы.
  4. К выделению примените растушевку шириной 10 пикселов, выбрав команду Select > Feather.
  5. Выделенную часть трансформируйте в Layer, выбрав команду Edit > Copy, и совместите с нижней частью исходного изображения, выбрав команду Edit > Paste. При совмещении установите Opacity — 50%, Composite Method — Pseudocolor.
  6. Такую же операцию проделайте с верхней частью — от поверхности воды до верхней границы. При совмещении установите Opacity — 50%, Composite Method — Colorize.
  7. В итоге к полученному изображению примените дополнительное освещение, направленное на верхнюю часть изображения, выбрав Effects > Surface Control > Apply Lighting > Pain Light (Эффекты > Управление поверхностью > Наложить освещение > Усиление света).

Результат приведен на рис. 16.5.

Рис. 16.5. Итоговое изображение после применения дополнительного освещения

Динамичный слой Tear

Динамичный слой Tear (Рваный край) имитирует оборванные края бумаги. С его помощью легко разрываются страницы книг, рисунки, карты, деньги, фотографии и тому подобное (рис. 16.6). В целом, динамичный слой Tear работает так же, как и динамичный слой Burn.

Рис. 16.6. Композиция, созданная с помощью динамичного слоя Tear. Фотография девушки разорвана и брошена на исходное изображение

Ниже в табл. 16.2 приведены параметры динамичного слоя Tear, устанавливаемого в диалоговом окне Tear Options (рис. 16.7).

Рис. 16.7. Диалоговое окно Tear Options и результат применения динамичного слоя Tear

Таблица 16.2. Параметры, устанавливаемые в окне Tear Options

Параметр | Устанавливает
Margin (Край обрыва) | Ширину каймы обрыва по отношению к размерам layer (слоя)
Strength (Сила обрыва) | Ширину области, уничтоженной при обрыве
Jaggedness (Неровность) | Неровность границы обрыва
Tear Color (Цвет обрыва) | Цвет оборванной каймы
Tear Interior edges (Обрыв внутренней кромки) | Распространение обрыва на внутреннюю кромку оборванного поля
Preview (Предварительный просмотр) | Предварительный просмотр
Off (Отменить) | Отмену данного динамичного слоя аналогично команде Revert to Original в меню Layers
Save As Default (Сохранить по умолчанию) | Применение заданных параметров к следующим объектам по умолчанию
Reset (Установить заново) | Применение предыдущих параметров

Создание эффекта оборванного края

Эффект оборванного края, представленный на рис. 16.6, создается с помощью динамичного слоя Tear.

Динамичный слой Tear применяется к выделенной области, для которой надо создать эффект оборванного края. Это может быть как все изображение, так и его часть.

  1. Откройте изображение, для которого создается эффект оборванного края.
  2. Выполните выделение инструментом Magic Wand.
  3. В секции Dynamic Layers палитры Objects щелкните на значке динамичного слоя Tear и нажмите кнопку Apply или выберите команду Apply в меню Layers. Откроется диалоговое окно Tear Options.
  4. Установите параметры оборванного края. Все изменения параметров сразу же проявляются в рабочем изображении (см. рис. 16.7).
  5. Если выбранные параметры вас устраивают, нажмите кнопку ОК. Динамичный слой применен.
  6. Выберите команду Edit > Copy. Создайте новый документ, равный по величине исходному. Вставьте скопированное изображение, выбрав Edit > Paste.
  7. Переместите вставленное изображение в нужное место.
  8. Вернитесь в первое изображение. В секции Layers палитры Objects выделите слой в списке и нажмите кнопку Drop.
  9. Повторите выделение и применение динамичного слоя к оставшемуся фрагменту изображения. Снова скопируйте его и вставьте во второй документ. Вы получите применение эффекта оборванного края, подобное приведенному на рис. 16.7.

Использование эффекта Tear

В качестве примера рассмотрим применение динамичного слоя Tear к изображению. Результат воздействия приведен на рис. 16.8.

Рис. 16.8. Результат применения динамичного слоя Tear

  1. Откройте изображение и выберите команду File > Clone. Копию исходного изображения, полученную с помощью клонирования, мы используем в качестве фона нового изображения.
  2. Выделите область изображения с помощью инструмента Lasso (Лассо). Примените к ней динамичный слой Tear с параметрами Margin — 1%, Strength — 50%, Jaggedness —50%. Выберите команду Edit > Copy.
  3. Перейдите в клонированный документ и вставьте скопированный фрагмент, выбрав Edit > Paste. Переместите вставленную часть, поверните или измените ее размер, выбрав команды Effects > Orientation > Rotate и Effects > Orientation > Scale.
  4. Чтобы выделить «оторванные» части на фоне оригинала, к вставленной части примените текстуру, выбрав Effects > Apply Surface Texture, с параметрами Softness — 1, Amount — 30%, а также эффект тени, выбрав Effects > Objects > Create Drop Shadow.
  5. Повторите действия для других фрагментов изображения.

Итоговое изображение приведено на рис. 16.8. Копия исходного изображения «разорвана» и «брошена» на оригинал.

Динамичный слой Tear может быть применен к любому выделенному объекту, например к тексту. На рис. 16.9 приведен пример применения динамичного слоя к слову Mist и его отражению в воде.

Рис. 16.9. Результат применения динамичного слоя Tear к тексту

  1. Выберите инструмент Text и введите текст со следующими параметрами: Size - 130, Tracking - 30, Font — Arial Black.
  2. Для получения отражения скопируйте каждую букву, выбрав команды Edit > Copy, Edit > Paste.
  3. Поверните буквы, выбрав Effects > Orientation > Flip Vertical, и деформируйте их, выбрав Effects > Orientation > Distort.
  4. Затем выделите каждую букву, выбрав Shapes > Convert to Selection, и примените к ней динамичный слой Tear с параметрами Margin — 30%, Strength — 70%, Jaggedness - 80%.

Динамичный слой Tear может использоваться и как самостоятельный инструмент для создания изображений. Например, на рис. 16.10 приведено изображение цветка, полученное путем применения динамичного слоя Tear сначала к контуру, нарисованному инструментом Реn (Перо), а затем к его внутренним частям, выделенным с помощью инструмента Magic wand (Волшебная палочка). Параметры динамичного слоя Tear задавались в следующих пределах: Margin — 8-10%, Strength — 20-25%, Jaggedness — 30-50%.

Рис. 16.10. Изображение цветка, полученное с помощью динамичного слоя Tear

Изображение цветка положено в основу композиции, приведенной на рис. 16.11. Цветок несколько раз скопирован (Edit > Copy, Edit > Paste > Normal), уменьшен в масштабе (Effects > Orientation > Scale) до 70-80% и несколько деформирован (Effects > Orientation > Distort). После совмещения с холстом изображение обработано с помощью заливки без выделения. Заливка осуществлялась градацией, вариант Stripes 7 (Полосы), из стандартной библиотеки, способ заливки Спираль.

Рис. 16.11. Итоговое изображение цветов в композиции

Динамичный слой Bevel World

Динамичный слой Bevel World (Призматический мир) [image] позволяет создавать удивительные трехмерные призматические эффекты (рис. 16.12).

Рис. 16.12. Применение динамичного слоя Bevel World к башне — справа, слева — исходное изображение

Как и предыдущие динамические слои. Bevel World применяется только к выделенному изображению. Если в изображении отсутствует выделение, кнопка Apply и команда Apply меню секции не доступны.

На рис. 16.12 представлено изображение Эйфелевой башни, слева — исходная фотография, справа — после применения динамичного слоя Bevel World. Башня выделена с помощью инструмента Реn (Перо). Параметры динамичного слоя Bevel World приняты по умолчанию.

Параметры эффекта Bevel World

Параметры динамичного слоя Bevel World устанавливаются в диалоговом окне Bevel World (рис. 16.13), которое открывается нажатием кнопки или выбором команды Apply.

Рис. 16.13. Диалоговое окно динамичного слоя Bevel World

Все изменения параметров тут же появляются на схеме призмы в просмотровом окне Preview, где видно, как отразится изменение данного параметра на изображении. Одновременно все изменения появляются на вашем изображении при открытом диалоговом окне, и вы можете подобрать наиболее удачные параметры, наблюдая за изменениями оригинала.

На первый взгляд кажется, что очень сложно разобраться, что к чему относится. Но когда вы начнете перемещать ползунки диалогового окна динамичного слоя Bevel World, вам сразу станет все понятно. Чтобы дать возможность пользователю регулировать различные параметры призмы, она разбита на более мелкие фрагменты, назначение которых описано в табл. 16.3.

Таблица 16.3. Схема призмы динамичного слоя Bevel World

Название | Части призмы
Outside Portion | Глубина склона от границы до наклонной боковой грани
Base | Основание боковой грани
Cliff | Боковая грань
Rim | Верхняя часть боковой грани
Cliff Hight | Высота грани
Cliff Slope | Угол наклона между гранью и верхней частью
Rim Slope | Угол кривизны верхней части
Base Slope | Угол наклона между гранью и основанием

Параметры диалогового окна Bevel World приведены в табл. 16.4.

Таблица 16.4. Параметры диалогового окна Bevel World

Параметр | Устанавливает
Bevel Controls (Параметры призмы) | Параметры призмы
Bevel Width (Ширина призмы) | Размеры горизонтальной проекции призмы в процентах от размеров слоя; по умолчанию исходная призма имеет угол 45 градусов между боковой гранью и горизонтальной плоскостью
Outside Portion (Внешняя часть) | Размеры внешней части в процентах от размеров слоя
Rim Slope (Наклон верхнего края боковой грани) | Угол наклона верхнего края боковой грани относительно горизонтали
Cliff Portion (Размер грани) | Величину горизонтальной проекции боковой грани в процентах от величины проекции исходной призмы с углом 45 градусов
Cliff Height (Высота грани) | Величину вертикальной проекции боковой грани в процентах от величины проекции исходной призмы с углом 45 градусов
Cliff Slope (Наклон боковой грани) | Угол наклона боковой грани к горизонтальной плоскости
Base Slope (Наклон основания) | Угол между основанием боковой грани и горизонтальной плоскостью
Smoothing (Сглаживание) | Плавный переход между гранями призмы, увеличение этого параметра сглаживает рельеф призмы
Outside Color (Цвет внешней части) | Цвет внешней части, то есть цвет полосы, окаймляющей призму
Bevel Interior Edges (Призматическая внутренняя часть) | Призматический эффект для внутренних выделенных частей в пределах внешней границы выделения
Light Controls | Параметры освещения
Light Direction (Направление света) | Азимут источника света
Light Height (Высота источника света) | Высоту источника света над горизонтом
Brightness (Яркость) | Интенсивность источника света
Scatter (Рассеяние) | Интенсивность рассеяния света поверхностью призмы
Shine (Сияние) | Интенсивность световых бликов на гранях призмы
Reflection (Отражение) | Интенсивность света, отраженного поверхностью призмы
Light Color (Цвет освещения) | Цвет светового потока, освещающего призму
Preview (Предварительный просмотр) | Предварительный просмотр
Off (Отменить) | Отменяет применение данного встроенного модуля так же, как и команда Revert to Original в меню Dynamic Layers
Save As Default (Сохранить по умолчанию) | Сохраняет установленные параметры и применяет их по умолчанию к следующему объекту
Reset (Переустановить) | Ранее установленные параметры

Создание различных эффектов с помощью динамичного слоя Bevel World

Динамичный слой Bevel World применяется следующим образом:

  1. Выделите нужную область или активизируйте слой в секции Layers палитры Objects.
  2. Выберите динамичный слой Bevel World в секции Dynamic Layers, а затем нажмите кнопку Apply или выберите команду Apply в меню секции Dynamic Layers. Откроется диалоговое окно Bevel World.
  3. Установите параметры призматического эффекта, ориентируясь на происходящие с изображением изменения.
  4. Закончив установку параметров, нажмите кнопку ОК. Возможно, компьютеру понадобится некоторое время, чтобы создать изображение с требуемыми параметрами.

Чтобы изменить установки динамичного слоя Bevel World, выделите данный слой в списке секции Layers палитры Objects, а в меню секции Dynamic Layers выберите Options (Параметры) или дважды щелкните мышью на соответствующей строке списка. Откроется диалоговое окно Bevel World, в котором можно изменить параметры динамичного слоя.

Рассмотрим некоторые примеры применения динамичного слоя Bevel World.

Создание необычных очертаний

Интересный графический эффект дает применение динамичного слоя Bevel World к выделению, полученному с помощью инструмента Magic Wand (Волшебная палочка). Исходное изображение приведено на рис. 16.14.

Рис. 16.14. Исходное изображение

  1. Откройте изображение, выберите инструмент Magic Wand (Волшебная палочка). Сначала обработайте передний план. Отдельные лепестки и крупные листья выделите с помощью инструмента Magic Wand. Параметры выделения, установленные на панели Control: Tolerance — 2, Feather — 0.
  2. К каждой выделенной области примените динамичный слой Bevel World с параметрами, принятыми по умолчанию.
  3. Затем таким же образом обработайте задний план. В завершение ко всему изображению по диагонали примените выделение с помощью инструмента Magic Wand с параметрами: Tolerance — 2, Feather — 2. Ко всей выделенной области примените динамичный слой Bevel World с параметрами, принятыми по умолчанию.
  4. В итоге ко всему изображению примените эффект Posterize (Превращение в постер), выбрав Effects > Tonal Control > Posterize, с числом уровней, равным 8. Итоговое изображение приведено на рис. 16.15.

Рис. 16.15. Применение динамичного слоя Bevel World к выделению, итоговое изображение

Имитация рельефа

Динамичный слой Bevel World позволяет имитировать разнообразные формы рельефа (рис. 16.16). Геометрическая форма, задающая рельеф, может быть получена самыми различными способами. Фрактальный рисунок границ рельефа можно получить, например, с помощью динамичного слоя Tear, примененного к выделению любой изометрической формы. Параметры диалогового окна Tear Options задаются в области максимальных значений, чтобы оторванный край закрывал всю центральную часть выделения (Margin — 40-50%, Strength — 50-100%, Jaggedness — 50-100%). Цвет рельефа задается в окне Tear Color. Цвет центральной части рельефа (вне границ оторванного края) и текстура задаются до применения динамичного слоя Tear. После создания фрактального рисунка рельефа к полученному слою применяется динамичный слой Bevel World. Меняя параметры области Bevel Controls, можно получать самые разнообразные формы рельефа: плоскогорья, пики, горные ущелья и т. п.

Рис. 16.16. Различные формы рельефа, полученные в результате последовательного применения динамичных слоев Tear и Bevel World

Создание объема и бликов

Интересный эффект дает применение динамичного слоя Bevel World при установке параметра Smoothing в области больших значений. Эффект призмы практически исчезает, но остаются световые блики, созданные призмой. Исходное изображение приведено на рис. 16.17.

Рис. 16.17. Исходная фотография

Прическа девушки, а также ее лицо, руки и груша выделены с помощью инструмента Реn (Перо).

Для каждого выделенного элемента композиции в диалоговом окне Set Shapes Attributes сняты флажки Stroke и Fill.

Полученная форма преобразована в выделение с помощью команды Shapes > Convert To Selection. К данному выделению применен динамичный слой Bevel World с параметром Smoothing, равным 100%. В результате выделенные элементы композиции приобретают рассеянные романтические блики.

Для создания контраста платье девушки выделено с помощью инструмента Magic Wand с параметрами: Tolerance — 2, Feather — 2. К выделенной области применен динамичный слой Bevel World с параметрами, принятыми по умолчанию. К тексту применен динамичный слой Tear с параметрами Margin — 15%, Strength — 10%, Jaggedness — 20%, Tear Color — желтый.

Затем к тексту применен динамичный слой Bevel World с параметрами, принятыми по умолчанию. Текст слит с основным изображением (Objects: Layers > Drop). В завершение область текста выделена с помощью инструмента Реn, преобразована в выделение, к которому применен динамичный слой Bevel World с параметром Smoothing, равным 100%, и желтым цветом светового потока. Полученный слой смещен вниз и вправо. Итоговое изображение приведено на рис. 16.18.

Рис. 16.18. Результат применения динамичного слоя Bevel World к прическе, лицу, рукам, груше и тексту

Упражнение. Применение динамичного слоя Bevel World при создании рельефного изображения

Создадим изображение вывески книжного магазина с названием BOOK WORM (Книжный червь). Постараемся сделать так, чтобы рамка, текст и фон были рельефными.

  1. Создайте новый документ размерами 500 x 333 пикселов, выбрав команду File > New. Для сохранения его выберите команду File > Save as и введите имя BOOK WORM.
  2. Создайте рамку для вывески. Выберите Select > All > Convert to Shape. Задайте параметры формы. Выберите Shape > Set Shape Attributes. Откроется диалоговое окно Shape Attributes. Чтобы отменить заливку, снимите флажок Fill. В левой части устанавливаются параметры обводки. Выберите для обводки ярко-желтый цвет и задайте ширину 20 пикселов. В результате на месте рамки задана желтая полоса.
  3. Откройте секцию Layers палитры Objects и выберите команду Drop and Select. Желтая полоса совмещена с холстом и выделена.
  4. Задайте текстуру поверхности рамки. Выберите Effects > Apply Surface Texture, предварительно выбрав текстуру бумаги Pavement. Параметры в окне диалога Apply Surface Texture оставьте принятыми по умолчанию.
  5. Откройте секцию Dynamic Layers палитры Objects и выберите Bevel World. Установите параметры диалогового окна Bevel World, приведенные в таблице.
  6. Рельефная рамка создана. Перейдите в секцию Layers палитры Objects и нажмите кнопку Drop.

Bevel Control | Значение | Light Control | Значение
Bevel Width | 25% | Light direction | 125
Outside Portion | 5% | Light Height | 51
Rim Slope | 0 | Brightness | 1,50
Cliff Portion | 50% | Scatter | 31%
Cliff Height | 50% | Shine | 41%
Cliff Slope | 45% | Reflection | 25%
Base Slope | 45% |  |
Smoothing | 0 |  |
Bevel Interior Edges | установлен |  |

Перейдем к созданию фона для текста.

  1. С помощью Magic Wand выделите белое поле внутри рамки. В секции Gradients палитры Art Materials выберите градиентную заливку зеленого цвета, чтобы верхняя и нижняя части фона были темными, а средняя часть светлой. А затем выберите Effects > Fill. В диалоговом окне Fill, в области Fill with, установите переключатель Gradation.
  2. Задайте текстуру фона. Выберите в секции Paper палитры Art Materials текстуру бумаги Smooth. Выберите команду Effects > Surface Control > Apply Surface Texture. Установите параметры диалогового окна Apply Surface Texture, приведенные в таблице.
  3. Для отмены выделения выберите Select > Non. Приступим к созданию текста.

Параметр | Значение | Параметр | Значение
Softness | 0 | Reflection | 0
Amount | 150% | Brightness | 1,15
Picture | 100% | Conc | 5,0
Shine | 30% | Exposur | 1,41

Приступим к созданию текста.

  1. Чтобы симметрично расположить текст, выберите команды Canvas > Rulers > Show Rulers и Canvas > Grid Show Grid.
  2. Выберите инструмент Text (Текст). На панели управления выберите шрифт Garamond, Size — 22 пиксела, Tracking — 0. Цвет — ярко-желтый. Расположите текст на двух строках.
  3. Выберите в списке слоев секции Layers палитры Objects символ В. Выберите в меню секции команду Drop and Select. Символ В совмещен с холстом и выделен.
  4. Задайте текстуру поверхности буквы. Выберите в секции Paper палитры Art Materials текстуру бумаги Pavement. Выберите команду Effects > Surface Control > Apply Surface Texture. Параметры палитры Apply Surface Texture оставьте те же, что и при создании рельефа рамки.
  5. В секции Dynamic Layers палитры Objects выберите Bevel World. Параметры палитры Bevel World приведены на рис. 16.19. Рельефный символ В создан.
  6. Повторите указанные действия для всех остальных букв.
  7. На вывеске, сделанной авторами, один из символов имеет дефект. Это второе О в слове BOOK. Буква смещена и еле держится. За ней просматривается оставшийся от нее след. Чтобы получить подобный эффект, при обработке этого символа в окне Apply Surface Texture, в списке поля Using, выберите Image Luminance. След от буквы О готов.
  8. Выберите в списке слоев секции Layers первый символ О. Выберите команду Edit > Copy, а затем Edit > Paste > Normal. Вторая рельефная буква О готова.
  9. Выберите Effects > Orientation > Rotate и в диалоговом окне Rotate Selection установите угол 15 градусов. Дефектная буква готова.
  10. Последняя деталь — пенсне.
  11. Создайте новый документ небольшого размера, например 200 х 100 пикселов. Выберите инструмент Oval Shape (Овальная форма) и при нажатой клавише Shift создайте круглую форму диаметром около 70 пикселов.
  12. Выберите Select > All > Convert to Shape. Задайте параметры формы. Выберите Shape > Shape Attributes. Откроется диалоговое окно Shape Attributes. Отмените заливку, выберите для обводки ярко-желтый цвет и задайте ширину 2 пиксела. Первый круг готов.
  13. Выберите Edit > Copy, а затем Edit > Paste > Normal. Второй круг готов, расположите его на расстоянии 20 пикселов от первого.
  14. Выберите инструмент Реn (Перо) или Quick Curve (Быстрое перо). Соедините оба круга дугой. Объедините три формы в одну. Для этого в списке секции Layers палитры Objects выделите при нажатой клавише Shift позиции каждую из деталей пенсне, а затем выберите в меню секции команды Group и Drop and Select.
  15. Выберите Effects > Surface Control > Apply Surface Texture, предварительно выбрав текстуру бумаги Pavement. Параметры диалогового окна Apply Surface Texture оставьте те же, что и при создании текстуры букв.
  16. В секции Dynamic Layers выберите Bevel World. Параметры диалогового окна Bevel World оставьте те же, что и при создании рельефа букв.
  17. Выберите Edit > Copy, а затем перейдите в документ BOOK WORM и выберите Edit > Paste. Расположите пенсне там, где сочтете нужным.

Рис. 16.19. Параметры диалогового окна Bevel World при создании текста

Вывеска книжного магазина «Книжный червь» готова. У авторов она получилась такой, как на рис. 16.20.

Рис. 16.20. Вывеска для магазина «Книжный червь»

Динамичный слой Liquid Metal

Динамичный слой Liquid Metal (Жидкий Металл) [image] имитирует всевозможные эффекты жидкости с высоким коэффициентом отражения, например, расплавленного металла или ртути. Это могут быть отдельные капли, бусинки, шары, лужи и т. д., вплоть до ртутного дождя или потоков жидкого металла, заливающего исходное изображение. Уменьшив коэффициент отражения, вы можете превратить металл в воду. С помощью этих увлекательных алхимических преобразований удается добиваться эффектов, удивительно преобразующих исходное изображение (рис. 16.21).

Рис. 16.21. Результат применения динамичного слоя Liquid Metal

Динамичный слой Liquid Metal применяется не к активному выделению и не ко всему слою, а используется с помощью своего собственного инструментария, следом за указателем.

Параметры динамичного слоя Liquid Metal

С помощью инструментов диалогового окна Liquid Metal можно создавать отдельные капли, перемещать их, сливать и разъединять, рисовать штрихом из жидкого металла, создавая объемное изображение.

Чтобы открыть диалоговое окно Liquid Metal, в секции Objects палитры Dynamic Layers, выберите в списке динамичный слой Liquid Metal, а затем нажмите кнопку Apply или выберите команду Apply в меню секции. В диалоговом окне Liquid Metal (рис. 16.22) установите параметры динамичного слоя, выберите нужный инструмент и приступайте к работе. Диалоговое окно при этом должно быть открыто.

Рис. 16.22. Диалоговое окно Liquid Metal

Установите параметры динамичного слоя, то есть параметры капли или следа кисти, состоящего также из отдельных капель жидкого металла, используя табл. 16.5.

Таблица 16.5. Параметры динамичного слоя Liquid Metal

Параметр | Устанавливает
Amount (Эффект) | Кривизну каждой капли, а следовательно выразительность металлического эффекта. Положительные величины залают выпуклость, а отрицательные — вогнутость. При значениях, близких к нулю, капля становится плоской
Smooth (Сглаживание) | Плавность перехода от капли к капли в штрихе, то есть регулирует слияние капель. Уменьшая данный параметр, вы разделяете отдельные капли. Напротив, увеличивая сглаживание, вы способствуете слиянию отдельных капель
Size (Размер) | Размер кисти, то есть размер отдельных капель, формирующих штрих или след кисти
Volume (Объем) | Объем капли относительно начального диаметра, задаваемого ползунком Size. Перемещая ползунок вправо, вы раздуваете каплю. Перемещая ползунок влево, вы можете уменьшить объем капель настолько, что сделаете их невидимыми
Spacing (Промежуток) | Расстояние между точками приложения инструмента, то есть между отдельными каплями в штрихе
Refraction (Преломление) | Преломляющие свойства жидкого металла. Уменьшая преломление, вы уменьшаете количество отраженного света, делаете капли более прозрачными. Перемещая регулятор влево, вы увеличиваете количество отраженного света, придаете каплям металлический блеск
Surface Tension (Поверхностное натяжение) | Флажок установлен по умолчанию, снятие флажка приводит к втягиванию капель, делая их вогнутыми
Map (Карта) | Параметры материала в раскрывающемся меню
Standard Metal (Обычный метал) | Эффект жидкого металла типа ртути
Chrome1 (Хром1) | Серый блестящий металл
Chrome2 (Хром2) | Аналогичный предыдущему, но с другими отражающими свойствами
Interior (Внутренний вид) | Внутренний вид некоего помещения
Clone Source (Источник клонирования) | Изображение, заданное в качестве источника клонирования; если таковое не задано, вместо него используется активный шаблон
Display Handles (Показать метки) | Выводит на экран центр каждой капли и ограничивающую окружность
Rain (Дождь) | Случайное распределение капель по поверхности изображения
Сlear (Очистить) | Удаляет динамичный слой Liquid Metal из изображения
Reset (Возврат) | Возврат к параметрам, заданным по умолчанию

После установки параметров нажмите кнопку ОК, диалоговое окно закроется. Чтобы использовать в одной работе различные параметры слоя, необходимо каждый раз устанавливать новые параметры, подтверждать их назначение нажатием кнопки ОК и закрывать диалоговое окно.

ПРИМЕЧАНИЕ. Если вы закрыли диалоговое окно, то при следующем открытии вы не сможете изменить уже существующие параметры или удалить капли из изображения.

Инструменты динамичного слоя Liquid Metal

Возможные варианты инструментов динамичного слоя Liquid Metal — Круг, Стрелка и Кисть выбираются нажатием соответствующих кнопок в левой части диалогового окна.

Непосредственно для создания капель предназначен вариант Круг [image]. Выбрав вариант Круг, установите указатель мыши в нужном месте изображения. Указатель при этом приобретает форму круга. Перемещая указатель, вы меняете размер капли. По достижении нужного размера, отпустите кнопку мыши. Переместить каплю с помощью Круга вы не можете.

При максимальном значении параметра ползунка Amount и достаточно большом размере капли, в ней видны отражение мастерской и штатив фотоаппарата в момент, когда была сфотографирована капля ртути (рис. 16.23). изображение которой использовано при создании плавающего слоя Liquid Metal.

Рис. 16.23. Капля, использованная при создании плавающего динамичного слоя Liquid Metal

В качестве примера использования инструмента Круг на рис. 16.24 приведена композиция с девушкой под зонтом.

Рис. 16.24. Результат применения динамичного слоя Liquid Metal, вариант Круг

Вариант Стрелка [image] служит для выделения отдельных капель. После выделения капли вы можете ее переместить в любое место изображения.

Для удобства работы с вариантом Стрелка установите флажок Display Handles. При этом появляется маркер капли, выделяющийся на фоне капли.

Для выделения отдельной капли установите указатель на маркере и нажмите кнопку мыши. Указатель примет форму квадрата. Чтобы распространить выделение на другую каплю, щелкните на ней мышью при нажатой клавише Shift.

Для снятия выделения с капли щелкните на ней мышью при нажатой клавише Alt.

Выделенную каплю или группу капель можно редактировать, изменяя ее параметры, перемещать с помощью мыши или удалить, нажав на клавишу Backspace или Delete.

Вариант Кисть [image] оставляет рельефный след, состоящий из сливающихся вместе капель жидкого металла, и предназначен для рисования штрихом из жидкого металла (рис. 16.25).

Рис. 16.25. Изображение выполнено вариантом Кисть

Чтобы изменить размер кисти по ходу создания рисунка, активизируйте вариант Стрелка и щелкните за пределами рисунка, затем вновь активизируйте вариант Кисть и измените его размер.

Чтобы удалить рисунок, созданный вариантом Кисть, обработайте его вариантом Кисть при нажатой клавише Alt или нажмите кнопку Clear.

Рассмотрим несколько примеров применения динамичного слоя Liquid Metal.

На рис. 16.26 приведен результат применения динамичного слоя Liquid Metal, вариант Кисть. Исходное изображение приведено сверху слева, оно же использовано в качестве источника клонирования. Внизу слева — одиночная капля. Штрих с параметрами динамичного слоя Liquid Metal нанесен в нижней части исходного изображения, имитируя реку с отражением деревьев.

Рис. 16.26. Результат применения динамичного слоя Liquid Metai, вариант Кисть

Металлический блеск, получающийся при выборе различных вариантов в раскрывающемся меню Map, обладает достаточной художественной выразительностью, чтобы полностью изменить впечатление от исходного изображения после применения динамичного слоя Liquid Metal.

В качестве исходного изображения взят фотографический натюрморт, приведенный на рис. 16.27.

Рис. 16.27. Исходное изображение

Обработку изображения выполните в два этапа.

  1. Сначала примените к исходному изображению динамичный слой Liquid Metal с параметрами, взятыми по умолчанию, выбрав Interior в раскрывающемся меню Map.
  2. Нажмите кнопку Rain, дождитесь, пока «жидким металлом» покроется все изображение, остановите процесс щелчком мыши.
  3. Совместите плавающий слой с исходным изображением, выбрав команду Layers > Drop, а в раскрывающемся меню Composite Method — пункт Overlay.
  4. На втором этапе к полученному изображению примените еще раз динамичный слой Liquid Metal с параметрами, взятыми по умолчанию. Повторите действия, выбрав Chrome1 в меню Map.
  5. При совмещении следующего плавающего объекта с исходным изображением (Layers > Drop) выберите Soft Light в раскрывающемся меню Composite Method.

Итоговое изображение натюрморта после двукратного применения динамичного слоя Liquid Metal приведено на рис. 16.28.

Рис. 16.28. Итоговое изображение

Упражнение. Использование динамичного слоя Liquid Metal при работе с текстом

Рассмотрим использование художественных возможностей динамичного слоя Liquid Metal при работе с текстом. Создадим рекламный постер для гостиницы с названием «Серебряный ручей»: Welcome to the «Silver Brook» (Добро пожаловать в гостиницу «Серебряный ручей»). За основу возьмем фотографию горного ручья, приведенную на рис. 16.29.

Рис. 16.29. Основа для создания рекламного постера — фотография горного ручья

  1. Создайте новый документ, равный по размерам исходному изображению, и примените к нему динамичный слой Liquid Lens (вариант Rain) так, чтобы он покрыл все изображение.
  2. Активизируйте инструмент Text с параметрами: Font Size — 80, Tracking — 0.0, Font — Arial Black. Введите первое слово рекламного текста. Выберите команду Layer > Group, а затем Shapes > Set Shapes Attribute и снимите флажки Stroke и Fill, в результате текст исчезнет с экрана. Преобразуйте форму в выделение, выбрав Shapes > Convert to Selection, текст вновь появится на экране, на этот раз в качестве выделения.
  3. Чтобы создать эффект деформации букв потоком ручья, примените к выделенному тексту динамичный слой Tear с параметрами Margin — 1%, Strength — 50%, Jaggedness — 50%, цвет обрыва — белый.
  4. Перенесите первое слово рекламного текста на исходное изображение, выбрав команды Edit > Copy, Edit > Paste. Выберите команду Effects > Orientation > Distort и деформируйте текст таким образом, чтобы получить эффект букв, плывущих по воде. Совместите слово с исходным изображением (Layers > Drop). При совмещении в списке Composite Method выберите Normal.
  5. Повторите указанные действия для остальных слов рекламного текста, а в последнем слове для каждой буквы. Деформируйте буквы последнего слова так, чтобы создалось впечатление, что ручей, подхватив слово, разделяет его на буквы.

Итоговое изображение рекламного текста, подхваченного горным ручьем, приведено на рис. 16.30.

Рис. 16.30. Итоговое изображение рекламного текста, подхваченного горным ручьем

Упражнение. Создание изображения из серии «Искусственные атмосферные явления»

Рассмотрим еще один пример. Исходное изображение скалистого плато приведено на рис. 16.31.

Рис. 16.31. Исходное изображение скалистого плато

  1. Сначала создайте клон исходного изображения, выбрав команду File > Clone. Исходное изображение задайте в качестве источника клонирования (выберите File > Clone Source).
  2. К клону примените динамичный слой Liquid Metal в варианте Круг с параметрами: Amount — 5, Smooth — 100%, Volume — 100%, Map: Clone Source, Refraction — 0, Surface Tension — установлен. Динамичный слой Liquid Metal примените несколько раз подряд, чтобы получилась вереница шаров, исчезающих за горизонтом.
  3. Плавающий объект совместите с холстом и выделите, выбрав Layers > Drop and Select, вокруг него задайте минимальную область растушевки размером в один пиксел, выбрав Select > Feather.
  4. Примените динамичный слой Bevel World с параметрами, взятыми по умолчанию, за исключением Base Slope — 0 градусов и Smoothing — 100%. Плавающий объект перенесите на исходное изображение (выберите Edit > Copy; Edit > Paste > Normal) и совместите с холстом (Layers > Drop), при этом на панели Layer Adjuster в списке Composite Method выберите Overlay.

Итоговое изображение пейзажа с искусственным атмосферным явлением — артефактом в виде вереницы полупрозрачных шаров-линз приведено на рис. 16.32.

Рис. 16.32. Итоговое изображение пейзажа


Динамичные слои над всем холстом

  • Динамичный слой Brightness/Contrast
    • Применение динамичного слоя Brightness/Contrast
  • Динамичный слой Equalize
    • Установка параметров динамичного слоя Equalize
    • Упражнение. Создание и корректировка черно-белой фотографии
  • Динамичный слой Posterize
    • Применение динамичного слоя Posterize
  • Динамичный слой Glass Distortion
    • Создание эффекта Glass Distortion
  • Динамичный слой Liquid Lens
    • Упражнение. Обработка изображения с помощью эффекта Liquid Lens
    • Упражнение. Создание рекламной надписи
    • Упражнение. Совместное применение динамичных слоев Liquid Lens и Bevel World
  • Динамичный слой Kaleidoscope

Эффекты, при которых динамичный слой создается надо всем холстом; за основу берется исходное изображение или Layer

В следующих разделах мы рассмотрим тип эффектов, при которых динамичный слой создается над всем холстом, при этом за основу берется исходное изображение или Layer. К таким эффектам относятся:

  • Brightness/Contrast (Яркость/Контрастность);
  • Equalize (Выравнивание);
  • Posterize (Постер);
  • Glass Distortion (Сквозь стекло);
  • Kaleidoscope (Калейдоскоп);
  • Liquid Lens (Текучая линза).

Динамичный слой Brightness/Contrast

Динамичный слой Brightness/Contrast (Яркость/Контрастность) позволяет корректировать цвета, изменяя соотношение между яркостью и контрастностью для всего изображения. Это незаменимый инструмент при работе с фотографиями. Слой Brightness/Contrast регулирует соотношение между яркостью и контрастностью для всего находящегося под ним изображения, включая обычные слои. Применение динамичного слоя Brightness/Contrast подобно выбору команды Effects > Tonal Control > Brightness/Contrast (Эффекты > Управление тоном > Яркость/Контрастность). Разница в том, что динамичный слой создается надо всем документом и ликвидирует любое выделение. При этом у вас появляется возможность получать интересные эффекты при совмещении слоя с холстом, изменяя установки в раскрывающемся меню Composite Method (Способ объединения) на панели Controls: Adjuster (Управление: Регулятор). Аналогичная команда из меню Effects применяется как ко всему изображению, так и к выделенной его части. Однако вы лишаетесь возможности изменять установки при совмещении плавающего объекта с холстом.

Чтобы применить динамичный слой Brightness/Contrast, достаточно выбрать его в секции Dynamic Layers и нажать кнопку Apply или выбрать команду Apply.

Откроется диалоговое окно Brightness/Contrast (рис. 17.1). С помощью ползунков установите нужный уровень яркости и контрастности и нажмите кнопку ОК.

Рис. 17.1. Результат применения динамичного слоя Brightness/Contrast. Слева — исходное изображение

Чтобы вернуться к исходным параметрам изображения, нажмите кнопку Reset.

Для изменения соотношения Яркость/Контрастность в уже созданном динамичном слое Brightness/Contrast дважды щелкните мышью на его строке в секции Layers или раскройте меню секции и выберите команду Options. Откроется диалоговое окно Brightness/Contrast, в котором можно изменить уровни яркости и контрастности.

Уменьшить яркость и контрастность для части изображения можно ползунком Opacity на контрольной панели Controls: Adjuster. Для этого необходимо выделить заданную область и преобразовать ее в слой, выбрав команду Select > Float (Выделить > Всплыть) (рис. 17.2).

Рис. 17.2. Уменьшение яркости и контрастности для части изображения с помощью плавного ползунка Opacity на контрольной панели Controls: Adjuster

Применение динамичного слоя Brightness/Contrast

Применение динамичного слоя Brightness/Contrast позволяет получить интересные эффекты, особенно в сочетании с возможностями применения различных способов совмещения динамичного слоя с холстом.

В качестве примера рассмотрим несколько вариантов применения динамичного слоя Brightness/Contrast к одному и тому же исходному изображению.

На рис. 17.3 приведено исходное изображение городка в долине на фоне гор, с которым мы будем работать.

Рис. 17.3. Исходное изображение

  1. Сначала выделите небо с помощью Lasso и скопируйте его в буфер.
  2. К исходному изображению примените динамичный слой Brightness/Contrast. Ползунок Brightness установите в нулевое положение. Ползунок Contrast — на одной трети шкалы слева.
  3. Затем из буфера извлеките изображение неба, причем слой с изображением неба установите над динамичным слоем Brightness/Contrast, благодаря чему эффект изменения яркости и контрастности на нем не проявится.
  4. При совмещении слоя Brightness/Contrast и исходного изображения выберите Magic Combine (Волшебное сочетание) в раскрывающемся меню Composite Method на панели Controls: Adjuster. В итоге, на погруженную во тьму долину наложено светлое небо (рис. 17.4).
  5. Снова выделите небо, выбрав команду Color Select, установите параметры: Hue — 15%, Saturation — 10%, Value — 20% и для всех этих параметров Feather — 100%. Выберите Select > Invert (Выделение > Обратное). Выделилось изображение гор и долины, которое скопируйте в буфер.
  6. Применив динамичный слой Brightness/Contrast к исходному изображению и поместив над этим слоем изображение гор и долины, вы получите совершенно другое впечатление от итогового изображения (рис. 17.5).
  7. При совмещении слоя Brightness/Contrast и исходного изображения также выберите Magic Combine в раскрывающемся меню Composite Method на панели Controls: Adjuster.
  8. Затем к изображению примените динамичный слой Brightness/Contrast. Ползунок Brightness установите на одной трети шкалы слева. Ползунок Contrast установите в нулевое положение.
  9. Теперь выделите горы, выбрав команду Color Select. Затем выделение преобразуйте в плавающий объект, выбрав Select > Float.
  10. Плавающий объект, соответствующий выделенной части изображения, поместите над динамичным слоем Brightness/Contrast. При совмещении слоя Brightness/Contrast и исходного изображения выберите Luminocity (Яркость) в раскрывающемся меню Composite Method на панели Controls: Adjuster. В результате создается впечатление рассвета, освещающего спящий город, подернутый дымкой тумана (рис. 17.6).

Рис. 17.4. Применение динамичного слоя Brightness/Contrast

Рис. 17.5. Изображение помещено над слоем Brightness/Contrast

Рис. 17.6. Итоговое изображение

Динамичный слой Equalize

Динамичный слой Equalize (Выравнивание) [image] создает корректирующий слой над исходным изображением и позволяет изменять яркость и контрастность исходного изображения.

Эффект динамичного слоя Equalize достигается регулированием общего уровня яркости изображения или установлением соотношения между количеством черных и белых точек, распределенных в изображении. Разумеется, при этом меняется и впечатление, производимое исходным изображением (рис. 17.8).

Рис. 17.8. Применение динамичного слоя Equalize к части изображения, слева — исходное изображение, справа — результат

Динамичный слой Equalize применяется аналогично предыдущему варианту, то есть не требует активного выделения.

В секции Dynamic Layers палитры Objects выберите динамичный слой Equalize, нажмите кнопку Apply или в меню секции выберите команду Apply. Откроется диалоговое окно Equalize (рис. 17.7). При этом формируется корректирующий динамичный слой, равный по размеру исходному изображению.

Рис. 17.7. Диалоговое окно Equalize

Установка параметров динамичного слоя Equalize

В верхней части диалогового окна приведено распределение пикселов по уровням яркости. Положение правого (белого) ползунка задает справа от него количество пикселов, окрашенных в белый цвет. Соответственно положение левого (черного) ползунка задает слева от него количество пикселов, окрашенных в черный цвет. Точки между правым и левым ползунками имеют окраску в градациях серого.

  1. Меняя положение левого и правого ползунков, задайте контрастность изображения. Наиболее яркие точки справа от белого ползунка становятся белыми, а наименее яркие точки слева от черного ползунка становятся черными.
  2. В нижней части диалогового окна находится ползунок яркости для всего изображения в целом, то есть, без изменения соотношения между количеством белых и черных пикселов. Перемещая ползунок, задайте уровень яркости всего изображения и нажмите кнопку ОК.

Чтобы изменить установки динамичного слоя Equalize:

  1. Выделите данный слой в списке секции Dynamic Layers палитры Objects.
  2. Выберите в меню секции команду Options или дважды щелкните мышью на соответствующей строке списка Layers. Откроется диалоговое окно Equalize.
  3. Задайте новые параметры контрастности и яркости.

Можно применить динамичный слой Equalize к части изображения, имеющей неправильную форму. Для этого:

  1. Создайте копию изображения, выбрав команду File > Clone, и примените к ней динамичный слой Equalize.
  2. С помощью подходящего инструмента выделите необходимый элемент изображения, скопируйте его, выбрав команду Edit > Сору, и перенесите на оригинал исходного изображения, выбрав Edit > Paste.

В качестве примера приведено изображение вазы, обработанное с помощью динамичного слоя Equalize, выделенное с помощью инструмента Реn (Перо) и помещенное на серый фон исходного изображения (рис. 17.8).

Аналогично примените динамичный слой Equalize ко всему изображению, за исключением заданного элемента:

  1. С помощью подходящего инструмента выделите необходимый элемент изображения и скопируйте его, выбрав команду Edit > Copy.
  2. Примените динамичный слой Equalize ко всему изображению.
  3. Перенесите сохраненную копию элемента на исходное изображение, выбрав команду Edit > Paste, и совместите ее с оригиналом.

Упражнение. Создание и корректировка черно-белой фотографии

Динамичный слой Equalize — весьма полезный инструмент и для корректировки черно-белой фотографии.

  1. Раскройте исходное изображение (рис. 17.9) и создайте его клон, выбрав команду File > Clone.
  2. Создайте негатив исходного изображения. Выделите клон, выбрав команду Select > All, создайте его копию, выбрав Edit > Сору, и совместите копию с клоном, выбрав Edit > Paste. При этом в раскрывающемся меню Composite Method панели управления Control: Adjuster выберите Reverse-Out (Обратный снаружи), установите Opacity — 100%.
  3. В секции Layer палитры Objects выберите команду Layer > Drop. Выделите негатив, выбрав команду Select > All, скопируйте его, выбрав Edit > Copy, и совместите с исходным изображением, выбрав Edit > Paste. При этом в раскрывающемся меню Composite Method выберите Hue (Тон), Opacity — 50%. Черно-белое изображение готово (рис. 17.10). Изображение в градации серого получится также, если в меню Composite Method вы выберите Color или Colorize (Раскрашивающий).
  4. Чтобы откорректировать контрастность полученного изображения, примените к нему динамичный слой Equalize. В диалоговом окне Equalize уменьшите контрастность черно-белого изображения. Для этого установите ползунки, определяющие количество черных и белых точек, в крайние положения (правый — в крайне правое положение, а левый — в крайне левое). В результате черно-белое изображение становится менее контрастным. Мягкие серые тона создают эффект старой фотографии (рис. 17.11).
  5. Чтобы придать изображению оттенок поблекшей старой фотографии, воспользуемся цветовой корректировкой. Выберите Effects > Tonal Control > Correc: Color (Эффекты > Управление тоном > Цветовая коррекция). Откроется диалоговое окно Color Correction. В меню, расположенном в нижней части окна, выберите Curve (Кривая) и активизируйте корректировку красного оттенка. Установив указатель мыши на кривой, откорректируйте оттенок изображения.
  6. Выберите текстуру в секции Paper. Примените эффект текстуры к полученному изображению, выбрав команду Effects > Surface Control > Apply Surface Texture (Эффекты > Управление поверхностью > Наложить текстуру на поверхность). Создайте, с помощью инструмента выделения прямоугольной формы рамку. Получаем итоговое изображение поблекшей черно-белой фотографии (рис. 17.12).

Рис. 17.9. Исходное изображение

Рис. 17.10. Изображение в градации серого

Рис. 17.11. Корректировка контрастности

Рис. 17.12. Полученная черно-белая «старая» фотография

Небольшие преобразования черно-белого изображения после цветовой коррекции позволяют создать почти симметричную панораму.

  1. Создайте новый документ двойной ширины и скопируйте в него дважды черно-белое изображение, полученное после цветовой коррекции. Одну из копий разверните зеркально по горизонтали, выбрав Effects > Orientation > Flip Horizontal (Эффекты > Положение > Горизонтальный переворот), и создайте симметричную панораму из этих двух изображений.
  2. Вертикальный шов в месте соединения обработайте кистью Photo (вариант Scratch Remover), или кистью Cloners (вариант Soft Cloner), размер кисти 3-5 пикселов. Панорама, полученная из черно-белого изображения, представлена на рис. 17.13.

Рис. 17.13. Итоговое изображение панорамы

Динамичный слой Posterize

Динамичный слой Posterize [image] создает надо всем исходным изображением корректирующий слой с заданным числом уровней яркости в градации серого. В результате создается новое изображение, разделенное по оттенкам на области равной яркости. Такое изображение напоминает гравюру, плакат, постер и т. п. (рис. 17.14).

Рис. 17.14. Результат применения динамичного слоя Posterize

Динамичный слой Posterize применяется аналогично предыдущим слоям этой группы. Для этого достаточно выбрать его в секции Dynamic Layers, нажать кнопку Apply или выбрать команду Apply. В результате откроется диалоговое окно Posterize (рис. 17.15). Задайте нужное количество уровней яркости и нажмите кнопку ОК.

Рис. 17.15. Диалоговое окно Posterize и контрольная панель Control: Adjuster

Команда, аналогичная динамичному слою Posterize, имеется в меню Effects > Tonal Control (Эффекты > Управление тоном). Выбрав команду Effects > Тоnаl Control > Posterize, вы можете задать несколько уровней яркости к любой выделенной области любой конфигурации, но при этом корректирующий слой отсутствует и изменяется само исходное изображение. Напротив, при использовании динамичного слоя Posterize корректирующий слой создается над всем изображением. При совмещении плавающего слоя с холстом можно пользоваться меню Composite Method.

СОВЕТ. Работая с динамичным слоем Posterize, при совмещении плавающего слоя с исходным изображением не забывайте про возможности раскрывающегося меню Composite Method на панели Controls: Adjuster.

Компромиссный вариант состоит в создании клона исходного изображения, выделении нужной области и выбора команды Effects > Tonal Control > Posterize. Затем область, выделенная и обработанная с помощью команд Edit > Copy, Edit > Paste, может быть совмещена с исходным изображением с использованием возможностей меню Composite Method.

Применение динамичного слоя Posterize

Рассмотрим в качестве примера создание постера из исходного изображения Колизея, сфотографированного в мягком свете облачного вечера (рис. 17.16).

Рис. 17.16. Исходное изображение Колизея

  1. Выберите инструмент Text, установите его параметры на панели управления (Point Size — 50, Tracking — 0, Font — Arial Black ) и введите слово Colesseum в нижней части рисунка.
  2. Выберите Effects > Orientation > Distort (Эффекты > Положение > Искажение) деформируйте текст так, чтобы создать эффект лежащих букв. Преобразуйте текст в выделение, выбрав команду Shapes > Convert to Selection (Форма > Преобразовать в выделение), и заполните его, выбрав команду Effects > Fill (Эффекты > Заполнить), подходящим изображением (в данном случае взята фотография камней на дне мелкого ручья).
  3. Примените к данному изображению динамичный слой Posterize, задав число уровней, равное двум. При совмещении плавающего слоя с исходным изображением выберите Luminosity в раскрывающемся меню Composite Method и задайте уровень непрозрачности равным 75%. В результате получено изображение Колизея, имитирующее гравюру (рис. 17.17).

Рис. 17.17. Результат применения динамичного слоя Posterize с числом уровней, равным двум

В следующем примере покажем, что результат применения динамичного слоя Posterize может быть достаточно выразителен. Исходное изображение горного пейзажа приведено на рис. 17.18.

Рис. 17.18. Исходное изображение горного пейзажа

  1. Примените к исходному изображению динамичный слой Posterize с числом уровней, равным семи.
  2. При совмещении плавающего слоя с исходным изображением выберите Pseudocolor (Ложный цвет) в раскрывающемся меню Composite Method, уровень непрозрачности равен 100%.
  3. Создайте новый документ, увеличив его размеры по ширине в два раза, и перенесите туда полученное изображение дважды, выбирая команды Edit > Copy, Edit > Paste.
  4. Первую копию разместите в левой части нового документа, а вторую копию зеркально разверните по горизонтали, выбрав Effects > Orientation > Horizontal Flip (Эффекты > Положение > Горизонвальный переворот), и совместите с первой.
  5. Создайте рамку, для чего выберите Select > All (Выделить все), Select > Convert to Shape (Выделить > Преобразовать в форму), установите атрибуты формы, выбрав Shapes > Set Shape Attributes (Формы > Установить параметры формы), снимите флажок заливки Fill (Заполнить) и установите флажок обводки Stroke (Обводка). Итоговое изображение, симметричный горный пейзаж, приведено на рис. 17.19.

Рис. 17.19. Итоговое изображение — симметричный горный пейзаж

Динамичный слой Glass Distortion

Динамичный слой Glass Distortion (Сквозь стекло) [image] создает эффект неровного, запотевшего, мокрого или замерзшего стекла, наложенного на исходное изображение (рис. 17.20).

Рис. 17.20. Применение эффекта Glass Distortion

Динамичный слой Glass Distortion применяется к выделенной области изображения, над которой создается плавающий слой с эффектом неровного стекла.

ПРИМЕЧАНИЕ. Если отсутствует предварительное выделение, то по умолчанию эффект применяется к плавающему слою, размером 100 х 100 пикселов, который можно перемещать над исходным изображением с помощью инструмента Layer Adjuster.

Перемещая данный плавающий слой с помощью инструмента Layer Adjuster, можно наблюдать действие динамичного слоя по всему изображению.

Эффект смещения может быть пропорционален:

  • текстуре бумаги, установленной в данный момент в секции Paper палитры Art Materials;
  • текущему выделению;
  • яркости исходного изображения;
  • яркости изображения, заданного в качестве источника клонирования в меню File > Clone Source (Файл > Клонировать источник).

Создание эффекта Glass Distortion

Эффект неровного или мокрого стекла создается следующим образом:

  1. Выделите все исходное изображение или часть его.
  2. Выберите динамичный слой Glass Distortion в секции Dynamic Layers палитры Objects. Нажмите кнопку Apply или выберите команду Apply в меню секции. В результате формируется плавающий слой, совпадающий с выделенным изображением. Откроется диалоговое окно Glass Distortion Options (Параметры искажения стеклом) (рис. 17.21).
  3. Установите параметры динамичного слоя (табл. 17.1). Нажмите кнопку ОК.

ПРИМЕЧАНИЕ. Если источник клонирования не указан, при выборе параметра Original Luminance в качестве источника клонирования по умолчанию используется установленный шаблон на палитре Art Materials.

Рис. 17.21. Диалоговое окно Glass Distortion Options

Таблица 17.1. Параметры динамичного слоя Glass Distortion

Параметр | Устанавливает
Using (Использование) | Основу для построения карты смещений, имитирующих эффект мокрого или неровного стекла
Paper (Бумага) | Эффект текстуры бумаги, установленной в данный момент в секции Paper палитры Art Materials
Current Selection (Текущее выделение) | Эффект, определяемый текущим выделением. Если выделение конвертировано в маску, то в меню автоматически появляется Current Mask (Текущая маска) и для создания эффекта используется изображение маски в градациях серого
Image Luminance (Яркость изображения) | Эффект, задаваемый яркостью исходного изображения
Оriginal Luminance (Яркость оригинала) | Эффект, задаваемый яркостью источника клонирования, выбранного в меню File > Clone Source
Preview (Предварительный просмотр) | Предварительный просмотр
Inverted (Инвертированный) | Построение негативной карты смещений для основы, заданной в меню Using
Softness (Плавность) | Смещение области плавного цветового перехода
Amount (Количество) | Степень эффекта, то есть величину смещений, искажающих исходное изображение
Variance (Изменение) | Смещение размеров области, затронутой искажением, вокруг каждой точки

Рассмотрим пример, в котором в качестве основы для создания эффекта Glass Distortion принята яркость клонируемого изображения (в списке Using выбран Original Luminance).

Исходное изображение — закатный морской пейзаж (рис. 17.22).

Рис. 17.22. Исходное изображение

Создадим на небе искусственное атмосферное явление, имеющее форму звезды, а в воде вместо отражения — волны, разбегающиеся в форме звезды. Изображение звезды на небе создадим с помощью выделения. Разбегающиеся волны в форме звезды создадим с помощью заготовки-источника клонирования.

Для этого:

  1. Создайте новый документ, равный по размеру исходному изображению. Для создания звезды используем выделение в форме семиконечной звезды из стандартной библиотеки. Выберите Select > Selection Portfolio (Выделить > Коллекция выделений) и перетащите выделение в форме семпконечной звезды в нижнюю часть документа.
  2. Преобразуйте данное выделение в форму, выбрав Select > Convert to Shape (Выделить > Преобразовать в форму), деформируйте так, как должно выглядеть отражение, то есть сожмите верхнюю часть и растяните нижнюю, выбрав команду Effects > Orientation > Distort.
  3. Задайте параметры обводки, выбрав Shapes > Set Shape Attributes, и совместите с холстом (в секции Layers палитры Objects нажмите кнопку Drop).
  4. С помощью пера дорисуйте внешние лучи звезды большего размера. Основа для создания волн, разбегающихся в форме звезды, готова (рис. 17.23).
  5. В этом же документе подберите размеры и форму выделения для создания изображения на небе. Переместите еще раз выделение в форме семиконечной звезды из стандартной библиотеки, деформируйте его так, чтобы оно соответствовало уже созданному отражению, скопируйте, выбрав Edit > Copy, и перенесите это выделение на исходное изображение, выбрав Edit > Paste.
  6. Примените к созданному выделению динамичный слой Glass Distortion с параметрами: Using — Current Selection, Softness — 3.0, Amount — 0.10, Variance — 4.5.
  7. Примените динамичный слой Glass Distortion еще раз, задав в качестве источника документ-заготовку: Using — Original Luminance, Softness — 3.0, Amount — 0.04, Variance — 1.0. Совместите плавающий слой с холстом в секции Layers палитры Objects, выбрав в меню секции команду Drop All. Изображение искусственного атмосферного явления готово (рис. 17.24).

Рис. 17.23. Заготовка источника клонирования для создания разбегающихся волн в форме звезды

Рис. 17.24. Результат применения динамичного слоя Giass Distortion

Динамичный слой Liquid Lens

Динамичный слой Liquid Lens (Текучая линза) [image] удивительным образом имитирует эффекты, создаваемые каплями дождя, неровным стеклом или слоем воды, а также позволяет деформировать изображения, создавая эффекты кривого зеркала (рис. 17.25). Динамичный слой Liquid Lens применяется ко всему изображению.

Рис. 17.25. Применение динамичного слоя Liquid Lens, вариант Кисть

Диалоговое окно Liquid Lens открывается, как обычно, при выборе эффекта и нажатии кнопки Apply. В левой части окна расположены кнопки инструментов, позволяющих применить эффект Liquid Lens, в правой части — параметры настройки этих инструментов (рис. 17.26). Состав диалогового окна Liquid Lens приведен в табл. 17.2, 17.3.

Рис. 17.26. Диалоговое окно Liquid Lens

Таблица 17.2. Диалоговое окно Liquid Lens

Состав | Описание
Amount (Количество) | Ползунок. Устанавливает величину искажения. Положительные величины задают искажения в направлении перемещения указателя, отрицательные — в противоположном направлении
Size (Размер) | Ползунок. Устанавливает размер инструмента, то есть размер штриха однократно деформируемой области или размер одной капли линзы
Smooth (Сглаживание) | Ползунок. Устанавливает плавность перехода от деформированной области к неизмененному изображению. Уменьшая данный параметр, вы делаете переход более резким, контрастным. Напротив, увеличивая сглаживание, вы делайте переход плавным, при больших значениях практически незаметным
Spacing (Промежуток) | Ползунок. Устанавливает расстояние между однократно деформируемыми областями или между отдельными каплями линзы
Rain (Дождь) | Кнопка. Включает случайное деформирование изображения под отдельными падающими каплями, причем смещение происходит сверху вниз. Для отмены щелкните мышью в .побои точке изображения
Clear (Очистить) | Кнопка возврата к исходному недеформированному изображению
Reset (Возврат) | Кнопка возврата к параметрам, заданным но умолчанию

Таблица 17.3. Инструменты диалогового окна Liquid Lens и их назначение

Кнопка | Название | Смещение
 | Circle (Круг) | Деталей по окружности
 | Eraser (Ластик) | Удаляет смещение, созданное другими инструментами
 | Right Twirl (Правый поворот) | По ходу и вправо
 | Left Twirl (Левый поворот) | По ходу и влево
 | Bugle (Выпуклость) | По ходу и наружу
 | Pinch (Вогнутость) | По ходу и внутрь
 | Brush (Кисть) | Смещение по ходу указателя мыши

Различные варианты применения эффекта Liquid Lens приведены на рис. 17.27, 17.28, 17.29, 17.30, 17.31 и 17.32.

Рис. 17.27. Результат применения динамичного слоя Liquid Lens

Варианты Left Twirl (Левый поворот) или Right Twirl (Правый поворот) (рис. 17.28) деформируют изображение с поворотом налево или направо в пределах круга, заданного ползунком Size.

Рис. 17.28. Результат применения динамичного слоя Liquid Lens, варианты нижний и верхний поворот, исходное изображение — в центре

Вариант Bugle (Выпуклость) (рис. 17.29) деформирует изображение в обе стороны от траектории указателя, а также по направлению его перемещения. Наиболее интересные результаты получаются при комбинированном использовании различных вариантов эффекта Liquid Lens.

Рис. 17.29. Результат применения динамичного слоя Liquid Lens, вариант Выпуклость (применен к варианту Круг)

На рис. 17.30 — результат многократного применения динамичного слоя Liquid Lens, вариант Pinch (Вогнутость) с низким значением сглаживания (2%).

Рис. 17.30. Результат применения варианта Вогнутость

Вариант Eraser (Ластик) восстанавливает исходное изображение в пределах заданного размера. Переход от измененного изображения к исходному определяется параметром сглаживания.

На рис. 17.31 — результат многократного применения динамичного слоя Liquid Lens, обработка изображения вариантом Ластик после применения варианта Выпуклость с максимальным эффектом и высоким параметром сглаживания — 175%.

Рис. 17.31. Результат обработки изображения вариантом Ластик

Вариант Brush (Кисть) деформирует исходное изображение в направлении движения указателя в пределах области, задаваемой размером инструмента.

На рис. 17.32 результат применения динамичного слоя Liquid Lens, вариант Brush (Кисть) при маленьком размере и высокой сглаженности. Все лица на коллаже получены обработкой лица, приведенного на исходном изображении.

Рис. 17.32. Исходное изображение лица вверху, следующие — после применения варианта Кисть

Упражнение. Обработка изображения с помощью эффекта Liquid Lens

Динамичный слой Liquid Lens — это мощный инструмент, позволяющий радикально изменить исходное изображение.

В качестве примера рассмотрим применение динамичного слоя Liquid Lens к исходной фотографии закатного Нью-Йорка (рис. 17.33).

Рис. 17.33. Исходная фотография закатного Нью-Йорка

  1. Создайте клон исходного изображения, выбрав File > Clone.
  2. К данному клону несколько раз подряд примените динамичный слой Liquid Lens в варианте Circle (Круг) с параметрами: Amount — 1.0, Smooth — 200%. Направление искажения задается снизу вверх от нижней кромки рисунка, изображение города как бы задирается кверху, при этом старайтесь, чтобы два небоскреба, определяющих центр композиции, оставались вертикальными.
  3. После деформации плавающий слой совместите с холстом, выбрав команду Layers > Drop.
  4. В изображении города и неба над ним выделите часть изображения, окрашенную в самые темные тона, инструментом Magic wand (Волшебная палочка) с минимальными значениями параметров (Tolerance — 3.0, Feather — 0.0), а затем выделение переносите на остальную часть изображения, выбрав команду Select > Invert (Выделить > Обратное).
  5. Скопируйте выделенную область, состоящую из города и неба над ним, выбрав команду Edit > Сору, и перенесите на исходное изображение, выбрав Edit > Paste.
  6. Данный плавающий слой совместите с исходным изображением в секции Layers, при этом в списке Composite Method выберите Magic Combine.
  7. Повторите несколько раз шаги 2 и 3, каждый раз увеличивая деформируемую область. Не забудьте совмещать плавающий слой с холстом, выбирая команду Layers > Drop (Слой > Опустить). После многократного применения динамичного слоя Liquid Lens к нижней части исходного изображения получено многослойное изображение города, приведенное на рис. 17.34.
  8. На следующем этапе снова создайте клон полученного изображения, но на этот раз примените динамичный слой Liquid Lens с теми же параметрами к верхней части изображения. Направление искажения задается сверху вниз от верхней кромки рисунка, изображение неба и города опускаются. После деформации плавающий слой совместите с холстом, выбрав Layers > Drop.
  9. Далее, с помощью инструмента Magic wand (Волшебная палочка) в изображении неба и города произведите обратное (Invert) выделение и перенесите на многослойное изображение города, поднятого кверху. Совмещение этой деформации с последней деформацией нижней части дает итоговое изображение, напоминающее глаз (рис. 17.35). Поэтому итоговое изображение было названо «Взгляд города».

Рис. 17.34. Результат многократного применения динамичного слоя Liquid Lens к нижней части исходного изображения

Рис. 17.35. Итоговое изображение — «Взгляд города»

Меняя способ совмещения плавающих слоев с холстом с помощью списка Composite Method и используя другие способы, например Luminosity (Яркость), Difference (Различие) или Multiply (Умножение), можно существенно изменить эффект от итогового изображения. Один из вариантов итогового изображения, полученный путем совмещения плавающих слоев методом Multiply, приведен на рис. 17.36.

Рис. 17.36. Изображение, полученное путем совмещения слоев методом Multiply

Упражнение. Создание рекламной надписи

В качестве еще одного примера работы с динамичным слоем Liquid Lens рассмотрим создание рекламной надписи для серфинга, нанесенной на исходное изображение двух спортсменов, летящих на гребне прибоя на серфипговых досках (рис. 17.37).

Рис. 17.37. Исходное изображение для рекламы серфинга

Надпись создается в несколько этапов.

  1. Сначала создайте клон исходного изображения и введите текст (Point Size — 90, Tracking — 0).
  2. В списке секции Layers палитры Objects выделите символы и выберите команду Shapes > Set Shape Attributes. В открывшемся диалоговом окне Set Shape Attributes снимите флажок Fill. Таким образом, текст лишен заливки.
  3. Преобразуйте текст в выделение, выбрав команду Shapes > Convert to Selection.
  4. Примените к выделению динамичный слой Bevel World с параметрами: Bevel Width — 1%, Smoothing — 200% (остальные параметры слоя взяты по умолчанию). Слой, полученный в результате применения эффекта Bevel World, совместите с холстом, выбрав команду Layers > Drop All (Слои > Опустить все). Результат применения Bevel World к тексту, нанесенному на клон исходного изображения, приведен на рис. 17.38.
  5. Поверните изображение на 270 градусов, выбрав команду Effects > Orientation > Rotate (Эффекты > Положение > Поворот). Плавающий слой, полученный в результате этого преобразования, скопируйте, выбрав Edit > Copy, перенесите в новый документ соответствующего размера, выбрав команду Edit > Paste, и совместите с холстом, выбрав Layers > Drop All.
  6. К полученному изображению примените динамичный слой Liquid Lens в варианте Rain с параметрами: Amount — 5.0, Smooth — 200%, Size — 0.9, Spacing — 0.052. Текст после обработки динамичным слоем Liquid Lens выделен с помощью инструмента Реn (Перо). Выделенный текст после применения динамичного слоя Liquid Lens приведен на рис. 17.39.
  7. Выделенному тексту придайте небольшую растушевку размером в 10 пикселов, выбрав Select > Feather (Выделить > Плавный переход). Затем выделенную область поверните на 90 градусов и поместите на исходное изображение. Полученная в итоге надпись, как бы смазанная при быстром движении, передает динамику серфинка (рис. 17.40).

Рис. 17.38. Результат применения Bevel World к тексту, нанесенному на клон исходного изображения

Рис. 17.39. Выделенный текст после применения динамичного слоя Liquid Lens

Рис. 17.40. Итоговое изображение

Упражнение. Совместное применение динамичных слоев Liquid Lens и Bevel World

Следующий пример иллюстрирует совместное применение динамичных слоев Liquid Lens и Bevel World при создании рисунка из серии «Искусственные атмосферные явления». Исходное изображение рассветного леса в туманной дымке (рис. 17.41) преобразуйте следующим образом:

Рис. 17.41. Исходное изображение рассветного леса в туманной дымке

  1. Из стандартного набора выделений Selection Portfolio палитры Object перетащите в выбранное место треугольники, затем преобразуйте в форму, выбрав команду Select > Convert to Shape.
  2. Разверните на 90 градусов, выбрав Effects > Orientation > Rotate, преобразуйте в выделение, выбрав Shapes > Convert to Selection (Выделить > Преобразовать в форму), подберите нужный размер, выбрав команду Select > Modify > Widen (Выделить > Изменить > Расширить) или Select > Modify > Contract (Выделить > Изменить > Сжать), и преобразуйте в рамки треугольной формы заданной ширины, пропорциональной размеру треугольника, выбрав команду Select > Modify > Border (Выделить > Изменить > Обрамление). Вокруг выделения создайте область растушевки, выбрав Select > Feather (Выделить > Плавный переход).
  3. После описанных предварительных преобразований к выделению примените динамичный слой Bevel World с параметрами: Bevel Width — в диапазоне от 1 до 50% пропорционально размеру, Smoothing — 100%, Base Slope — 0, Shine — в диапазоне от 50 до 75% пропорционально размеру; остальные параметры — по умолчанию. Плавающий слой Bevel World совместите с холстом, выбрав команду Layers > Drop.
  4. Каждый из треугольников обрабатывается с помощью динамичного слоя Liquid Lens. Внутренняя часть — с помощью вариантов Левый и Правый поворот (Size — в диапазоне от 3 до 9 пропорционально размеру; остальные параметры — по умолчанию). Рамка обрабатывается с помощью варианта Кисть (Size — в диапазоне от 0.5 до 2.0 пропорционально размеру; остальные параметры — по умолчанию).

Итоговое изображение — лес с артефактами треугольной формы — приведено на рис. 17.42.

Рис. 17.42. Итоговое изображение

Динамичный слой Kaleidoscope

Динамичный слой Kaleidoscope (Калейдоскоп) [image] имитирует эффекты, создаваемые четырехгранным калейдоскопом. Узор калейдоскопа формируется из части изображения, находящейся в данный момент под встроенным плавающим слоем. Перемещая динамичный слой по исходному документу. можно получать удивительные узоры самой разнообразной формы, но окрашенных в цветовую гамму исходного изображения (рис. 17.43).

Рис. 17.43. Изображение, полученное с помощью динамичного слоя Kaleidoscope

Эффект изображения, увиденного в калейдоскопе, создается аналогично описанным выше вариантам динамичных слоев. В результате выбора слоя Kaleidoscope и нажатия кнопки Apply открывается диалоговое окно Kaleidoscope (рис. 17.44). В поле Size задайте размер изображения, создаваемого калейдоскопом, и нажмите кнопку ОК.

Рис. 17.44. Диалоговое окно Kaleidoscope и результат применения динамичного слоя Kaleidoscope

Узор динамичного слоя Kaleidoscope меняется при перемещении рамки объекта по экрану. Существенно, что динамичный слой не затрагивает самого исходного изображения. Чтобы преобразовать динамичный слой Kaleidoscope в обычный слой, доступный для команд меню Effects, выберите в меню Dynamic Layers команду Commit.

Динамичный слой Kaleidoscope — полезный инструмент для создания различных необычных композиций. Например, два исходных изображения, приведенные на рис. 17.45, положены в основу композиции, полученной с помощью динамичного слоя Kaleidoscope (рис. 17.46).

Рис. 17.45. Исходные изображения, положенные в основу композиции, полученной с помощью динамичного слоя Kaleidoscope

Рис. 17.46. Изображение, полученное с помощью динамичного слоя Kaleidoscope

  1. Предварительно из исходных изображений создайте основу композиции: дерево выделите с помощью инструмента Magic wand (Волшебная палочка) и наложите на облачное небо.
  2. С помощью копирования и горизонтального разворота создайте композицию из двух сросшихся деревьев.
  3. Преобразуйте композицию, применив динамичный слой Kaleidoscope. При создании изображения узор калейдоскопа размещайте таким образом, чтобы детали исходного изображения плавно переходили в детали узора.
  4. Узор калейдоскопа трансформируйте в обычный слой, выбрав команду Dynamic Layers > Commit, и разместите, выбирая команды меню Effects > Orientation.

Результат применения динамичного слоя Kaleidoscope может использоваться как самостоятельный элемент при создании композиций. Примеры таких композиций из серии «Искусственные атмосферные явления» приведены на рис. 17.47 и 17.48. При этом важно, что результат применения динамичного слоя Kaleidoscope имеет ту же цветовую гамму, что и исходное изображение.

Для создания композиции, приведенной на рис. 17.47:

Рис. 17.47. Композиция «Окно в небо» из серии «Искусственные атмосферные явления»

  1. Исходное изображение предварительно клонируйте, затем к нему примените динамичный слой Kaleidoscope.
  2. Квадрат калейдоскопного изображения преобразуйте в обычный слой, доступный для команд меню Edit и меню Effects, выбрав команду Dynamic Layers > Commit.
  3. Деформируйте его в соответствии с законами перспективы, выбрав Effects > Orientation > Distort, и поместите на поверхность воды, а затем в воздухе.
  4. Создайте контур калейдоскопного квадрата, выбрав команду Select > Modify > Border, деформируйте его и разместите над объектом в воде.

Следующая композиция из серии «Искусственные атмосферные явления» — «Звезды на море» (рис. 17.48). Для создания композиции:

Рис. 17.48. Композиция «Звезды на море»

  1. Исходное изображение предварительно клонируйте. К нему примените динамичный слой Kaleidoscope. Результат совместите с холстом.
  2. После этого к калейдоскопному узору примените выделение в форме шестиконечной звезды.
  3. Выделенную область преобразуйте в слой, выбрав Select > Float, деформируйте в соответствии с законами перспективы, выбрав Effects > Orientation > Distort, и поместите на поверхность воды.
  4. Создайте контуры звезд в небе, выбрав команду Select > Modify > Border, затем деформируйте их и разместите над соответствующими объектами в воде.


Инструменты Impasto и Мозаика

  • Параметры эффекта Impasto
  • Создание эффекта Impasto
    • Упражнение. Применение эффекта Impasto
  • Мозаика
  • Создание мозаики
    • Выбор цвета плиток
    • Режимы Dimensions и Randomness
    • Меню команд
    • Создание эффекта трехмерности
    • Создание мозаики по эскизу
    • Упражнение. Создание мозаики
  • Полигональная мозаика — Tessellation
    • Использование средств диалогового окна Make Mosaic
    • Упражнение. Создание мозаики с использованием техники Tessellation

Impasto и Мозаика позволяют просто рисовать элементами, с установленными параметрами

Impasto и мозаика — два совершенно различных изобразительных средства. Объединение их в один урок связано с тем, что они стоят особняком по отношению к другим средствам.

Эффект Impasto имитирует рельефное изображение, получаемое с помощью масляной краски, выдавливаемой на холст прямо из тюбика или наносимой с помощью шпателя. Для создания рельефного изображения Impasto могут использоваться почти все кисти.

Теперь Impasto не относится к динамичным слоям, как в предыдущих версиях. Он больше не входит в секцию Dynamic Layers палитры Objects, а перенесен в палитру Brushes и относится к инструментам рисования.

Эффект рельефной поверхности создается с помощью слоя глубины для установки рельефа и цветового слоя, используемого для создания цветного изображения и задания параметров освещения холста.

Мозаика, как и Impasto, позволяет просто рисовать элементами, с установленными параметрами. Кроме того, вы можете использовать готовое изображение в качестве основы для создания мозаичного панно. Используя близкое с мозаикой средство — Tessellation, можно создавать в автоматическом режиме изображения, напоминающие витражи.

Параметры эффекта Impasto

Кнопка включения [image] эффекта Impasto расположена на вертикальной полосе прокрутки рабочей области. Когда эффект включен, кнопка становится рельефной [image]. Инструмент Impasto является одной из самых многочисленных категорий по количеству вариантов и разнообразной по качеству. Достаточно выбрать инструмент Impasto в палитре Brushes, выбрать соответствующий вариант кисти, настроить цвет, размер и можно начать рисовать.

Настройки параметров Impasto производятся двояко:

  • характеристики глубины штриха устанавливаются в соответствующей секции палитры Brush Controls;
  • параметры освещения — в диалоговом окне Impasto Lighting (Освещение), открываемом командой Canvas > Impasto Lighting.

На рис. 18.1 приведен пример применения эффекта Impasto.

Рис. 18.1. Результат применения Impasto

Чтобы применить эффект Impasto:

  1. На панели инструментов выберите Brush (Кисть), на панели Brushes выберите Impasto, затем выберите необходимый вариант кисти.
  2. В секции Color палитры Art Materials задайте цвет.
  3. Нажмите кнопку Impasto на полосе прокрутки рабочего поля.
  4. Откройте секцию Impasto палитры Brush Controls и установите параметры глубины:

    • В раскрывающемся списке Draw To (Рисовать с помощью) выберите один из трех параметров:

      • Color (Цвета) — цветность штриха, сам цвет выбирается отдельно в палитре Color;
      • Depth (Глубины) — объем (если вы наносите слой Impasto на цветное изображение и цвет вам не нужен);
      • Color and Depth (Цвета и глубины) — цвет и объем штриха.

    • В раскрывающемся меню Depth Method (Способы создания рельефа) выберите из пяти вариантов, характеризующих рельеф штриха:

      • Uniform (Постоянная форма) — постоянный рельеф штриха по всей длине;
      • Erase (Ластик) — удаление рельефа штриха, после чего он становится плоским;
      • Paper (Бумага) — рельеф штриха определяется текстурой бумаги, заданной в секции Paper палитры Art Materials;
      • Original Luminance (Освещенность оригинала) — рельеф штриха пропорционален освещенности оригинала, заданного в качестве источника клонирования. Если источник клонирования не указан, его заменяет выделенный в данный момент шаблон;
      • Weaving Luminance (Освещенность плетения) — рельеф линии пропорционален освещенности узора плетения.

    • Invert (Инверсия) — параметры задания рельефа линии для вариантов Paper, Original Luminance и Weaving Luminance меняются на обратные.
    • Negative Depth (Отрицательный рельеф)— рельеф штриха становится вогнутым или вдавленным.
    • Depth (Глубина) — устанавливает высоту и объем штриха.
    • Smoothing (Сглаживание) — устанавливает рельефность текстуры штриха, при перемещении ползунка вправо текстура сглаживается.
    • Plow (Плуг) — устанавливает взаимодействие штрихов между собой.

  5. После того как вы сделаете установки в секции Impasto, выберите команду Canvas > Impasto Lighting, откроется диалоговое окно Surface Lighting (рис. 18.2). Установите описанные ниже параметры, и нажмите кнопку ОК.

    • Appearance of Depth (Имитация рельефа) — область окна, содержащая параметры установок, применяемых ко всему изображению, созданному с помощью эффекта Impasto:

      • Amount (Эффект) — устанавливает объемный эффект на текстуру поверхности изображения;
      • Picture (Изображение) — освещенность изображения при постоянных параметрах источника света;
      • Shine (Блеск) — яркость освещенных участков рельефа.

    • Light Controls (Управление освещением) — область, содержащая параметры освещения:

      • Brightness (Яркость) — яркость источника света;
      • Conc (Концентрация) — ширина светового пучка;
      • Exposure (Экспозиция) — интенсивность падающего света;

    • Light Color (Цвет освещения) — цвет освещения.
    • Display (Отображение) — регулирует яркость источника света только в окне предварительного просмотра.
    • Show Light Icon (Показать значок источника света) — показывает метку, обозначающую центр светового пятна на условной сфере в окне предварительного просмотра.
    • Enable Surface (Включение Surface) — позволяет отключить эффект и включить его снова.

Рис. 18.2. Диалоговое окно Surface Lighting

Чтобы попрактиковаться, почувствовать, как работают кисти категории Impasto, как влияют на изображение различные параметры, выберите небольшое изображение бытового предмета, растения или животного с обилием мелких деталей, лучше в светлых тонах. Переходите от кисти к кисти, от одного параметра к другому и наблюдайте за происходящими изменениями. Если вам кажется, что почти ничего не меняется, отключите кнопку Impasto на полосе прокрутки рабочей области и вы увидите эффект.

На рис. 18.3 приведен пример использования Impasto для создания монохромного рельефного изображения.

Рис. 18.3. Результат применения эффекта Impasto для создания одноцветного рельефного изображения

Создание эффекта Impasto

Рассмотрим несколько примеров использования эффекта Impasto.

Поставим целью создать обложку меню для кафе с названием, заимствованным из рассказа Эрнеста Хемингуэя «The Clean, Well-Lighted Place» («Там, где чисто и светло»). Причем рисунок обложки должен имитировать рельеф. Работа разбивается на два этапа. На первом этапе создается черно-белая заготовка, которая будет использоваться в качестве источника клонирования при создании рельефа. Точнее, яркость этого изображения будет основой для создания рельефного рисунка.

  1. Создайте новый документ подходящего размера, например 500 х 300 пикселов. Выберите инструмент Реn (Перо) и изобразите справа внизу винную рюмку и бутылку. Самое сложное в этом рисунке — добиться симметрии. Для этой цели удобно воспользоваться сеткой (выберите команду Canvas > Grid > Show Grid) с ячейкой в 3-4 пиксела (выберите Canvas > Grid > Grid Options).
  2. Готовые формы залейте черным цветом. Для этого выберите команду Shapes > Set Shape Attributes (Формы > Установить параметры формы). В открывшемся диалоговом окне Set Shape Attributes установите флажок Fill. Щелкните на индикаторе цвета заливки и задайте черный цвет на открывшейся вспомогательной цветовой палитре.
  3. Полученные формы откорректируйте, выбрав в меню Effects команду Effects > Orientation > Distort (Эффекты > Положение > Искажение).
  4. Выберите инструмент Text с параметрами Point Size — 50, Tracking — 0,01, Font — Arial Black и введите название кафе в три строки в левой части документа-заготовки.
  5. Создайте рамку, выбрав команды Select > All, затем — Select > Modify > Border.
  6. Совместите все формы с исходным документом, выбрав команду Layers > Drop All. Полученное изображение приведено на рис. 18.4.

Рис. 18.4. Черно-белое изображение-заготовка

На втором этапе применим к данной заготовке эффект Impasto.

  1. Предварительно задайте исходный документ-заготовку в качестве источника клонирования, выбрав File > Clone Source.
  2. Подберите вариант и размер кисти Impasto, установите цвет. Если вы хотите создать только рельеф, не изменяя исходный цвет холста, выберите Depth Eraser. Чтобы не было неровностей, задайте кисть большого размера, порядка 100 пикселов.
  3. Нажмите кнопку Impasto на полосе прокрутки. Откройте секцию Impasto в палитре Brush Controls. Сделайте установки глубины: в раскрывающемся списке Draw To выберите Depth and Color. В раскрывающемся меню Depth Method выберите Original Luminance. Установите Depth — 300%, Smoothing — 0.
  4. Выберите команду Canvas > Impasto Lighting. В раскрывшемся окне установите Amount — 300%. Остальные параметры оставьте по умолчанию. Нажмите кнопку ОК.
  5. Обработайте документ плавными движениями кисти так, чтобы рельеф стал четким и одинаковым по всему полю.
  6. Создайте рамку, выбрав Select > All, Select > Modify > Border, и залейте ее подходящим цветом. Изображение обложки меню приведено на рис. 18.5.

Рис. 18.5. Изображение обложки меню

Используя созданную заготовку, полезно рассмотреть другие возможные варианты завершения композиции. Например, примените эффект Impasto дважды. Сначала создайте рельефный фон, для чего в раскрывающемся меню Depth Method выберите Paper, предварительно выбрав подходящий тип бумаги. Нажмите кнопку ОК.

Затем в том же меню выберите Original Luminance, а также задайте белый цвет в окне индикатора цвета переднего плана. Обработайте область, включающую в себя текст. Результат работы над данным вариантом приведен на рис. 18.6.

Рис. 18.6. Возможный вариант итогового изображения обложки меню

Упражнение. Применение эффекта Impasto

Рассмотрим применение эффекта Impasto при создании изображения из серии «Искусственные атмосферные явления». В качестве исходного изображения воспользуемся ночным морским пейзажем, приведенным на рис. 18.7.

Рис. 18.7. Исходное изображение ночного морского пейзажа

  1. Воспользуйтесь заготовкой выделения в форме равностороннего треугольника из стандартной библиотеки секции Selection Portfolio палитры Objects. Перетащите треугольник в пределы исходного изображения.
  2. Преобразуйте его в форму, выбрав команду Select > Convert to Shape (Выделить > Преобразовать в форму), разверните на 270 градусов, выбрав команду Effects > Orientation > Rotate (Эффекты > Положение > Поворот), и деформируйте так, чтобы создалось впечатление, что треугольник лежит на поверхности воды, выбрав Effects > Orientation > Distort (Эффекты > Положение > Искажение).
  3. Выбирая команды Edit > Copy, Edit > Paste, создайте три подобных треугольника различной величины и разместите их с соблюдением законов перспективы в полосе прибоя.
  4. Выберите команду Shape > Convert to Selection (Форма > Преобразовать в выделение) для преобразования полученной формы в выделение.
  5. Выберите в палитре Brushes категорию Impasto, вариант Smeary Varnish (Вязкий лак). В секции Impasto палитры Brush Controls в меню Depth Method выберите Uniform, в меню Draw To — Color and Depth. Остальные установки оставьте без изменений.
  6. Цвет установите с помощью инструмента Dropper (Пипетка) как цвет луны. Пределы вариаций параметров цвета (Н, S, V) примите равными 20%. Размер кисти примите минимальным, равным 1 пикселу. Обработайте выделенную область горизонтальными мазками так, чтобы передать неровности поверхности моря.
  7. При совмещении слоя с холстом примите Opacity — 75%. а в меню Composite Method выберите Magic Combine. Итоговое изображение искусственного атмосферного явления — искрящихся треугольников, отражающих лунный свет, приведено на рис. 18.8.

Рис. 18.8. Итоговое изображение

Мозаика

Мозаика, как и Impasto, позволяет просто рисовать элементами с установленными параметрами. Кроме того, вы можете использовать готовое изображение в качестве основы для создания мозаичного панно. Используя близкое с мозаикой средство — Tessellation, можно создавать в автоматическом режиме изображения, напоминающие витражи.

Работа с мозаикой и Tessellation по разным причинам имеет ряд ограничений, о них мы поговорим подробнее.

Мозаичные плитки, из которых создается изображение, являются векторным объектом, поэтому можно менять размер и разрешение изображения без угрозы потери качества. Однако это свойство характерно только при сохранении работы в RIFF-формате. При переносе изображения в любой другой формат мозаика становится растровой.

Мозаика создается на чистом холсте. Если у вас есть изображение на холсте и вы собираетесь часть его сделать мозаикой, то изображение будет уничтожено.

При создании мозаики Painter уничтожает все имевшиеся слои, зато после создания мозаики позволяет применить к ней желаемые эффекты, рисовать кистями, использовать динамичные и обычные слои.

Создание мозаики

Для создания мозаики предназначено специальное диалоговое окно Make Mosaic (рис. 18.9). Весь процесс создания происходит только при открытом окне, причем все остальные команды и палитры становятся недоступными, кроме секций Color палитры Art Materials. В различных вариантах секций Color вы можете выбирать цвет для мозаичных плиток. Параметры самих плиток устанавливаются в диалоговом окне.

Рис. 18.9. Диалоговое окно Make Mosaic

Состав диалогового окна Make Mosaic приведен в табл. 18.1 и 18.2.

Таблица 18.1. Параметры диалогового окна Make Mosaic

Параметр | Назначение
Dimensions (Размер) | Режим, при котором задается точный размер плиток
Randomness (Разброс) | Режим, при котором задается разброс величин элементов мозаики
Width (Ширина) | Устанавливает вертикальный размер плитки
Length (Длина) | Устанавливает горизонтальный размер плитки
Cut (Край) | Задает угол края плитки, при значении 0 — край перпендикулярен направлению штриха (только для режима Randomness)
Pressure (Нажим) | Устанавливает зависимость между нажимом на стилус и размерами плитки
Grout (Основа) | Задает цвет основы
Use Tracing Paper (Использовать кальку) | Дает возможность использовать подлежащее изображение для создания мозаики
Done (Применить) | Закрывает диалоговое окно

Таблица 18.2. Кнопки диалогового окна Make Mosaic

Кнопка | Название | Назначение
 | Apply Tiles (Наложить плитки) | Позволяет рисовать плитками
 | Remove Tiles (Удалить плитки) | Удаляет плитки
 | Change Tile Color (Изменить цвет плитки) | Позволяет изменить цвет плиток
 | Select Tiles (Выделить плитки) | Выделяет плитки

Попробуйте создать простую мозаику, рисуя этим инструментом на холсте. Для этого:

  1. Создайте новый документ.
  2. Выберите команду Canvas > Make Mosaic (Холст > Создать мозаику). Откроется диалоговое окно Make Mosaic (рис. 18.9).
  3. Откройте секцию Color палитры Art materials и выберите основной цвет.
  4. Нажмите кнопку Apply Tiles (Наложить плитки) и начинайте рисовать мозаичными плитками.
  5. Попробуйте поменять параметры плитки (см. табл. 18.1 и 18.2).
  6. Если какие-то участки мозаики вам не нравятся, удалите их, нажав кнопку Remove Tiles (Удалить плитки).
  7. Завершив работу, нажмите кнопку Done.

Выбор цвета плиток

Как вы помните, единственная палитра, которой вы можете пользоваться, — Art Materials, а именно ее секции Colors, Color Variability, Pattern.

Если вы работаете выбранным цветом, но хотите придать мозаике более естественный вид, откройте секцию Color Variability. Установите значения Hue около 10-15%, а остальные параметры оставьте равными нулю, тогда колебания цвета будут незначительными, но изображение будет интереснее.

Для использования цветовой гаммы шаблона установите флажок Clone Color в секции Colors.

Помимо секции Colors, изменить цвет плитки можно с помощью собственных средств диалогового окна Make Mosaic. Для этого нажмите кнопку Change Tile Color (Изменить цвет плитки). Становится доступным раскрывающееся меню Color.

С помощью этого меню вы можете изменить цвет плиток в определенных пределах. В меню предлагаются следующие варианты:

  • Color (Цвет) — мозаичная плитка окрашивается первичным цветом, установленным в секциях Color палитры Art Materials;
  • Darken (Затемнить) — цвет плитки затемняется добавлением небольшого количества черного цвета;
  • Lighten (Осветлить) — цвет плитки осветляется добавлением небольшого количества белого цвета;
  • Tint (Подцвечивать) — цвет плитки создается добавлением небольшого количества основного цвета;
  • Vary (Вариабельность) — цвет определяется положением ползунков секции Color Variability.

Кроме того, вы можете изменить цвет основы. По умолчанию установлен белый цвет. Для изменения цвета щелкните на поле Grout, откроется стандартное окно Цвет. Выберите нужный цвет, нажмите кнопку ОК. Если мозаика уже создана, Painter автоматически переберет ее заново.

Изменение параметров плиток для режима Dimensions представлен на рис. 18.10.

Рис. 18.10. Результат изменения параметров плитки в режиме Dimensions: а — значения Width и Length приблизительно равны; б — малое значение Width при неизменном значении Length; в — малое значение Length при большом значении Width; г — малые значения Length и Width; д — средние значения Length и Width при увеличенном значении Grout

Режимы Dimensions и Randomness

При создании мозаики используется один из двух режимов — Dimensions (Измерение) или Randomness (Разброс).

Для режима Dimensions характерны плитки правильной формы, край плиток перпендикулярен направлению штриха.

Влияние изменения параметров плитки на изображение очень наглядно и очевидно. Примеры результатов изменения параметров в режиме Dimensions см. рис. 18.10. Результаты изменения параметров плитки в режиме Randomness показаны на рис. 18.11.

Рис. 18.11. Результат изменения параметров плитки в режиме Randomness: а — значения Width и Length приблизительно равны; б — большое значение Width при неизменном значении Length; в — малое значение Width при большом значении Length; г — средние значения Length и Width при увеличенном значении Grout

Для режима Randomness (Разброс) характерно разнообразие форм и размеров плиток в штрихе, край штриха неровный. Изменения параметров плитки в режиме Randomness не очень заметны, так как они устанавливаются в процентах от величин, заданных в режиме Dimensions. Поэтому, прежде чем изменять параметры в режиме Randomness, установите соответствующие параметры в режиме Dimensions.

На рис. 18.11 приведены результаты изменения параметров плитки, произведенные сначала в режиме Dimensions, затем в режиме Randomness. Как видите, плитки более разнообразны как по форме, так и по размеру. В режиме Randomness мозаика выглядит более естественно.

Меню команд

В правом верхнем углу палитры расположена кнопка в виде небольшого прямоугольника. Она открывает меню команд диалогового окна:

  • Reset Mosaic (Переустановить мозаику) — уничтожает изображение и заливает цветом основы;
  • Re-render Mosaic (Повторно представить мозаику) — создает повторно мозаику в соответствии с установленным разрешением;
  • Render Tiles into Mask (Представить плитки в виде маски) — создает маску на основе плиток; в дальнейшем вы можете ее использовать для создания эффекта трехмерности;
  • Starting with a Triangle (Начинать с треугольника) — начинает строку плиток с острого угла;
  • Respecting the Edge of an Image (Учитывать край изображения) — используется для создания края из основы. Painter выкладывает плитки, учитывая край, не ближе установленного значения;
  • Stroke Selection (Обвести выделение) — используется только для контурного выделения;
  • Fill Selection (Залить выделение) — заливает мозаичными плитками выделенную область.

Если вы создали мозаику при малом разрешении документа и сочли ее удачной, выберите команду Re-render Mosaic — Painter автоматически переберет мозаику заново, точно так же, как и при изменении цвета основы.

Команда Starting with a Triangle (Начинать с треугольника) актуальна в местах, где линия рисунка должна утоньшаться. Особенно удачно это используется с удлиненной узкой плиткой, то есть, при увеличении параметра Length (Длина) и уменьшении Width (Ширина).

Обычно Painter выкладывает плитки мозаики в край изображения, но можно сделать кромку из основы, особенно, если используется цветная основа. Для этого достаточно выбрать команду Respecting the Edge of an Image (Учитывать край изображения), тогда Painter оставляет кромку основы по краям изображения.

С помощью команды Stroke Selection (Обвести выделение) можно автоматически обвести выделение. А при выборе команды Fill Selection (Залить выделение) Painter автоматически заполняет все выделение. Однако при использовании обеих команд следует в промежутке между ними что-то изменить. Например, вы решили обвести, а затем заполнить выделение. Тогда после выполнения обводки, поменяйте цвет или размер плиток, а затем выполните заполнение. На рис. 18.12 приведен пример автоматического выполнения обводки выделения (слева), автоматического заполнения (справа), и комбинированного действия, сначала обводки, затем заполнения (в центре). Если вы не удовлетворены полученными результатами, можете вручную откорректировать заполнение.

Рис. 18.12. Пример обводки (вверху), обводки и заполнения (в центре), и заполнения (внизу)

Создание эффекта трехмерности

Вы можете создать эффект объема мозаики. Для этого используется команда Render Tiles into Mask (Представить плитки в виде маски) меню диалогового окна Make Mosaic.

Команда Render Tiles into Mask (Представить плитки в виде маски) создает маску на основе плиток. Далее выбирается команда Effect > Surface Control > Apply Surface Texture (Эффекты > Управление поверхностью > Наложить текстуру).

Чтобы создать объемную мозаику:

  1. После создания мозаики, выберите в меню диалогового окна команду Render Tiles into Mask (Представить плитки в виде маски). Нажмите кнопку Done. Диалоговое окно Make Mosaic закроется.
  2. Выберите команду Effect > Surface Control > Apply Surface Texture, откроется диалоговое окно Apply Surface Texture (рис. 18.13). Раскройте меню Using и выберите команду Mosaic Mask.
  3. Отрегулируйте с помощью ползунков параметры Amount, Softness, Picture. Наблюдайте за изменениями мозаики в просмотровом окне. Достигнув нужного эффекта, нажмите кнопку ОК. На рис. 18.14 приведен пример создания эффекта объемной плитки.

Рис. 18.13. Диалоговое окно Apply Surface Texture

Рис. 18.14. Придание эффекта трехмерности мозаичной плитке

Создание мозаики по эскизу

Как вы помните, особенность техники мозаики состоит в том, что Painter укладывает плитки непосредственно на основу, в качестве которой используется Canvas. Поэтому все имеющиеся изображения будут уничтожены. Тем не менее можно создавать мозаику, пользуясь эскизом через кальку (Tracing Paper).

Для создания мозаики по эскизу:

  1. Откройте изображение, которое хотите положить в основу вашей мозаики. Выберите команду File > Clone.
  2. Выберите команду Selection > All, затем нажмите клавишу Delete или Backspace, изображение исчезнет. Выберите команду Canvas > Tracing Paper, изображение появится в осветленном варианте.
  3. Выберите команду Canvas > Make Mosaic. Установите параметры мозаики и начинайте рисовать.
  4. При установленном флажке Clone Color в секции Colors палитры Art Materials цвета плиток мозаики будут соответствовать источнику изображения. Если вы не хотите использовать исходные цвета, снимите флажок и подбирайте цвета с помощью цветового кольца секции Colors.

На рис. 18.15 и 18.16 приведен пример создания мозаики, в основу которой положена фотография. В верхней части расположена исходная фотография, ниже — результат создания мозаики.

Рис. 18.15. Исходная фотография

Рис. 18.16. Создание мозаики с использованием эскиза

Упражнение. Создание мозаики

В качестве исходного изображения взят рисунок птицы. Наша задача — сделать из этого рисунка мозаику, например, для орнитологического общества.

  1. Раскройте исходный файл (рис. 18.17) и создайте его клон, выбрав команду File > Clone.
  2. Продолжим работу с клоном исходного изображения. Задайте в качестве источника клонирования исходное изображение, выбрав File > Clone Source. Выберите Canvas > Make Mosaic. Открывается диалоговое окно Make Mosaic (рис. 18.18). При выполнении команды Make Mosaic клон исходного файла трансформируется в белый холст. Выберите команду Canvas > Use Tracing Paper (Холст > Использовать кальку). В результате видно исходное изображение.

Рис. 18.17. Исходное изображение птицы

Рис. 18.18. Применена команда Use Tracing Paper

При создании мозаики следует придерживаться следующего правила. Размер элементов мозаики следует задавать в зависимости от детальности изображения. Чем меньше детали изображения, тем меньше размер элементов (квадратов или прямоугольников), из которых создается изображение. Данное изображение можно условно разделить на несколько областей, каждой из которых соответствует свой размер мозаики. Первая область — это голова птицы.

  1. Цвет мозаики установите с помощью инструмента Dropper (Пипетка). На палитре Art Materials в секции Colors автоматически установится основной цвет. В секции Color Variability задайте вариации каждого из параметров цвета (Н, S, V), равными 10%.
  2. Нажмите кнопку Apply Tiles (Наложить плитки) [image].
  3. Приступайте к созданию мозаики. Сначала создается глаз, а вокруг него обводка — два ряда квадратных элементов мозаики со стороной, равной 3 пикселам. Просвет между элементами мозаики (Grout) задайте равным 1 пикселу. Затем создается клюв и оперенье головы, где используются элементы мозаики прямоугольной формы. Ширина элементов (Width) задается равной 4 пикселам, а длина (Length) — 6 пикселам. Просвет остается равным 1 пикселу. Закончив изображение головы, нажмите кнопку Done (Применить). Законченное изображение головы приведено на рис. 18.19.

Рис. 18.19. Законченное изображение головы

Следующая область — это крылья, спина и хвост. При создании этой области удобно задать автоматическую обводку элементами мозаики.

  1. Для выделения данной области воспользуйтесь инструментом Реn (Перо), с помощью которого аккуратно обведите сначала крылья и спину, а затем хвост. Полученную форму преобразуйте в выделение, выбрав команду Shapes > Convert to Selection.
  2. Затем выберите Canvas > Make Mosaic и задайте размер элемента мозаики для обводки. Пусть это будет квадратный элемент со стороной, равной 3 пикселам. Откройте меню диалогового окна Make Mosaic. Для этого нажмите квадратик, расположенный в правом верхнем углу диалогового окна. Выберите команду Stroke Selection. В результате созданный контур выделения обведен элементами мозаики. Аккуратно заполните созданный контур элементами мозаики прямоугольной формы 4 x 6 пикселов.

Следующая область — грудь птицы. Эта область заполняется элементами квадратной формы со стороной, равной 3 пикселам. Не забудьте изменить цвет элементов. Теперь он должен быть ярко-желтый. Вариации параметров цвета оставьте без изменения, то есть равными 10%.

  1. Закончив грудь, переходите к лапам. При создании этой области также удобно использовать обводку. Однако размер элементов мозаики, используемый при обводке, должен быть очень маленьким. Это квадратики со стороной, равной 1 пикселу, просвет — 0,1 пиксела. При заполнении выделенной области размер квадратиков можно увеличить до 2 пикселов. Аналогичным образом создается изображение ветки, на которой сидит птица.
  2. Чтобы создать рамку, выберите Select > All, а затем Select > Modify > Contract (Выделить > Изменить > Сжать). Откроется диалоговое окно Contract Selection. Задайте размер сжатия выделенной области равным 10 пикселам. Выберите цвет рамки, он может быть таким же темным, как цвет головы, крыльев и хвоста. Активизируйте диалоговое окно Make Mosaic и задайте размер квадратного элемента мозаики равным 10 пикселам. Выберите в меню диалогового окна Make Mosaic команду Stroke Selection (Выделение обводкой). Рамка готова.
  3. Теперь перейдем к созданию фона. Выберите цвет фона. Вариации цветовых параметров оставьте без изменения. Задайте элемент мозаики квадратной формы со стороной, равной 10 пикселам. Заполните фон элементами мозаики. Закончив мозаику, выберите подходящий цвет для просвета между элементами. Мозаика готова. Итоговое изображение приведено на рис. 18.20.
  4. Последним шагом является создание рельефной текстуры. Для этого выберите Canvas > Make Mosaic. Раскройте меню диалогового окна Make Mosaic и выберите команду Render Tiles into Mask. Нажмите кнопку Done. Выберите Effect > Apply Surface Texture (Эффекты > Наложить текстуру). Откроется диалоговое окно Apply Surface Texture. В списке Using выберите Mosaic Mask. Остальные параметры диалогового окна можете взять по умолчанию. Нажмите кнопку ОК. В результате созданная мозаика приобрела рельефную текстуру. Итоговое изображение мозаики с рельефной текстурой приведено на рис. 18.21.

Рис. 18.20. Итоговое изображение мозаики

Рис. 18.21. Итоговое изображение с рельефной текстурой

Полигональная мозаика — Tessellation

Painter предусматривает возможность автоматического создания мозаики с помощью диалогового окна Tessellation (рис. 18.22). При этом мозаика создается из плиток-многоугольников.

Рис. 18.22. Диалоговое окно Tesselation

Предварительно в диалоговом окне Make Mosaic необходимо установить цвет основы и интервал между плитками. Обычно в качестве основы мозаики Tessellation используется рисунок или фотография. Последовательность действий такая же, как в предыдущем примере, где для создания мозаики использовалась фотография в качестве эскиза.

Выберите команду Canvas > Make Tessellation (Создать витраж) для открытия диалогового окна Tessellation. Раскрывающийся список Display (Показать) позволяет выбрать вариант формы плиток: Triangles (Треугольники), Crack (Трещины), Pieces (Кусочки) (рис. 18.23, 18.24).

Рис. 18.23. Использование треугольных плиток и плиток неправильной формы Crack

Рис. 18.24. Плитки Pieces, вариант Add 500 Random (слева), Points Add 500 Evenly-Spaced Points (справа)

Нажатием маленького прямоугольника в правом верхнем углу диалогового окна открывается меню команд, позволяющих изменять количество и принцип добавления точек. Повторно выбирая любую команду, кроме Reset, вы добавляете новые 500 точек, уменьшая размер плиток.

Состав диалогового окна Tessellation:

  • Display (Показать) — раскрывающееся меню вариантов формы плиток:

    • Triangles;
    • Crack;
    • Pieces.

  • Меню команд:

    • Reset — удаляет все;
    • Add 500 Random Points (Добавить 500 случайных точек) — добавляет новые точки, используя принцип случайного разброса;
    • Add 500 Evenly Spaced Points (Добавить 500 равномерно распределенных точек) — добавляет новые точки, равномерно распределяя их по различным областям;
    • Add 500 Clone Spaced Points (Добавить 500 точек, распределенных в соответствии с источником) — добавляет новые точки, распределяя их в соответствии со светлыми и темными фрагментами источника;
    • Add 500 Inverse Clone Spaced Points (Добавить 500 точек, обратных к источнику) — добавляет новые точки, распределяя их обратно светлым и темным областям источника.

  • Done (Применить) — кнопка, закрывающая диалоговое окно.

Для создания мозаики Tessellation выполните следующее:

  1. Откройте изображение-эскиз, выберите команду File > Clone.
  2. Установите флажок Clone Color в секции Color.
  3. Выберите команду Canvas > Make Mosaic и установите цвет основы и величину промежутков между плитками с помощью ползунка Grout. Нажмите кнопку Done.
  4. Выберите команду Canvas > Make Tessellation. В диалоговом окне выберите Add 500 Clone Spaced Points (Добавить 500 точек, распределенных в соответствии с источником). Повторите эту команду несколько раз до получения нужного количества точек. В местах, где это необходимо, установите указатель мыши и нажмите кнопку — Painter разбивает указанные плитки на более мелкие фрагменты. Нажмите кнопку Done. Вы получите мозаику, выполненную с помощью плиток неправильной формы в технике Tessellation.

Для создания мозаики с помощью диалогового окна Tessellation вы можете сами задать цвет в секциях Color и Color Variability. При этом нужно установить основной цвет и его отклонения. Можно использовать шаблон для создания мозаики. При этом не забудьте установить флажок Clone Color в секции Color, а в меню команд следует выбрать Add 500 Clone Spaced Points.

С помощью диалогового окна Tessellation можно создавать мозаику и вручную. Для этого:

  1. Создайте новый документ, выбрав команду File > New.
  2. Установите цвет и его колебания или используйте в качестве цветовой основы один из шаблонов.
  3. Выберите команду Canvas > Make Tessellation.
  4. Установите указатель мыши — он будет иметь форму перекрестья, на чистом холсте. Щелкните мышью, вы получите равносторонний треугольник. Щелкните снова, появится треугольная призма, продолжайте щелкать мышью в различных точках холста, пока не получите желаемый результат (рис. 18.25).
  5. В заключение нажмите кнопку Done.

Рис. 18.25. Этапы разделения плиток вручную

Использование средств диалогового окна Make Mosaic

При работе в технике Tessellation вы можете использовать ряд команд диалогового окна Make Mosaic: Reset Mosaic, Re-Render Mosaic, Render Tiles Into Mask. Кроме того, можно раскрыть список Change Tile Color (Изменить цвет плитки) [image] и с помощью меню изменять цвет плиток мозаики.

При создании мозаики без эскиза, вручную, без установки цвета, Painter создает ее в цвете, используемом по умолчанию, то есть мозаика будет черной, а основа — белой (рис. 18.26).

Рис. 18.26. Мозаика без установленного цвета

Для изменения цвета мозаики достаточно воспользоваться кнопкой Change Tile Color (Изменить цвет плитки) в диалоговом окне Make Mosaic. При этом работа с плитками не отличается от аналогичных действий с обычной мозаикой. Точно так же, выбирая плитку за плиткой, вы окрашиваете ее в нужный цвет с помощью секции Colors и команд меню Color кнопки Change Tile Color (рис. 18.27).

Рис. 18.27. Изменение цвета плиток средствами диалогового окна Make Mosaic

Упражнение. Создание мозаики с использованием техники Tessellation

Мозаика из элементов непрямоугольной формы (треугольников или многоугольников) создается с помощью инструмента Tessellation.

  1. Раскройте исходное изображение — фотографию скульптуры Нефертити (рис. 18.28).
  2. Создайте клон исходного изображения, выбрав File > Clone, и задайте исходное изображение в качестве источника клонирования, выбрав команду File > Clone Source.
  3. В секции Color палитры Art Materials установите флажок Clone Color, а в секции Color Variability задайте вариации параметров цвета равными 3%.
  4. Выберите команду Canvas > Make Mosaic. Откройте диалоговое окно Make Mosaic. Установите размер просвета между элементами мозаики равным 0,1. Задайте цвет основы мозаики, установите флажок Use Tracing Paper и нажмите кнопку Done.
  5. Выберите команду Canvas > Make Tessellation. Откроется диалоговое окно Tessellation. В меню Display выберите варианты Pieces или Cracks. Щелкните на квадрате в правом верхнем углу окна, раскроется меню диалогового окна, где находятся команды, задающие распределение элементов мозаики. Выберите Add 500 Clone-Spaced Points. В этом варианте число элементов мозаики в выбранной области обратно пропорционально яркости источника клонирования. Изображение покрывается элементами мозаики. Пример мозаики после создания первых 2000 элементов приведен на рис. 18.29.
  6. Повторите выбор Add 500 Clone-Colored Points. По мере увеличения числа элементов их размер уменьшается, то есть детальность мозаики возрастает. Мозаика с числом элементов порядка 10 000 обладает достаточной детальностью. Если вы удовлетворены детальностью мозаики, нажмите кнопку Done. После выполнения рендеринга на экране появляется итоговое изображение мозаики (рис. 18.30).
  7. Последний шаг — создание рельефной текстуры. Выберите команду Canvas > Make Mosaic. В меню диалогового окна Make Mosaic выберите Render Tiles into Mask. Нажмите кнопку Done. Выберите Effects > Apply Surface Texture. Откроется диалоговое окно Apply Surface Texture. В списке Using выберите Mosaic Mask. Остальные параметры диалогового окна можете взять по умолчанию. Нажмите кнопку ОК. В результате созданная мозаика приобрела рельефную текстуру. Окончательный вид мозаики после создания рельефной текстуры приведен на рис. 18.31.

Рис. 18.28. Исходное изображение — фотография скульптуры Нефертити

Рис. 18.29. Вид мозаики после создания первых 2000 элементов

Рис. 18.30. Итоговое изображение мозаики после создания 10 000 элементов

Рис. 18.31. Окончательный вид мозаики после создания рельефной текстуры


Работа с текстом

  • Работа с инструментом Text
    • Текст как пример формы
    • Применение динамичных слоев к тексту
  • Пример комплексного применения действий к тексту
  • Упражнение. Работа с инструментом Text
  • Использование динамичного слоя Dynamic Text
    • Установка базовой линии
    • Установка параметров шрифта
    • Установка эффектов
    • Упражнение. Применение Dynamic Text

Для работы с текстом Painter предлагает два инструмента. Выбор зависит от эффектов, которые вы хотите применить к тексту

На протяжении всех предыдущих глав нашей книги вы встречали примеры работы с текстом. В главе 15 рассказывалось о действиях с формами (Shapes), иногда на примере работы с текстом как вариантом форм. Эта глава целиком посвящена работе с текстом.

Работать с текстом можно двумя способами:

  • с помощью инструмента Text (Текст), входящего в палитру инструментов;
  • с помощью динамичного слоя Dynamic Text, входящего в состав секции Dynamic Layers палитры Objects.

Оба инструмента удобны в работе, имеют свои особенности и обладают широкими возможностями.

При использовании инструмента Text каждая буква представляет собой векторный объект, или форму, и располагается в отдельном слое. Слои следуют друг за другом в порядке набора текста. Отдельные буквы, разумеется, могут быть объединены в группы, соответствующие словам или предложениям. Параметры текста — тип шрифта, размер букв и расстояние между ними, задаются на панели управления Controls: Text, а свойства векторного объекта — заливка и обводка, устанавливаются в диалоговом окне Set Shape Attributes (Установка параметров формы). Буквы располагаются в прямолинейной строке, а переход на следующую строку осуществляется нажатием клавиши Enter. К буквам применимы различные команды из меню Effects, а также динамичные слои.

При работе с динамичным слоем Dynamic Text текст располагается в пределах одного слоя, поэтому при изменении параметров текста меняются свойства всех букв, находящихся в данном слое. Форма строки может быть любой, она задается базовой линией, представляющей собой кривую Безье, которая редактируется так же. как и гладкие кривые, создаваемые инструментом Реn (Перо). С помощью указателя или ползунков можно изменять размер букв, расстояние между ними, соотношение между шириной и высотой буквы, а также изменять наклон букв и поворачивать их вокруг базовой линии (базовая линия является осью поворота). К тексту, созданному с помощью Dynamic Text, могут быть применены различные команды из меню Effects и другие динамичные слои.

Выбор инструмента зависит от эффектов, которые планируется применить к тексту. Если текст располагается в прямых строках, и вы собираетесь обрабатывать отдельно каждую букву, выбирайте инструмент Text. Если предполагается работа с большими текстовыми блоками, причем строки должны иметь прихотливую форму, то нужен инструмент Dynamic Text.

Работа с инструментом Text

Инструмент Text [image] используется для создания текстовых форм. Текстовые формы иногда просто незаменимы в дизайнерских или рекламных проектах. Работать с текстом несложно:

  1. Выберите инструмент Text на панели инструментов. Палитра управления при этом трансформируется в Controls: Text (рис. 19.1).
  2. Щелкните на раскрывающемся списке Font (Гарнитура шрифта) на панели управления и выберите нужный вам шрифт.
  3. Последней строкой списка является команда Other Font (Другой шрифт), выбор которой существенно расширяет список шрифтов. При выборе этой команды открывается диалоговое окно Choose Font (рис. 19.2) со списком шрифтов, установленных на нашем компьютере.
  4. Установите ползунком Point Size — размер шрифта (кегль), который вы можете увеличивать до 300 кегля.
  5. Ползунком Tracking установите межсимвольный интервал.
  6. Установите указатель в месте начала текста и введите нужный текст.

Рис. 19.1. Палитра Controls: Text

Рис. 19.2. Диалоговое окно Choose Font

Для перехода на новую строку, так же как и в любом текстовом редакторе, пользуйтесь клавишей Enter.

В Painter каждая буква представляет собой отдельную форму и при вводе текста заносится в список секции Layers палитры Objects.

Чтобы сразу убрать ошибочную букву, нажмите клавишу Backspace либо выберите команду Undo. Для удаления ошибки, спустя некоторое время, выделите ее в списке секции Layers палитры Objects и нажмите кнопку Delete.

ПРИМЕЧАНИЕ. Формы, как и другие объекты, нумерованы снизу вверх, то есть первые буквы опускаются вниз, последние остаются вверху списка. Это связано с тем, что, как вы уже знаете, формы являются плавающими векторными объектами, каждый последующий слой располагается над предыдущим (рис. 19.3).

Рис. 19.3. Текст и список слоев, соответствующих буквам, в разделе Layers палитры Objects

Для удобства отдельные буквы рекомендуется объединять в группы, соответствующие словам или предложениям, именуя группы этими же словами. Для объединения отдельных букв необходимо выделить слои, соответствующие буквам, в списке слоев при нажатой клавише Shift, а затем нажать кнопку Group (Группировать) или выбрать команду Group в меню секции Layers. Разумеется, чтобы выполнить операции с какой-либо одной буквой из группы, необходимо выделить нужную группу, выбрать команду Ungroup (Разгруппировать), а затем выделить данную букву и выполнить с ней необходимые преобразования. Подробно формы рассмотрены в главе 15.

Текст как пример формы

Помимо обычных шрифтов Painter предусматривает все разнообразие эффектов, применяемых к формам.

При работе с текстом вы можете использовать следующие средства:

  • инструменты редактирования формы;
  • команды меню Effect;
  • параметры диалогового окна Set Shape Attributes (Установка параметров формы);
  • преобразование в плавающий объект и применение команд, свойственных растровым объектам (заливка градацией, использование кистей).

Далее мы коротко напомним вам о всевозможных эффектах, применимых к тексту.

Изменение формы символа

Можно деформировать символ, то есть вытянуть, сжать или просто изменить размер данной буквы вручную.

  1. Выделите соответствующий слой в списке секции.
  2. Выберите инструмент Layer Adjuster.
  3. Установите указатель на нужном маркере и перемещайте до тех пор, пока не получите желаемого результата (рис. 19.4).

Рис. 19.4. Деформация символа с помощью инструмента Layer Adjuster

Чтобы изменить форму данного символа с помощью команд меню Effects, выполните следующее:

  1. Выделите соответствующий слой в списке.
  2. Выберите команду Effects > Orientation > Distort (Эффекты > Положение > Искажение). Откроется диалоговое окно Distort Selection (Искажение выделения) (рис. 19.5).
  3. Перемещая маркер, измените форму буквы и нажмите кнопку ОК.

Рис. 19.5. Изменение формы символа

Применение эффектов

Можно применить к тексту разнообразные эффекты, представленные в меню Effects. Предварительно необходимо преобразовать буквы в выделение. Для этого:

  1. Выделите нужные символы в списке секции Layers палитры Objects.
  2. Выберите команду Drop and Select (Опустить и выделить) в меню секции Layers.
  3. Выбор команды Effects > Fill, позволяет заливать буквы текущим цветом, градацией, шаблоном или тканевым узором (рис. 19.6). Аналогичным образом применяются остальные команды меню Effects: Surface Control, Focus, Esoterica.

Рис. 19.6. Применение заливки градацией

Как и для любого плавающего объекта, для текста можно создать тень:

  1. Выделите соответствующий слой и выберите команду Effects > Objects > Create Drop Shadow (Эффекты > Объекты > Создать, опустить тень).
  2. Откроется диалоговое окно Drop Shadow. Задайте параметры тени и нажмите кнопку ОК. В итоге буква и тень преобразуются из формы в растровое изображение и располагаются в одном слое (рис. 19.7).

Рис. 19.7. Создание тени от буквы

Применение динамичных слоев к тексту

Вы можете применить к тексту эффекты, соответствующие следующим динамичным слоям: Burn, Tear, Bevel World, Glass Distortion, которые используются с активным выделением или применяются к плавающим слоям (см. глава 16, глава 17 ).

Чтобы применить к тексту указанные динамичные слои, выделите соответствующий слой в списке секции Layers палитры Objects, а затем применяйте необходимый динамичный слой (рис. 19.8).

Рис. 19.8. Применение к букве динамичного слоя Bevel World

Чтобы применить динамичный слой к нескольким буквам, их надо предварительно объединить в группу. Не забудьте совместить текст с холстом, то есть сделать текст частью данного изображения. Для этого нажмите кнопку Collapse (Объединить) в секции Layers.

Пример комплексного применения действий к тексту

Рассмотрим пример применения эффектов к тексту:

  1. Создайте новый документ размером 500 х 300 пикселов.
  2. Выберите инструмент Text. На панели управления установите с помощью ползунка кегль (Point Size), лучше больше 100, для наглядности, и гарнитуру (Font).
  3. Введите текст. Выделите при нажатой клавише Shift все символы в списке секции Layer. Нажмите кнопку Group.
  4. Откройте список символов секции и, выбирая по одному символу, работайте с ним (рис. 19.9):

    • К первому символу примените параметры диалогового окна Set Shape Attributes, установите обрамление формы, цвет формы и обрамления.
    • Символ Н наклоните с помощью инструмента Layer Adjuster, задайте цвет.
    • Символы A, D, О деформируйте с помощью инструментов редактирования формы.
    • Символ W наклоните и сожмите, установите обрамление.

  5. Выделите все символы в списке при нажатой клавише Shift. Нажмите кнопку Group.
  6. После этого выберите инструмент Layer Adjuster, форма обрамляется полосатой рамкой.
  7. Выберите команду Effects > Objects > Create Drop Shadow. Откроется диалоговое окно Drop Shadows. Установите параметры тени (см. главу 15). Нажмите кнопку ОК (рис. 19.10).

Рис. 19.9. Выделены все символы, образующие группу, что не мешает редактированию каждого символа отдельно

Рис. 19.10. После наложения тени в списке секции не осталось форм. Все они преобразованы в слои

Упражнение. Работа с инструментом Text

  1. Создайте новый документ, выберите инструмент Text (Текст). На панели Controls:Text выберите тип шрифта, например, Arial Narrow, установите размер шрифта и межсимвольный интервал. Введите слово privet («привет» в латинской транскрипции). По умолчанию буквы окрашены в черный цвет.
  2. Чтобы надежно контролировать изменение формы символов, залейте их белым цветом и задайте тонкую темную обводку. Для этого для каждой буквы проделайте следующую операцию. Двойным щелчком мыши на строке в списке слоев вызовите диалоговое окно Set Shape Attributes (рис. 19.11). Установите флажок Stroke (Обводка) и, перемещая ползунок Width, ширину обводки. Установите флажок Fill (Заливка), двойным щелчком мыши на цветовом квадрате откройте палитру и выберите белый цвет.
  3. Измените форму символов. Для этого выделите соответствующий слой, активизируйте инструмент Layer Adjuster и, установив его на нужном маркере, перемещайте до тех пор, пока не получите желаемого результата. Вытяните букву Р так, чтобы под ней уместились все остальные буквы. Сместите остальные буквы как можно ближе к букве Р. Слой с буквой Р разместите над слоями с остальными буквами. Результат деформации приведен на рис. 19.12.
  4. Залейте символы цветами радуги. Для каждого из них откройте секцию Grad палитры Art Materials и выберите вариант Rainbow (Радуга). Выберите слой с данным символом. Выберите команду Effects > Fill with. Откроется диалоговое окно Fill. Установите флажок Gradient и нажмите кнопку ОК. Результат заливки приведен на рис. 19.13.

Рис. 19.11. Диалоговое окно Set Shape Attributes

Рис. 19.12. Результат деформирования букв с помощью инструмента Layer Adjuster

Рис. 19.13. Заливка букв градацией. Диалоговое окно Fill

Сделайте символы рельефными. Для каждого из них:

  1. Выберите слой с данным символом. Откройте секцию Dynamic Layers палитры Objects, выберите динамичный слой Bevel World и нажмите кнопку Apply. Принятые по умолчанию параметры диалогового окна Bevel World оставьте без изменения. Результат применения динамичного слоя Bevel World приведен на рис. 19.14.
  2. Работа над текстом закончена, осталось удачно его разместить. Вы можете разместить этот текст где угодно, например на стене в виде старательного граффити, частично прикрытого листвой дерева и скамьей, которые скопированы с предварительно созданного клона исходной фотографии (рис. 19.15).
  3. Выделите текст. Для этого в списке слоев выделите при нажатой клавише Shift каждый слой и нажмите кнопку Group или выберите команду Group в меню секции. Выберите команду Edit > Сору, затем вставьте его в новый документ с помощью команды Edit > Paste. Завершив работу с текстом, не забудьте нажать кнопку Collapse в секции Layers, чтобы совместить плавающие слои с исходным изображением. Итоговое изображение приведено на рис. 19.15.

Рис. 19.14. Результат применения к тексту динамичного слоя Bevel World

Рис. 19.15. Итоговое изображение

Использование динамичного слоя Dynamic Text

Динамичный слой Dynamic Text (Динамичный текст) — очень удобный инструмент для создания довольно сложного текста, в котором строки могут принимать самую прихотливую форму.

Пример использования Dynamic Text приведен на рис. 19.16. Это рекламный постер для туристической компании с цитатой из Гамлета: «Как много всякого на небе и земле...» Текст цитаты нанесен на фотографию из коллекции ландшафтов. При работе с текстом использовано несколько базовых линий. Для символов, расположенных по дуге на фоне горы, использован эффект тени.

Рис. 19.16. Пример использования слоя Dynamic Text

Динамичный слой Dynamic Text позволяет:

  • менять параметры шрифта, включая наклон букв относительно строки;
  • выполнять заливку букв и теней самыми разнообразными способами;
  • создавать эффект движения, то есть размывания текста, как при фотографировании быстро движущегося объекта.

Все эти возможности обеспечивает диалоговое окно Dynamic Text (рис. 19.17). Для его открытия щелкните на значке Dynamic Text в секции Layers палитры Objects, затем нажмите кнопку Apply или выберите команду Apply в меню секции.

Рис. 19.17. Вкладка Baseline диалогового окна Dynamic Text

В верхней части окна находится поле для ввода текста. Ниже — раскрывающийся список шрифтов, (справа от списка три варианта выравнивания текста: по левому краю, по центру и по правому краю. Слева — средство, устанавливающее перемещения базовой линии.

Нижняя часть диалогового окна состоит из трех вкладок:

  • Baseline (Базовая линия) предназначена для работы с базовой линией, по которой располагается текст, а также для задания стиля расположения текста.
  • Adjustment (Регулировка) задает параметры шрифта.
  • Appearance (Эффект) служит для заливки символов, создания тени и размытости изображения.

Установка базовой линии

Чтобы установить базовую линию:

  1. Раскройте вкладку Baseline. В поле Curve Style (Стиль кривой) выберите подходящий стиль базовой линии и вариант расположения текста. Вам предоставляется четыре варианта:

    • Базовая линия горизонтальная, начальное положение букв — вертикальное.
    • Базовая линия кривая, начальное положение букв вертикальное.
    • Базовая линия кривая, начальное положение букв перпендикулярно базовой линии.
    • Базовая линия кривая, начальное положение букв по радиусам кривизны: в зависимости от знака кривизны буквы будут расширяться или сужаться по мере удаления от базовой линии.

  2. Выберите инструмент для задания формы базовой линии. Эти инструменты полностью идентичны трем вариантам инструмента Реn (Перо).
  3. Установите ползунок центрирования текста Centering в нужное положение.

Установка параметров шрифта

На вкладке Adjustment устанавливаются параметры шрифта (рис. 19.18).

Рис. 19.18. Вкладка Adjustment диалогового окна Dynamic Text

В левой части окна расположены четыре кнопки для быстрой регулировки параметров шрифта.

Нажав любую из кнопок, вы можете изменять параметры шрифта прямо в документе, перемещая указатель в нужную сторону. Одновременно с происходящими в документе изменениями меняются установки ползунков, расположенных в правой части. Изменять параметры можно и с помощью ползунков. Все зависит от того, как будет удобно вам.

В правой части вкладки расположены ползунки:

  • Size — размер шрифта;
  • V/H Ratio — отношение высоты буквы к ширине;
  • Angle — угол наклона строки (инструмент работает только в том случае, если базовая линия — прямая);
  • Slant — угол наклона буквы по отношению к базовой линии;
  • Tracking — расстояние между буквами;
  • Leading — расстояние между строками.

Таблица 19.1. Кнопки быстрой регулировки параметров шрифта

Кнопка | Название | Устанавливает
 | Size | Размер шрифта
 | V/H Ratio | Отношение высоты буквы к ширине
 | Angle | Угол наклона строки (инструмент работает только в том случае, если базовая линия прямая)
 | Slant | Угол наклона буквы по отношению к базовой линии

Установка эффектов

Вкладка Appearance (Эффект) (рис. 19.19) позволяет устанавливать ряд эффектов.

Рис. 19.19. Вкладка Appearance диалогового окна Dynamic Text

Рассмотрим параметры вкладки, назначение которых приведено в табл. 19.2.

Таблица 19.2. Параметры вкладки Appearance

Параметр | Устанавливает применение | Параметр | Устанавливает применение
Text | эффекта к тексту | Auto Apply | заливки автоматически
Shadow | эффекта к тени | Apply Fill | заливки
Opacity | непрозрачности | Blur | размытости
Color | цвета | Focus | размытости изображения, связанной с потерей контрастности
Pattern | шаблона | Motion | размытости изображения, передающей эффект движения
Grad | градации | Amount | задает степень эффекта
Weave | плетения | Direction | задает направление движения эффекта размытости

Учтите, что заливка может применяться как к букве, так и к тени. Объект заливки задается кнопками Text или Shadow.

ВНИМАНИЕ. Направление движения задается относительно базовой линии.

В области Shadow Style (Стиль Тени) расположены кнопки, устанавливающие наличие или отсутствие тени и рельефность символа (табл. 19.3).

Таблица 19.3. Кнопки диалогового окна вкладки Appearance

Кнопка | Устанавливает
 | Символ без тени
 | Символ с тенью
 | Рельефный символ

На рис. 19.20 и 19.21 приведены два примера, передающих эффект размытого изображения.

На рис. 19.20 размытое изображение текста «Густой туман» создано за счет потери контрастности. При создании надписи использованы следующие параметры: установлены переключатели Focus и Text, ползунок непрозрачности Opacity установлен в положение 100. Заливка букв выполнена белым цветом. Ползунок Amount, задающий степень эффекта, установлен в положение 45. При создании тени: установлен переключатель Shadow, ползунок Opacity в положении 200. Ползунок Amount — в положении 90. Заливка тени выполнена черным цветом.

Рис. 19.20. Размытое изображение получено за счет потери контрастности

На рис. 19.21 размытое изображение получено за счет эффекта движения. При создании надписи установлен переключатель Motion. Использованы следующие параметры: установлен переключатель Text, ползунок Opacity находится в положении 125. Заливка произведена градацией Rainbow (Радуга). При создании тени: установлен переключатель Shadow, ползунок Opacity установлен в положение 100. Для передачи эффекта движения установлен переключатель Motion. Ползунок Amount, задающий степень эффекта, установлен в положение 80. Ползунок Direction, задающий направление движения, установлен в положение 180.

Рис. 19.21. Размытое изображение текста «Высокая скорость! Это класс!»

Возможности слоя Dynamic Text довольно разнообразны.

На рис. 19.22 приведен пример использования эффекта Dynamic Text при создании обложки для компакт-диска с произведениями Дюка Элингтона.

Рис. 19.22. Пример использования эффекта Dynamic Text

Цепочка уменьшающихся букв ассоциируется с его знаменитым произведением «Караван». Шрифт нанесен на фотографию из коллекции ландшафтов.

Каждая буква и тень от нее представляют собой отдельные слои динамичного текста. Тени получены повторением буквы, заливкой ее черным цветом, поворотом и вытягиванием.

Упражнение. Применение Dynamic Text

Интересные эффекты могут быть получены при сочетании Dynamic Text с другими динамичными слоями.

Для примера рассмотрим совместное использование динамичных слоев Dynamic Text и Liquid Metal при создании поздравительной открытки. В качестве исходного изображения взята пейзажная фотография, приведенная на рис. 19.23.

Рис. 19.23. Исходное изображение, использованное при создании открытки

  1. Создайте новый документ, равный по размеру исходному.
  2. С помощью инструмента Dropper (Пипетка) подберите цвет неба на исходном изображении и создайте фон для текста, выбрав команду Effects > Fill with > Color.
  3. Примените к полученному изображению динамичный слой Dynamic text, при этом выберите базовую линию с вертикальными буквами. Введите текст: Happy Birthday, расположите его по дуге и залейте каким-нибудь темным цветом. В секции Layers палитры Objects выберите в меню секции команду Drop and Select (рис. 19.24).
  4. Выберите команду Select > Invert, а затем Edit > Copy. В результате в буфер занесен слой с вырезанным из него текстом.
  5. Создайте еще одно изображение, окрашенное в тон неба, и перенесите на него из буфера слой с вырезанным из него текстом, выбрав команду Edit > Paste. Примените к полученному изображению динамичный слой Liquid Metal. В диалоговом окне Liquid Metal нажмите кнопку ОК.
  6. В списке секции Layers переместите этот слой под слой с вырезанным текстом. Перейдите в секцию Dynamic Layers и снова выберите Liquid Metal.
  7. В диалоговом окне Liquid Metal установите параметры динамичного слоя: Amount — 1, Smooth — 60%, Volume — 100%, Map — Standard Metal, Refraction — 90%, флажок Surface Tension — установлен. Выберите инструмент Круг и заполните текст крутыми полупрозрачными каплями. Выберите слой Liquid Metal, затем — команду Objects > Layers > Drop and Select (Объекты > Слои > Опустить и выделить).
  8. Выберите цвет и заполните выделение, выбрав команду Effects > Fill with > Current Color (Эффекты > Заполнить > Текущий цвет). Повторите указанные операции несколько раз и заполните весь текст полупрозрачными каплями, окрашенными в цвета радуги и напоминающими мыльные пузыри (рис. 19.25).
  9. Активизируйте слой с вырезанным из него текстом и выберите в секции Layers команду Drop and Select, а затем Edit > Copy. Перенесите текст на исходное изображение, выбрав Edit > Paste. Добавьте тень, выбрав команду Effects > Objects > Create Drop Shadow.
  10. Чтобы закончить композицию добавьте к ней еще несколько полупрозрачных капель разного размера, окрашенных в цвета радуги. Выберите в секции Layers команду Drop All. Поздравительная открытка готова. Итоговое изображение приведено на рис. 19.26.

Рис. 19.24. Текст открытки

Рис. 19.25. Текст открытки после применения динамичного слоя Liquid metal

Рис. 19.26. Итоговое изображение поздравительной открытки


Введение

Итак, перед вами один из графических продуктов — Corel Painter 8 (далее вместо Corel Painter мы будем пользоваться кратким названием Painter), традиционно представляющий собой одну из наиболее мощных графических программ в мире. Painter уникален тем, что, по сути, представляет собой мастерскую художника с многочисленными средствами и возможностями.

Painter предоставляет возможность:

  • обрабатывать цифровые изображения;
  • создавать изображения с помощью традиционных изобразительных средств;
  • использовать средства, которым нет аналогов среди обычных изобразительных средств.

Вы можете с помощью Painter создавать изображения в технике станковой живописи, гравюры, рисунка, акварели, мозаики и т. д. А многочисленные фильтры (Plug-in), в данной редакции — динамические слои (Dynamic layers), позволяют получать удивительные эффекты. С помощью Painter можно создавать изображения для Интернета и даже основу для анимации, пробные проекты, но небольших размеров, так как сама по себе программа требует достаточной емкости памяти (для создания анимации существуют специальные программы).

Однако Painter, как и приемы изобразительного искусства, требует определенного времени и терпения для освоения. К сожалению, интерфейс Painter нельзя назвать интуитивным. Это и понятно, ведь воспроизведение изобразительных средств — довольно сложная задача. Кроме того, не существует русскоязычной версии программы, поэтому мы будем изучать англоязычную версию.

Настоящая книга знакомит вас с большинством средств, предоставляемых в ваше распоряжение программой Painter 8. При написании книги использован подход «на примерах», при котором вам предлагается в процессе знакомства с новыми средствами выполнять ряд упражнений. Как показывает практика, такой подход является наиболее действенным и позволяет быстро познакомиться со средствами программы и максимально эффективно их использовать. Кроме того, такой подход обладает одним ценным качеством: приведенные примеры фактически составляют ситуационный справочник.

Книга представляет интерес практически для всех групп пользователей, начиная от новичка и заканчивая искушенными пользователями. Начинающие пользователи смогут в максимально короткий срок приступить к практическому использованию Painter, опытные пользователи найдут информацию по конкретным вопросам, а профессионалы — профессиональные советы и маленькие хитрости.

Книга содержит большое количество иллюстраций и упражнений, которые помогут вам эффективно овладеть изложенным в ней материалом.

Тем пользователям, которые только приступают к изучению Painter, рекомендуется последовательно знакомиться с материалом, изложенным в книге. Опытный пользователь может пропустить отдельные уроки и обратиться непосредственно к интересующему его материалу.

Книга состоит из девятнадцати уроков, которые объединены в пять частей.

Часть I (главы 1-4) содержит информацию о повседневных действиях, выполняемых в Painter: начале и завершении сеанса работы, создании документа и выводе его на печать. Основные представления о цвете и разрешении приведены в главе 3. Эта часть содержит сведения, которые будут интересны не только начинающим пользователям (предварительный просмотр документа перед печатью, функции печати и т. д.).

Часть II (главы 5-7) посвящена вспомогательным средствам: настройке кистей, записи сценариев, созданию клона-изображения. Усвоив эти главы, вы сможете начать создавать изображения в Painter.

Часть III (главы 8-12) посвящена работе и свойствам одной из основополагающих палитр Painter — Art Materials.

Часть IV (главы 13-15) посвящена базовым понятиям и средствам, необходимым для повседневной работы: выделениям, маскам, слоям и формам.

В заключительной части V рассматриваются специальные эффекты — динамические слои (Dynamic layers), мозаика и работа с текстом.

Используемые в книге обозначения

При рассмотрении панелей инструментов и диалоговых окон параметры и команды собраны в таблицы, объясняющие их смысл и назначение.

Некоторые слова и фразы в тексте выделяются специальным шрифтом. Поскольку книга написана по нелокализованной версии Painter 8, экранные (интерфейсные) термины являются англоязычными, приводятся в тексте в точности так, как они видны на экране, и определенным образом выделяются. К экранным терминам относятся названия команд, диалоговых окон, элементов диалогов (полей ввода, флажков, кнопок, списков, переключателей и т. д.), панелей инструментов, значков и кнопок, значения раскрывающихся списков. Для удобства пользователей Painter рядом в скобках приводится перевод термина.

Новые понятия, а также слова или выражения, на которые мы хотим обратить внимание читателя, выделяются.

Слова и фразы, которые читатель при выполнении упражнений должен вводить с клавиатуры, названия папок и файлов тоже выделяются специальным стилем.

Кроме шрифтовых выделений используются три специальных типа представления информации.

СОВЕТ. Это интересно. Имеет смысл отметить и воспользоваться данным советом.

ВНИМАНИЕ. Не пропустите эту информацию, что позволит вам избежать многих неприятностей.

ПРИМЕЧАНИЕ. Замечание, на которое следует обратить внимание, возможно, вам это пригодится.

Искренне надеемся, что данная книга будет полезна самому широкому кругу отечественных пользователей

Painter.